implement event loop for console applications (heavily modified patch 1715735)
[wxWidgets.git] / wxGTK.spec
1 %define _prefix /usr
2 %define ver 2.9.0
3 %define ver2 2.9
4 %define rel 1
5
6 # Configurable settings (use --with(out) {unicode,gtk2} on rpmbuild cmd line):
7 %define unicode 1
8 %{?_with_unicode: %{expand: %%define unicode 1}}
9 %{?_without_unicode: %{expand: %%define unicode 0}}
10
11 %define gtk2 1
12 %{?_with_gtk2: %{expand: %%define gtk2 1}}
13 %{?_without_gtk2: %{expand: %%define gtk2 0}}
14
15 # "buildname" needs to be e.g. gtk2ud for debug builds
16 %if %{gtk2}
17 %define gtkver 2
18 %define portname gtk2
19 %if %{unicode}
20 %define buildname gtk2u
21 %else
22 %define buildname gtk2
23 %endif
24 %else
25 %define gtkver 1.2
26 %define portname gtk
27 %define buildname gtk
28 %endif
29
30 %if %{unicode}
31 %define name wx-%{portname}-unicode
32 %define wxconfig %{portname}-unicode-release-%{ver2}
33 %define wxconfigstatic %{portname}-unicode-release-static-%{ver2}
34 %define wxconfiglink wx%{portname}u-%{ver2}-config
35 %else
36 %define name wx-%{portname}-ansi
37 %define wxconfig %{portname}-ansi-release-%{ver2}
38 %define wxconfigstatic %{portname}-ansi-release-static-%{ver2}
39 %define wxconfiglink wx%{portname}-%{ver2}-config
40 %endif
41
42 %if %{unicode}
43 %define wxbasename wx-base-unicode
44 %define wxbaseconfig base-unicode-release-%{ver2}
45 %define wxbaseconfiglink wxbaseu-%{ver2}-config
46 %else
47 %define wxbasename wx-base-ansi
48 %define wxbaseconfig base-ansi-release-%{ver2}
49 %define wxbaseconfiglink wxbase-%{ver2}-config
50 %endif
51
52 Summary: The GTK+ %{gtkver} port of the wxWidgets library
53 Name: %{name}
54 Version: %{ver}
55 Release: %{rel}
56 License: wxWindows Licence
57 Group: X11/Libraries
58 Source: wxGTK-%{ver}.tar.bz2
59 URL: http://www.wxwidgets.org
60 Packager: Vadim Zeitlin <vadim@wxwindows.org>
61 Prefix: %{_prefix}
62 BuildRoot: %{_tmppath}/%{name}-root
63 Requires: %{wxbasename} = %{ver}
64 %if %{portname} == gtk2
65 BuildRequires: gtk+-2.0-devel
66 %else
67 BuildRequires: gtk+-devel >= 1.2.0
68 %endif
69
70 BuildRequires: zlib-devel, libjpeg-devel, libpng-devel, libtiff-devel
71
72 # all packages providing an implementation of wxWidgets library (regardless of
73 # the toolkit used) should provide the (virtual) wxwin package, this makes it
74 # possible to require wxwin instead of requiring "wxgtk or wxmotif or wxuniv..."
75 Provides: wxwin
76 Provides: wxGTK
77
78 %description
79 wxWidgets is a free C++ library for cross-platform GUI development.
80 With wxWidgets, you can create applications for different GUIs (GTK+,
81 Motif, MS Windows, MacOS X, Windows CE, GPE) from the same source code.
82
83 %package -n wx-i18n
84 Summary: The translations for the wxWidgets library.
85 Group: X11/Libraries
86
87 %description -n wx-i18n
88 The translations files for the wxWidgets library.
89
90 %package devel
91 Summary: The GTK+ %{gtkver} port of the wxWidgets library
92 Group: X11/Libraries
93 Requires: %{name} = %{ver}
94 Requires: %{wxbasename}-devel = %{ver}
95 Provides: wxGTK-devel
96
97 %description devel
98 The GTK+ %{gtkver} port of the wxWidgets library, header files.
99
100 %package gl
101 Summary: The GTK+ %{gtkver} port of the wxWidgets library, OpenGL add-on.
102 Group: X11/Libraries
103 Requires: %{name} = %{ver}
104 Provides: wxGTK-gl
105
106 %description gl
107 OpenGL add-on library for wxGTK, the GTK+ %{gtkver} port of the wxWidgets library.
108
109 %package -n %{wxbasename}
110 Summary: wxBase library - non-GUI support classes of the wxWidgets toolkit
111 Group: Development/Libraries
112 Provides: wxBase
113
114 %description -n %{wxbasename}
115 wxBase is a collection of C++ classes providing basic data structures (strings,
116 lists, arrays), portable wrappers around many OS-specific funstions (file
117 operations, time/date manipulations, threads, processes, sockets, shared
118 library loading) as well as other utility classes (streams, archive and
119 compression). wxBase currently supports Win32, most Unix variants (Linux,
120 FreeBSD, Solaris, HP-UX) and MacOS X (Carbon and Mach-0).
121
122 %package -n %{wxbasename}-devel
123 Summary: wxBase library, header files.
124 Group: Development/Libraries
125 Provides: wxBase-devel
126
127 %description -n %{wxbasename}-devel
128 wxBase library - non-GUI support classes of the wxWidgets toolkit,
129 header files.
130
131 %package contrib
132 Summary: The GTK+ %{gtkver} port of the wxWidgets library, contributed libraries.
133 Group: X11/Libraries
134 Requires: %{name} = %{ver}
135
136 %description contrib
137 Contributed libraries for wxGTK, the GTK+ %{gtkver} port of the wxWidgets library.
138
139 %package contrib-devel
140 Summary: The GTK+ %{gtkver} port of the wxWidgets library
141 Group: X11/Libraries
142 Requires: %{name}-contrib = %{ver}
143 Requires: %{name}-devel = %{ver}
144
145 %description contrib-devel
146 Header files for contributed libraries for wxGTK, the GTK+ %{gtkver} port of the wxWidgets library.
147
148 %prep
149 %setup -q -n wxGTK-%{ver}
150
151 %build
152 if [ "$SMP" != "" ]; then
153 export MAKE="make -j$SMP"
154 else
155 export MAKE="make"
156 fi
157
158 mkdir obj-shared
159 cd obj-shared
160 ../configure --prefix=%{_prefix} \
161 %if ! %{gtk2}
162 --with-gtk=1 \
163 %else
164 --with-gtk=2 \
165 %endif
166 %if %{unicode}
167 --enable-unicode \
168 %else
169 --disable-unicode \
170 --with-odbc \
171 %endif
172 --with-opengl
173 $MAKE
174
175 cd contrib/src
176 $MAKE
177 cd ../../..
178
179 mkdir obj-static
180 cd obj-static
181 ../configure --prefix=%{_prefix} \
182 %if ! %{gtk2}
183 --with-gtk=1 \
184 %else
185 --with-gtk=2 \
186 %endif
187 --disable-shared \
188 %if %{unicode}
189 --enable-unicode \
190 %else
191 --disable-unicode \
192 --with-odbc \
193 %endif
194 --with-opengl
195 $MAKE
196
197 cd contrib/src
198 $MAKE
199 cd ../../..
200
201 make -C locale allmo
202
203 %install
204 rm -rf $RPM_BUILD_ROOT
205 (cd obj-static; make DESTDIR=$RPM_BUILD_ROOT prefix=%{_prefix} install)
206 (cd obj-shared; make DESTDIR=$RPM_BUILD_ROOT prefix=%{_prefix} install)
207
208 # --- wxBase headers list begins here ---
209 cat <<EOF >wxbase-headers.files
210 wx/afterstd.h
211 wx/app.h
212 wx/apptrait.h
213 wx/archive.h
214 wx/arrimpl.cpp
215 wx/arrstr.h
216 wx/beforestd.h
217 wx/buffer.h
218 wx/build.h
219 wx/chartype.h
220 wx/chkconf.h
221 wx/clntdata.h
222 wx/cmdline.h
223 wx/confbase.h
224 wx/config.h
225 wx/convauto.h
226 wx/containr.h
227 wx/cpp.h
228 wx/datetime.h
229 wx/datstrm.h
230 wx/dde.h
231 wx/debug.h
232 wx/defs.h
233 wx/dir.h
234 wx/dlimpexp.h
235 wx/dynarray.h
236 wx/dynlib.h
237 wx/dynload.h
238 wx/encconv.h
239 wx/event.h
240 wx/except.h
241 wx/features.h
242 wx/flags.h
243 wx/ffile.h
244 wx/file.h
245 wx/fileconf.h
246 wx/filefn.h
247 wx/filename.h
248 wx/filesys.h
249 wx/fontenc.h
250 wx/fontmap.h
251 wx/fs_arc.h
252 wx/fs_filter.h
253 wx/fs_mem.h
254 wx/fs_zip.h
255 wx/hash.h
256 wx/hashmap.h
257 wx/hashset.h
258 wx/html/forcelnk.h
259 wx/iconloc.h
260 wx/init.h
261 wx/intl.h
262 wx/iosfwrap.h
263 wx/ioswrap.h
264 wx/ipc.h
265 wx/ipcbase.h
266 wx/isql.h
267 wx/isqlext.h
268 wx/link.h
269 wx/list.h
270 wx/listimpl.cpp
271 wx/log.h
272 wx/longlong.h
273 wx/math.h
274 wx/memconf.h
275 wx/memory.h
276 wx/memtext.h
277 wx/mimetype.h
278 wx/module.h
279 wx/msgout.h
280 wx/mstream.h
281 wx/object.h
282 wx/platform.h
283 wx/platinfo.h
284 wx/power.h
285 wx/process.h
286 wx/ptr_scpd.h
287 wx/recguard.h
288 wx/regex.h
289 wx/scopeguard.h
290 wx/snglinst.h
291 wx/sstream.h
292 wx/stack.h
293 wx/stackwalk.h
294 wx/stdpaths.h
295 wx/stockitem.h
296 wx/stopwatch.h
297 wx/strconv.h
298 wx/stream.h
299 wx/string.h
300 wx/stringimpl.h
301 wx/stringops.h
302 wx/strvararg.h
303 wx/sysopt.h
304 wx/tarstrm.h
305 wx/textbuf.h
306 wx/textfile.h
307 wx/thread.h
308 wx/thrimpl.cpp
309 wx/timer.h
310 wx/tokenzr.h
311 wx/txtstrm.h
312 wx/types.h
313 wx/unichar.h
314 wx/uri.h
315 wx/utils.h
316 wx/variant.h
317 wx/vector.h
318 wx/version.h
319 wx/volume.h
320 wx/wfstream.h
321 wx/wx.h
322 wx/wxchar.h
323 wx/wxcrt.h
324 wx/wxcrtvararg.h
325 wx/wxprec.h
326 wx/xti.h
327 wx/xtistrm.h
328 wx/zipstrm.h
329 wx/zstream.h
330 wx/unix/app.h
331 wx/unix/apptbase.h
332 wx/unix/apptrait.h
333 wx/unix/execute.h
334 wx/unix/evtloop.h
335 wx/unix/mimetype.h
336 wx/unix/pipe.h
337 wx/unix/private.h
338 wx/unix/stackwalk.h
339 wx/unix/stdpaths.h
340 wx/fs_inet.h
341 wx/gsocket.h
342 wx/protocol/file.h
343 wx/protocol/ftp.h
344 wx/protocol/http.h
345 wx/protocol/protocol.h
346 wx/sckaddr.h
347 wx/sckipc.h
348 wx/sckstrm.h
349 wx/socket.h
350 wx/url.h
351 wx/unix/gsockunx.h
352 wx/xml/xml.h
353 wx/xtixml.h
354 wx/db.h
355 wx/dbkeyg.h
356 wx/dbtable.h
357 EOF
358 # --- wxBase headers list ends here ---
359 cat <<EOF >wxbase-headers.paths
360 %{_includedir}/wx-%{ver2}/wx/afterstd.h
361 %{_includedir}/wx-%{ver2}/wx/app.h
362 %{_includedir}/wx-%{ver2}/wx/apptrait.h
363 %{_includedir}/wx-%{ver2}/wx/archive.h
364 %{_includedir}/wx-%{ver2}/wx/arrimpl.cpp
365 %{_includedir}/wx-%{ver2}/wx/arrstr.h
366 %{_includedir}/wx-%{ver2}/wx/beforestd.h
367 %{_includedir}/wx-%{ver2}/wx/buffer.h
368 %{_includedir}/wx-%{ver2}/wx/build.h
369 %{_includedir}/wx-%{ver2}/wx/chkconf.h
370 %{_includedir}/wx-%{ver2}/wx/clntdata.h
371 %{_includedir}/wx-%{ver2}/wx/cmdline.h
372 %{_includedir}/wx-%{ver2}/wx/confbase.h
373 %{_includedir}/wx-%{ver2}/wx/config.h
374 %{_includedir}/wx-%{ver2}/wx/containr.h
375 %{_includedir}/wx-%{ver2}/wx/convauto.h
376 %{_includedir}/wx-%{ver2}/wx/datetime.h
377 %{_includedir}/wx-%{ver2}/wx/datstrm.h
378 %{_includedir}/wx-%{ver2}/wx/dde.h
379 %{_includedir}/wx-%{ver2}/wx/debug.h
380 %{_includedir}/wx-%{ver2}/wx/defs.h
381 %{_includedir}/wx-%{ver2}/wx/dir.h
382 %{_includedir}/wx-%{ver2}/wx/dlimpexp.h
383 %{_includedir}/wx-%{ver2}/wx/dynarray.h
384 %{_includedir}/wx-%{ver2}/wx/dynlib.h
385 %{_includedir}/wx-%{ver2}/wx/dynload.h
386 %{_includedir}/wx-%{ver2}/wx/encconv.h
387 %{_includedir}/wx-%{ver2}/wx/event.h
388 %{_includedir}/wx-%{ver2}/wx/except.h
389 %{_includedir}/wx-%{ver2}/wx/features.h
390 %{_includedir}/wx-%{ver2}/wx/ffile.h
391 %{_includedir}/wx-%{ver2}/wx/file.h
392 %{_includedir}/wx-%{ver2}/wx/fileconf.h
393 %{_includedir}/wx-%{ver2}/wx/filefn.h
394 %{_includedir}/wx-%{ver2}/wx/filename.h
395 %{_includedir}/wx-%{ver2}/wx/filesys.h
396 %{_includedir}/wx-%{ver2}/wx/fontenc.h
397 %{_includedir}/wx-%{ver2}/wx/fontmap.h
398 %{_includedir}/wx-%{ver2}/wx/fs_mem.h
399 %{_includedir}/wx-%{ver2}/wx/fs_zip.h
400 %{_includedir}/wx-%{ver2}/wx/hash.h
401 %{_includedir}/wx-%{ver2}/wx/hashmap.h
402 %{_includedir}/wx-%{ver2}/wx/hashset.h
403 %{_includedir}/wx-%{ver2}/wx/html/forcelnk.h
404 %{_includedir}/wx-%{ver2}/wx/iconloc.h
405 %{_includedir}/wx-%{ver2}/wx/init.h
406 %{_includedir}/wx-%{ver2}/wx/intl.h
407 %{_includedir}/wx-%{ver2}/wx/iosfwrap.h
408 %{_includedir}/wx-%{ver2}/wx/ioswrap.h
409 %{_includedir}/wx-%{ver2}/wx/ipc.h
410 %{_includedir}/wx-%{ver2}/wx/ipcbase.h
411 %{_includedir}/wx-%{ver2}/wx/isql.h
412 %{_includedir}/wx-%{ver2}/wx/isqlext.h
413 %{_includedir}/wx-%{ver2}/wx/link.h
414 %{_includedir}/wx-%{ver2}/wx/list.h
415 %{_includedir}/wx-%{ver2}/wx/listimpl.cpp
416 %{_includedir}/wx-%{ver2}/wx/log.h
417 %{_includedir}/wx-%{ver2}/wx/longlong.h
418 %{_includedir}/wx-%{ver2}/wx/math.h
419 %{_includedir}/wx-%{ver2}/wx/memconf.h
420 %{_includedir}/wx-%{ver2}/wx/memory.h
421 %{_includedir}/wx-%{ver2}/wx/memtext.h
422 %{_includedir}/wx-%{ver2}/wx/mimetype.h
423 %{_includedir}/wx-%{ver2}/wx/module.h
424 %{_includedir}/wx-%{ver2}/wx/msgout.h
425 %{_includedir}/wx-%{ver2}/wx/mstream.h
426 %{_includedir}/wx-%{ver2}/wx/object.h
427 %{_includedir}/wx-%{ver2}/wx/platform.h
428 %{_includedir}/wx-%{ver2}/wx/power.h
429 %{_includedir}/wx-%{ver2}/wx/process.h
430 %{_includedir}/wx-%{ver2}/wx/ptr_scpd.h
431 %{_includedir}/wx-%{ver2}/wx/recguard.h
432 %{_includedir}/wx-%{ver2}/wx/regex.h
433 %{_includedir}/wx-%{ver2}/wx/scopeguard.h
434 %{_includedir}/wx-%{ver2}/wx/snglinst.h
435 %{_includedir}/wx-%{ver2}/wx/sstream.h
436 %{_includedir}/wx-%{ver2}/wx/stack.h
437 %{_includedir}/wx-%{ver2}/wx/stackwalk.h
438 %{_includedir}/wx-%{ver2}/wx/stdpaths.h
439 %{_includedir}/wx-%{ver2}/wx/stockitem.h
440 %{_includedir}/wx-%{ver2}/wx/stopwatch.h
441 %{_includedir}/wx-%{ver2}/wx/strconv.h
442 %{_includedir}/wx-%{ver2}/wx/stream.h
443 %{_includedir}/wx-%{ver2}/wx/string.h
444 %{_includedir}/wx-%{ver2}/wx/sysopt.h
445 %{_includedir}/wx-%{ver2}/wx/textbuf.h
446 %{_includedir}/wx-%{ver2}/wx/textfile.h
447 %{_includedir}/wx-%{ver2}/wx/thread.h
448 %{_includedir}/wx-%{ver2}/wx/thrimpl.cpp
449 %{_includedir}/wx-%{ver2}/wx/timer.h
450 %{_includedir}/wx-%{ver2}/wx/tokenzr.h
451 %{_includedir}/wx-%{ver2}/wx/txtstrm.h
452 %{_includedir}/wx-%{ver2}/wx/types.h
453 %{_includedir}/wx-%{ver2}/wx/uri.h
454 %{_includedir}/wx-%{ver2}/wx/utils.h
455 %{_includedir}/wx-%{ver2}/wx/variant.h
456 %{_includedir}/wx-%{ver2}/wx/vector.h
457 %{_includedir}/wx-%{ver2}/wx/version.h
458 %{_includedir}/wx-%{ver2}/wx/volume.h
459 %{_includedir}/wx-%{ver2}/wx/wfstream.h
460 %{_includedir}/wx-%{ver2}/wx/wx.h
461 %{_includedir}/wx-%{ver2}/wx/wxchar.h
462 %{_includedir}/wx-%{ver2}/wx/wxprec.h
463 %{_includedir}/wx-%{ver2}/wx/xti.h
464 %{_includedir}/wx-%{ver2}/wx/xtistrm.h
465 %{_includedir}/wx-%{ver2}/wx/zipstrm.h
466 %{_includedir}/wx-%{ver2}/wx/zstream.h
467 %{_includedir}/wx-%{ver2}/wx/fs_inet.h
468 %{_includedir}/wx-%{ver2}/wx/gsocket.h
469 %{_includedir}/wx-%{ver2}/wx/protocol/file.h
470 %{_includedir}/wx-%{ver2}/wx/protocol/ftp.h
471 %{_includedir}/wx-%{ver2}/wx/protocol/http.h
472 %{_includedir}/wx-%{ver2}/wx/protocol/protocol.h
473 %{_includedir}/wx-%{ver2}/wx/sckaddr.h
474 %{_includedir}/wx-%{ver2}/wx/sckipc.h
475 %{_includedir}/wx-%{ver2}/wx/sckstrm.h
476 %{_includedir}/wx-%{ver2}/wx/socket.h
477 %{_includedir}/wx-%{ver2}/wx/url.h
478 %{_includedir}/wx-%{ver2}/wx/xml/xml.h
479 %{_includedir}/wx-%{ver2}/wx/xtixml.h
480 %{_includedir}/wx-%{ver2}/wx/db.h
481 %{_includedir}/wx-%{ver2}/wx/dbkeyg.h
482 %{_includedir}/wx-%{ver2}/wx/dbtable.h
483 %{_includedir}/wx-%{ver2}/wx/unix/apptbase.h
484 %{_includedir}/wx-%{ver2}/wx/unix/apptrait.h
485 %{_includedir}/wx-%{ver2}/wx/unix/execute.h
486 %{_includedir}/wx-%{ver2}/wx/unix/gsockunx.h
487 %{_includedir}/wx-%{ver2}/wx/unix/mimetype.h
488 %{_includedir}/wx-%{ver2}/wx/unix/pipe.h
489 %{_includedir}/wx-%{ver2}/wx/unix/private.h
490 %{_includedir}/wx-%{ver2}/wx/unix/stackwalk.h
491 %{_includedir}/wx-%{ver2}/wx/unix/stdpaths.h
492 EOF
493 # --- wxBase headers list ends here ---
494
495 # temporarily remove base headers
496 mkdir $RPM_BUILD_ROOT/_save_dir
497 cp -r $RPM_BUILD_ROOT%{_includedir}/wx-%{ver2} $RPM_BUILD_ROOT/_save_dir
498 for f in `cat wxbase-headers.files` ; do
499 rm -f $RPM_BUILD_ROOT%{_includedir}/wx-%{ver2}/$f
500 done
501 # list of all core headers:
502 find $RPM_BUILD_ROOT%{_includedir}/wx-%{ver2} -type f | sed -e "s,$RPM_BUILD_ROOT,,g" >core-headers.files
503 # move base headers (actually all headers) back again
504 cp -f -r $RPM_BUILD_ROOT/_save_dir/* $RPM_BUILD_ROOT%{_includedir}
505 rm -rf $RPM_BUILD_ROOT/_save_dir
506
507 # contrib stuff:
508 (cd obj-static/contrib; make DESTDIR=$RPM_BUILD_ROOT prefix=%{_prefix} install)
509 (cd obj-shared/contrib; make DESTDIR=$RPM_BUILD_ROOT prefix=%{_prefix} install)
510
511 # utils:
512 (cd obj-shared/utils/wxrc; make DESTDIR=$RPM_BUILD_ROOT prefix=%{_prefix} install)
513
514 # wx-config link is created during package installation, remove it for now
515 rm -f $RPM_BUILD_ROOT%{_bindir}/wx-config
516
517 %clean
518 rm -rf $RPM_BUILD_ROOT
519
520 %post
521 /sbin/ldconfig
522
523 %postun
524 /sbin/ldconfig
525
526 %post devel
527 # link wx-config when you install RPM.
528 %if %{unicode}
529 ln -sf %{_libdir}/wx/config/%{wxconfig} %{_bindir}/wx-config
530 %endif
531 # link wx-config with explicit name.
532 ln -sf %{_libdir}/wx/config/%{wxconfig} %{_bindir}/%{wxconfiglink}
533 /sbin/ldconfig
534
535 %postun devel
536 /sbin/ldconfig
537
538 %preun devel
539 %if %{unicode}
540 rm -f %{_bindir}/wx-config
541 %endif
542 rm -f %{_bindir}/%{wxconfiglink}
543
544 %post -n %{wxbasename}
545 /sbin/ldconfig
546
547 %postun -n %{wxbasename}
548 /sbin/ldconfig
549
550 %post -n %{wxbasename}-devel
551 # link wx-config with explicit name.
552 ln -sf %{_libdir}/wx/config/%{wxbaseconfig} %{_bindir}/%{wxbaseconfiglink}
553 /sbin/ldconfig
554
555 %postun -n %{wxbasename}-devel
556 /sbin/ldconfig
557
558 %preun -n %{wxbasename}-devel
559 rm -f %{_bindir}/%{wxbaseconfiglink}
560
561 %post gl
562 /sbin/ldconfig
563
564 %postun gl
565 /sbin/ldconfig
566
567 %post contrib
568 /sbin/ldconfig
569
570 %postun contrib
571 /sbin/ldconfig
572
573 %post contrib-devel
574 /sbin/ldconfig
575
576 %postun contrib-devel
577 /sbin/ldconfig
578
579 %files
580 %defattr(-,root,root)
581 %doc COPYING.LIB *.txt
582 %{_libdir}/libwx_%{buildname}_adv-%{ver2}.so.*
583 %{_libdir}/libwx_%{buildname}_aui-%{ver2}.so.*
584 %{_libdir}/libwx_%{buildname}_core-%{ver2}.so.*
585 %if !%{unicode}
586 %{_libdir}/libwx_%{buildname}_dbgrid-%{ver2}.so.*
587 %endif
588 %{_libdir}/libwx_%{buildname}_html-%{ver2}.so.*
589 %{_libdir}/libwx_%{buildname}_mmedia-%{ver2}.so.*
590 %{_libdir}/libwx_%{buildname}_qa-%{ver2}.so.*
591 %{_libdir}/libwx_%{buildname}_richtext-%{ver2}.so.*
592 %{_libdir}/libwx_%{buildname}_xrc-%{ver2}.so.*
593
594 %files -n wx-i18n
595 %defattr(-,root,root)
596 %{_datadir}/locale/*/LC_MESSAGES/*.mo
597
598 %files devel -f core-headers.files
599 %defattr(-,root,root)
600 # shared libs
601 %{_libdir}/libwx_%{buildname}_adv-%{ver2}.so
602 %{_libdir}/libwx_%{buildname}_aui-%{ver2}.so
603 %{_libdir}/libwx_%{buildname}_core-%{ver2}.so
604 %if !%{unicode}
605 %{_libdir}/libwx_%{buildname}_dbgrid-%{ver2}.so
606 %endif
607 %{_libdir}/libwx_%{buildname}_gl-%{ver2}.so
608 %{_libdir}/libwx_%{buildname}_html-%{ver2}.so
609 %{_libdir}/libwx_%{buildname}_mmedia-%{ver2}.so
610 %{_libdir}/libwx_%{buildname}_qa-%{ver2}.so
611 %{_libdir}/libwx_%{buildname}_richtext-%{ver2}.so
612 %{_libdir}/libwx_%{buildname}_xrc-%{ver2}.so
613 # static libs
614 %{_libdir}/libwx_%{buildname}_adv-%{ver2}.a
615 %{_libdir}/libwx_%{buildname}_aui-%{ver2}.a
616 %{_libdir}/libwx_%{buildname}_core-%{ver2}.a
617 %if !%{unicode}
618 %{_libdir}/libwx_%{buildname}_dbgrid-%{ver2}.a
619 %endif
620 %{_libdir}/libwx_%{buildname}_gl-%{ver2}.a
621 %{_libdir}/libwx_%{buildname}_html-%{ver2}.a
622 %{_libdir}/libwx_%{buildname}_qa-%{ver2}.a
623 %{_libdir}/libwx_%{buildname}_richtext-%{ver2}.a
624 %{_libdir}/libwx_%{buildname}_xrc-%{ver2}.a
625 %dir %{_libdir}/wx
626 %{_libdir}/wx/config/%{wxconfig}
627 %{_libdir}/wx/include/%{wxconfig}/wx/setup.h
628 %{_libdir}/wx/config/%{wxconfigstatic}
629 %{_libdir}/wx/include/%{wxconfigstatic}/wx/setup.h
630 %{_bindir}/wxrc*
631
632 %files -n %{wxbasename}
633 %defattr(-,root,root)
634 %{_libdir}/libwx_base*-%{ver2}.so.*
635
636 %files -n %{wxbasename}-devel -f wxbase-headers.paths
637 %defattr (-,root,root)
638 %dir %{_includedir}/wx-%{ver2}
639 %{_libdir}/libwx_base*-%{ver2}.so
640 %{_libdir}/libwx_base*-%{ver2}.a
641 %if %{unicode}
642 %{_libdir}/libwxregexu-%{ver2}.a
643 %endif
644 %dir %{_libdir}/wx
645 %{_datadir}/aclocal/*.m4
646 %{_datadir}/bakefile/presets/*
647
648 %files gl
649 %defattr(-,root,root)
650 %{_libdir}/libwx_%{buildname}_gl-%{ver2}.so.*
651
652 %files contrib
653 %defattr(-,root,root)
654 %{_libdir}/libwx_%{buildname}_animate-%{ver2}.so.*
655 %{_libdir}/libwx_%{buildname}_deprecated-%{ver2}.so.*
656 %{_libdir}/libwx_%{buildname}_fl-%{ver2}.so.*
657 %{_libdir}/libwx_%{buildname}_gizmos-%{ver2}.so.*
658 %{_libdir}/libwx_%{buildname}_gizmos_xrc-%{ver2}.so.*
659 %{_libdir}/libwx_%{buildname}_mmedia-%{ver2}.so.*
660 %{_libdir}/libwx_%{buildname}_ogl-%{ver2}.so.*
661 %{_libdir}/libwx_%{buildname}_plot-%{ver2}.so.*
662 %{_libdir}/libwx_%{buildname}_stc-%{ver2}.so.*
663 %{_libdir}/libwx_%{buildname}_svg-%{ver2}.so.*
664
665 # static libs
666 %{_libdir}/libwx_%{buildname}_animate-%{ver2}.a
667 %{_libdir}/libwx_%{buildname}_deprecated-%{ver2}.a
668 %{_libdir}/libwx_%{buildname}_fl-%{ver2}.a
669 %{_libdir}/libwx_%{buildname}_gizmos-%{ver2}.a
670 %{_libdir}/libwx_%{buildname}_gizmos_xrc-%{ver2}.a
671 %{_libdir}/libwx_%{buildname}_mmedia-%{ver2}.a
672 %{_libdir}/libwx_%{buildname}_ogl-%{ver2}.a
673 %{_libdir}/libwx_%{buildname}_plot-%{ver2}.a
674 %{_libdir}/libwx_%{buildname}_stc-%{ver2}.a
675 %{_libdir}/libwx_%{buildname}_svg-%{ver2}.a
676
677 %files contrib-devel
678 %defattr(-,root,root)
679 %dir %{_includedir}/wx-%{ver2}/wx/animate
680 %{_includedir}/wx-%{ver2}/wx/animate/*
681 %{_libdir}/libwx_%{buildname}_animate-%{ver2}.so
682
683 %dir %{_includedir}/wx-%{ver2}/wx/deprecated
684 %{_includedir}/wx-%{ver2}/wx/deprecated/*
685 %{_libdir}/libwx_%{buildname}_deprecated-%{ver2}.so
686
687 %dir %{_includedir}/wx-%{ver2}/wx/fl
688 %{_includedir}/wx-%{ver2}/wx/fl/*
689 %{_libdir}/libwx_%{buildname}_fl-%{ver2}.so
690
691 %dir %{_includedir}/wx-%{ver2}/wx/gizmos
692 %{_includedir}/wx-%{ver2}/wx/gizmos/*
693 %{_libdir}/libwx_%{buildname}_gizmos-%{ver2}.so
694 %{_libdir}/libwx_%{buildname}_gizmos_xrc-%{ver2}.so
695
696 %dir %{_includedir}/wx-%{ver2}/wx/mmedia
697 %{_includedir}/wx-%{ver2}/wx/mmedia/*
698 %{_libdir}/libwx_%{buildname}_mmedia-%{ver2}.so
699
700 %dir %{_includedir}/wx-%{ver2}/wx/ogl
701 %{_includedir}/wx-%{ver2}/wx/ogl/*
702 %{_libdir}/libwx_%{buildname}_ogl-%{ver2}.so
703
704 %dir %{_includedir}/wx-%{ver2}/wx/plot
705 %{_includedir}/wx-%{ver2}/wx/plot/*
706 %{_libdir}/libwx_%{buildname}_plot-%{ver2}.so
707
708 %dir %{_includedir}/wx-%{ver2}/wx/stc
709 %{_includedir}/wx-%{ver2}/wx/stc/*
710 %{_libdir}/libwx_%{buildname}_stc-%{ver2}.so
711
712 %dir %{_includedir}/wx-%{ver2}/wx/svg
713 %{_includedir}/wx-%{ver2}/wx/svg/*
714 %{_libdir}/libwx_%{buildname}_svg-%{ver2}.so