Merge the new wxWebView classes from the SOC2011_WEBVIEW branch.
[wxWidgets.git] / wxMGL.spec
1 %define pref /usr
2 %define ver 2.9.3
3 %define ver2 2.9
4 %define rel 1
5
6 Summary: The SciTech MGL port of the wxWindows library
7 Name: wxMGL
8 Version: %{ver}
9 Release: %{rel}
10 License: wxWindows Licence
11 Group: System/Libraries
12 Source: wxMGL-%{ver}.tar.bz2
13 URL: http://www.wxwindows.org
14 Packager: Vaclav Slavik <vaclav@wxwindows.org>
15 Prefix: %{pref}
16 BuildRoot: /var/tmp/%{name}-root
17
18 # all packages providing an implementation of wxWindows library (regardless of
19 # the toolkit used) should provide the (virtual) wxwin package, this makes it
20 # possible to require wxwin instead of requiring "wxgtk or wxmotif or wxuniv..."
21 Provides: wxwin
22
23 Provides: libwx_mgl.so
24 Provides: libwx_mgl-%{ver2}.so
25
26 Requires: mgl
27 BuildRequires: mgl-devel
28
29 %description
30 wxWindows is a free C++ library for cross-platform GUI development.
31 With wxWindows, you can create applications for different GUIs (GTK+,
32 Motif/LessTif, MS Windows, Mac) from the same source code.
33
34 %package devel
35 Summary: The SciTech MGL port of the wxWindows library
36 Group: Development/Libraries
37 Requires: wxMGL = %{ver}
38
39 %description devel
40 Header files for wxMGL, the SciTech MGL port of the wxWindows library.
41
42 %package static
43 Summary: wxMGL static libraries
44 Group: Development/Libraries
45
46 %description static
47 Static libraries for wxMGL. You need them if you want to link statically against wxMGL.
48
49 %prep
50 %setup -n wxMGL-%{ver}
51
52 %build
53 if [ "$SMP" != "" ]; then
54 export MAKE="make -j$SMP"
55 else
56 export MAKE="make"
57 fi
58
59 mkdir obj-shared
60 cd obj-shared
61 ../configure --prefix=%{pref} --with-mgl --disable-fs_inet
62 $MAKE
63 cd ..
64
65 mkdir obj-static
66 cd obj-static
67 ../configure --prefix=%{pref} --disable-shared --with-mgl --disable-fs_inet
68 $MAKE
69 cd ..
70
71 %install
72 rm -rf $RPM_BUILD_ROOT
73 (cd obj-static; make prefix=$RPM_BUILD_ROOT%{pref} install)
74 (cd obj-shared; make prefix=$RPM_BUILD_ROOT%{pref} install)
75
76 %find_lang wxstd
77
78 %clean
79 rm -rf $RPM_BUILD_ROOT
80
81 %post
82 /sbin/ldconfig
83
84 %postun
85 /sbin/ldconfig
86
87 %files -f wxstd.lang
88 %defattr(-,root,root)
89 %doc COPYING.LIB *.txt
90 %{_libdir}/libwx_mgl*-%{ver2}*.so.*
91
92 %files devel
93 %defattr(-,root,root)
94 %{_libdir}/libwx_mgl*-%{ver2}*.so
95 %dir %{_includedir}/wx-*
96 %{_includedir}/wx-*/*
97 %dir %{_libdir}/wx
98 %{_libdir}/wx/*
99 %{_bindir}/wxmgl*-config
100 %{_datadir}/aclocal/*.m4
101
102 %files static
103 %defattr (-,root,root)
104 %{_libdir}/lib*.a