6 # Configurable settings (use --with(out) unicode on rpmbuild cmd line):
8 %{?_with_unicode: %{expand: %%define unicode 1}}
9 %{?_without_unicode: %{expand: %%define unicode 0}}
13 %define name wx
-%{portname}-unicode
14 %define wxbasename wx
-base
-unicode
16 %define name wx
-%{portname}
17 %define wxbasename wx
-base
21 %define wxconfigname wx
%{portname}univu-%{ver2}-config
23 %define wxconfigname wx
%{portname}univ-%{ver2}-config
26 Summary: The X11 port of the wxWindows library
30 License: wxWindows Licence
32 Source: wxX11
-%{ver}.tar.bz2
33 URL: http
://www.wxwindows.org
34 Packager: Vadim Zeitlin
<vadim@wxwindows.org
>
36 BuildRoot: /var
/tmp
/%{name}-root
38 # all packages providing an implementation of wxWindows library (regardless of
39 # the toolkit used) should provide the (virtual) wxwin package, this makes it
40 # possible to require wxwin instead of requiring "wxgtk or wxmotif or wxuniv..."
43 # in addition, we should provide libwx_gtk as automatic generator only notices
44 # libwx_gtk-%{ver}-%{rel}
45 Provides: libwx_x11.so
46 Provides: libwx_x11
-%{ver2}.so
49 Requires: %{wxbasename} = %{ver}
52 wxWindows is a free C
++ library
for cross
-platform GUI development.
53 With wxWindows
, you can create applications
for different GUIs
(GTK
+,
54 Motif
/LessTif
, MS Windows
, Mac
) from the same
source code.
57 Summary: The X11 port of the wxWindows library
59 Requires: %{name} = %{ver}
60 Requires: %{wxbasename}-devel = %{ver}
63 Header files
for wxX11
, the X11 port of the wxWindows library.
66 Summary: The X11 port of the wxWindows library
, OpenGL add
-on.
68 Requires: %{name} = %{ver}
71 OpenGL add
-on library
for wxX11
, the X11 port of the wxWindows library.
74 Summary: wxX11 static libraries
75 Group: Development
/Libraries
78 Static libraries
for wxX11. You need them
if you want to link statically against wxX11.
81 Summary: Contrib libraries
for wxX11.
83 Requires: %{name} = %{ver}
86 Contributed libraries
for wxX11.
88 %package contrib
-devel
89 Summary: Contrib libraries
for wxX11.
91 Requires: %{name}-contrib = %{ver}
92 Requires: %{name}-devel = %{ver}
94 %description contrib
-devel
95 Header files
for contributed libraries
for wxX11.
98 %setup -q
-n wxX11
-%{ver}
101 if [ "$SMP"
!= ""
]; then
102 export MAKE
="
make -j$SMP"
109 ..
/configure
--prefix
=%{pref} --with
-x11 \
123 ..
/configure
--prefix
=%{pref} --with
-x11
--disable
-shared \
134 rm -rf $RPM_BUILD_ROOT
135 (cd obj
-static
; make prefix
=$RPM_BUILD_ROOT
%{pref} install)
136 (cd obj
-shared
; make prefix
=$RPM_BUILD_ROOT
%{pref} install)
138 # Remove headers that are part of wx-base-devel:
140 # --- wxBase headers list begins here ---
141 cat
<<EOF
>wxbase
-headers
-list
253 wx
/protocol
/protocol.h
266 # --- wxBase headers list ends here ---
267 for f
in `cat wxbase
-headers
-list`
; do
268 rm -f $RPM_BUILD_ROOT
%{_includedir}/$f
271 # list of all core headers:
272 find $RPM_BUILD_ROOT
/usr
/include
/wx
-type f | sed
-e "s
,$RPM_BUILD_ROOT
,,g"
>core
-headers.files
275 (cd obj
-shared
/contrib
/src
; make prefix
=$RPM_BUILD_ROOT
%{pref} install)
276 (cd obj
-shared
/contrib
/utils
/wxrc
; make prefix
=$RPM_BUILD_ROOT
%{pref} install)
279 rm -rf $RPM_BUILD_ROOT
294 # Install wx-config if there isn't any
295 if test ! -f
%{_bindir}/wx
-config
; then
296 ln
-sf
%{wxconfigname} %{_bindir}/wx
-config
300 # Remove wx-config if it points to this package
301 if test -f
%{_bindir}/wx
-config
-a
-f
/usr
/bin
/md5sum
; then
302 SUM1
=`md5sum
%{_bindir}/%{wxconfigname} | cut
-c
0-32`
303 SUM2
=`md5sum
%{_bindir}/wx
-config | cut
-c
0-32`
304 if test "x$SUM1"
= "x$SUM2"
; then
305 rm -f
%{_bindir}/wx
-config
311 %defattr(-,root
,root
)
312 %doc COPYING.LIB
*.txt
315 %{_libdir}/libwx_%{portname}*_core
*.so.
*
316 %{_libdir}/libwx_%{portname}*_html
*.so.
*
317 %{_libdir}/libwx_%{portname}*_adv
*.so.
*
319 %{_libdir}/libwx_%{portname}*_dbgrid
*.so.
*
322 %files devel
-f core
-headers.files
323 %defattr(-,root
,root
)
324 %{_libdir}/libwx_%{portname}*_core
*.so
325 %{_libdir}/libwx_%{portname}*_html
*.so
326 %{_libdir}/libwx_%{portname}*_adv
*.so
328 %{_libdir}/libwx_%{portname}*_dbgrid
*.so
330 %{_libdir}/libwx_%{portname}*_gl
*.so
333 %{_bindir}/%{wxconfigname}
336 %defattr(-,root
,root
)
337 %{_libdir}/libwx_%{portname}*_gl
*.so.
*
340 %defattr (-,root
,root
)
341 %{_libdir}/libwx_%{portname}*.a
344 %defattr(-,root
,root
)
345 %{_libdir}/libwx_%{portname}*_animate
*.so.
*
346 %{_libdir}/libwx_%{portname}*_deprecated
*.so.
*
347 %{_libdir}/libwx_%{portname}*_fl
*.so.
*
348 %{_libdir}/libwx_%{portname}*_gizmos
*.so.
*
349 %{_libdir}/libwx_%{portname}*_mmedia
*.so.
*
350 %{_libdir}/libwx_%{portname}*_ogl
*.so.
*
351 %{_libdir}/libwx_%{portname}*_plot
*.so.
*
352 %{_libdir}/libwx_%{portname}*_stc
*.so.
*
353 %{_libdir}/libwx_%{portname}*_svg
*.so.
*
354 %{_libdir}/libwx_%{portname}*_xrc
*.so.
*
357 %defattr(-,root
,root
)
359 %dir %{_includedir}/wx
/animate
360 %{_includedir}/wx
/animate
/*
361 %{_libdir}/libwx_%{portname}*_animate
*.so
363 %dir %{_includedir}/wx
/deprecated
364 %{_includedir}/wx
/deprecated
/*
365 %{_libdir}/libwx_%{portname}*_deprecated
*.so
367 %dir %{_includedir}/wx
/fl
368 %{_includedir}/wx
/fl
/*
369 %{_libdir}/libwx_%{portname}*_fl
*.so
371 %dir %{_includedir}/wx
/gizmos
372 %{_includedir}/wx
/gizmos
/*
373 %{_libdir}/libwx_%{portname}*_gizmos
*.so
375 %dir %{_includedir}/wx
/mmedia
376 %{_includedir}/wx
/mmedia
/*
377 %{_libdir}/libwx_%{portname}*_mmedia
*.so
379 %dir %{_includedir}/wx
/ogl
380 %{_includedir}/wx
/ogl
/*
381 %{_libdir}/libwx_%{portname}*_ogl
*.so
383 %dir %{_includedir}/wx
/plot
384 %{_includedir}/wx
/plot
/*
385 %{_libdir}/libwx_%{portname}*_plot
*.so
387 %dir %{_includedir}/wx
/stc
388 %{_includedir}/wx
/stc
/*
389 %{_libdir}/libwx_%{portname}*_stc
*.so
391 %dir %{_includedir}/wx
/svg
392 %{_includedir}/wx
/svg
/*
393 %{_libdir}/libwx_%{portname}*_svg
*.so
395 %dir %{_includedir}/wx
/xrc
396 %{_includedir}/wx
/xrc
/*
397 %{_libdir}/libwx_%{portname}*_xrc
*.so