fixed to the newly added crt.h header:
[wxWidgets.git] / wxGTK.spec
1 %define _prefix /usr
2 %define ver 2.9.0
3 %define ver2 2.9
4 %define rel 1
5
6 # Configurable settings (use --with(out) {unicode,gtk2} on rpmbuild cmd line):
7 %define unicode 1
8 %{?_with_unicode: %{expand: %%define unicode 1}}
9 %{?_without_unicode: %{expand: %%define unicode 0}}
10
11 %define gtk2 1
12 %{?_with_gtk2: %{expand: %%define gtk2 1}}
13 %{?_without_gtk2: %{expand: %%define gtk2 0}}
14
15 # "buildname" needs to be e.g. gtk2ud for debug builds
16 %if %{gtk2}
17 %define gtkver 2
18 %define portname gtk2
19 %if %{unicode}
20 %define buildname gtk2u
21 %else
22 %define buildname gtk2
23 %endif
24 %else
25 %define gtkver 1.2
26 %define portname gtk
27 %define buildname gtk
28 %endif
29
30 %if %{unicode}
31 %define name wx-%{portname}-unicode
32 %define wxconfig %{portname}-unicode-release-%{ver2}
33 %define wxconfigstatic %{portname}-unicode-release-static-%{ver2}
34 %define wxconfiglink wx%{portname}u-%{ver2}-config
35 %else
36 %define name wx-%{portname}-ansi
37 %define wxconfig %{portname}-ansi-release-%{ver2}
38 %define wxconfigstatic %{portname}-ansi-release-static-%{ver2}
39 %define wxconfiglink wx%{portname}-%{ver2}-config
40 %endif
41
42 %if %{unicode}
43 %define wxbasename wx-base-unicode
44 %define wxbaseconfig base-unicode-release-%{ver2}
45 %define wxbaseconfiglink wxbaseu-%{ver2}-config
46 %else
47 %define wxbasename wx-base-ansi
48 %define wxbaseconfig base-ansi-release-%{ver2}
49 %define wxbaseconfiglink wxbase-%{ver2}-config
50 %endif
51
52 Summary: The GTK+ %{gtkver} port of the wxWidgets library
53 Name: %{name}
54 Version: %{ver}
55 Release: %{rel}
56 License: wxWindows Licence
57 Group: X11/Libraries
58 Source: wxGTK-%{ver}.tar.bz2
59 URL: http://www.wxwidgets.org
60 Packager: Vadim Zeitlin <vadim@wxwindows.org>
61 Prefix: %{_prefix}
62 BuildRoot: %{_tmppath}/%{name}-root
63 Requires: %{wxbasename} = %{ver}
64 %if %{portname} == gtk2
65 BuildRequires: gtk+-2.0-devel
66 %else
67 BuildRequires: gtk+-devel >= 1.2.0
68 %endif
69
70 BuildRequires: zlib-devel, libjpeg-devel, libpng-devel, libtiff-devel
71
72 # all packages providing an implementation of wxWidgets library (regardless of
73 # the toolkit used) should provide the (virtual) wxwin package, this makes it
74 # possible to require wxwin instead of requiring "wxgtk or wxmotif or wxuniv..."
75 Provides: wxwin
76 Provides: wxGTK
77
78 %description
79 wxWidgets is a free C++ library for cross-platform GUI development.
80 With wxWidgets, you can create applications for different GUIs (GTK+,
81 Motif, MS Windows, MacOS X, Windows CE, GPE) from the same source code.
82
83 %package -n wx-i18n
84 Summary: The translations for the wxWidgets library.
85 Group: X11/Libraries
86
87 %description -n wx-i18n
88 The translations files for the wxWidgets library.
89
90 %package devel
91 Summary: The GTK+ %{gtkver} port of the wxWidgets library
92 Group: X11/Libraries
93 Requires: %{name} = %{ver}
94 Requires: %{wxbasename}-devel = %{ver}
95 Provides: wxGTK-devel
96
97 %description devel
98 The GTK+ %{gtkver} port of the wxWidgets library, header files.
99
100 %package gl
101 Summary: The GTK+ %{gtkver} port of the wxWidgets library, OpenGL add-on.
102 Group: X11/Libraries
103 Requires: %{name} = %{ver}
104 Provides: wxGTK-gl
105
106 %description gl
107 OpenGL add-on library for wxGTK, the GTK+ %{gtkver} port of the wxWidgets library.
108
109 %package -n %{wxbasename}
110 Summary: wxBase library - non-GUI support classes of the wxWidgets toolkit
111 Group: Development/Libraries
112 Provides: wxBase
113
114 %description -n %{wxbasename}
115 wxBase is a collection of C++ classes providing basic data structures (strings,
116 lists, arrays), portable wrappers around many OS-specific funstions (file
117 operations, time/date manipulations, threads, processes, sockets, shared
118 library loading) as well as other utility classes (streams, archive and
119 compression). wxBase currently supports Win32, most Unix variants (Linux,
120 FreeBSD, Solaris, HP-UX) and MacOS X (Carbon and Mach-0).
121
122 %package -n %{wxbasename}-devel
123 Summary: wxBase library, header files.
124 Group: Development/Libraries
125 Provides: wxBase-devel
126
127 %description -n %{wxbasename}-devel
128 wxBase library - non-GUI support classes of the wxWidgets toolkit,
129 header files.
130
131 %package contrib
132 Summary: The GTK+ %{gtkver} port of the wxWidgets library, contributed libraries.
133 Group: X11/Libraries
134 Requires: %{name} = %{ver}
135
136 %description contrib
137 Contributed libraries for wxGTK, the GTK+ %{gtkver} port of the wxWidgets library.
138
139 %package contrib-devel
140 Summary: The GTK+ %{gtkver} port of the wxWidgets library
141 Group: X11/Libraries
142 Requires: %{name}-contrib = %{ver}
143 Requires: %{name}-devel = %{ver}
144
145 %description contrib-devel
146 Header files for contributed libraries for wxGTK, the GTK+ %{gtkver} port of the wxWidgets library.
147
148 %prep
149 %setup -q -n wxGTK-%{ver}
150
151 %build
152 if [ "$SMP" != "" ]; then
153 export MAKE="make -j$SMP"
154 else
155 export MAKE="make"
156 fi
157
158 mkdir obj-shared
159 cd obj-shared
160 ../configure --prefix=%{_prefix} \
161 %if ! %{gtk2}
162 --with-gtk=1 \
163 %else
164 --with-gtk=2 \
165 %endif
166 %if %{unicode}
167 --enable-unicode \
168 %else
169 --disable-unicode \
170 --with-odbc \
171 %endif
172 --with-opengl
173 $MAKE
174
175 cd contrib/src
176 $MAKE
177 cd ../../..
178
179 mkdir obj-static
180 cd obj-static
181 ../configure --prefix=%{_prefix} \
182 %if ! %{gtk2}
183 --with-gtk=1 \
184 %else
185 --with-gtk=2 \
186 %endif
187 --disable-shared \
188 %if %{unicode}
189 --enable-unicode \
190 %else
191 --disable-unicode \
192 --with-odbc \
193 %endif
194 --with-opengl
195 $MAKE
196
197 cd contrib/src
198 $MAKE
199 cd ../../..
200
201 make -C locale allmo
202
203 %install
204 rm -rf $RPM_BUILD_ROOT
205 (cd obj-static; make DESTDIR=$RPM_BUILD_ROOT prefix=%{_prefix} install)
206 (cd obj-shared; make DESTDIR=$RPM_BUILD_ROOT prefix=%{_prefix} install)
207
208 # --- wxBase headers list begins here ---
209 cat <<EOF >wxbase-headers.files
210 wx/afterstd.h
211 wx/app.h
212 wx/apptrait.h
213 wx/archive.h
214 wx/arrimpl.cpp
215 wx/arrstr.h
216 wx/beforestd.h
217 wx/buffer.h
218 wx/build.h
219 wx/chartype.h
220 wx/chkconf.h
221 wx/clntdata.h
222 wx/cmdline.h
223 wx/confbase.h
224 wx/config.h
225 wx/convauto.h
226 wx/containr.h
227 wx/cpp.h
228 wx/crt.h
229 wx/datetime.h
230 wx/datstrm.h
231 wx/dde.h
232 wx/debug.h
233 wx/defs.h
234 wx/dir.h
235 wx/dlimpexp.h
236 wx/dynarray.h
237 wx/dynlib.h
238 wx/dynload.h
239 wx/encconv.h
240 wx/event.h
241 wx/except.h
242 wx/features.h
243 wx/flags.h
244 wx/ffile.h
245 wx/file.h
246 wx/fileconf.h
247 wx/filefn.h
248 wx/filename.h
249 wx/filesys.h
250 wx/fontenc.h
251 wx/fontmap.h
252 wx/fs_arc.h
253 wx/fs_filter.h
254 wx/fs_mem.h
255 wx/fs_zip.h
256 wx/hash.h
257 wx/hashmap.h
258 wx/hashset.h
259 wx/html/forcelnk.h
260 wx/iconloc.h
261 wx/init.h
262 wx/intl.h
263 wx/iosfwrap.h
264 wx/ioswrap.h
265 wx/ipc.h
266 wx/ipcbase.h
267 wx/isql.h
268 wx/isqlext.h
269 wx/link.h
270 wx/list.h
271 wx/listimpl.cpp
272 wx/log.h
273 wx/longlong.h
274 wx/math.h
275 wx/memconf.h
276 wx/memory.h
277 wx/memtext.h
278 wx/mimetype.h
279 wx/module.h
280 wx/msgout.h
281 wx/mstream.h
282 wx/object.h
283 wx/platform.h
284 wx/platinfo.h
285 wx/power.h
286 wx/process.h
287 wx/ptr_scpd.h
288 wx/recguard.h
289 wx/regex.h
290 wx/scopeguard.h
291 wx/snglinst.h
292 wx/sstream.h
293 wx/stack.h
294 wx/stackwalk.h
295 wx/stdpaths.h
296 wx/stockitem.h
297 wx/stopwatch.h
298 wx/strconv.h
299 wx/stream.h
300 wx/string.h
301 wx/stringimpl.h
302 wx/stringops.h
303 wx/strvararg.h
304 wx/sysopt.h
305 wx/tarstrm.h
306 wx/textbuf.h
307 wx/textfile.h
308 wx/thread.h
309 wx/thrimpl.cpp
310 wx/timer.h
311 wx/tokenzr.h
312 wx/txtstrm.h
313 wx/types.h
314 wx/unichar.h
315 wx/uri.h
316 wx/utils.h
317 wx/variant.h
318 wx/vector.h
319 wx/version.h
320 wx/volume.h
321 wx/wfstream.h
322 wx/wx.h
323 wx/wxchar.h
324 wx/wxcrt.h
325 wx/wxcrtvararg.h
326 wx/wxprec.h
327 wx/xti.h
328 wx/xtistrm.h
329 wx/zipstrm.h
330 wx/zstream.h
331 wx/unix/app.h
332 wx/unix/apptbase.h
333 wx/unix/apptrait.h
334 wx/unix/execute.h
335 wx/unix/evtloop.h
336 wx/unix/mimetype.h
337 wx/unix/pipe.h
338 wx/unix/private.h
339 wx/unix/stackwalk.h
340 wx/unix/stdpaths.h
341 wx/fs_inet.h
342 wx/gsocket.h
343 wx/protocol/file.h
344 wx/protocol/ftp.h
345 wx/protocol/http.h
346 wx/protocol/protocol.h
347 wx/sckaddr.h
348 wx/sckipc.h
349 wx/sckstrm.h
350 wx/socket.h
351 wx/url.h
352 wx/unix/gsockunx.h
353 wx/xml/xml.h
354 wx/xtixml.h
355 wx/db.h
356 wx/dbkeyg.h
357 wx/dbtable.h
358 EOF
359 # --- wxBase headers list ends here ---
360 cat <<EOF >wxbase-headers.paths
361 %{_includedir}/wx-%{ver2}/wx/afterstd.h
362 %{_includedir}/wx-%{ver2}/wx/app.h
363 %{_includedir}/wx-%{ver2}/wx/apptrait.h
364 %{_includedir}/wx-%{ver2}/wx/archive.h
365 %{_includedir}/wx-%{ver2}/wx/arrimpl.cpp
366 %{_includedir}/wx-%{ver2}/wx/arrstr.h
367 %{_includedir}/wx-%{ver2}/wx/beforestd.h
368 %{_includedir}/wx-%{ver2}/wx/buffer.h
369 %{_includedir}/wx-%{ver2}/wx/build.h
370 %{_includedir}/wx-%{ver2}/wx/chkconf.h
371 %{_includedir}/wx-%{ver2}/wx/clntdata.h
372 %{_includedir}/wx-%{ver2}/wx/cmdline.h
373 %{_includedir}/wx-%{ver2}/wx/confbase.h
374 %{_includedir}/wx-%{ver2}/wx/config.h
375 %{_includedir}/wx-%{ver2}/wx/containr.h
376 %{_includedir}/wx-%{ver2}/wx/convauto.h
377 %{_includedir}/wx-%{ver2}/wx/datetime.h
378 %{_includedir}/wx-%{ver2}/wx/datstrm.h
379 %{_includedir}/wx-%{ver2}/wx/dde.h
380 %{_includedir}/wx-%{ver2}/wx/debug.h
381 %{_includedir}/wx-%{ver2}/wx/defs.h
382 %{_includedir}/wx-%{ver2}/wx/dir.h
383 %{_includedir}/wx-%{ver2}/wx/dlimpexp.h
384 %{_includedir}/wx-%{ver2}/wx/dynarray.h
385 %{_includedir}/wx-%{ver2}/wx/dynlib.h
386 %{_includedir}/wx-%{ver2}/wx/dynload.h
387 %{_includedir}/wx-%{ver2}/wx/encconv.h
388 %{_includedir}/wx-%{ver2}/wx/event.h
389 %{_includedir}/wx-%{ver2}/wx/except.h
390 %{_includedir}/wx-%{ver2}/wx/features.h
391 %{_includedir}/wx-%{ver2}/wx/ffile.h
392 %{_includedir}/wx-%{ver2}/wx/file.h
393 %{_includedir}/wx-%{ver2}/wx/fileconf.h
394 %{_includedir}/wx-%{ver2}/wx/filefn.h
395 %{_includedir}/wx-%{ver2}/wx/filename.h
396 %{_includedir}/wx-%{ver2}/wx/filesys.h
397 %{_includedir}/wx-%{ver2}/wx/fontenc.h
398 %{_includedir}/wx-%{ver2}/wx/fontmap.h
399 %{_includedir}/wx-%{ver2}/wx/fs_mem.h
400 %{_includedir}/wx-%{ver2}/wx/fs_zip.h
401 %{_includedir}/wx-%{ver2}/wx/hash.h
402 %{_includedir}/wx-%{ver2}/wx/hashmap.h
403 %{_includedir}/wx-%{ver2}/wx/hashset.h
404 %{_includedir}/wx-%{ver2}/wx/html/forcelnk.h
405 %{_includedir}/wx-%{ver2}/wx/iconloc.h
406 %{_includedir}/wx-%{ver2}/wx/init.h
407 %{_includedir}/wx-%{ver2}/wx/intl.h
408 %{_includedir}/wx-%{ver2}/wx/iosfwrap.h
409 %{_includedir}/wx-%{ver2}/wx/ioswrap.h
410 %{_includedir}/wx-%{ver2}/wx/ipc.h
411 %{_includedir}/wx-%{ver2}/wx/ipcbase.h
412 %{_includedir}/wx-%{ver2}/wx/isql.h
413 %{_includedir}/wx-%{ver2}/wx/isqlext.h
414 %{_includedir}/wx-%{ver2}/wx/link.h
415 %{_includedir}/wx-%{ver2}/wx/list.h
416 %{_includedir}/wx-%{ver2}/wx/listimpl.cpp
417 %{_includedir}/wx-%{ver2}/wx/log.h
418 %{_includedir}/wx-%{ver2}/wx/longlong.h
419 %{_includedir}/wx-%{ver2}/wx/math.h
420 %{_includedir}/wx-%{ver2}/wx/memconf.h
421 %{_includedir}/wx-%{ver2}/wx/memory.h
422 %{_includedir}/wx-%{ver2}/wx/memtext.h
423 %{_includedir}/wx-%{ver2}/wx/mimetype.h
424 %{_includedir}/wx-%{ver2}/wx/module.h
425 %{_includedir}/wx-%{ver2}/wx/msgout.h
426 %{_includedir}/wx-%{ver2}/wx/mstream.h
427 %{_includedir}/wx-%{ver2}/wx/object.h
428 %{_includedir}/wx-%{ver2}/wx/platform.h
429 %{_includedir}/wx-%{ver2}/wx/power.h
430 %{_includedir}/wx-%{ver2}/wx/process.h
431 %{_includedir}/wx-%{ver2}/wx/ptr_scpd.h
432 %{_includedir}/wx-%{ver2}/wx/recguard.h
433 %{_includedir}/wx-%{ver2}/wx/regex.h
434 %{_includedir}/wx-%{ver2}/wx/scopeguard.h
435 %{_includedir}/wx-%{ver2}/wx/snglinst.h
436 %{_includedir}/wx-%{ver2}/wx/sstream.h
437 %{_includedir}/wx-%{ver2}/wx/stack.h
438 %{_includedir}/wx-%{ver2}/wx/stackwalk.h
439 %{_includedir}/wx-%{ver2}/wx/stdpaths.h
440 %{_includedir}/wx-%{ver2}/wx/stockitem.h
441 %{_includedir}/wx-%{ver2}/wx/stopwatch.h
442 %{_includedir}/wx-%{ver2}/wx/strconv.h
443 %{_includedir}/wx-%{ver2}/wx/stream.h
444 %{_includedir}/wx-%{ver2}/wx/string.h
445 %{_includedir}/wx-%{ver2}/wx/sysopt.h
446 %{_includedir}/wx-%{ver2}/wx/textbuf.h
447 %{_includedir}/wx-%{ver2}/wx/textfile.h
448 %{_includedir}/wx-%{ver2}/wx/thread.h
449 %{_includedir}/wx-%{ver2}/wx/thrimpl.cpp
450 %{_includedir}/wx-%{ver2}/wx/timer.h
451 %{_includedir}/wx-%{ver2}/wx/tokenzr.h
452 %{_includedir}/wx-%{ver2}/wx/txtstrm.h
453 %{_includedir}/wx-%{ver2}/wx/types.h
454 %{_includedir}/wx-%{ver2}/wx/uri.h
455 %{_includedir}/wx-%{ver2}/wx/utils.h
456 %{_includedir}/wx-%{ver2}/wx/variant.h
457 %{_includedir}/wx-%{ver2}/wx/vector.h
458 %{_includedir}/wx-%{ver2}/wx/version.h
459 %{_includedir}/wx-%{ver2}/wx/volume.h
460 %{_includedir}/wx-%{ver2}/wx/wfstream.h
461 %{_includedir}/wx-%{ver2}/wx/wx.h
462 %{_includedir}/wx-%{ver2}/wx/wxchar.h
463 %{_includedir}/wx-%{ver2}/wx/wxprec.h
464 %{_includedir}/wx-%{ver2}/wx/xti.h
465 %{_includedir}/wx-%{ver2}/wx/xtistrm.h
466 %{_includedir}/wx-%{ver2}/wx/zipstrm.h
467 %{_includedir}/wx-%{ver2}/wx/zstream.h
468 %{_includedir}/wx-%{ver2}/wx/fs_inet.h
469 %{_includedir}/wx-%{ver2}/wx/gsocket.h
470 %{_includedir}/wx-%{ver2}/wx/protocol/file.h
471 %{_includedir}/wx-%{ver2}/wx/protocol/ftp.h
472 %{_includedir}/wx-%{ver2}/wx/protocol/http.h
473 %{_includedir}/wx-%{ver2}/wx/protocol/protocol.h
474 %{_includedir}/wx-%{ver2}/wx/sckaddr.h
475 %{_includedir}/wx-%{ver2}/wx/sckipc.h
476 %{_includedir}/wx-%{ver2}/wx/sckstrm.h
477 %{_includedir}/wx-%{ver2}/wx/socket.h
478 %{_includedir}/wx-%{ver2}/wx/url.h
479 %{_includedir}/wx-%{ver2}/wx/xml/xml.h
480 %{_includedir}/wx-%{ver2}/wx/xtixml.h
481 %{_includedir}/wx-%{ver2}/wx/db.h
482 %{_includedir}/wx-%{ver2}/wx/dbkeyg.h
483 %{_includedir}/wx-%{ver2}/wx/dbtable.h
484 %{_includedir}/wx-%{ver2}/wx/unix/apptbase.h
485 %{_includedir}/wx-%{ver2}/wx/unix/apptrait.h
486 %{_includedir}/wx-%{ver2}/wx/unix/execute.h
487 %{_includedir}/wx-%{ver2}/wx/unix/gsockunx.h
488 %{_includedir}/wx-%{ver2}/wx/unix/mimetype.h
489 %{_includedir}/wx-%{ver2}/wx/unix/pipe.h
490 %{_includedir}/wx-%{ver2}/wx/unix/private.h
491 %{_includedir}/wx-%{ver2}/wx/unix/stackwalk.h
492 %{_includedir}/wx-%{ver2}/wx/unix/stdpaths.h
493 EOF
494 # --- wxBase headers list ends here ---
495
496 # temporarily remove base headers
497 mkdir $RPM_BUILD_ROOT/_save_dir
498 cp -r $RPM_BUILD_ROOT%{_includedir}/wx-%{ver2} $RPM_BUILD_ROOT/_save_dir
499 for f in `cat wxbase-headers.files` ; do
500 rm -f $RPM_BUILD_ROOT%{_includedir}/wx-%{ver2}/$f
501 done
502 # list of all core headers:
503 find $RPM_BUILD_ROOT%{_includedir}/wx-%{ver2} -type f | sed -e "s,$RPM_BUILD_ROOT,,g" >core-headers.files
504 # move base headers (actually all headers) back again
505 cp -f -r $RPM_BUILD_ROOT/_save_dir/* $RPM_BUILD_ROOT%{_includedir}
506 rm -rf $RPM_BUILD_ROOT/_save_dir
507
508 # contrib stuff:
509 (cd obj-static/contrib; make DESTDIR=$RPM_BUILD_ROOT prefix=%{_prefix} install)
510 (cd obj-shared/contrib; make DESTDIR=$RPM_BUILD_ROOT prefix=%{_prefix} install)
511
512 # utils:
513 (cd obj-shared/utils/wxrc; make DESTDIR=$RPM_BUILD_ROOT prefix=%{_prefix} install)
514
515 # wx-config link is created during package installation, remove it for now
516 rm -f $RPM_BUILD_ROOT%{_bindir}/wx-config
517
518 %clean
519 rm -rf $RPM_BUILD_ROOT
520
521 %post
522 /sbin/ldconfig
523
524 %postun
525 /sbin/ldconfig
526
527 %post devel
528 # link wx-config when you install RPM.
529 %if %{unicode}
530 ln -sf %{_libdir}/wx/config/%{wxconfig} %{_bindir}/wx-config
531 %endif
532 # link wx-config with explicit name.
533 ln -sf %{_libdir}/wx/config/%{wxconfig} %{_bindir}/%{wxconfiglink}
534 /sbin/ldconfig
535
536 %postun devel
537 /sbin/ldconfig
538
539 %preun devel
540 %if %{unicode}
541 rm -f %{_bindir}/wx-config
542 %endif
543 rm -f %{_bindir}/%{wxconfiglink}
544
545 %post -n %{wxbasename}
546 /sbin/ldconfig
547
548 %postun -n %{wxbasename}
549 /sbin/ldconfig
550
551 %post -n %{wxbasename}-devel
552 # link wx-config with explicit name.
553 ln -sf %{_libdir}/wx/config/%{wxbaseconfig} %{_bindir}/%{wxbaseconfiglink}
554 /sbin/ldconfig
555
556 %postun -n %{wxbasename}-devel
557 /sbin/ldconfig
558
559 %preun -n %{wxbasename}-devel
560 rm -f %{_bindir}/%{wxbaseconfiglink}
561
562 %post gl
563 /sbin/ldconfig
564
565 %postun gl
566 /sbin/ldconfig
567
568 %post contrib
569 /sbin/ldconfig
570
571 %postun contrib
572 /sbin/ldconfig
573
574 %post contrib-devel
575 /sbin/ldconfig
576
577 %postun contrib-devel
578 /sbin/ldconfig
579
580 %files
581 %defattr(-,root,root)
582 %doc COPYING.LIB *.txt
583 %{_libdir}/libwx_%{buildname}_adv-%{ver2}.so.*
584 %{_libdir}/libwx_%{buildname}_aui-%{ver2}.so.*
585 %{_libdir}/libwx_%{buildname}_core-%{ver2}.so.*
586 %if !%{unicode}
587 %{_libdir}/libwx_%{buildname}_dbgrid-%{ver2}.so.*
588 %endif
589 %{_libdir}/libwx_%{buildname}_html-%{ver2}.so.*
590 %{_libdir}/libwx_%{buildname}_mmedia-%{ver2}.so.*
591 %{_libdir}/libwx_%{buildname}_qa-%{ver2}.so.*
592 %{_libdir}/libwx_%{buildname}_richtext-%{ver2}.so.*
593 %{_libdir}/libwx_%{buildname}_xrc-%{ver2}.so.*
594
595 %files -n wx-i18n
596 %defattr(-,root,root)
597 %{_datadir}/locale/*/LC_MESSAGES/*.mo
598
599 %files devel -f core-headers.files
600 %defattr(-,root,root)
601 # shared libs
602 %{_libdir}/libwx_%{buildname}_adv-%{ver2}.so
603 %{_libdir}/libwx_%{buildname}_aui-%{ver2}.so
604 %{_libdir}/libwx_%{buildname}_core-%{ver2}.so
605 %if !%{unicode}
606 %{_libdir}/libwx_%{buildname}_dbgrid-%{ver2}.so
607 %endif
608 %{_libdir}/libwx_%{buildname}_gl-%{ver2}.so
609 %{_libdir}/libwx_%{buildname}_html-%{ver2}.so
610 %{_libdir}/libwx_%{buildname}_mmedia-%{ver2}.so
611 %{_libdir}/libwx_%{buildname}_qa-%{ver2}.so
612 %{_libdir}/libwx_%{buildname}_richtext-%{ver2}.so
613 %{_libdir}/libwx_%{buildname}_xrc-%{ver2}.so
614 # static libs
615 %{_libdir}/libwx_%{buildname}_adv-%{ver2}.a
616 %{_libdir}/libwx_%{buildname}_aui-%{ver2}.a
617 %{_libdir}/libwx_%{buildname}_core-%{ver2}.a
618 %if !%{unicode}
619 %{_libdir}/libwx_%{buildname}_dbgrid-%{ver2}.a
620 %endif
621 %{_libdir}/libwx_%{buildname}_gl-%{ver2}.a
622 %{_libdir}/libwx_%{buildname}_html-%{ver2}.a
623 %{_libdir}/libwx_%{buildname}_qa-%{ver2}.a
624 %{_libdir}/libwx_%{buildname}_richtext-%{ver2}.a
625 %{_libdir}/libwx_%{buildname}_xrc-%{ver2}.a
626 %dir %{_libdir}/wx
627 %{_libdir}/wx/config/%{wxconfig}
628 %{_libdir}/wx/include/%{wxconfig}/wx/setup.h
629 %{_libdir}/wx/config/%{wxconfigstatic}
630 %{_libdir}/wx/include/%{wxconfigstatic}/wx/setup.h
631 %{_bindir}/wxrc*
632
633 %files -n %{wxbasename}
634 %defattr(-,root,root)
635 %{_libdir}/libwx_base*-%{ver2}.so.*
636
637 %files -n %{wxbasename}-devel -f wxbase-headers.paths
638 %defattr (-,root,root)
639 %dir %{_includedir}/wx-%{ver2}
640 %{_libdir}/libwx_base*-%{ver2}.so
641 %{_libdir}/libwx_base*-%{ver2}.a
642 %if %{unicode}
643 %{_libdir}/libwxregexu-%{ver2}.a
644 %endif
645 %dir %{_libdir}/wx
646 %{_datadir}/aclocal/*.m4
647 %{_datadir}/bakefile/presets/*
648
649 %files gl
650 %defattr(-,root,root)
651 %{_libdir}/libwx_%{buildname}_gl-%{ver2}.so.*
652
653 %files contrib
654 %defattr(-,root,root)
655 %{_libdir}/libwx_%{buildname}_animate-%{ver2}.so.*
656 %{_libdir}/libwx_%{buildname}_deprecated-%{ver2}.so.*
657 %{_libdir}/libwx_%{buildname}_fl-%{ver2}.so.*
658 %{_libdir}/libwx_%{buildname}_gizmos-%{ver2}.so.*
659 %{_libdir}/libwx_%{buildname}_gizmos_xrc-%{ver2}.so.*
660 %{_libdir}/libwx_%{buildname}_mmedia-%{ver2}.so.*
661 %{_libdir}/libwx_%{buildname}_ogl-%{ver2}.so.*
662 %{_libdir}/libwx_%{buildname}_plot-%{ver2}.so.*
663 %{_libdir}/libwx_%{buildname}_stc-%{ver2}.so.*
664 %{_libdir}/libwx_%{buildname}_svg-%{ver2}.so.*
665
666 # static libs
667 %{_libdir}/libwx_%{buildname}_animate-%{ver2}.a
668 %{_libdir}/libwx_%{buildname}_deprecated-%{ver2}.a
669 %{_libdir}/libwx_%{buildname}_fl-%{ver2}.a
670 %{_libdir}/libwx_%{buildname}_gizmos-%{ver2}.a
671 %{_libdir}/libwx_%{buildname}_gizmos_xrc-%{ver2}.a
672 %{_libdir}/libwx_%{buildname}_mmedia-%{ver2}.a
673 %{_libdir}/libwx_%{buildname}_ogl-%{ver2}.a
674 %{_libdir}/libwx_%{buildname}_plot-%{ver2}.a
675 %{_libdir}/libwx_%{buildname}_stc-%{ver2}.a
676 %{_libdir}/libwx_%{buildname}_svg-%{ver2}.a
677
678 %files contrib-devel
679 %defattr(-,root,root)
680 %dir %{_includedir}/wx-%{ver2}/wx/animate
681 %{_includedir}/wx-%{ver2}/wx/animate/*
682 %{_libdir}/libwx_%{buildname}_animate-%{ver2}.so
683
684 %dir %{_includedir}/wx-%{ver2}/wx/deprecated
685 %{_includedir}/wx-%{ver2}/wx/deprecated/*
686 %{_libdir}/libwx_%{buildname}_deprecated-%{ver2}.so
687
688 %dir %{_includedir}/wx-%{ver2}/wx/fl
689 %{_includedir}/wx-%{ver2}/wx/fl/*
690 %{_libdir}/libwx_%{buildname}_fl-%{ver2}.so
691
692 %dir %{_includedir}/wx-%{ver2}/wx/gizmos
693 %{_includedir}/wx-%{ver2}/wx/gizmos/*
694 %{_libdir}/libwx_%{buildname}_gizmos-%{ver2}.so
695 %{_libdir}/libwx_%{buildname}_gizmos_xrc-%{ver2}.so
696
697 %dir %{_includedir}/wx-%{ver2}/wx/mmedia
698 %{_includedir}/wx-%{ver2}/wx/mmedia/*
699 %{_libdir}/libwx_%{buildname}_mmedia-%{ver2}.so
700
701 %dir %{_includedir}/wx-%{ver2}/wx/ogl
702 %{_includedir}/wx-%{ver2}/wx/ogl/*
703 %{_libdir}/libwx_%{buildname}_ogl-%{ver2}.so
704
705 %dir %{_includedir}/wx-%{ver2}/wx/plot
706 %{_includedir}/wx-%{ver2}/wx/plot/*
707 %{_libdir}/libwx_%{buildname}_plot-%{ver2}.so
708
709 %dir %{_includedir}/wx-%{ver2}/wx/stc
710 %{_includedir}/wx-%{ver2}/wx/stc/*
711 %{_libdir}/libwx_%{buildname}_stc-%{ver2}.so
712
713 %dir %{_includedir}/wx-%{ver2}/wx/svg
714 %{_includedir}/wx-%{ver2}/wx/svg/*
715 %{_libdir}/libwx_%{buildname}_svg-%{ver2}.so