7 %define name wx
-%{portname}
8 %define wxbasename wx
-base
10 %define wxconfig
%{portname}-ansi-release-%{ver2}
11 %define wxconfiglink wx
%{portname}-%{ver2}-config
13 Summary: The Motif
/Lesstif port of the wxWidgets library
17 License: wxWindows Licence
19 Source: wxMotif
-%{ver}.tar.bz2
20 URL: http
://www.wxwidgets.org
21 Packager: wxWidgets developers
<wx
-dev@lists.wxwidgets.org
>
22 BuildRoot: %{_tmppath}/%{name}-root
23 Requires: %{wxbasename} = %{ver}
25 # all packages providing an implementation of wxWidgets library (regardless of
26 # the toolkit used) should provide the (virtual) wxwin package, this makes it
27 # possible to require wxwin instead of requiring "wxgtk or wxmotif or wxuniv..."
32 wxWidgets is a free C
++ library
for cross
-platform GUI development.
33 With wxWidgets
, you can create applications
for different GUIs
(GTK
+,
34 Motif
/LessTif
, MS Windows
, Mac
) from the same
source code.
37 Summary: The Motif
/Lesstif port of the wxWidgets library
39 Requires: %{name} = %{ver}
40 Requires: %{wxbasename}-devel = %{ver}
43 Header files
for wxMotif
, the Motif
/Lesstif port of the wxWidgets library.
46 Summary: The Motif
/Lesstif port of the wxWidgets library
, OpenGL add
-on.
48 Requires: %{name} = %{ver}
51 OpenGL add
-on library
for wxMotif
, the Motif
/Lesstif port of the wxWidgets library.
54 Summary: wxMotif static libraries
55 Group: Development
/Libraries
56 Requires: %{wxbasename}-static
57 Requires: %{name}-devel = %{ver}
60 Static libraries
for wxMotif. You need them
if you want to link statically against wxMotif.
63 %setup -q
-n wxMotif
-%{ver}
66 if [ "$SMP"
!= ""
]; then
67 export MAKE
="
make -j$SMP"
74 ..
/configure
--prefix
=%{pref} --with
-motif
--with
-opengl
80 ..
/configure
--prefix
=%{pref} --with
-motif
--disable
-shared
--with
-opengl
85 rm -rf $RPM_BUILD_ROOT
86 (cd obj
-static
; make prefix
=$RPM_BUILD_ROOT
%{pref} install)
87 (cd obj
-shared
; make prefix
=$RPM_BUILD_ROOT
%{pref} install)
89 # Remove headers that are part of wx-base-devel:
91 # --- wxBase headers list begins here ---
92 cat
<<EOF
>wxbase
-headers.files
237 wx
/meta
/convertible.h
243 wx
/generic
/fswatcher.h
254 wx
/unix
/fswatcher_kqueue.h
257 wx
/unix
/fswatcher_inotify.h
263 wx
/protocol
/protocol.h
272 # --- wxBase headers list ends here ---
273 for f
in `cat wxbase
-headers
-list`
; do
274 rm -f $RPM_BUILD_ROOT
%{_includedir}/wx-%{ver2}/$f
277 # list of all core headers:
278 find $RPM_BUILD_ROOT
%{_includedir}/wx-%{ver2} -type f | sed
-e "s
,$RPM_BUILD_ROOT
,,g"
>core
-headers.files
280 # remove wxBase files so that RPM doesn't complain about unpackaged files:
281 rm -f $RPM_BUILD_ROOT
%{_libdir}/libwx_base
*
282 rm -f $RPM_BUILD_ROOT
%{_datadir}/aclocal
/*
283 rm -f $RPM_BUILD_ROOT
%{_datadir}/locale
/*/*/*
286 rm -rf $RPM_BUILD_ROOT
295 # link wx-config when you install RPM.
296 ln
-sf
%{_libdir}/wx/config/%{wxconfig} %{_bindir}/wx
-config
297 # link wx-config with explicit name.
298 ln
-sf
%{_libdir}/wx/config/%{wxconfig} %{_bindir}/%{wxconfiglink}
305 if test -f
%{_bindir}/wx
-config
-a
-f
/usr
/bin
/md5sum
; then
306 SUM1
=`md5sum
%{_libdir}/wx/config/%{wxconfig} | cut
-c
0-32`
307 SUM2
=`md5sum
%{_bindir}/wx
-config | cut
-c
0-32`
308 if test "x$SUM1"
= "x$SUM2"
; then
309 rm -f
%{_bindir}/wx
-config
312 rm -f
%{_bindir}/%{wxconfiglink}
321 %defattr(-,root
,root
)
322 %doc COPYING.LIB
*.txt
323 %{_libdir}/libwx_%{portname}*_adv-%{ver2}.so.
*
324 %{_libdir}/libwx_%{portname}*_core-%{ver2}.so.
*
325 %{_libdir}/libwx_%{portname}*_html-%{ver2}.so.
*
326 %{_libdir}/libwx_%{portname}*_media-%{ver2}.so.
*
327 %{_libdir}/libwx_%{portname}*_qa-%{ver2}.so.
*
328 %{_libdir}/libwx_%{portname}*_xrc-%{ver2}.so.
*
331 %files devel
-f core
-headers.files
332 %defattr(-,root
,root
)
333 %{_libdir}/libwx_%{portname}*_adv-%{ver2}.so
334 %{_libdir}/libwx_%{portname}*_core-%{ver2}.so
335 %{_libdir}/libwx_%{portname}*_gl-%{ver2}.so
336 %{_libdir}/libwx_%{portname}*_html-%{ver2}.so
337 %{_libdir}/libwx_%{portname}*_media-%{ver2}.so
338 %{_libdir}/libwx_%{portname}*_qa-%{ver2}.so
339 %{_libdir}/libwx_%{portname}*_xrc-%{ver2}.so
345 %defattr(-,root
,root
)
346 %{_libdir}/libwx_%{portname}*_gl-%{ver2}.so.
*
349 %defattr (-,root
,root
)
350 %{_libdir}/libwx_%{portname}*_*-%{ver2}.a