extract parts of wxXRC depending on wxAdv in a separate file to allow statically...
[wxWidgets.git] / wxGTK.spec
1 %define _prefix /usr
2 %define ver 2.9.0
3 %define ver2 2.9
4 %define rel 1
5
6 # Configurable settings (use --with(out) {unicode,gtk2} on rpmbuild cmd line):
7 %define unicode 1
8 %{?_with_unicode: %{expand: %%define unicode 1}}
9 %{?_without_unicode: %{expand: %%define unicode 0}}
10
11 %define gtk2 1
12 %{?_with_gtk2: %{expand: %%define gtk2 1}}
13 %{?_without_gtk2: %{expand: %%define gtk2 0}}
14
15 # "buildname" needs to be e.g. gtk2ud for debug builds
16 %if %{gtk2}
17 %define gtkver 2
18 %define portname gtk2
19 %if %{unicode}
20 %define buildname gtk2u
21 %else
22 %define buildname gtk2
23 %endif
24 %else
25 %define gtkver 1.2
26 %define portname gtk
27 %define buildname gtk
28 %endif
29
30 %if %{unicode}
31 %define name wx-%{portname}-unicode
32 %define wxconfig %{portname}-unicode-release-%{ver2}
33 %define wxconfigstatic %{portname}-unicode-release-static-%{ver2}
34 %define wxconfiglink wx%{portname}u-%{ver2}-config
35 %else
36 %define name wx-%{portname}-ansi
37 %define wxconfig %{portname}-ansi-release-%{ver2}
38 %define wxconfigstatic %{portname}-ansi-release-static-%{ver2}
39 %define wxconfiglink wx%{portname}-%{ver2}-config
40 %endif
41
42 %if %{unicode}
43 %define wxbasename wx-base-unicode
44 %define wxbaseconfig base-unicode-release-%{ver2}
45 %define wxbaseconfiglink wxbaseu-%{ver2}-config
46 %else
47 %define wxbasename wx-base-ansi
48 %define wxbaseconfig base-ansi-release-%{ver2}
49 %define wxbaseconfiglink wxbase-%{ver2}-config
50 %endif
51
52 Summary: The GTK+ %{gtkver} port of the wxWidgets library
53 Name: %{name}
54 Version: %{ver}
55 Release: %{rel}
56 License: wxWindows Licence
57 Group: X11/Libraries
58 Source: wxGTK-%{ver}.tar.bz2
59 URL: http://www.wxwidgets.org
60 Packager: Vadim Zeitlin <vadim@wxwindows.org>
61 Prefix: %{_prefix}
62 BuildRoot: %{_tmppath}/%{name}-root
63 Requires: %{wxbasename} = %{ver}
64 %if %{portname} == gtk2
65 BuildRequires: gtk+-2.0-devel
66 %else
67 BuildRequires: gtk+-devel >= 1.2.0
68 %endif
69
70 BuildRequires: zlib-devel, libjpeg-devel, libpng-devel, libtiff-devel
71
72 # all packages providing an implementation of wxWidgets library (regardless of
73 # the toolkit used) should provide the (virtual) wxwin package, this makes it
74 # possible to require wxwin instead of requiring "wxgtk or wxmotif or wxuniv..."
75 Provides: wxwin
76 Provides: wxGTK
77
78 %description
79 wxWidgets is a free C++ library for cross-platform GUI development.
80 With wxWidgets, you can create applications for different GUIs (GTK+,
81 Motif, MS Windows, MacOS X, Windows CE, GPE) from the same source code.
82
83 %package -n wx-i18n
84 Summary: The translations for the wxWidgets library.
85 Group: X11/Libraries
86
87 %description -n wx-i18n
88 The translations files for the wxWidgets library.
89
90 %package devel
91 Summary: The GTK+ %{gtkver} port of the wxWidgets library
92 Group: X11/Libraries
93 Requires: %{name} = %{ver}
94 Requires: %{wxbasename}-devel = %{ver}
95 Provides: wxGTK-devel
96
97 %description devel
98 The GTK+ %{gtkver} port of the wxWidgets library, header files.
99
100 %package gl
101 Summary: The GTK+ %{gtkver} port of the wxWidgets library, OpenGL add-on.
102 Group: X11/Libraries
103 Requires: %{name} = %{ver}
104 Provides: wxGTK-gl
105
106 %description gl
107 OpenGL add-on library for wxGTK, the GTK+ %{gtkver} port of the wxWidgets library.
108
109 %package -n %{wxbasename}
110 Summary: wxBase library - non-GUI support classes of the wxWidgets toolkit
111 Group: Development/Libraries
112 Provides: wxBase
113
114 %description -n %{wxbasename}
115 wxBase is a collection of C++ classes providing basic data structures (strings,
116 lists, arrays), portable wrappers around many OS-specific funstions (file
117 operations, time/date manipulations, threads, processes, sockets, shared
118 library loading) as well as other utility classes (streams, archive and
119 compression). wxBase currently supports Win32, most Unix variants (Linux,
120 FreeBSD, Solaris, HP-UX) and MacOS X (Carbon and Mach-0).
121
122 %package -n %{wxbasename}-devel
123 Summary: wxBase library, header files.
124 Group: Development/Libraries
125 Provides: wxBase-devel
126
127 %description -n %{wxbasename}-devel
128 wxBase library - non-GUI support classes of the wxWidgets toolkit,
129 header files.
130
131 %package contrib
132 Summary: The GTK+ %{gtkver} port of the wxWidgets library, contributed libraries.
133 Group: X11/Libraries
134 Requires: %{name} = %{ver}
135
136 %description contrib
137 Contributed libraries for wxGTK, the GTK+ %{gtkver} port of the wxWidgets library.
138
139 %package contrib-devel
140 Summary: The GTK+ %{gtkver} port of the wxWidgets library
141 Group: X11/Libraries
142 Requires: %{name}-contrib = %{ver}
143 Requires: %{name}-devel = %{ver}
144
145 %description contrib-devel
146 Header files for contributed libraries for wxGTK, the GTK+ %{gtkver} port of the wxWidgets library.
147
148 %prep
149 %setup -q -n wxGTK-%{ver}
150
151 %build
152 if [ "$SMP" != "" ]; then
153 export MAKE="make -j$SMP"
154 else
155 export MAKE="make"
156 fi
157
158 mkdir obj-shared
159 cd obj-shared
160 ../configure --prefix=%{_prefix} \
161 %if ! %{gtk2}
162 --with-gtk=1 \
163 %else
164 --with-gtk=2 \
165 %endif
166 %if %{unicode}
167 --enable-unicode \
168 %else
169 --disable-unicode \
170 %endif
171 --with-opengl
172 $MAKE
173
174 cd contrib/src
175 $MAKE
176 cd ../../..
177
178 mkdir obj-static
179 cd obj-static
180 ../configure --prefix=%{_prefix} \
181 %if ! %{gtk2}
182 --with-gtk=1 \
183 %else
184 --with-gtk=2 \
185 %endif
186 --disable-shared \
187 %if %{unicode}
188 --enable-unicode \
189 %else
190 --disable-unicode \
191 %endif
192 --with-opengl
193 $MAKE
194
195 cd contrib/src
196 $MAKE
197 cd ../../..
198
199 make -C locale allmo
200
201 %install
202 rm -rf $RPM_BUILD_ROOT
203 (cd obj-static; make DESTDIR=$RPM_BUILD_ROOT prefix=%{_prefix} install)
204 (cd obj-shared; make DESTDIR=$RPM_BUILD_ROOT prefix=%{_prefix} install)
205
206 # --- wxBase headers list begins here ---
207 cat <<EOF >wxbase-headers.files
208 wx/afterstd.h
209 wx/app.h
210 wx/apptrait.h
211 wx/archive.h
212 wx/arrimpl.cpp
213 wx/arrstr.h
214 wx/atomic.h
215 wx/base64.h
216 wx/beforestd.h
217 wx/buffer.h
218 wx/build.h
219 wx/chartype.h
220 wx/chkconf.h
221 wx/clntdata.h
222 wx/cmdargs.h
223 wx/cmdline.h
224 wx/confbase.h
225 wx/config.h
226 wx/convauto.h
227 wx/containr.h
228 wx/cpp.h
229 wx/crt.h
230 wx/datetime.h
231 wx/datstrm.h
232 wx/dde.h
233 wx/debug.h
234 wx/defs.h
235 wx/dir.h
236 wx/dlimpexp.h
237 wx/dynarray.h
238 wx/dynlib.h
239 wx/dynload.h
240 wx/encconv.h
241 wx/event.h
242 wx/except.h
243 wx/features.h
244 wx/flags.h
245 wx/ffile.h
246 wx/file.h
247 wx/fileconf.h
248 wx/filefn.h
249 wx/filename.h
250 wx/filesys.h
251 wx/fontenc.h
252 wx/fontmap.h
253 wx/fs_arc.h
254 wx/fs_filter.h
255 wx/fs_mem.h
256 wx/fs_zip.h
257 wx/hash.h
258 wx/hashmap.h
259 wx/hashset.h
260 wx/html/forcelnk.h
261 wx/iconloc.h
262 wx/init.h
263 wx/intl.h
264 wx/iosfwrap.h
265 wx/ioswrap.h
266 wx/ipc.h
267 wx/ipcbase.h
268 wx/link.h
269 wx/list.h
270 wx/listimpl.cpp
271 wx/log.h
272 wx/longlong.h
273 wx/math.h
274 wx/memconf.h
275 wx/memory.h
276 wx/memtext.h
277 wx/mimetype.h
278 wx/module.h
279 wx/msgout.h
280 wx/mstream.h
281 wx/object.h
282 wx/platform.h
283 wx/platinfo.h
284 wx/power.h
285 wx/process.h
286 wx/ptr_scpd.h
287 wx/ptr_shrd.h
288 wx/recguard.h
289 wx/regex.h
290 wx/scopeguard.h
291 wx/snglinst.h
292 wx/sstream.h
293 wx/stack.h
294 wx/stackwalk.h
295 wx/stdpaths.h
296 wx/stockitem.h
297 wx/stopwatch.h
298 wx/strconv.h
299 wx/stream.h
300 wx/string.h
301 wx/stringimpl.h
302 wx/stringops.h
303 wx/strvararg.h
304 wx/sysopt.h
305 wx/tarstrm.h
306 wx/textbuf.h
307 wx/textfile.h
308 wx/thread.h
309 wx/thrimpl.cpp
310 wx/timer.h
311 wx/tokenzr.h
312 wx/tracker.h
313 wx/txtstrm.h
314 wx/types.h
315 wx/unichar.h
316 wx/uri.h
317 wx/ustring.h
318 wx/utils.h
319 wx/variant.h
320 wx/vector.h
321 wx/version.h
322 wx/volume.h
323 wx/weakref.h
324 wx/wfstream.h
325 wx/wx.h
326 wx/wxchar.h
327 wx/wxcrt.h
328 wx/wxcrtbase.h
329 wx/wxcrtvararg.h
330 wx/wxprec.h
331 wx/xlocale.h
332 wx/xti.h
333 wx/xtistrm.h
334 wx/zipstrm.h
335 wx/zstream.h
336 wx/meta/convertible.h
337 wx/meta/if.h
338 wx/meta/int2type.h
339 wx/meta/movable.h
340 wx/private/fdiodispatcher.h
341 wx/private/selectdispatcher.h
342 wx/unix/app.h
343 wx/unix/apptbase.h
344 wx/unix/apptrait.h
345 wx/unix/chkconf.h
346 wx/unix/evtloop.h
347 wx/unix/pipe.h
348 wx/unix/stdpaths.h
349 wx/unix/stackwalk.h
350 wx/unix/execute.h
351 wx/unix/mimetype.h
352 wx/unix/private.h
353 wx/private/gsocketiohandler.h
354 wx/fs_inet.h
355 wx/gsocket.h
356 wx/protocol/file.h
357 wx/protocol/ftp.h
358 wx/protocol/http.h
359 wx/protocol/protocol.h
360 wx/sckaddr.h
361 wx/sckipc.h
362 wx/sckstrm.h
363 wx/socket.h
364 wx/url.h
365 wx/unix/gsockunx.h
366 wx/xml/xml.h
367 wx/xtixml.h
368 EOF
369 # --- wxBase headers list ends here ---
370 cat <<EOF >wxbase-headers.paths
371 %{_includedir}/wx-%{ver2}/wx/afterstd.h
372 %{_includedir}/wx-%{ver2}/wx/app.h
373 %{_includedir}/wx-%{ver2}/wx/apptrait.h
374 %{_includedir}/wx-%{ver2}/wx/archive.h
375 %{_includedir}/wx-%{ver2}/wx/arrimpl.cpp
376 %{_includedir}/wx-%{ver2}/wx/arrstr.h
377 %{_includedir}/wx-%{ver2}/wx/beforestd.h
378 %{_includedir}/wx-%{ver2}/wx/buffer.h
379 %{_includedir}/wx-%{ver2}/wx/build.h
380 %{_includedir}/wx-%{ver2}/wx/chkconf.h
381 %{_includedir}/wx-%{ver2}/wx/clntdata.h
382 %{_includedir}/wx-%{ver2}/wx/cmdline.h
383 %{_includedir}/wx-%{ver2}/wx/confbase.h
384 %{_includedir}/wx-%{ver2}/wx/config.h
385 %{_includedir}/wx-%{ver2}/wx/containr.h
386 %{_includedir}/wx-%{ver2}/wx/convauto.h
387 %{_includedir}/wx-%{ver2}/wx/datetime.h
388 %{_includedir}/wx-%{ver2}/wx/datstrm.h
389 %{_includedir}/wx-%{ver2}/wx/dde.h
390 %{_includedir}/wx-%{ver2}/wx/debug.h
391 %{_includedir}/wx-%{ver2}/wx/defs.h
392 %{_includedir}/wx-%{ver2}/wx/dir.h
393 %{_includedir}/wx-%{ver2}/wx/dlimpexp.h
394 %{_includedir}/wx-%{ver2}/wx/dynarray.h
395 %{_includedir}/wx-%{ver2}/wx/dynlib.h
396 %{_includedir}/wx-%{ver2}/wx/dynload.h
397 %{_includedir}/wx-%{ver2}/wx/encconv.h
398 %{_includedir}/wx-%{ver2}/wx/event.h
399 %{_includedir}/wx-%{ver2}/wx/except.h
400 %{_includedir}/wx-%{ver2}/wx/features.h
401 %{_includedir}/wx-%{ver2}/wx/ffile.h
402 %{_includedir}/wx-%{ver2}/wx/file.h
403 %{_includedir}/wx-%{ver2}/wx/fileconf.h
404 %{_includedir}/wx-%{ver2}/wx/filefn.h
405 %{_includedir}/wx-%{ver2}/wx/filename.h
406 %{_includedir}/wx-%{ver2}/wx/filesys.h
407 %{_includedir}/wx-%{ver2}/wx/fontenc.h
408 %{_includedir}/wx-%{ver2}/wx/fontmap.h
409 %{_includedir}/wx-%{ver2}/wx/fs_mem.h
410 %{_includedir}/wx-%{ver2}/wx/fs_zip.h
411 %{_includedir}/wx-%{ver2}/wx/hash.h
412 %{_includedir}/wx-%{ver2}/wx/hashmap.h
413 %{_includedir}/wx-%{ver2}/wx/hashset.h
414 %{_includedir}/wx-%{ver2}/wx/html/forcelnk.h
415 %{_includedir}/wx-%{ver2}/wx/iconloc.h
416 %{_includedir}/wx-%{ver2}/wx/init.h
417 %{_includedir}/wx-%{ver2}/wx/intl.h
418 %{_includedir}/wx-%{ver2}/wx/iosfwrap.h
419 %{_includedir}/wx-%{ver2}/wx/ioswrap.h
420 %{_includedir}/wx-%{ver2}/wx/ipc.h
421 %{_includedir}/wx-%{ver2}/wx/ipcbase.h
422 %{_includedir}/wx-%{ver2}/wx/isql.h
423 %{_includedir}/wx-%{ver2}/wx/isqlext.h
424 %{_includedir}/wx-%{ver2}/wx/link.h
425 %{_includedir}/wx-%{ver2}/wx/list.h
426 %{_includedir}/wx-%{ver2}/wx/listimpl.cpp
427 %{_includedir}/wx-%{ver2}/wx/log.h
428 %{_includedir}/wx-%{ver2}/wx/longlong.h
429 %{_includedir}/wx-%{ver2}/wx/math.h
430 %{_includedir}/wx-%{ver2}/wx/memconf.h
431 %{_includedir}/wx-%{ver2}/wx/memory.h
432 %{_includedir}/wx-%{ver2}/wx/memtext.h
433 %{_includedir}/wx-%{ver2}/wx/mimetype.h
434 %{_includedir}/wx-%{ver2}/wx/module.h
435 %{_includedir}/wx-%{ver2}/wx/msgout.h
436 %{_includedir}/wx-%{ver2}/wx/mstream.h
437 %{_includedir}/wx-%{ver2}/wx/object.h
438 %{_includedir}/wx-%{ver2}/wx/platform.h
439 %{_includedir}/wx-%{ver2}/wx/power.h
440 %{_includedir}/wx-%{ver2}/wx/process.h
441 %{_includedir}/wx-%{ver2}/wx/ptr_scpd.h
442 %{_includedir}/wx-%{ver2}/wx/recguard.h
443 %{_includedir}/wx-%{ver2}/wx/regex.h
444 %{_includedir}/wx-%{ver2}/wx/scopeguard.h
445 %{_includedir}/wx-%{ver2}/wx/snglinst.h
446 %{_includedir}/wx-%{ver2}/wx/sstream.h
447 %{_includedir}/wx-%{ver2}/wx/stack.h
448 %{_includedir}/wx-%{ver2}/wx/stackwalk.h
449 %{_includedir}/wx-%{ver2}/wx/stdpaths.h
450 %{_includedir}/wx-%{ver2}/wx/stockitem.h
451 %{_includedir}/wx-%{ver2}/wx/stopwatch.h
452 %{_includedir}/wx-%{ver2}/wx/strconv.h
453 %{_includedir}/wx-%{ver2}/wx/stream.h
454 %{_includedir}/wx-%{ver2}/wx/string.h
455 %{_includedir}/wx-%{ver2}/wx/sysopt.h
456 %{_includedir}/wx-%{ver2}/wx/textbuf.h
457 %{_includedir}/wx-%{ver2}/wx/textfile.h
458 %{_includedir}/wx-%{ver2}/wx/thread.h
459 %{_includedir}/wx-%{ver2}/wx/thrimpl.cpp
460 %{_includedir}/wx-%{ver2}/wx/timer.h
461 %{_includedir}/wx-%{ver2}/wx/tokenzr.h
462 %{_includedir}/wx-%{ver2}/wx/txtstrm.h
463 %{_includedir}/wx-%{ver2}/wx/types.h
464 %{_includedir}/wx-%{ver2}/wx/uri.h
465 %{_includedir}/wx-%{ver2}/wx/utils.h
466 %{_includedir}/wx-%{ver2}/wx/variant.h
467 %{_includedir}/wx-%{ver2}/wx/vector.h
468 %{_includedir}/wx-%{ver2}/wx/version.h
469 %{_includedir}/wx-%{ver2}/wx/volume.h
470 %{_includedir}/wx-%{ver2}/wx/wfstream.h
471 %{_includedir}/wx-%{ver2}/wx/wx.h
472 %{_includedir}/wx-%{ver2}/wx/wxchar.h
473 %{_includedir}/wx-%{ver2}/wx/wxprec.h
474 %{_includedir}/wx-%{ver2}/wx/xti.h
475 %{_includedir}/wx-%{ver2}/wx/xtistrm.h
476 %{_includedir}/wx-%{ver2}/wx/zipstrm.h
477 %{_includedir}/wx-%{ver2}/wx/zstream.h
478 %{_includedir}/wx-%{ver2}/wx/fs_inet.h
479 %{_includedir}/wx-%{ver2}/wx/gsocket.h
480 %{_includedir}/wx-%{ver2}/wx/protocol/file.h
481 %{_includedir}/wx-%{ver2}/wx/protocol/ftp.h
482 %{_includedir}/wx-%{ver2}/wx/protocol/http.h
483 %{_includedir}/wx-%{ver2}/wx/protocol/protocol.h
484 %{_includedir}/wx-%{ver2}/wx/sckaddr.h
485 %{_includedir}/wx-%{ver2}/wx/sckipc.h
486 %{_includedir}/wx-%{ver2}/wx/sckstrm.h
487 %{_includedir}/wx-%{ver2}/wx/socket.h
488 %{_includedir}/wx-%{ver2}/wx/url.h
489 %{_includedir}/wx-%{ver2}/wx/xml/xml.h
490 %{_includedir}/wx-%{ver2}/wx/xtixml.h
491 %{_includedir}/wx-%{ver2}/wx/unix/apptbase.h
492 %{_includedir}/wx-%{ver2}/wx/unix/apptrait.h
493 %{_includedir}/wx-%{ver2}/wx/unix/execute.h
494 %{_includedir}/wx-%{ver2}/wx/unix/gsockunx.h
495 %{_includedir}/wx-%{ver2}/wx/unix/mimetype.h
496 %{_includedir}/wx-%{ver2}/wx/unix/pipe.h
497 %{_includedir}/wx-%{ver2}/wx/unix/private.h
498 %{_includedir}/wx-%{ver2}/wx/unix/stackwalk.h
499 %{_includedir}/wx-%{ver2}/wx/unix/stdpaths.h
500 EOF
501 # --- wxBase headers list ends here ---
502
503 # temporarily remove base headers
504 mkdir $RPM_BUILD_ROOT/_save_dir
505 cp -r $RPM_BUILD_ROOT%{_includedir}/wx-%{ver2} $RPM_BUILD_ROOT/_save_dir
506 for f in `cat wxbase-headers.files` ; do
507 rm -f $RPM_BUILD_ROOT%{_includedir}/wx-%{ver2}/$f
508 done
509 # list of all core headers:
510 find $RPM_BUILD_ROOT%{_includedir}/wx-%{ver2} -type f | sed -e "s,$RPM_BUILD_ROOT,,g" >core-headers.files
511 # move base headers (actually all headers) back again
512 cp -f -r $RPM_BUILD_ROOT/_save_dir/* $RPM_BUILD_ROOT%{_includedir}
513 rm -rf $RPM_BUILD_ROOT/_save_dir
514
515 # contrib stuff:
516 (cd obj-static/contrib; make DESTDIR=$RPM_BUILD_ROOT prefix=%{_prefix} install)
517 (cd obj-shared/contrib; make DESTDIR=$RPM_BUILD_ROOT prefix=%{_prefix} install)
518
519 # utils:
520 (cd obj-shared/utils/wxrc; make DESTDIR=$RPM_BUILD_ROOT prefix=%{_prefix} install)
521
522 # wx-config link is created during package installation, remove it for now
523 rm -f $RPM_BUILD_ROOT%{_bindir}/wx-config
524
525 %clean
526 rm -rf $RPM_BUILD_ROOT
527
528 %post
529 /sbin/ldconfig
530
531 %postun
532 /sbin/ldconfig
533
534 %post devel
535 # link wx-config when you install RPM.
536 %if %{unicode}
537 ln -sf %{_libdir}/wx/config/%{wxconfig} %{_bindir}/wx-config
538 %endif
539 # link wx-config with explicit name.
540 ln -sf %{_libdir}/wx/config/%{wxconfig} %{_bindir}/%{wxconfiglink}
541 /sbin/ldconfig
542
543 %postun devel
544 /sbin/ldconfig
545
546 %preun devel
547 %if %{unicode}
548 rm -f %{_bindir}/wx-config
549 %endif
550 rm -f %{_bindir}/%{wxconfiglink}
551
552 %post -n %{wxbasename}
553 /sbin/ldconfig
554
555 %postun -n %{wxbasename}
556 /sbin/ldconfig
557
558 %post -n %{wxbasename}-devel
559 # link wx-config with explicit name.
560 ln -sf %{_libdir}/wx/config/%{wxbaseconfig} %{_bindir}/%{wxbaseconfiglink}
561 /sbin/ldconfig
562
563 %postun -n %{wxbasename}-devel
564 /sbin/ldconfig
565
566 %preun -n %{wxbasename}-devel
567 rm -f %{_bindir}/%{wxbaseconfiglink}
568
569 %post gl
570 /sbin/ldconfig
571
572 %postun gl
573 /sbin/ldconfig
574
575 %post contrib
576 /sbin/ldconfig
577
578 %postun contrib
579 /sbin/ldconfig
580
581 %post contrib-devel
582 /sbin/ldconfig
583
584 %postun contrib-devel
585 /sbin/ldconfig
586
587 %files
588 %defattr(-,root,root)
589 %doc COPYING.LIB *.txt
590 %{_libdir}/libwx_%{buildname}_adv-%{ver2}.so.*
591 %{_libdir}/libwx_%{buildname}_aui-%{ver2}.so.*
592 %{_libdir}/libwx_%{buildname}_core-%{ver2}.so.*
593 %{_libdir}/libwx_%{buildname}_html-%{ver2}.so.*
594 %{_libdir}/libwx_%{buildname}_mmedia-%{ver2}.so.*
595 %{_libdir}/libwx_%{buildname}_qa-%{ver2}.so.*
596 %{_libdir}/libwx_%{buildname}_richtext-%{ver2}.so.*
597 %{_libdir}/libwx_%{buildname}_xrc-%{ver2}.so.*
598
599 %files -n wx-i18n
600 %defattr(-,root,root)
601 %{_datadir}/locale/*/LC_MESSAGES/*.mo
602
603 %files devel -f core-headers.files
604 %defattr(-,root,root)
605 # shared libs
606 %{_libdir}/libwx_%{buildname}_adv-%{ver2}.so
607 %{_libdir}/libwx_%{buildname}_aui-%{ver2}.so
608 %{_libdir}/libwx_%{buildname}_core-%{ver2}.so
609 %{_libdir}/libwx_%{buildname}_gl-%{ver2}.so
610 %{_libdir}/libwx_%{buildname}_html-%{ver2}.so
611 %{_libdir}/libwx_%{buildname}_mmedia-%{ver2}.so
612 %{_libdir}/libwx_%{buildname}_qa-%{ver2}.so
613 %{_libdir}/libwx_%{buildname}_richtext-%{ver2}.so
614 %{_libdir}/libwx_%{buildname}_xrc-%{ver2}.so
615 # static libs
616 %{_libdir}/libwx_%{buildname}_adv-%{ver2}.a
617 %{_libdir}/libwx_%{buildname}_aui-%{ver2}.a
618 %{_libdir}/libwx_%{buildname}_core-%{ver2}.a
619 %{_libdir}/libwx_%{buildname}_gl-%{ver2}.a
620 %{_libdir}/libwx_%{buildname}_html-%{ver2}.a
621 %{_libdir}/libwx_%{buildname}_qa-%{ver2}.a
622 %{_libdir}/libwx_%{buildname}_richtext-%{ver2}.a
623 %{_libdir}/libwx_%{buildname}_xrc-%{ver2}.a
624 %dir %{_libdir}/wx
625 %{_libdir}/wx/config/%{wxconfig}
626 %{_libdir}/wx/include/%{wxconfig}/wx/setup.h
627 %{_libdir}/wx/config/%{wxconfigstatic}
628 %{_libdir}/wx/include/%{wxconfigstatic}/wx/setup.h
629 %{_bindir}/wxrc*
630
631 %files -n %{wxbasename}
632 %defattr(-,root,root)
633 %{_libdir}/libwx_base*-%{ver2}.so.*
634
635 %files -n %{wxbasename}-devel -f wxbase-headers.paths
636 %defattr (-,root,root)
637 %dir %{_includedir}/wx-%{ver2}
638 %{_libdir}/libwx_base*-%{ver2}.so
639 %{_libdir}/libwx_base*-%{ver2}.a
640 %if %{unicode}
641 %{_libdir}/libwxregexu-%{ver2}.a
642 %endif
643 %dir %{_libdir}/wx
644 %{_datadir}/aclocal/*.m4
645 %{_datadir}/bakefile/presets/*
646
647 %files gl
648 %defattr(-,root,root)
649 %{_libdir}/libwx_%{buildname}_gl-%{ver2}.so.*
650
651 %files contrib
652 %defattr(-,root,root)
653 %{_libdir}/libwx_%{buildname}_animate-%{ver2}.so.*
654 %{_libdir}/libwx_%{buildname}_deprecated-%{ver2}.so.*
655 %{_libdir}/libwx_%{buildname}_fl-%{ver2}.so.*
656 %{_libdir}/libwx_%{buildname}_gizmos-%{ver2}.so.*
657 %{_libdir}/libwx_%{buildname}_gizmos_xrc-%{ver2}.so.*
658 %{_libdir}/libwx_%{buildname}_mmedia-%{ver2}.so.*
659 %{_libdir}/libwx_%{buildname}_ogl-%{ver2}.so.*
660 %{_libdir}/libwx_%{buildname}_plot-%{ver2}.so.*
661 %{_libdir}/libwx_%{buildname}_stc-%{ver2}.so.*
662 %{_libdir}/libwx_%{buildname}_svg-%{ver2}.so.*
663
664 # static libs
665 %{_libdir}/libwx_%{buildname}_animate-%{ver2}.a
666 %{_libdir}/libwx_%{buildname}_deprecated-%{ver2}.a
667 %{_libdir}/libwx_%{buildname}_fl-%{ver2}.a
668 %{_libdir}/libwx_%{buildname}_gizmos-%{ver2}.a
669 %{_libdir}/libwx_%{buildname}_gizmos_xrc-%{ver2}.a
670 %{_libdir}/libwx_%{buildname}_mmedia-%{ver2}.a
671 %{_libdir}/libwx_%{buildname}_ogl-%{ver2}.a
672 %{_libdir}/libwx_%{buildname}_plot-%{ver2}.a
673 %{_libdir}/libwx_%{buildname}_stc-%{ver2}.a
674 %{_libdir}/libwx_%{buildname}_svg-%{ver2}.a
675
676 %files contrib-devel
677 %defattr(-,root,root)
678 %dir %{_includedir}/wx-%{ver2}/wx/animate
679 %{_includedir}/wx-%{ver2}/wx/animate/*
680 %{_libdir}/libwx_%{buildname}_animate-%{ver2}.so
681
682 %dir %{_includedir}/wx-%{ver2}/wx/deprecated
683 %{_includedir}/wx-%{ver2}/wx/deprecated/*
684 %{_libdir}/libwx_%{buildname}_deprecated-%{ver2}.so
685
686 %dir %{_includedir}/wx-%{ver2}/wx/fl
687 %{_includedir}/wx-%{ver2}/wx/fl/*
688 %{_libdir}/libwx_%{buildname}_fl-%{ver2}.so
689
690 %dir %{_includedir}/wx-%{ver2}/wx/gizmos
691 %{_includedir}/wx-%{ver2}/wx/gizmos/*
692 %{_libdir}/libwx_%{buildname}_gizmos-%{ver2}.so
693 %{_libdir}/libwx_%{buildname}_gizmos_xrc-%{ver2}.so
694
695 %dir %{_includedir}/wx-%{ver2}/wx/mmedia
696 %{_includedir}/wx-%{ver2}/wx/mmedia/*
697 %{_libdir}/libwx_%{buildname}_mmedia-%{ver2}.so
698
699 %dir %{_includedir}/wx-%{ver2}/wx/ogl
700 %{_includedir}/wx-%{ver2}/wx/ogl/*
701 %{_libdir}/libwx_%{buildname}_ogl-%{ver2}.so
702
703 %dir %{_includedir}/wx-%{ver2}/wx/plot
704 %{_includedir}/wx-%{ver2}/wx/plot/*
705 %{_libdir}/libwx_%{buildname}_plot-%{ver2}.so
706
707 %dir %{_includedir}/wx-%{ver2}/wx/stc
708 %{_includedir}/wx-%{ver2}/wx/stc/*
709 %{_libdir}/libwx_%{buildname}_stc-%{ver2}.so
710
711 %dir %{_includedir}/wx-%{ver2}/wx/svg
712 %{_includedir}/wx-%{ver2}/wx/svg/*
713 %{_libdir}/libwx_%{buildname}_svg-%{ver2}.so