Put libraries in %{_libdir} when building wxGTK RPMs.
[wxWidgets.git] / wxGTK.spec
1 %define _prefix /usr
2 %define ver 2.9.2
3 %define ver2 2.9
4 %define rel 1
5
6 # Configurable settings (use --with(out) {unicode,gtk2} on rpmbuild cmd line):
7 %define unicode 1
8 %{?_with_unicode: %{expand: %%define unicode 1}}
9 %{?_without_unicode: %{expand: %%define unicode 0}}
10
11 %define gtk2 1
12 %{?_with_gtk2: %{expand: %%define gtk2 1}}
13 %{?_without_gtk2: %{expand: %%define gtk2 0}}
14
15 # "buildname" needs to be e.g. gtk2ud for debug builds
16 %if %{gtk2}
17 %define gtkver 2
18 %define portname gtk2
19 %if %{unicode}
20 %define buildname gtk2u
21 %else
22 %define buildname gtk2
23 %endif
24 %else
25 %define gtkver 1.2
26 %define portname gtk
27 %define buildname gtk
28 %endif
29
30 %if %{unicode}
31 %define name wx-%{portname}-unicode
32 %define wxconfig %{portname}-unicode-release-%{ver2}
33 %define wxconfigstatic %{portname}-unicode-release-static-%{ver2}
34 %define wxconfiglink wx%{portname}u-%{ver2}-config
35 %else
36 %define name wx-%{portname}-ansi
37 %define wxconfig %{portname}-ansi-release-%{ver2}
38 %define wxconfigstatic %{portname}-ansi-release-static-%{ver2}
39 %define wxconfiglink wx%{portname}-%{ver2}-config
40 %endif
41
42 %if %{unicode}
43 %define wxbasename wx-base-unicode
44 %define wxbaseconfig base-unicode-release-%{ver2}
45 %define wxbaseconfiglink wxbaseu-%{ver2}-config
46 %else
47 %define wxbasename wx-base-ansi
48 %define wxbaseconfig base-ansi-release-%{ver2}
49 %define wxbaseconfiglink wxbase-%{ver2}-config
50 %endif
51
52 Summary: The GTK+ %{gtkver} port of the wxWidgets library
53 Name: %{name}
54 Version: %{ver}
55 Release: %{rel}
56 License: wxWindows Licence
57 Group: X11/Libraries
58 Source: wxGTK-%{ver}.tar.bz2
59 URL: http://www.wxwidgets.org
60 Packager: Vadim Zeitlin <vadim@wxwindows.org>
61 Prefix: %{_prefix}
62 BuildRoot: %{_tmppath}/%{name}-root
63 Requires: %{wxbasename} = %{ver}
64 %if %{portname} == gtk2
65 BuildRequires: gtk2-devel
66 %else
67 BuildRequires: gtk+-devel >= 1.2.0
68 %endif
69
70 BuildRequires: zlib-devel, libjpeg-devel, libpng-devel, libtiff-devel
71
72 # all packages providing an implementation of wxWidgets library (regardless of
73 # the toolkit used) should provide the (virtual) wxwin package, this makes it
74 # possible to require wxwin instead of requiring "wxgtk or wxmotif or wxuniv..."
75 Provides: wxwin
76 Provides: wxGTK
77
78 %description
79 wxWidgets is a free C++ library for cross-platform GUI development.
80 With wxWidgets, you can create applications for different GUIs (GTK+,
81 Motif, MS Windows, MacOS X, Windows CE, GPE) from the same source code.
82
83 %package -n wx-i18n
84 Summary: The translations for the wxWidgets library.
85 Group: X11/Libraries
86
87 %description -n wx-i18n
88 The translations files for the wxWidgets library.
89
90 %package devel
91 Summary: The GTK+ %{gtkver} port of the wxWidgets library
92 Group: X11/Libraries
93 Requires: %{name} = %{ver}
94 Requires: %{wxbasename}-devel = %{ver}
95 Provides: wxGTK-devel
96
97 %description devel
98 The GTK+ %{gtkver} port of the wxWidgets library, header files.
99
100 %package gl
101 Summary: The GTK+ %{gtkver} port of the wxWidgets library, OpenGL add-on.
102 Group: X11/Libraries
103 Requires: %{name} = %{ver}
104 Provides: wxGTK-gl
105
106 %description gl
107 OpenGL add-on library for wxGTK, the GTK+ %{gtkver} port of the wxWidgets library.
108
109 %package -n %{wxbasename}
110 Summary: wxBase library - non-GUI support classes of the wxWidgets toolkit
111 Group: Development/Libraries
112 Provides: wxBase
113
114 %description -n %{wxbasename}
115 wxBase is a collection of C++ classes providing basic data structures (strings,
116 lists, arrays), portable wrappers around many OS-specific funstions (file
117 operations, time/date manipulations, threads, processes, sockets, shared
118 library loading) as well as other utility classes (streams, archive and
119 compression). wxBase currently supports Win32, most Unix variants (Linux,
120 FreeBSD, Solaris, HP-UX) and MacOS X (Carbon and Mach-0).
121
122 %package -n %{wxbasename}-devel
123 Summary: wxBase library, header files.
124 Group: Development/Libraries
125 Provides: wxBase-devel
126
127 %description -n %{wxbasename}-devel
128 wxBase library - non-GUI support classes of the wxWidgets toolkit,
129 header files.
130
131 %prep
132 %setup -q -n wxGTK-%{ver}
133
134 %build
135 if [ "$SMP" != "" ]; then
136 export MAKE="make -j$SMP"
137 else
138 export MAKE="make"
139 fi
140
141 mkdir obj-shared
142 cd obj-shared
143 ../configure --prefix=%{_prefix} --libdir=%{_libdir} \
144 %if ! %{gtk2}
145 --with-gtk=1 \
146 %else
147 --with-gtk=2 \
148 %endif
149 %if %{unicode}
150 --enable-unicode \
151 %else
152 --disable-unicode \
153 %endif
154 --with-opengl
155 $MAKE
156
157 cd ..
158
159 mkdir obj-static
160 cd obj-static
161 ../configure --prefix=%{_prefix} --libdir=%{_libdir} \
162 %if ! %{gtk2}
163 --with-gtk=1 \
164 %else
165 --with-gtk=2 \
166 %endif
167 --disable-shared \
168 %if %{unicode}
169 --enable-unicode \
170 %else
171 --disable-unicode \
172 %endif
173 --with-opengl
174 $MAKE
175
176 cd ..
177
178 make -C locale allmo
179
180 %install
181 rm -rf $RPM_BUILD_ROOT
182 (cd obj-static; make DESTDIR=$RPM_BUILD_ROOT prefix=%{_prefix} install)
183 (cd obj-shared; make DESTDIR=$RPM_BUILD_ROOT prefix=%{_prefix} install)
184
185 # --- wxBase headers list begins here ---
186 cat <<EOF >wxbase-headers.files
187 wx/afterstd.h
188 wx/any.h
189 wx/anystr.h
190 wx/app.h
191 wx/apptrait.h
192 wx/archive.h
193 wx/arrimpl.cpp
194 wx/arrstr.h
195 wx/atomic.h
196 wx/base64.h
197 wx/beforestd.h
198 wx/buffer.h
199 wx/build.h
200 wx/chartype.h
201 wx/checkeddelete.h
202 wx/chkconf.h
203 wx/clntdata.h
204 wx/cmdargs.h
205 wx/cmdline.h
206 wx/confbase.h
207 wx/config.h
208 wx/convauto.h
209 wx/containr.h
210 wx/cpp.h
211 wx/crt.h
212 wx/datetime.h
213 wx/datstrm.h
214 wx/dde.h
215 wx/debug.h
216 wx/defs.h
217 wx/dir.h
218 wx/dlimpexp.h
219 wx/dlist.h
220 wx/dynarray.h
221 wx/dynlib.h
222 wx/dynload.h
223 wx/encconv.h
224 wx/event.h
225 wx/evtloop.h
226 wx/except.h
227 wx/features.h
228 wx/flags.h
229 wx/ffile.h
230 wx/file.h
231 wx/fileconf.h
232 wx/filefn.h
233 wx/filename.h
234 wx/filesys.h
235 wx/fontenc.h
236 wx/fontmap.h
237 wx/fs_arc.h
238 wx/fs_filter.h
239 wx/fs_mem.h
240 wx/fs_zip.h
241 wx/hash.h
242 wx/hashmap.h
243 wx/hashset.h
244 wx/html/forcelnk.h
245 wx/iconloc.h
246 wx/init.h
247 wx/intl.h
248 wx/iosfwrap.h
249 wx/ioswrap.h
250 wx/ipc.h
251 wx/ipcbase.h
252 wx/kbdstate.h
253 wx/language.h
254 wx/link.h
255 wx/list.h
256 wx/listimpl.cpp
257 wx/log.h
258 wx/longlong.h
259 wx/math.h
260 wx/memconf.h
261 wx/memory.h
262 wx/memtext.h
263 wx/mimetype.h
264 wx/module.h
265 wx/mousestate.h
266 wx/msgout.h
267 wx/msgqueue.h
268 wx/mstream.h
269 wx/object.h
270 wx/platform.h
271 wx/platinfo.h
272 wx/power.h
273 wx/process.h
274 wx/ptr_scpd.h
275 wx/ptr_shrd.h
276 wx/recguard.h
277 wx/regex.h
278 wx/scopedarray.h
279 wx/scopedptr.h
280 wx/scopeguard.h
281 wx/sharedptr.h
282 wx/snglinst.h
283 wx/sstream.h
284 wx/stack.h
285 wx/stackwalk.h
286 wx/stdpaths.h
287 wx/stdstream.h
288 wx/stockitem.h
289 wx/stopwatch.h
290 wx/strconv.h
291 wx/stream.h
292 wx/string.h
293 wx/stringimpl.h
294 wx/stringops.h
295 wx/strvararg.h
296 wx/sysopt.h
297 wx/tarstrm.h
298 wx/textbuf.h
299 wx/textfile.h
300 wx/thread.h
301 wx/thrimpl.cpp
302 wx/timer.h
303 wx/tls.h
304 wx/tokenzr.h
305 wx/tracker.h
306 wx/translation.h
307 wx/txtstrm.h
308 wx/typeinfo.h
309 wx/types.h
310 wx/unichar.h
311 wx/uri.h
312 wx/ustring.h
313 wx/utils.h
314 wx/variant.h
315 wx/vector.h
316 wx/version.h
317 wx/volume.h
318 wx/weakref.h
319 wx/wfstream.h
320 wx/wx.h
321 wx/wxchar.h
322 wx/wxcrt.h
323 wx/wxcrtbase.h
324 wx/wxcrtvararg.h
325 wx/wxprec.h
326 wx/xlocale.h
327 wx/xti.h
328 wx/xtistrm.h
329 wx/zipstrm.h
330 wx/zstream.h
331 wx/meta/convertible.h
332 wx/meta/if.h
333 wx/meta/int2type.h
334 wx/meta/movable.h
335 wx/meta/pod.h
336 wx/fswatcher.h
337 wx/generic/fswatcher.h
338 wx/unix/app.h
339 wx/unix/apptbase.h
340 wx/unix/apptrait.h
341 wx/unix/chkconf.h
342 wx/unix/evtloop.h
343 wx/unix/evtloopsrc.h
344 wx/unix/pipe.h
345 wx/unix/stdpaths.h
346 wx/unix/stackwalk.h
347 wx/unix/tls.h
348 wx/unix/fswatcher_kqueue.h
349 wx/unix/execute.h
350 wx/unix/mimetype.h
351 wx/unix/fswatcher_inotify.h
352 wx/fs_inet.h
353 wx/protocol/file.h
354 wx/protocol/ftp.h
355 wx/protocol/http.h
356 wx/protocol/log.h
357 wx/protocol/protocol.h
358 wx/sckaddr.h
359 wx/sckipc.h
360 wx/sckstrm.h
361 wx/socket.h
362 wx/url.h
363 wx/xml/xml.h
364 wx/xtixml.h
365 EOF
366 # --- wxBase headers list ends here ---
367 cat <<EOF >wxbase-headers.paths
368 %{_includedir}/wx-%{ver2}/wx/afterstd.h
369 %{_includedir}/wx-%{ver2}/wx/app.h
370 %{_includedir}/wx-%{ver2}/wx/apptrait.h
371 %{_includedir}/wx-%{ver2}/wx/archive.h
372 %{_includedir}/wx-%{ver2}/wx/arrimpl.cpp
373 %{_includedir}/wx-%{ver2}/wx/arrstr.h
374 %{_includedir}/wx-%{ver2}/wx/beforestd.h
375 %{_includedir}/wx-%{ver2}/wx/buffer.h
376 %{_includedir}/wx-%{ver2}/wx/build.h
377 %{_includedir}/wx-%{ver2}/wx/chkconf.h
378 %{_includedir}/wx-%{ver2}/wx/clntdata.h
379 %{_includedir}/wx-%{ver2}/wx/cmdline.h
380 %{_includedir}/wx-%{ver2}/wx/confbase.h
381 %{_includedir}/wx-%{ver2}/wx/config.h
382 %{_includedir}/wx-%{ver2}/wx/containr.h
383 %{_includedir}/wx-%{ver2}/wx/convauto.h
384 %{_includedir}/wx-%{ver2}/wx/datetime.h
385 %{_includedir}/wx-%{ver2}/wx/datstrm.h
386 %{_includedir}/wx-%{ver2}/wx/dde.h
387 %{_includedir}/wx-%{ver2}/wx/debug.h
388 %{_includedir}/wx-%{ver2}/wx/defs.h
389 %{_includedir}/wx-%{ver2}/wx/dir.h
390 %{_includedir}/wx-%{ver2}/wx/dlimpexp.h
391 %{_includedir}/wx-%{ver2}/wx/dynarray.h
392 %{_includedir}/wx-%{ver2}/wx/dynlib.h
393 %{_includedir}/wx-%{ver2}/wx/dynload.h
394 %{_includedir}/wx-%{ver2}/wx/encconv.h
395 %{_includedir}/wx-%{ver2}/wx/event.h
396 %{_includedir}/wx-%{ver2}/wx/except.h
397 %{_includedir}/wx-%{ver2}/wx/features.h
398 %{_includedir}/wx-%{ver2}/wx/ffile.h
399 %{_includedir}/wx-%{ver2}/wx/file.h
400 %{_includedir}/wx-%{ver2}/wx/fileconf.h
401 %{_includedir}/wx-%{ver2}/wx/filefn.h
402 %{_includedir}/wx-%{ver2}/wx/filename.h
403 %{_includedir}/wx-%{ver2}/wx/filesys.h
404 %{_includedir}/wx-%{ver2}/wx/fontenc.h
405 %{_includedir}/wx-%{ver2}/wx/fontmap.h
406 %{_includedir}/wx-%{ver2}/wx/fs_mem.h
407 %{_includedir}/wx-%{ver2}/wx/fs_zip.h
408 %{_includedir}/wx-%{ver2}/wx/hash.h
409 %{_includedir}/wx-%{ver2}/wx/hashmap.h
410 %{_includedir}/wx-%{ver2}/wx/hashset.h
411 %{_includedir}/wx-%{ver2}/wx/html/forcelnk.h
412 %{_includedir}/wx-%{ver2}/wx/iconloc.h
413 %{_includedir}/wx-%{ver2}/wx/init.h
414 %{_includedir}/wx-%{ver2}/wx/intl.h
415 %{_includedir}/wx-%{ver2}/wx/iosfwrap.h
416 %{_includedir}/wx-%{ver2}/wx/ioswrap.h
417 %{_includedir}/wx-%{ver2}/wx/ipc.h
418 %{_includedir}/wx-%{ver2}/wx/ipcbase.h
419 %{_includedir}/wx-%{ver2}/wx/isql.h
420 %{_includedir}/wx-%{ver2}/wx/isqlext.h
421 %{_includedir}/wx-%{ver2}/wx/link.h
422 %{_includedir}/wx-%{ver2}/wx/list.h
423 %{_includedir}/wx-%{ver2}/wx/listimpl.cpp
424 %{_includedir}/wx-%{ver2}/wx/log.h
425 %{_includedir}/wx-%{ver2}/wx/longlong.h
426 %{_includedir}/wx-%{ver2}/wx/math.h
427 %{_includedir}/wx-%{ver2}/wx/memconf.h
428 %{_includedir}/wx-%{ver2}/wx/memory.h
429 %{_includedir}/wx-%{ver2}/wx/memtext.h
430 %{_includedir}/wx-%{ver2}/wx/mimetype.h
431 %{_includedir}/wx-%{ver2}/wx/module.h
432 %{_includedir}/wx-%{ver2}/wx/msgout.h
433 %{_includedir}/wx-%{ver2}/wx/mstream.h
434 %{_includedir}/wx-%{ver2}/wx/object.h
435 %{_includedir}/wx-%{ver2}/wx/platform.h
436 %{_includedir}/wx-%{ver2}/wx/power.h
437 %{_includedir}/wx-%{ver2}/wx/process.h
438 %{_includedir}/wx-%{ver2}/wx/ptr_scpd.h
439 %{_includedir}/wx-%{ver2}/wx/recguard.h
440 %{_includedir}/wx-%{ver2}/wx/regex.h
441 %{_includedir}/wx-%{ver2}/wx/scopeguard.h
442 %{_includedir}/wx-%{ver2}/wx/snglinst.h
443 %{_includedir}/wx-%{ver2}/wx/sstream.h
444 %{_includedir}/wx-%{ver2}/wx/stack.h
445 %{_includedir}/wx-%{ver2}/wx/stackwalk.h
446 %{_includedir}/wx-%{ver2}/wx/stdpaths.h
447 %{_includedir}/wx-%{ver2}/wx/stockitem.h
448 %{_includedir}/wx-%{ver2}/wx/stopwatch.h
449 %{_includedir}/wx-%{ver2}/wx/strconv.h
450 %{_includedir}/wx-%{ver2}/wx/stream.h
451 %{_includedir}/wx-%{ver2}/wx/string.h
452 %{_includedir}/wx-%{ver2}/wx/sysopt.h
453 %{_includedir}/wx-%{ver2}/wx/textbuf.h
454 %{_includedir}/wx-%{ver2}/wx/textfile.h
455 %{_includedir}/wx-%{ver2}/wx/thread.h
456 %{_includedir}/wx-%{ver2}/wx/thrimpl.cpp
457 %{_includedir}/wx-%{ver2}/wx/timer.h
458 %{_includedir}/wx-%{ver2}/wx/tokenzr.h
459 %{_includedir}/wx-%{ver2}/wx/txtstrm.h
460 %{_includedir}/wx-%{ver2}/wx/types.h
461 %{_includedir}/wx-%{ver2}/wx/uri.h
462 %{_includedir}/wx-%{ver2}/wx/utils.h
463 %{_includedir}/wx-%{ver2}/wx/variant.h
464 %{_includedir}/wx-%{ver2}/wx/vector.h
465 %{_includedir}/wx-%{ver2}/wx/version.h
466 %{_includedir}/wx-%{ver2}/wx/volume.h
467 %{_includedir}/wx-%{ver2}/wx/wfstream.h
468 %{_includedir}/wx-%{ver2}/wx/wx.h
469 %{_includedir}/wx-%{ver2}/wx/wxchar.h
470 %{_includedir}/wx-%{ver2}/wx/wxprec.h
471 %{_includedir}/wx-%{ver2}/wx/xti.h
472 %{_includedir}/wx-%{ver2}/wx/xtistrm.h
473 %{_includedir}/wx-%{ver2}/wx/zipstrm.h
474 %{_includedir}/wx-%{ver2}/wx/zstream.h
475 %{_includedir}/wx-%{ver2}/wx/fs_inet.h
476 %{_includedir}/wx-%{ver2}/wx/gsocket.h
477 %{_includedir}/wx-%{ver2}/wx/protocol/file.h
478 %{_includedir}/wx-%{ver2}/wx/protocol/ftp.h
479 %{_includedir}/wx-%{ver2}/wx/protocol/http.h
480 %{_includedir}/wx-%{ver2}/wx/protocol/protocol.h
481 %{_includedir}/wx-%{ver2}/wx/sckaddr.h
482 %{_includedir}/wx-%{ver2}/wx/sckipc.h
483 %{_includedir}/wx-%{ver2}/wx/sckstrm.h
484 %{_includedir}/wx-%{ver2}/wx/socket.h
485 %{_includedir}/wx-%{ver2}/wx/url.h
486 %{_includedir}/wx-%{ver2}/wx/xml/xml.h
487 %{_includedir}/wx-%{ver2}/wx/xtixml.h
488 %{_includedir}/wx-%{ver2}/wx/unix/apptbase.h
489 %{_includedir}/wx-%{ver2}/wx/unix/apptrait.h
490 %{_includedir}/wx-%{ver2}/wx/unix/execute.h
491 %{_includedir}/wx-%{ver2}/wx/unix/gsockunx.h
492 %{_includedir}/wx-%{ver2}/wx/unix/mimetype.h
493 %{_includedir}/wx-%{ver2}/wx/unix/pipe.h
494 %{_includedir}/wx-%{ver2}/wx/unix/private.h
495 %{_includedir}/wx-%{ver2}/wx/unix/stackwalk.h
496 %{_includedir}/wx-%{ver2}/wx/unix/stdpaths.h
497 EOF
498 # --- wxBase headers list ends here ---
499
500 # temporarily remove base headers
501 mkdir $RPM_BUILD_ROOT/_save_dir
502 cp -r $RPM_BUILD_ROOT%{_includedir}/wx-%{ver2} $RPM_BUILD_ROOT/_save_dir
503 for f in `cat wxbase-headers.files` ; do
504 rm -f $RPM_BUILD_ROOT%{_includedir}/wx-%{ver2}/$f
505 done
506 # list of all core headers:
507 find $RPM_BUILD_ROOT%{_includedir}/wx-%{ver2} -type f | sed -e "s,$RPM_BUILD_ROOT,,g" >core-headers.files
508 # move base headers (actually all headers) back again
509 cp -f -r $RPM_BUILD_ROOT/_save_dir/* $RPM_BUILD_ROOT%{_includedir}
510 rm -rf $RPM_BUILD_ROOT/_save_dir
511
512 # utils:
513 (cd obj-shared/utils/wxrc; make DESTDIR=$RPM_BUILD_ROOT prefix=%{_prefix} install)
514
515 # wx-config link is created during package installation, remove it for now
516 rm -f $RPM_BUILD_ROOT%{_bindir}/wx-config
517
518 %clean
519 rm -rf $RPM_BUILD_ROOT
520
521 %post
522 /sbin/ldconfig
523
524 %postun
525 /sbin/ldconfig
526
527 %post devel
528 # link wx-config when you install RPM.
529 %if %{unicode}
530 ln -sf %{_libdir}/wx/config/%{wxconfig} %{_bindir}/wx-config
531 %endif
532 # link wx-config with explicit name.
533 ln -sf %{_libdir}/wx/config/%{wxconfig} %{_bindir}/%{wxconfiglink}
534 /sbin/ldconfig
535
536 %postun devel
537 /sbin/ldconfig
538
539 %preun devel
540 %if %{unicode}
541 rm -f %{_bindir}/wx-config
542 %endif
543 rm -f %{_bindir}/%{wxconfiglink}
544
545 %post -n %{wxbasename}
546 /sbin/ldconfig
547
548 %postun -n %{wxbasename}
549 /sbin/ldconfig
550
551 %post -n %{wxbasename}-devel
552 # link wx-config with explicit name.
553 ln -sf %{_libdir}/wx/config/%{wxbaseconfig} %{_bindir}/%{wxbaseconfiglink}
554 /sbin/ldconfig
555
556 %postun -n %{wxbasename}-devel
557 /sbin/ldconfig
558
559 %preun -n %{wxbasename}-devel
560 rm -f %{_bindir}/%{wxbaseconfiglink}
561
562 %post gl
563 /sbin/ldconfig
564
565 %postun gl
566 /sbin/ldconfig
567
568 %files
569 %defattr(-,root,root)
570 %doc COPYING.LIB *.txt
571 %{_libdir}/libwx_%{buildname}_adv-%{ver2}.so.*
572 %{_libdir}/libwx_%{buildname}_aui-%{ver2}.so.*
573 %{_libdir}/libwx_%{buildname}_core-%{ver2}.so.*
574 %{_libdir}/libwx_%{buildname}_html-%{ver2}.so.*
575 %{_libdir}/libwx_%{buildname}_media-%{ver2}.so.*
576 %{_libdir}/libwx_%{buildname}_propgrid-%{ver2}.so.*
577 %{_libdir}/libwx_%{buildname}_qa-%{ver2}.so.*
578 %{_libdir}/libwx_%{buildname}_ribbon-%{ver2}.so.*
579 %{_libdir}/libwx_%{buildname}_richtext-%{ver2}.so.*
580 %{_libdir}/libwx_%{buildname}_stc-%{ver2}.so.*
581 %{_libdir}/libwx_%{buildname}_xrc-%{ver2}.so.*
582
583 %files -n wx-i18n
584 %defattr(-,root,root)
585 %{_datadir}/locale/*/LC_MESSAGES/*.mo
586
587 %files devel -f core-headers.files
588 %defattr(-,root,root)
589 # shared libs
590 %{_libdir}/libwx_%{buildname}_adv-%{ver2}.so
591 %{_libdir}/libwx_%{buildname}_aui-%{ver2}.so
592 %{_libdir}/libwx_%{buildname}_core-%{ver2}.so
593 %{_libdir}/libwx_%{buildname}_gl-%{ver2}.so
594 %{_libdir}/libwx_%{buildname}_html-%{ver2}.so
595 %{_libdir}/libwx_%{buildname}_media-%{ver2}.so
596 %{_libdir}/libwx_%{buildname}_propgrid-%{ver2}.so
597 %{_libdir}/libwx_%{buildname}_qa-%{ver2}.so
598 %{_libdir}/libwx_%{buildname}_ribbon-%{ver2}.so
599 %{_libdir}/libwx_%{buildname}_richtext-%{ver2}.so
600 %{_libdir}/libwx_%{buildname}_stc-%{ver2}.so
601 %{_libdir}/libwx_%{buildname}_xrc-%{ver2}.so
602 # static libs
603 %{_libdir}/libwx_%{buildname}_adv-%{ver2}.a
604 %{_libdir}/libwx_%{buildname}_aui-%{ver2}.a
605 %{_libdir}/libwx_%{buildname}_core-%{ver2}.a
606 %{_libdir}/libwx_%{buildname}_gl-%{ver2}.a
607 %{_libdir}/libwx_%{buildname}_html-%{ver2}.a
608 %{_libdir}/libwx_%{buildname}_media-%{ver2}.a
609 %{_libdir}/libwx_%{buildname}_propgrid-%{ver2}.a
610 %{_libdir}/libwx_%{buildname}_qa-%{ver2}.a
611 %{_libdir}/libwx_%{buildname}_ribbon-%{ver2}.a
612 %{_libdir}/libwx_%{buildname}_richtext-%{ver2}.a
613 %{_libdir}/libwx_%{buildname}_stc-%{ver2}.a
614 %{_libdir}/libwx_%{buildname}_xrc-%{ver2}.a
615 %dir %{_libdir}/wx
616 %{_libdir}/wx/config/%{wxconfig}
617 %{_libdir}/wx/include/%{wxconfig}/wx/setup.h
618 %{_libdir}/wx/config/%{wxconfigstatic}
619 %{_libdir}/wx/include/%{wxconfigstatic}/wx/setup.h
620 %{_bindir}/wxrc*
621
622 %files -n %{wxbasename}
623 %defattr(-,root,root)
624 %{_libdir}/libwx_base*-%{ver2}.so.*
625
626 %files -n %{wxbasename}-devel -f wxbase-headers.paths
627 %defattr (-,root,root)
628 %dir %{_includedir}/wx-%{ver2}
629 %{_libdir}/libwx_base*-%{ver2}.so
630 %{_libdir}/libwx_base*-%{ver2}.a
631 %if %{unicode}
632 %{_libdir}/libwxregexu-%{ver2}.a
633 %endif
634 %dir %{_libdir}/wx
635 %{_datadir}/aclocal/*.m4
636 %{_datadir}/bakefile/presets/*
637
638 %files gl
639 %defattr(-,root,root)
640 %{_libdir}/libwx_%{buildname}_gl-%{ver2}.so.*