A bit of distribution/makefiles things.
[wxWidgets.git] / wxGTK.spec
1 # Note that this is NOT a relocatable package
2 %define pref /usr
3 %define ver 2.1.0
4 %define rel 7
5
6 Summary: The GTK+ 1.2 port of the wxWindows library
7 Name: wxGTK
8 Version: %{ver}
9 Release: %{rel}
10 Copyright: wxWindows Licence
11 Group: X11/Libraries
12 Source: ftp://wesley.informatik.uni-freiburg.de/pub/linux/wxxt/source/wxGTK-2.1.0-b7.tgz
13 URL: http://wesley.informatik.uni-freiburg.de/~wxxt/docs.html
14 Packager: Robert Roebling <roebling@ruf.uni-freiburg.de>
15 Requires: gtk+ >= 1.2.1
16 BuildRoot: /tmp/wxgtk_root
17
18 # all packages providing an implementation of wxWindows library (regardless of
19 # the toolkit used) should provide the (virtual) wxwin package, this makes it
20 # possible to require wxwin instead of requiring "wxgtk or wxmotif or wxqt..."
21 Provides: wxwin
22
23 %description
24 wxWindows is a free C++ library for cross-platform GUI development.
25 With wxWindows, you can create applications for different GUIs (GTK+,
26 Motif/LessTif, MS Windows, Mac) from the same source code.
27
28 %prep
29 %setup -n wxGTK
30 ./configure --prefix=%{pref} --enable-threads
31
32 %build
33 cd src && make
34
35 %install
36 rm -rf $RPM_BUILD_ROOT
37 make prefix=$RPM_BUILD_ROOT%{pref} install
38
39 %clean
40 rm -rf $RPM_BUILD_ROOT
41
42 %post
43 /sbin/ldconfig
44
45 %postun
46 /sbin/ldconfig
47
48 %files
49 %defattr (644, root, root, 755)
50 %doc COPYING.LIB INSTALL.txt LICENCE.txt README.txt SYMBOLS.txt TODO.txt
51 %dir %{pref}/include/wx
52 %{pref}/include/wx/*
53 %dir %{pref}/lib/wx
54 %{pref}/lib/wx/*
55 %dir %{pref}/share/wx
56 %{pref}/share/wx/*
57 %attr(755, -, -) %{pref}/lib/libwx_gtk*
58 %attr(755, -, -) %{pref}/bin/wx-config
59