1 %define _prefix
/opt
/gnome
6 # Configurable settings (use --with(out) {unicode,gtk2} on rpmbuild cmd line):
8 %{?_with_unicode: %{expand: %%define unicode 1}}
9 %{?_without_unicode: %{expand: %%define unicode 0}}
12 %{?_with_gtk2: %{expand: %%define gtk2 1}}
13 %{?_without_gtk2: %{expand: %%define gtk2 0}}
15 # "buildname" needs to be e.g. gtk2ud for debug builds
20 %define buildname gtk2u
22 %define buildname gtk2
31 %define name wx
-%{portname}-unicode
32 %define wxconfig
%{portname}-unicode-release-%{ver2}
33 %define wxconfigstatic
%{portname}-unicode-release-static-%{ver2}
34 %define wxconfiglink wx
%{portname}u-%{ver2}-config
36 %define name wx
-%{portname}-ansi
37 %define wxconfig
%{portname}-ansi-release-%{ver2}
38 %define wxconfigstatic
%{portname}-ansi-release-static-%{ver2}
39 %define wxconfiglink wx
%{portname}-%{ver2}-config
43 %define wxbasename wx
-base
-unicode
44 %define wxbaseconfig base
-unicode
-release
-%{ver2}
45 %define wxbaseconfigstatic base
-unicode
-release
-static
-%{ver2}
46 %define wxbaseconfiglink wxbaseu
-%{ver2}-config
48 %define wxbasename wx
-base
-ansi
49 %define wxbaseconfig base
-ansi
-release
-%{ver2}
50 %define wxbaseconfigstatic base
-ansi
-release
-static
-%{ver2}
51 %define wxbaseconfiglink wxbase
-%{ver2}-config
54 Summary: The GTK
+ %{gtkver} port of the wxWidgets library
58 License: wxWindows Licence
60 Source: wxGTK
-%{ver}.tar.gz
61 URL: http
://www.wxwidgets.org
62 Packager: Vadim Zeitlin
<vadim@wxwindows.org
>
64 BuildRoot: %{_tmppath}/%{name}-root
65 Requires: %{wxbasename} = %{ver}
66 %if %{portname} == gtk2
67 # BuildRequires: gtk+-2.0-devel
69 # BuildRequires: gtk+-devel >= 1.2.0
72 BuildRequires
: zlib
-devel
, libjpeg
-devel
, libpng
-devel
, libtiff
-devel
74 # all packages providing an implementation of wxWidgets library (regardless of
75 # the toolkit used) should provide the (virtual) wxwin package, this makes it
76 # possible to require wxwin instead of requiring "wxgtk or wxmotif or wxuniv..."
81 wxWidgets is a free C
++ library
for cross
-platform GUI development.
82 With wxWidgets
, you can create applications
for different GUIs
(GTK
+,
83 Motif
, MS Windows
, MacOS X
, Windows CE
, GPE
) from the same
source code.
86 Summary: The translations
for the wxWidgets library.
89 %description -n wx
-i18n
90 The translations files
for the wxWidgets library.
93 Summary: The GTK
+ %{gtkver} port of the wxWidgets library
95 Requires: %{name} = %{ver}
96 Requires: %{wxbasename}-devel = %{ver}
100 The GTK
+ %{gtkver} port of the wxWidgets library
, header files.
103 Summary: The GTK
+ %{gtkver} port of the wxWidgets library
, OpenGL add
-on.
105 Requires: %{name} = %{ver}
109 OpenGL add
-on library
for wxGTK
, the GTK
+ %{gtkver} port of the wxWidgets library.
111 %package -n
%{wxbasename}
112 Summary: wxBase library
- non
-GUI support classes of the wxWidgets toolkit
113 Group: Development
/Libraries
116 %description -n
%{wxbasename}
117 wxBase is a collection of C
++ classes providing basic data structures
(strings
,
118 lists
, arrays
), portable wrappers around many OS
-specific funstions
(file
119 operations
, time/date manipulations
, threads
, processes
, sockets
, shared
120 library loading
) as well as other utility classes
(streams
, archive and
121 compression
). wxBase currently supports Win32
, most Unix variants
(Linux
,
122 FreeBSD
, Solaris
, HP
-UX
) and MacOS X
(Carbon and Mach
-0).
124 %package -n
%{wxbasename}-devel
125 Summary: wxBase library
, header files.
126 Group: Development
/Libraries
127 Provides: wxBase
-devel
129 %description -n
%{wxbasename}-devel
130 wxBase library
- non
-GUI support classes of the wxWidgets toolkit
,
134 Summary: The GTK
+ %{gtkver} port of the wxWidgets library
, contributed libraries.
136 Requires: %{name} = %{ver}
139 Contributed libraries
for wxGTK
, the GTK
+ %{gtkver} port of the wxWidgets library.
141 %package contrib
-devel
142 Summary: The GTK
+ %{gtkver} port of the wxWidgets library
144 Requires: %{name}-contrib = %{ver}
145 Requires: %{name}-devel = %{ver}
147 %description contrib
-devel
148 Header files
for contributed libraries
for wxGTK
, the GTK
+ %{gtkver} port of the wxWidgets library.
151 %setup -q
-n wxGTK
-%{ver}
154 if [ "$SMP"
!= ""
]; then
155 export MAKE
="
make -j$SMP"
160 mkdir obj
-shared
-no
-gui
162 ..
/configure
--prefix
=%{_prefix} \
174 ..
/configure
--prefix
=%{_prefix} \
193 mkdir obj
-static
-no
-gui
195 ..
/configure
--prefix
=%{_prefix} \
208 ..
/configure
--prefix
=%{_prefix} \
229 rm -rf $RPM_BUILD_ROOT
230 (cd obj
-static
-no
-gui
; make DESTDIR
=$RPM_BUILD_ROOT
install)
231 (cd obj
-static
; make DESTDIR
=$RPM_BUILD_ROOT
install)
232 (cd obj
-shared
-no
-gui
; make DESTDIR
=$RPM_BUILD_ROOT
install)
233 (cd obj
-shared
; make DESTDIR
=$RPM_BUILD_ROOT
install)
235 # --- wxBase headers list begins here ---
236 cat
<<EOF
>wxbase
-headers
-list
360 wx
/protocol
/protocol.h
373 # --- wxBase headers list ends here ---
374 cat
<<EOF
>wxbase
-headers.paths
375 %{_includedir}/wx-%{ver2}/wx
/afterstd.h
376 %{_includedir}/wx-%{ver2}/wx
/app.h
377 %{_includedir}/wx-%{ver2}/wx
/apptrait.h
378 %{_includedir}/wx-%{ver2}/wx
/archive.h
379 %{_includedir}/wx-%{ver2}/wx
/arrimpl.cpp
380 %{_includedir}/wx-%{ver2}/wx
/arrstr.h
381 %{_includedir}/wx-%{ver2}/wx
/beforestd.h
382 %{_includedir}/wx-%{ver2}/wx
/buffer.h
383 %{_includedir}/wx-%{ver2}/wx
/build.h
384 %{_includedir}/wx-%{ver2}/wx
/chkconf.h
385 %{_includedir}/wx-%{ver2}/wx
/clntdata.h
386 %{_includedir}/wx-%{ver2}/wx
/cmdline.h
387 %{_includedir}/wx-%{ver2}/wx
/confbase.h
388 %{_includedir}/wx-%{ver2}/wx
/config.h
389 %{_includedir}/wx-%{ver2}/wx
/containr.h
390 %{_includedir}/wx-%{ver2}/wx
/datetime.h
391 %{_includedir}/wx-%{ver2}/wx
/datetime.inl
392 %{_includedir}/wx-%{ver2}/wx
/datstrm.h
393 %{_includedir}/wx-%{ver2}/wx
/dde.h
394 %{_includedir}/wx-%{ver2}/wx
/debug.h
395 %{_includedir}/wx-%{ver2}/wx
/defs.h
396 %{_includedir}/wx-%{ver2}/wx
/dir.h
397 %{_includedir}/wx-%{ver2}/wx
/dlimpexp.h
398 %{_includedir}/wx-%{ver2}/wx
/dynarray.h
399 %{_includedir}/wx-%{ver2}/wx
/dynlib.h
400 %{_includedir}/wx-%{ver2}/wx
/dynload.h
401 %{_includedir}/wx-%{ver2}/wx
/encconv.h
402 %{_includedir}/wx-%{ver2}/wx
/event.h
403 %{_includedir}/wx-%{ver2}/wx
/except.h
404 %{_includedir}/wx-%{ver2}/wx
/features.h
405 %{_includedir}/wx-%{ver2}/wx
/ffile.h
406 %{_includedir}/wx-%{ver2}/wx
/file.h
407 %{_includedir}/wx-%{ver2}/wx
/fileconf.h
408 %{_includedir}/wx-%{ver2}/wx
/filefn.h
409 %{_includedir}/wx-%{ver2}/wx
/filename.h
410 %{_includedir}/wx-%{ver2}/wx
/filesys.h
411 %{_includedir}/wx-%{ver2}/wx
/fontenc.h
412 %{_includedir}/wx-%{ver2}/wx
/fontmap.h
413 %{_includedir}/wx-%{ver2}/wx
/fs_mem.h
414 %{_includedir}/wx-%{ver2}/wx
/fs_zip.h
415 %{_includedir}/wx-%{ver2}/wx
/hash.h
416 %{_includedir}/wx-%{ver2}/wx
/hashmap.h
417 %{_includedir}/wx-%{ver2}/wx
/hashset.h
418 %{_includedir}/wx-%{ver2}/wx
/html
/forcelnk.h
419 %{_includedir}/wx-%{ver2}/wx
/iconloc.h
420 %{_includedir}/wx-%{ver2}/wx
/init.h
421 %{_includedir}/wx-%{ver2}/wx
/intl.h
422 %{_includedir}/wx-%{ver2}/wx
/iosfwrap.h
423 %{_includedir}/wx-%{ver2}/wx
/ioswrap.h
424 %{_includedir}/wx-%{ver2}/wx
/ipc.h
425 %{_includedir}/wx-%{ver2}/wx
/ipcbase.h
426 %{_includedir}/wx-%{ver2}/wx
/isql.h
427 %{_includedir}/wx-%{ver2}/wx
/isqlext.h
428 %{_includedir}/wx-%{ver2}/wx
/list.h
429 %{_includedir}/wx-%{ver2}/wx
/listimpl.cpp
430 %{_includedir}/wx-%{ver2}/wx
/log.h
431 %{_includedir}/wx-%{ver2}/wx
/longlong.h
432 %{_includedir}/wx-%{ver2}/wx
/math.h
433 %{_includedir}/wx-%{ver2}/wx
/memconf.h
434 %{_includedir}/wx-%{ver2}/wx
/memory.h
435 %{_includedir}/wx-%{ver2}/wx
/memtext.h
436 %{_includedir}/wx-%{ver2}/wx
/mimetype.h
437 %{_includedir}/wx-%{ver2}/wx
/module.h
438 %{_includedir}/wx-%{ver2}/wx
/msgout.h
439 %{_includedir}/wx-%{ver2}/wx
/mstream.h
440 %{_includedir}/wx-%{ver2}/wx
/object.h
441 %{_includedir}/wx-%{ver2}/wx
/platform.h
442 %{_includedir}/wx-%{ver2}/wx
/process.h
443 %{_includedir}/wx-%{ver2}/wx
/ptr_scpd.h
444 %{_includedir}/wx-%{ver2}/wx
/regex.h
445 %{_includedir}/wx-%{ver2}/wx
/scopeguard.h
446 %{_includedir}/wx-%{ver2}/wx
/snglinst.h
447 %{_includedir}/wx-%{ver2}/wx
/sstream.h
448 %{_includedir}/wx-%{ver2}/wx
/stack.h
449 %{_includedir}/wx-%{ver2}/wx
/stackwalk.h
450 %{_includedir}/wx-%{ver2}/wx
/stdpaths.h
451 %{_includedir}/wx-%{ver2}/wx
/stockitem.h
452 %{_includedir}/wx-%{ver2}/wx
/stopwatch.h
453 %{_includedir}/wx-%{ver2}/wx
/strconv.h
454 %{_includedir}/wx-%{ver2}/wx
/stream.h
455 %{_includedir}/wx-%{ver2}/wx
/string.h
456 %{_includedir}/wx-%{ver2}/wx
/sysopt.h
457 %{_includedir}/wx-%{ver2}/wx
/textbuf.h
458 %{_includedir}/wx-%{ver2}/wx
/textfile.h
459 %{_includedir}/wx-%{ver2}/wx
/thread.h
460 %{_includedir}/wx-%{ver2}/wx
/thrimpl.cpp
461 %{_includedir}/wx-%{ver2}/wx
/timer.h
462 %{_includedir}/wx-%{ver2}/wx
/tokenzr.h
463 %{_includedir}/wx-%{ver2}/wx
/txtstrm.h
464 %{_includedir}/wx-%{ver2}/wx
/types.h
465 %{_includedir}/wx-%{ver2}/wx
/uri.h
466 %{_includedir}/wx-%{ver2}/wx
/utils.h
467 %{_includedir}/wx-%{ver2}/wx
/variant.h
468 %{_includedir}/wx-%{ver2}/wx
/vector.h
469 %{_includedir}/wx-%{ver2}/wx
/version.h
470 %{_includedir}/wx-%{ver2}/wx
/volume.h
471 %{_includedir}/wx-%{ver2}/wx
/wfstream.h
472 %{_includedir}/wx-%{ver2}/wx
/wx.h
473 %{_includedir}/wx-%{ver2}/wx
/wxchar.h
474 %{_includedir}/wx-%{ver2}/wx
/wxprec.h
475 %{_includedir}/wx-%{ver2}/wx
/xti.h
476 %{_includedir}/wx-%{ver2}/wx
/xtistrm.h
477 %{_includedir}/wx-%{ver2}/wx
/zipstrm.h
478 %{_includedir}/wx-%{ver2}/wx
/zstream.h
479 %{_includedir}/wx-%{ver2}/wx
/fs_inet.h
480 %{_includedir}/wx-%{ver2}/wx
/gsocket.h
481 %{_includedir}/wx-%{ver2}/wx
/protocol
/file.h
482 %{_includedir}/wx-%{ver2}/wx
/protocol
/ftp.h
483 %{_includedir}/wx-%{ver2}/wx
/protocol
/http.h
484 %{_includedir}/wx-%{ver2}/wx
/protocol
/protocol.h
485 %{_includedir}/wx-%{ver2}/wx
/sckaddr.h
486 %{_includedir}/wx-%{ver2}/wx
/sckipc.h
487 %{_includedir}/wx-%{ver2}/wx
/sckstrm.h
488 %{_includedir}/wx-%{ver2}/wx
/socket.h
489 %{_includedir}/wx-%{ver2}/wx
/url.h
490 %{_includedir}/wx-%{ver2}/wx
/xml
/xml.h
491 %{_includedir}/wx-%{ver2}/wx
/xtixml.h
492 %{_includedir}/wx-%{ver2}/wx
/db.h
493 %{_includedir}/wx-%{ver2}/wx
/dbkeyg.h
494 %{_includedir}/wx-%{ver2}/wx
/dbtable.h
495 %{_includedir}/wx-%{ver2}/wx
/unix
/apptbase.h
496 %{_includedir}/wx-%{ver2}/wx
/unix
/apptrait.h
497 %{_includedir}/wx-%{ver2}/wx
/unix
/execute.h
498 %{_includedir}/wx-%{ver2}/wx
/unix
/gsockunx.h
499 %{_includedir}/wx-%{ver2}/wx
/unix
/mimetype.h
500 %{_includedir}/wx-%{ver2}/wx
/unix
/pipe.h
501 %{_includedir}/wx-%{ver2}/wx
/unix
/stackwalk.h
502 %{_includedir}/wx-%{ver2}/wx
/unix
/stdpaths.h
504 # --- wxBase headers list ends here ---
506 # temporarily remove base headers
507 mkdir $RPM_BUILD_ROOT
/_save_dir
508 cp
-r $RPM_BUILD_ROOT
%{_includedir}/wx-%{ver2} $RPM_BUILD_ROOT
/_save_dir
509 for f
in `cat wxbase
-headers.files`
; do
510 rm -f $RPM_BUILD_ROOT
%{_includedir}/wx-%{ver2}/$f
512 # list of all core headers:
513 find $RPM_BUILD_ROOT
%{_includedir}/wx-%{ver2} -type f | sed
-e "s
,$RPM_BUILD_ROOT
,,g"
>core
-headers.files
514 # move base headers (actually all headers) back again
515 cp
-f
-r $RPM_BUILD_ROOT
/_save_dir
/* $RPM_BUILD_ROOT
%{_includedir}
516 rm -rf $RPM_BUILD_ROOT
/_save_dir
519 (cd obj
-shared
/contrib
/src
; make DESTDIR
=$RPM_BUILD_ROOT
install)
520 (cd obj
-shared
/utils
/wxrc
; make DESTDIR
=$RPM_BUILD_ROOT
install)
523 rm -rf $RPM_BUILD_ROOT
532 # link wx-config when you install RPM.
534 ln
-sf
%{_libdir}/wx/config/%{wxconfig} %{_bindir}/wx
-config
536 # link wx-config with explicit name.
537 ln
-sf
%{_libdir}/wx/config/%{wxconfig} %{_bindir}/%{wxconfiglink}
545 rm -f
%{_bindir}/wx
-config
547 rm -f
%{_bindir}/%{wxconfiglink}
549 %post -n
%{wxbasename}
552 %postun -n
%{wxbasename}
555 %post -n
%{wxbasename}-devel
556 # link wx-config with explicit name.
557 ln
-sf
%{_libdir}/wx/config/%{wxbaseconfig} %{_bindir}/%{wxbaseconfiglink}
560 %postun -n
%{wxbasename}-devel
563 %preun -n
%{wxbasename}-devel
564 rm -f
%{_bindir}/%{wxbaseconfiglink}
581 %postun contrib
-devel
585 %defattr(-,root
,root
)
586 %doc COPYING.LIB
*.txt
587 %{_libdir}/libwx_%{buildname}_adv-%{ver2}.so.
*
588 %{_libdir}/libwx_%{buildname}_core-%{ver2}.so.
*
590 %{_libdir}/libwx_%{buildname}_dbgrid-%{ver2}.so.
*
592 %{_libdir}/libwx_%{buildname}_html-%{ver2}.so.
*
593 %{_libdir}/libwx_%{buildname}_media-%{ver2}.so.
*
594 %{_libdir}/libwx_%{buildname}_qa-%{ver2}.so.
*
595 %{_libdir}/libwx_%{buildname}_xrc-%{ver2}.so.
*
598 %defattr(-,root
,root
)
599 %{_datadir}/locale
/*/*/*
601 %files devel
-f core
-headers.files
602 %defattr(-,root
,root
)
604 %{_libdir}/libwx_%{buildname}_adv-%{ver2}.so
605 %{_libdir}/libwx_%{buildname}_core-%{ver2}.so
607 %{_libdir}/libwx_%{buildname}_dbgrid-%{ver2}.so
609 %{_libdir}/libwx_%{buildname}_gl-%{ver2}.so
610 %{_libdir}/libwx_%{buildname}_html-%{ver2}.so
611 %{_libdir}/libwx_%{buildname}_media-%{ver2}.so
612 %{_libdir}/libwx_%{buildname}_qa-%{ver2}.so
613 %{_libdir}/libwx_%{buildname}_xrc-%{ver2}.so
615 %{_libdir}/libwx_%{buildname}_adv-%{ver2}.a
616 %{_libdir}/libwx_%{buildname}_core-%{ver2}.a
618 %{_libdir}/libwx_%{buildname}_dbgrid-%{ver2}.a
620 %{_libdir}/libwx_%{buildname}_gl-%{ver2}.a
621 %{_libdir}/libwx_%{buildname}_html-%{ver2}.a
622 %{_libdir}/libwx_%{buildname}_media-%{ver2}.a
623 %{_libdir}/libwx_%{buildname}_qa-%{ver2}.a
624 %{_libdir}/libwx_%{buildname}_xrc-%{ver2}.a
626 %{_libdir}/wx/config/%{wxconfig}
627 %{_libdir}/wx/include/%{wxconfig}/wx
/setup.h
628 %{_libdir}/wx/config/%{wxconfigstatic}
629 %{_libdir}/wx/include/%{wxconfigstatic}/wx
/setup.h
632 %files -n
%{wxbasename}
633 %defattr(-,root
,root
)
634 %{_libdir}/libwx_base*-%{ver2}.so.
*
636 %files -n
%{wxbasename}-devel
-f wxbase
-headers.paths
637 %defattr (-,root
,root
)
638 %dir %{_includedir}/wx-%{ver2}
639 %{_libdir}/libwx_base*-%{ver2}.so
640 %{_libdir}/libwx_base*-%{ver2}.a
642 %{_libdir}/libwxregexu-%{ver2}.a
645 %{_libdir}/wx/config/%{wxbaseconfig}
646 %{_libdir}/wx/include/%{wxbaseconfig}/wx
/setup.h
647 %{_libdir}/wx/config/%{wxbaseconfigstatic}
648 %{_libdir}/wx/include/%{wxbaseconfigstatic}/wx
/setup.h
649 %{_datadir}/aclocal
/*.m4
652 %defattr(-,root
,root
)
653 %{_libdir}/libwx_%{buildname}_gl-%{ver2}.so.
*
656 %defattr(-,root
,root
)
657 %{_libdir}/libwx_%{buildname}_animate-%{ver2}.so.
*
658 %{_libdir}/libwx_%{buildname}_deprecated-%{ver2}.so.
*
659 %{_libdir}/libwx_%{buildname}_fl-%{ver2}.so.
*
660 %{_libdir}/libwx_%{buildname}_gizmos-%{ver2}.so.
*
661 %{_libdir}/libwx_%{buildname}_gizmos_xrc-%{ver2}.so.
*
662 %{_libdir}/libwx_%{buildname}_mmedia-%{ver2}.so.
*
663 %{_libdir}/libwx_%{buildname}_ogl-%{ver2}.so.
*
664 %{_libdir}/libwx_%{buildname}_plot-%{ver2}.so.
*
665 %{_libdir}/libwx_%{buildname}_stc-%{ver2}.so.
*
666 %{_libdir}/libwx_%{buildname}_svg-%{ver2}.so.
*
669 %defattr(-,root
,root
)
670 %dir %{_includedir}/wx-%{ver2}/wx
/animate
671 %{_includedir}/wx-%{ver2}/wx
/animate
/*
672 %{_libdir}/libwx_%{buildname}_animate-%{ver2}.so
674 %dir %{_includedir}/wx-%{ver2}/wx
/deprecated
675 %{_includedir}/wx-%{ver2}/wx
/deprecated
/*
676 %{_libdir}/libwx_%{buildname}_deprecated-%{ver2}.so
678 %dir %{_includedir}/wx-%{ver2}/wx
/fl
679 %{_includedir}/wx-%{ver2}/wx
/fl
/*
680 %{_libdir}/libwx_%{buildname}_fl-%{ver2}.so
682 %dir %{_includedir}/wx-%{ver2}/wx
/gizmos
683 %{_includedir}/wx-%{ver2}/wx
/gizmos
/*
684 %{_libdir}/libwx_%{buildname}_gizmos-%{ver2}.so
685 %{_libdir}/libwx_%{buildname}_gizmos_xrc-%{ver2}.so
687 %dir %{_includedir}/wx-%{ver2}/wx
/mmedia
688 %{_includedir}/wx-%{ver2}/wx
/mmedia
/*
689 %{_libdir}/libwx_%{buildname}_mmedia-%{ver2}.so
691 %dir %{_includedir}/wx-%{ver2}/wx
/ogl
692 %{_includedir}/wx-%{ver2}/wx
/ogl
/*
693 %{_libdir}/libwx_%{buildname}_ogl-%{ver2}.so
695 %dir %{_includedir}/wx-%{ver2}/wx
/plot
696 %{_includedir}/wx-%{ver2}/wx
/plot
/*
697 %{_libdir}/libwx_%{buildname}_plot-%{ver2}.so
699 %dir %{_includedir}/wx-%{ver2}/wx
/stc
700 %{_includedir}/wx-%{ver2}/wx
/stc
/*
701 %{_libdir}/libwx_%{buildname}_stc-%{ver2}.so
703 %dir %{_includedir}/wx-%{ver2}/wx
/svg
704 %{_includedir}/wx-%{ver2}/wx
/svg
/*
705 %{_libdir}/libwx_%{buildname}_svg-%{ver2}.so