rebaked after adding convauto.cpp/.h
[wxWidgets.git] / wxMotif.spec
1 %define pref /usr
2 %define ver 2.6.2
3 %define ver2 2.6
4 %define rel 1
5
6 %define portname motif
7 %define name wx-%{portname}
8 %define wxbasename wx-base
9
10 %define wxconfig %{portname}-ansi-release-%{ver2}
11 %define wxconfiglink wx%{portname}-%{ver2}-config
12
13 Summary: The Motif/Lesstif port of the wxWidgets library
14 Name: %{name}
15 Version: %{ver}
16 Release: %{rel}
17 License: wxWindows Licence
18 Group: X11/Libraries
19 Source: wxMotif-%{ver}.tar.bz2
20 URL: http://www.wxwidgets.org
21 Packager: wxWidgets developers <wx-dev@lists.wxwidgets.org>
22 BuildRoot: %{_tmppath}/%{name}-root
23 Requires: %{wxbasename} = %{ver}
24
25 # all packages providing an implementation of wxWidgets library (regardless of
26 # the toolkit used) should provide the (virtual) wxwin package, this makes it
27 # possible to require wxwin instead of requiring "wxgtk or wxmotif or wxuniv..."
28 Provides: wxwin
29 Provides: wxMotif
30
31 %description
32 wxWidgets is a free C++ library for cross-platform GUI development.
33 With wxWidgets, you can create applications for different GUIs (GTK+,
34 Motif/LessTif, MS Windows, Mac) from the same source code.
35
36 %package devel
37 Summary: The Motif/Lesstif port of the wxWidgets library
38 Group: X11/Libraries
39 Requires: %{name} = %{ver}
40 Requires: %{wxbasename}-devel = %{ver}
41
42 %description devel
43 Header files for wxMotif, the Motif/Lesstif port of the wxWidgets library.
44
45 %package gl
46 Summary: The Motif/Lesstif port of the wxWidgets library, OpenGL add-on.
47 Group: X11/Libraries
48 Requires: %{name} = %{ver}
49
50 %description gl
51 OpenGL add-on library for wxMotif, the Motif/Lesstif port of the wxWidgets library.
52
53 %package static
54 Summary: wxMotif static libraries
55 Group: Development/Libraries
56 Requires: %{wxbasename}-static
57 Requires: %{name}-devel = %{ver}
58
59 %description static
60 Static libraries for wxMotif. You need them if you want to link statically against wxMotif.
61
62 %package contrib
63 Summary: Contrib libraries for wxMotif
64 Group: X11/Libraries
65 Requires: %{name} = %{ver}
66
67 %description contrib
68 Contrib libraries for wxMotif
69
70 %package contrib-devel
71 Summary: Contrib libraries for wxMotif
72 Group: X11/Libraries
73 Requires: %{name}-contrib = %{ver}
74 Requires: %{name}-devel = %{ver}
75
76 %description contrib-devel
77 Header files for contributed libraries for wxMotif.
78
79 %prep
80 %setup -q -n wxMotif-%{ver}
81
82 %build
83 if [ "$SMP" != "" ]; then
84 export MAKE="make -j$SMP"
85 else
86 export MAKE="make"
87 fi
88
89 mkdir obj-shared
90 cd obj-shared
91 ../configure --prefix=%{pref} --with-motif --with-odbc --with-opengl
92 $MAKE
93
94 cd contrib/src
95 $MAKE
96 cd ../../..
97
98 mkdir obj-static
99 cd obj-static
100 ../configure --prefix=%{pref} --with-motif --disable-shared --with-odbc --with-opengl
101 $MAKE
102 cd ..
103
104 %install
105 rm -rf $RPM_BUILD_ROOT
106 (cd obj-static; make prefix=$RPM_BUILD_ROOT%{pref} install)
107 (cd obj-shared; make prefix=$RPM_BUILD_ROOT%{pref} install)
108
109 # Remove headers that are part of wx-base-devel:
110
111 # --- wxBase headers list begins here ---
112 cat <<EOF >wxbase-headers.files
113 wx/afterstd.h
114 wx/app.h
115 wx/apptrait.h
116 wx/archive.h
117 wx/arrimpl.cpp
118 wx/arrstr.h
119 wx/beforestd.h
120 wx/buffer.h
121 wx/build.h
122 wx/chkconf.h
123 wx/clntdata.h
124 wx/cmdline.h
125 wx/confbase.h
126 wx/config.h
127 wx/convauto.h
128 wx/containr.h
129 wx/datetime.h
130 wx/datstrm.h
131 wx/dde.h
132 wx/debug.h
133 wx/defs.h
134 wx/dir.h
135 wx/dlimpexp.h
136 wx/dynarray.h
137 wx/dynlib.h
138 wx/dynload.h
139 wx/encconv.h
140 wx/event.h
141 wx/except.h
142 wx/features.h
143 wx/ffile.h
144 wx/file.h
145 wx/fileconf.h
146 wx/filefn.h
147 wx/filename.h
148 wx/filesys.h
149 wx/fontenc.h
150 wx/fontmap.h
151 wx/fs_mem.h
152 wx/fs_zip.h
153 wx/hash.h
154 wx/hashmap.h
155 wx/hashset.h
156 wx/html/forcelnk.h
157 wx/iconloc.h
158 wx/init.h
159 wx/intl.h
160 wx/iosfwrap.h
161 wx/ioswrap.h
162 wx/ipc.h
163 wx/ipcbase.h
164 wx/isql.h
165 wx/isqlext.h
166 wx/link.h
167 wx/list.h
168 wx/listimpl.cpp
169 wx/log.h
170 wx/longlong.h
171 wx/math.h
172 wx/memconf.h
173 wx/memory.h
174 wx/memtext.h
175 wx/mimetype.h
176 wx/module.h
177 wx/msgout.h
178 wx/mstream.h
179 wx/object.h
180 wx/platform.h
181 wx/process.h
182 wx/ptr_scpd.h
183 wx/recguard.h
184 wx/regex.h
185 wx/scopeguard.h
186 wx/snglinst.h
187 wx/sstream.h
188 wx/stack.h
189 wx/stackwalk.h
190 wx/stdpaths.h
191 wx/stockitem.h
192 wx/stopwatch.h
193 wx/strconv.h
194 wx/stream.h
195 wx/string.h
196 wx/sysopt.h
197 wx/textbuf.h
198 wx/textfile.h
199 wx/thread.h
200 wx/thrimpl.cpp
201 wx/timer.h
202 wx/tokenzr.h
203 wx/txtstrm.h
204 wx/types.h
205 wx/uri.h
206 wx/utils.h
207 wx/variant.h
208 wx/vector.h
209 wx/version.h
210 wx/volume.h
211 wx/wfstream.h
212 wx/wx.h
213 wx/wxchar.h
214 wx/wxprec.h
215 wx/xti.h
216 wx/xtistrm.h
217 wx/zipstrm.h
218 wx/zstream.h
219 wx/unix/apptbase.h
220 wx/unix/apptrait.h
221 wx/unix/execute.h
222 wx/unix/mimetype.h
223 wx/unix/pipe.h
224 wx/unix/private.h
225 wx/unix/stackwalk.h
226 wx/unix/stdpaths.h
227 wx/fs_inet.h
228 wx/gsocket.h
229 wx/protocol/file.h
230 wx/protocol/ftp.h
231 wx/protocol/http.h
232 wx/protocol/protocol.h
233 wx/sckaddr.h
234 wx/sckipc.h
235 wx/sckstrm.h
236 wx/socket.h
237 wx/url.h
238 wx/unix/gsockunx.h
239 wx/xml/xml.h
240 wx/xtixml.h
241 wx/db.h
242 wx/dbkeyg.h
243 wx/dbtable.h
244 EOF
245 # --- wxBase headers list ends here ---
246 for f in `cat wxbase-headers-list` ; do
247 rm -f $RPM_BUILD_ROOT%{_includedir}/wx-%{ver2}/$f
248 done
249
250 # list of all core headers:
251 find $RPM_BUILD_ROOT%{_includedir}/wx-%{ver2} -type f | sed -e "s,$RPM_BUILD_ROOT,,g" >core-headers.files
252
253 # contrib stuff:
254 (cd obj-shared/contrib/src; make prefix=$RPM_BUILD_ROOT%{pref} install)
255 (cd obj-shared/utils/wxrc; make prefix=$RPM_BUILD_ROOT%{pref} install)
256
257 # remove wxBase files so that RPM doesn't complain about unpackaged files:
258 rm -f $RPM_BUILD_ROOT%{_libdir}/libwx_base*
259 rm -f $RPM_BUILD_ROOT%{_datadir}/aclocal/*
260 rm -f $RPM_BUILD_ROOT%{_datadir}/locale/*/*/*
261
262 %clean
263 rm -rf $RPM_BUILD_ROOT
264
265 %post
266 /sbin/ldconfig
267
268 %postun
269 /sbin/ldconfig
270
271 %post devel
272 # link wx-config when you install RPM.
273 ln -sf %{_libdir}/wx/config/%{wxconfig} %{_bindir}/wx-config
274 # link wx-config with explicit name.
275 ln -sf %{_libdir}/wx/config/%{wxconfig} %{_bindir}/%{wxconfiglink}
276 /sbin/ldconfig
277
278 %postun devel
279 /sbin/ldconfig
280
281 %preun devel
282 if test -f %{_bindir}/wx-config -a -f /usr/bin/md5sum ; then
283 SUM1=`md5sum %{_libdir}/wx/config/%{wxconfig} | cut -c 0-32`
284 SUM2=`md5sum %{_bindir}/wx-config | cut -c 0-32`
285 if test "x$SUM1" = "x$SUM2" ; then
286 rm -f %{_bindir}/wx-config
287 fi
288 fi
289 rm -f %{_bindir}/%{wxconfiglink}
290
291 %post gl
292 /sbin/ldconfig
293
294 %postun gl
295 /sbin/ldconfig
296
297 %post contrib
298 /sbin/ldconfig
299
300 %postun contrib
301 /sbin/ldconfig
302
303 %post contrib-devel
304 /sbin/ldconfig
305
306 %postun contrib-devel
307 /sbin/ldconfig
308
309 %files
310 %defattr(-,root,root)
311 %doc COPYING.LIB *.txt
312 %{_libdir}/libwx_%{portname}*_adv-%{ver2}.so.*
313 %{_libdir}/libwx_%{portname}*_core-%{ver2}.so.*
314 %{_libdir}/libwx_%{portname}*_dbgrid-%{ver2}.so.*
315 %{_libdir}/libwx_%{portname}*_html-%{ver2}.so.*
316 %{_libdir}/libwx_%{portname}*_media-%{ver2}.so.*
317 %{_libdir}/libwx_%{portname}*_qa-%{ver2}.so.*
318 %{_libdir}/libwx_%{portname}*_xrc-%{ver2}.so.*
319
320
321 %files devel -f core-headers.files
322 %defattr(-,root,root)
323 %{_libdir}/libwx_%{portname}*_adv-%{ver2}.so
324 %{_libdir}/libwx_%{portname}*_core-%{ver2}.so
325 %{_libdir}/libwx_%{portname}*_dbgrid-%{ver2}.so
326 %{_libdir}/libwx_%{portname}*_gl-%{ver2}.so
327 %{_libdir}/libwx_%{portname}*_html-%{ver2}.so
328 %{_libdir}/libwx_%{portname}*_media-%{ver2}.so
329 %{_libdir}/libwx_%{portname}*_qa-%{ver2}.so
330 %{_libdir}/libwx_%{portname}*_xrc-%{ver2}.so
331 %dir %{_libdir}/wx
332 %{_libdir}/wx/*
333 %{_bindir}/wxrc*
334
335 %files gl
336 %defattr(-,root,root)
337 %{_libdir}/libwx_%{portname}*_gl-%{ver2}.so.*
338
339 %files static
340 %defattr (-,root,root)
341 %{_libdir}/libwx_%{portname}*_*-%{ver2}.a
342
343 %files contrib
344 %defattr(-,root,root)
345 %{_libdir}/libwx_%{portname}*_animate-%{ver2}.so.*
346 %{_libdir}/libwx_%{portname}*_deprecated-%{ver2}.so.*
347 %{_libdir}/libwx_%{portname}*_fl-%{ver2}.so.*
348 %{_libdir}/libwx_%{portname}*_gizmos-%{ver2}.so.*
349 %{_libdir}/libwx_%{portname}*_mmedia-%{ver2}.so.*
350 %{_libdir}/libwx_%{portname}*_ogl-%{ver2}.so.*
351 %{_libdir}/libwx_%{portname}*_plot-%{ver2}.so.*
352 %{_libdir}/libwx_%{portname}*_stc-%{ver2}.so.*
353 %{_libdir}/libwx_%{portname}*_svg-%{ver2}.so.*
354
355 %files contrib-devel
356 %defattr(-,root,root)
357 %dir %{_includedir}/wx-%{ver2}/wx/animate
358 %{_includedir}/wx-%{ver2}/wx/animate/*
359 %{_libdir}/libwx_%{portname}*_animate-%{ver2}.so
360
361 %dir %{_includedir}/wx-%{ver2}/wx/deprecated
362 %{_includedir}/wx-%{ver2}/wx/deprecated/*
363 %{_libdir}/libwx_%{portname}*_deprecated-%{ver2}.so
364
365 %dir %{_includedir}/wx-%{ver2}/wx/fl
366 %{_includedir}/wx-%{ver2}/wx/fl/*
367 %{_libdir}/libwx_%{portname}*_fl-%{ver2}.so
368
369 %dir %{_includedir}/wx-%{ver2}/wx/gizmos
370 %{_includedir}/wx-%{ver2}/wx/gizmos/*
371 %{_libdir}/libwx_%{portname}*_gizmos-%{ver2}.so
372
373 %dir %{_includedir}/wx-%{ver2}/wx/mmedia
374 %{_includedir}/wx-%{ver2}/wx/mmedia/*
375 %{_libdir}/libwx_%{portname}*_mmedia-%{ver2}.so
376
377 %dir %{_includedir}/wx-%{ver2}/wx/ogl
378 %{_includedir}/wx-%{ver2}/wx/ogl/*
379 %{_libdir}/libwx_%{portname}*_ogl-%{ver2}.so
380
381 %dir %{_includedir}/wx-%{ver2}/wx/plot
382 %{_includedir}/wx-%{ver2}/wx/plot/*
383 %{_libdir}/libwx_%{portname}*_plot-%{ver2}.so
384
385 %dir %{_includedir}/wx-%{ver2}/wx/stc
386 %{_includedir}/wx-%{ver2}/wx/stc/*
387 %{_libdir}/libwx_%{portname}*_stc-%{ver2}.so
388
389 %dir %{_includedir}/wx-%{ver2}/wx/svg
390 %{_includedir}/wx-%{ver2}/wx/svg/*
391 %{_libdir}/libwx_%{portname}*_svg-%{ver2}.so