Added wxUSE_CONSOLE_EVENTLOOP and wxUSE_SELECT/EPOLLDISPATCHER guards;
[wxWidgets.git] / wxX11.spec
1 %define pref /usr
2 %define ver 2.9.0
3 %define ver2 2.9
4 %define rel 1
5
6 # Configurable settings (use --with(out) unicode on rpmbuild cmd line):
7 %define unicode 0
8 %{?_with_unicode: %{expand: %%define unicode 1}}
9 %{?_without_unicode: %{expand: %%define unicode 0}}
10
11 %define portname x11univ
12
13 %if %{unicode}
14 %define wxbasename wx-base-unicode
15 %define name wx-%{portname}-unicode
16 %define wxconfig %{portname}-unicode-release-%{ver2}
17 %define wxconfiglink wx%{portname}u-%{ver2}-config
18 %else
19 %define wxbasename wx-base
20 %define name wx-%{portname}
21 %define wxconfig %{portname}-ansi-release-%{ver2}
22 %define wxconfiglink wx%{portname}-%{ver2}-config
23 %endif
24
25 Summary: The X11 port of the wxWidgets library
26 Name: %{name}
27 Version: %{ver}
28 Release: %{rel}
29 License: wxWindows Licence
30 Group: X11/Libraries
31 Source: wxX11-%{ver}.tar.bz2
32 URL: http://www.wxwidgets.org
33 Packager: Vadim Zeitlin <vadim@wxwindows.org>
34 Prefix: %{pref}
35 BuildRoot: %{_tmppath}/%{name}-root
36 Requires: %{wxbasename} = %{ver}
37
38 # all packages providing an implementation of wxWidgets library (regardless of
39 # the toolkit used) should provide the (virtual) wxwin package, this makes it
40 # possible to require wxwin instead of requiring "wxgtk or wxmotif or wxuniv..."
41 Provides: wxwin
42 Provides: wxX11
43
44 %description
45 wxWidgets is a free C++ library for cross-platform GUI development.
46 With wxWidgets, you can create applications for different GUIs (GTK+,
47 Motif/LessTif, MS Windows, Mac) from the same source code.
48
49 %package devel
50 Summary: The X11 port of the wxWidgets library
51 Group: X11/Libraries
52 Requires: %{name} = %{ver}
53 Requires: %{wxbasename}-devel = %{ver}
54
55 %description devel
56 Header files for wxX11, the X11 port of the wxWidgets library.
57
58 %package gl
59 Summary: The X11 port of the wxWidgets library, OpenGL add-on.
60 Group: X11/Libraries
61 Requires: %{name} = %{ver}
62
63 %description gl
64 OpenGL add-on library for wxX11, the X11 port of the wxWidgets library.
65
66 %package static
67 Summary: wxX11 static libraries
68 Group: Development/Libraries
69 Requires: %{wxbasename}-static
70 Requires: %{name}-devel = %{ver}
71
72 %description static
73 Static libraries for wxX11. You need them if you want to link statically against wxX11.
74
75 %package contrib
76 Summary: Contrib libraries for wxX11.
77 Group: X11/Libraries
78 Requires: %{name} = %{ver}
79
80 %description contrib
81 Contributed libraries for wxX11.
82
83 %package contrib-devel
84 Summary: Contrib libraries for wxX11.
85 Group: X11/Libraries
86 Requires: %{name}-contrib = %{ver}
87 Requires: %{name}-devel = %{ver}
88
89 %description contrib-devel
90 Header files for contributed libraries for wxX11.
91
92 %prep
93 %setup -q -n wxX11-%{ver}
94
95 %build
96 if [ "$SMP" != "" ]; then
97 export MAKE="make -j$SMP"
98 else
99 export MAKE="make"
100 fi
101
102 mkdir obj-shared
103 cd obj-shared
104 ../configure --prefix=%{pref} --with-x11 \
105 %if %{unicode}
106 --enable-unicode \
107 %else
108 --with-odbc \
109 %endif
110 --with-opengl
111 $MAKE
112
113 cd contrib/src
114 $MAKE
115 cd ../../..
116
117 mkdir obj-static
118 cd obj-static
119 ../configure --prefix=%{pref} --with-x11 --disable-shared \
120 %if %{unicode}
121 --enable-unicode \
122 %else
123 --with-odbc \
124 %endif
125 --with-opengl
126 $MAKE
127 cd ..
128
129 %install
130 rm -rf $RPM_BUILD_ROOT
131 (cd obj-static; make prefix=$RPM_BUILD_ROOT%{pref} install)
132 (cd obj-shared; make prefix=$RPM_BUILD_ROOT%{pref} install)
133
134 # Remove headers that are part of wx-base-devel:
135
136 # --- wxBase headers list begins here ---
137 cat <<EOF >wxbase-headers.files
138 wx/afterstd.h
139 wx/app.h
140 wx/apptrait.h
141 wx/archive.h
142 wx/arrimpl.cpp
143 wx/arrstr.h
144 wx/atomic.h
145 wx/base64.h
146 wx/beforestd.h
147 wx/buffer.h
148 wx/build.h
149 wx/chartype.h
150 wx/chkconf.h
151 wx/clntdata.h
152 wx/cmdline.h
153 wx/confbase.h
154 wx/config.h
155 wx/convauto.h
156 wx/containr.h
157 wx/cpp.h
158 wx/crt.h
159 wx/datetime.h
160 wx/datstrm.h
161 wx/dde.h
162 wx/debug.h
163 wx/defs.h
164 wx/dir.h
165 wx/dlimpexp.h
166 wx/dynarray.h
167 wx/dynlib.h
168 wx/dynload.h
169 wx/encconv.h
170 wx/event.h
171 wx/except.h
172 wx/features.h
173 wx/flags.h
174 wx/ffile.h
175 wx/file.h
176 wx/fileconf.h
177 wx/filefn.h
178 wx/filename.h
179 wx/filesys.h
180 wx/fontenc.h
181 wx/fontmap.h
182 wx/fs_arc.h
183 wx/fs_filter.h
184 wx/fs_mem.h
185 wx/fs_zip.h
186 wx/hash.h
187 wx/hashmap.h
188 wx/hashset.h
189 wx/html/forcelnk.h
190 wx/iconloc.h
191 wx/init.h
192 wx/intl.h
193 wx/iosfwrap.h
194 wx/ioswrap.h
195 wx/ipc.h
196 wx/ipcbase.h
197 wx/isql.h
198 wx/isqlext.h
199 wx/link.h
200 wx/list.h
201 wx/listimpl.cpp
202 wx/log.h
203 wx/longlong.h
204 wx/math.h
205 wx/memconf.h
206 wx/memory.h
207 wx/memtext.h
208 wx/mimetype.h
209 wx/module.h
210 wx/msgout.h
211 wx/mstream.h
212 wx/object.h
213 wx/platform.h
214 wx/platinfo.h
215 wx/power.h
216 wx/process.h
217 wx/ptr_scpd.h
218 wx/recguard.h
219 wx/regex.h
220 wx/scopeguard.h
221 wx/snglinst.h
222 wx/sstream.h
223 wx/stack.h
224 wx/stackwalk.h
225 wx/stdpaths.h
226 wx/stockitem.h
227 wx/stopwatch.h
228 wx/strconv.h
229 wx/stream.h
230 wx/string.h
231 wx/stringimpl.h
232 wx/stringops.h
233 wx/strvararg.h
234 wx/sysopt.h
235 wx/tarstrm.h
236 wx/textbuf.h
237 wx/textfile.h
238 wx/thread.h
239 wx/thrimpl.cpp
240 wx/timer.h
241 wx/tokenzr.h
242 wx/txtstrm.h
243 wx/types.h
244 wx/unichar.h
245 wx/uri.h
246 wx/utils.h
247 wx/variant.h
248 wx/vector.h
249 wx/version.h
250 wx/volume.h
251 wx/wfstream.h
252 wx/wx.h
253 wx/wxchar.h
254 wx/wxcrt.h
255 wx/wxcrtbase.h
256 wx/wxcrtvararg.h
257 wx/wxprec.h
258 wx/xti.h
259 wx/xtistrm.h
260 wx/zipstrm.h
261 wx/zstream.h
262 wx/unix/app.h
263 wx/unix/apptbase.h
264 wx/unix/apptrait.h
265 wx/unix/chkconf.h
266 wx/unix/execute.h
267 wx/unix/evtloop.h
268 wx/unix/mimetype.h
269 wx/unix/pipe.h
270 wx/unix/private.h
271 wx/unix/stackwalk.h
272 wx/unix/stdpaths.h
273 wx/fs_inet.h
274 wx/gsocket.h
275 wx/protocol/file.h
276 wx/protocol/ftp.h
277 wx/protocol/http.h
278 wx/protocol/protocol.h
279 wx/sckaddr.h
280 wx/sckipc.h
281 wx/sckstrm.h
282 wx/socket.h
283 wx/url.h
284 wx/unix/gsockunx.h
285 wx/xml/xml.h
286 wx/xtixml.h
287 wx/db.h
288 wx/dbkeyg.h
289 wx/dbtable.h
290 EOF
291 # --- wxBase headers list ends here ---
292 for f in `cat wxbase-headers-list` ; do
293 rm -f $RPM_BUILD_ROOT%{_includedir}/wx-%{ver2}/$f
294 done
295
296 # list of all core headers:
297 find $RPM_BUILD_ROOT%{_includedir}/wx-%{ver2} -type f | sed -e "s,$RPM_BUILD_ROOT,,g" >core-headers.files
298
299 # contrib stuff:
300 (cd obj-shared/contrib/src; make prefix=$RPM_BUILD_ROOT%{pref} install)
301 (cd obj-shared/utils/wxrc; make prefix=$RPM_BUILD_ROOT%{pref} install)
302
303 # remove wxBase files so that RPM doesn't complain about unpackaged files:
304 rm -f $RPM_BUILD_ROOT%{_libdir}/libwx_base*
305 %if %{unicode}
306 rm -f $RPM_BUILD_ROOT%{_libdir}/libwxregexu-%{ver2}.a
307 %endif
308 rm -f $RPM_BUILD_ROOT%{_datadir}/aclocal/*
309 rm -f $RPM_BUILD_ROOT%{_datadir}/locale/*/*/*
310
311 %clean
312 rm -rf $RPM_BUILD_ROOT
313
314 %post
315 /sbin/ldconfig
316
317 %postun
318 /sbin/ldconfig
319
320 %post devel
321 # link wx-config when you install RPM.
322 ln -sf %{_libdir}/wx/config/%{wxconfig} %{_bindir}/wx-config
323 # link wx-config with explicit name.
324 ln -sf %{_libdir}/wx/config/%{wxconfig} %{_bindir}/%{wxconfiglink}
325 /sbin/ldconfig
326
327 %postun devel
328 /sbin/ldconfig
329
330 %preun devel
331 if test -f %{_bindir}/wx-config -a -f /usr/bin/md5sum ; then
332 SUM1=`md5sum %{_libdir}/wx/config/%{wxconfig} | cut -c 0-32`
333 SUM2=`md5sum %{_bindir}/wx-config | cut -c 0-32`
334 if test "x$SUM1" = "x$SUM2" ; then
335 rm -f %{_bindir}/wx-config
336 fi
337 fi
338 rm -f %{_bindir}/%{wxconfiglink}
339
340 %post gl
341 /sbin/ldconfig
342
343 %postun gl
344 /sbin/ldconfig
345
346 %post contrib
347 /sbin/ldconfig
348
349 %postun contrib
350 /sbin/ldconfig
351
352 %post contrib-devel
353 /sbin/ldconfig
354
355 %postun contrib-devel
356 /sbin/ldconfig
357
358 %files
359 %defattr(-,root,root)
360 %doc COPYING.LIB *.txt
361 %{_libdir}/libwx_%{portname}*_adv-%{ver2}.so.*
362 %{_libdir}/libwx_%{portname}*_core-%{ver2}.so.*
363 %if !%{unicode}
364 %{_libdir}/libwx_%{portname}*_dbgrid-%{ver2}.so.*
365 %endif
366 %{_libdir}/libwx_%{portname}*_html-%{ver2}.so.*
367 %{_libdir}/libwx_%{portname}*_media-%{ver2}.so.*
368 %{_libdir}/libwx_%{portname}*_qa-%{ver2}.so.*
369 %{_libdir}/libwx_%{portname}*_xrc-%{ver2}.so.*
370
371
372 %files devel -f core-headers.files
373 %defattr(-,root,root)
374 %{_libdir}/libwx_%{portname}*_adv-%{ver2}.so
375 %{_libdir}/libwx_%{portname}*_core-%{ver2}.so
376 %if !%{unicode}
377 %{_libdir}/libwx_%{portname}*_dbgrid-%{ver2}.so
378 %endif
379 %{_libdir}/libwx_%{portname}*_gl-%{ver2}.so
380 %{_libdir}/libwx_%{portname}*_html-%{ver2}.so
381 %{_libdir}/libwx_%{portname}*_media-%{ver2}.so
382 %{_libdir}/libwx_%{portname}*_qa-%{ver2}.so
383 %{_libdir}/libwx_%{portname}*_xrc-%{ver2}.so
384 %dir %{_libdir}/wx
385 %{_libdir}/wx/*
386 %{_bindir}/wxrc*
387
388 %files gl
389 %defattr(-,root,root)
390 %{_libdir}/libwx_%{portname}*_gl-%{ver2}.so.*
391
392 %files static
393 %defattr (-,root,root)
394 %{_libdir}/libwx_%{portname}*_*-%{ver2}.a
395
396 %files contrib
397 %defattr(-,root,root)
398 %{_libdir}/libwx_%{portname}*_animate-%{ver2}.so.*
399 %{_libdir}/libwx_%{portname}*_deprecated-%{ver2}.so.*
400 %{_libdir}/libwx_%{portname}*_fl-%{ver2}.so.*
401 %{_libdir}/libwx_%{portname}*_gizmos-%{ver2}.so.*
402 %{_libdir}/libwx_%{portname}*_mmedia-%{ver2}.so.*
403 %{_libdir}/libwx_%{portname}*_ogl-%{ver2}.so.*
404 %{_libdir}/libwx_%{portname}*_plot-%{ver2}.so.*
405 %{_libdir}/libwx_%{portname}*_stc-%{ver2}.so.*
406 %{_libdir}/libwx_%{portname}*_svg-%{ver2}.so.*
407
408 %files contrib-devel
409 %defattr(-,root,root)
410 %dir %{_includedir}/wx-%{ver2}/wx/animate
411 %{_includedir}/wx-%{ver2}/wx/animate/*
412 %{_libdir}/libwx_%{portname}*_animate-%{ver2}.so
413
414 %dir %{_includedir}/wx-%{ver2}/wx/deprecated
415 %{_includedir}/wx-%{ver2}/wx/deprecated/*
416 %{_libdir}/libwx_%{portname}*_deprecated-%{ver2}.so
417
418 %dir %{_includedir}/wx-%{ver2}/wx/fl
419 %{_includedir}/wx-%{ver2}/wx/fl/*
420 %{_libdir}/libwx_%{portname}*_fl-%{ver2}.so
421
422 %dir %{_includedir}/wx-%{ver2}/wx/gizmos
423 %{_includedir}/wx-%{ver2}/wx/gizmos/*
424 %{_libdir}/libwx_%{portname}*_gizmos-%{ver2}.so
425
426 %dir %{_includedir}/wx-%{ver2}/wx/mmedia
427 %{_includedir}/wx-%{ver2}/wx/mmedia/*
428 %{_libdir}/libwx_%{portname}*_mmedia-%{ver2}.so
429
430 %dir %{_includedir}/wx-%{ver2}/wx/ogl
431 %{_includedir}/wx-%{ver2}/wx/ogl/*
432 %{_libdir}/libwx_%{portname}*_ogl-%{ver2}.so
433
434 %dir %{_includedir}/wx-%{ver2}/wx/plot
435 %{_includedir}/wx-%{ver2}/wx/plot/*
436 %{_libdir}/libwx_%{portname}*_plot-%{ver2}.so
437
438 %dir %{_includedir}/wx-%{ver2}/wx/stc
439 %{_includedir}/wx-%{ver2}/wx/stc/*
440 %{_libdir}/libwx_%{portname}*_stc-%{ver2}.so
441
442 %dir %{_includedir}/wx-%{ver2}/wx/svg
443 %{_includedir}/wx-%{ver2}/wx/svg/*
444 %{_libdir}/libwx_%{portname}*_svg-%{ver2}.so