6 # Configurable settings (use --with(out) unicode on rpmbuild cmd line):
8 %{?_with_unicode: %{expand: %%define unicode 1}}
9 %{?_without_unicode: %{expand: %%define unicode 0}}
13 %define name wx
-%{portname}-unicode
14 %define wxbasename wx
-base
-unicode
16 %define name wx
-%{portname}
17 %define wxbasename wx
-base
21 %define wxconfigname wx
%{portname}univu-%{ver2}-config
23 %define wxconfigname wx
%{portname}univ-%{ver2}-config
26 Summary: The X11 port of the wxWindows library
30 License: wxWindows Licence
32 Source: wxX11
-%{ver}.tar.bz2
33 URL: http
://www.wxwindows.org
34 Packager: Vadim Zeitlin
<vadim@wxwindows.org
>
36 BuildRoot: /var
/tmp
/%{name}-root
38 # all packages providing an implementation of wxWindows library (regardless of
39 # the toolkit used) should provide the (virtual) wxwin package, this makes it
40 # possible to require wxwin instead of requiring "wxgtk or wxmotif or wxuniv..."
43 # in addition, we should provide libwx_gtk as automatic generator only notices
44 # libwx_gtk-%{ver}-%{rel}
45 Provides: libwx_x11.so
46 Provides: libwx_x11
-%{ver2}.so
49 Requires: %{wxbasename} = %{ver}
52 wxWindows is a free C
++ library
for cross
-platform GUI development.
53 With wxWindows
, you can create applications
for different GUIs
(GTK
+,
54 Motif
/LessTif
, MS Windows
, Mac
) from the same
source code.
57 Summary: The X11 port of the wxWindows library
59 Requires: %{name} = %{ver}
60 Requires: %{wxbasename}-devel = %{ver}
63 Header files
for wxX11
, the X11 port of the wxWindows library.
66 Summary: The X11 port of the wxWindows library
, OpenGL add
-on.
68 Requires: %{name} = %{ver}
71 OpenGL add
-on library
for wxX11
, the X11 port of the wxWindows library.
74 Summary: wxX11 static libraries
75 Group: Development
/Libraries
78 Static libraries
for wxX11. You need them
if you want to link statically against wxX11.
81 Summary: Contrib libraries
for wxX11.
83 Requires: %{name} = %{ver}
86 Contributed libraries
for wxX11.
88 %package contrib
-devel
89 Summary: Contrib libraries
for wxX11.
91 Requires: %{name}-contrib = %{ver}
92 Requires: %{name}-devel = %{ver}
94 %description contrib
-devel
95 Header files
for contributed libraries
for wxX11.
98 %setup -q
-n wxX11
-%{ver}
101 if [ "$SMP"
!= ""
]; then
102 export MAKE
="
make -j$SMP"
109 ..
/configure
--prefix
=%{pref} --with
-x11 \
123 ..
/configure
--prefix
=%{pref} --with
-x11
--disable
-shared \
134 rm -rf $RPM_BUILD_ROOT
135 (cd obj
-static
; make prefix
=$RPM_BUILD_ROOT
%{pref} install)
136 (cd obj
-shared
; make prefix
=$RPM_BUILD_ROOT
%{pref} install)
138 # Remove headers that are part of wx-base-devel:
140 # --- wxBase headers list begins here ---
141 cat
<<EOF
>wxbase
-headers
-list
252 wx
/protocol
/protocol.h
265 # --- wxBase headers list ends here ---
266 for f
in `cat wxbase
-headers
-list`
; do
267 rm -f $RPM_BUILD_ROOT
%{_includedir}/$f
270 # list of all core headers:
271 find $RPM_BUILD_ROOT
/usr
/include
/wx
-type f | sed
-e "s
,$RPM_BUILD_ROOT
,,g"
>core
-headers.files
274 (cd obj
-shared
/contrib
/src
; make prefix
=$RPM_BUILD_ROOT
%{pref} install)
275 (cd obj
-shared
/contrib
/utils
/wxrc
; make prefix
=$RPM_BUILD_ROOT
%{pref} install)
278 rm -rf $RPM_BUILD_ROOT
293 # Install wx-config if there isn't any
294 if test ! -f
%{_bindir}/wx
-config
; then
295 ln
-sf
%{wxconfigname} %{_bindir}/wx
-config
299 # Remove wx-config if it points to this package
300 if test -f
%{_bindir}/wx
-config
-a
-f
/usr
/bin
/md5sum
; then
301 SUM1
=`md5sum
%{_bindir}/%{wxconfigname} | cut
-c
0-32`
302 SUM2
=`md5sum
%{_bindir}/wx
-config | cut
-c
0-32`
303 if test "x$SUM1"
= "x$SUM2"
; then
304 rm -f
%{_bindir}/wx
-config
310 %defattr(-,root
,root
)
311 %doc COPYING.LIB
*.txt
314 %{_libdir}/libwx_%{portname}*_core
*.so.
*
315 %{_libdir}/libwx_%{portname}*_html
*.so.
*
316 %{_libdir}/libwx_%{portname}*_adv
*.so.
*
318 %{_libdir}/libwx_%{portname}*_dbgrid
*.so.
*
321 %files devel
-f core
-headers.files
322 %defattr(-,root
,root
)
323 %{_libdir}/libwx_%{portname}*_core
*.so
324 %{_libdir}/libwx_%{portname}*_html
*.so
325 %{_libdir}/libwx_%{portname}*_adv
*.so
327 %{_libdir}/libwx_%{portname}*_dbgrid
*.so
329 %{_libdir}/libwx_%{portname}*_gl
*.so
332 %{_bindir}/%{wxconfigname}
335 %defattr(-,root
,root
)
336 %{_libdir}/libwx_%{portname}*_gl
*.so.
*
339 %defattr (-,root
,root
)
340 %{_libdir}/libwx_%{portname}*.a
343 %defattr(-,root
,root
)
344 %{_libdir}/libwx_%{portname}*_animate
*.so.
*
345 %{_libdir}/libwx_%{portname}*_deprecated
*.so.
*
346 %{_libdir}/libwx_%{portname}*_fl
*.so.
*
347 %{_libdir}/libwx_%{portname}*_gizmos
*.so.
*
348 %{_libdir}/libwx_%{portname}*_mmedia
*.so.
*
349 %{_libdir}/libwx_%{portname}*_ogl
*.so.
*
350 %{_libdir}/libwx_%{portname}*_plot
*.so.
*
351 %{_libdir}/libwx_%{portname}*_stc
*.so.
*
352 %{_libdir}/libwx_%{portname}*_svg
*.so.
*
353 %{_libdir}/libwx_%{portname}*_xrc
*.so.
*
356 %defattr(-,root
,root
)
358 %dir %{_includedir}/wx
/animate
359 %{_includedir}/wx
/animate
/*
360 %{_libdir}/libwx_%{portname}*_animate
*.so
362 %dir %{_includedir}/wx
/deprecated
363 %{_includedir}/wx
/deprecated
/*
364 %{_libdir}/libwx_%{portname}*_deprecated
*.so
366 %dir %{_includedir}/wx
/fl
367 %{_includedir}/wx
/fl
/*
368 %{_libdir}/libwx_%{portname}*_fl
*.so
370 %dir %{_includedir}/wx
/gizmos
371 %{_includedir}/wx
/gizmos
/*
372 %{_libdir}/libwx_%{portname}*_gizmos
*.so
374 %dir %{_includedir}/wx
/mmedia
375 %{_includedir}/wx
/mmedia
/*
376 %{_libdir}/libwx_%{portname}*_mmedia
*.so
378 %dir %{_includedir}/wx
/ogl
379 %{_includedir}/wx
/ogl
/*
380 %{_libdir}/libwx_%{portname}*_ogl
*.so
382 %dir %{_includedir}/wx
/plot
383 %{_includedir}/wx
/plot
/*
384 %{_libdir}/libwx_%{portname}*_plot
*.so
386 %dir %{_includedir}/wx
/stc
387 %{_includedir}/wx
/stc
/*
388 %{_libdir}/libwx_%{portname}*_stc
*.so
390 %dir %{_includedir}/wx
/svg
391 %{_includedir}/wx
/svg
/*
392 %{_libdir}/libwx_%{portname}*_svg
*.so
394 %dir %{_includedir}/wx
/xrc
395 %{_includedir}/wx
/xrc
/*
396 %{_libdir}/libwx_%{portname}*_xrc
*.so