6 # Configurable settings (use --with(out) {unicode,gtk2} on rpmbuild cmd line):
8 %{?_with_unicode: %{expand: %%define unicode 1}}
9 %{?_without_unicode: %{expand: %%define unicode 0}}
12 %{?_with_gtk2: %{expand: %%define gtk2 1}}
13 %{?_without_gtk2: %{expand: %%define gtk2 0}}
24 %define name wx
-%{portname}-unicode
25 %define wxbasename wx
-base
-unicode
27 %define name wx
-%{portname}
28 %define wxbasename wx
-base
32 %define wxconfigname wx
%{portname}u-%{ver2}-config
34 %define wxconfigname wx
%{portname}-%{ver2}-config
38 Summary: The GTK
+ %{gtkver} port of the wxWindows library
41 License: wxWindows Licence
43 Source: wxGTK
-%{ver}.tar.bz2
44 URL: http
://www.wxwindows.org
45 Packager: Vadim Zeitlin
<vadim@wxwindows.org
>
47 BuildRoot: /var
/tmp
/%{name}-root
49 # all packages providing an implementation of wxWindows library (regardless of
50 # the toolkit used) should provide the (virtual) wxwin package, this makes it
51 # possible to require wxwin instead of requiring "wxgtk or wxmotif or wxuniv..."
55 # in addition, we should provide libwx_gtk as automatic generator only notices
56 # libwx_gtk-%{ver}-%{rel}
57 Provides: libwx_gtk.so
58 Provides: libwx_gtk
-%{ver2}.so
60 Requires: %{wxbasename} = %{ver}
63 wxWindows is a free C
++ library
for cross
-platform GUI development.
64 With wxWindows
, you can create applications
for different GUIs
(GTK
+,
65 Motif
/LessTif
, MS Windows
, Mac
) from the same
source code.
68 Summary: The GTK
+ %{gtkver} port of the wxWindows library
70 Requires: %{name} = %{ver}
71 Requires: %{wxbasename}-devel = %{ver}
75 Header files
for wxGTK
, the GTK
+ %{gtkver} port of the wxWindows library.
78 Summary: The GTK
+ %{gtkver} port of the wxWindows library
, OpenGL add
-on.
80 Requires: %{name} = %{ver}
83 OpenGL add
-on library
for wxGTK
, the GTK
+ %{gtkver} port of the wxWindows library.
86 Summary: wxGTK static libraries
87 Group: Development
/Libraries
88 Requires: %{wxbasename}-static
91 Static libraries
for wxGTK. You need them
if you want to link statically against wxGTK.
94 Summary: The GTK
+ %{gtkver} port of the wxWindows library
, contributed libraries.
96 Requires: %{name} = %{ver}
99 Contributed libraries
for wxGTK
, the GTK
+ %{gtkver} port of the wxWindows library.
101 %package contrib
-devel
102 Summary: The GTK
+ %{gtkver} port of the wxWindows library
104 Requires: %{name}-contrib = %{ver}
105 Requires: %{name}-devel = %{ver}
107 %description contrib
-devel
108 Header files
for contributed libraries
for wxGTK
, the GTK
+ %{gtkver} port of the wxWindows library.
111 %setup -q
-n wxGTK
-%{ver}
114 if [ "$SMP"
!= ""
]; then
115 export MAKE
="
make -j$SMP"
122 ..
/configure
--prefix
=%{pref} \
139 ..
/configure
--prefix
=%{pref} --disable
-shared \
153 rm -rf $RPM_BUILD_ROOT
154 (cd obj
-static
; make prefix
=$RPM_BUILD_ROOT
%{pref} install)
155 (cd obj
-shared
; make prefix
=$RPM_BUILD_ROOT
%{pref} install)
157 # Remove headers that are part of wx-base-devel:
159 # --- wxBase headers list begins here ---
160 cat
<<EOF
>wxbase
-headers
-list
276 wx
/protocol
/protocol.h
289 # --- wxBase headers list ends here ---
290 for f
in `cat wxbase
-headers
-list`
; do
291 rm -f $RPM_BUILD_ROOT
%{_includedir}/wx
-*/$f
294 # list of all core headers:
295 find $RPM_BUILD_ROOT
/usr
/include
/wx
-type f | sed
-e "s
,$RPM_BUILD_ROOT
,,g"
>core
-headers.files
298 (cd obj
-shared
/contrib
/src
; make prefix
=$RPM_BUILD_ROOT
%{pref} install)
299 (cd obj
-shared
/contrib
/utils
/wxrc
; make prefix
=$RPM_BUILD_ROOT
%{pref} install)
301 # remove wxBase files so that RPM doesn't complain about unpackaged files:
302 rm -f $RPM_BUILD_ROOT
%{_libdir}/libwx_base
*
303 rm -f $RPM_BUILD_ROOT
%{_datadir}/aclocal
/*
304 rm -f $RPM_BUILD_ROOT
%{_datadir}/locale
/*/*/*
307 rm -rf $RPM_BUILD_ROOT
323 %defattr(-,root
,root
)
324 %doc COPYING.LIB
*.txt
327 %{_libdir}/libwx_%{portname}*_core
*.so.
*
328 %{_libdir}/libwx_%{portname}*_html
*.so.
*
329 %{_libdir}/libwx_%{portname}*_adv
*.so.
*
331 %{_libdir}/libwx_%{portname}*_dbgrid
*.so.
*
334 %files devel
-f core
-headers.files
335 %defattr(-,root
,root
)
336 %{_libdir}/libwx_%{portname}*_core
*.so
337 %{_libdir}/libwx_%{portname}*_html
*.so
338 %{_libdir}/libwx_%{portname}*_adv
*.so
340 %{_libdir}/libwx_%{portname}*_dbgrid
*.so
342 %{_libdir}/libwx_%{portname}*_gl
*.so
345 %{_bindir}/%{wxconfigname}
348 %defattr(-,root
,root
)
349 %{_libdir}/libwx_%{portname}*_gl
*.so.
*
352 %defattr (-,root
,root
)
353 %{_libdir}/libwx_gtk
*.a
356 %defattr(-,root
,root
)
357 %{_libdir}/libwx_%{portname}*_animate
*.so.
*
358 %{_libdir}/libwx_%{portname}*_deprecated
*.so.
*
359 %{_libdir}/libwx_%{portname}*_fl
*.so.
*
360 %{_libdir}/libwx_%{portname}*_gizmos
*.so.
*
361 %{_libdir}/libwx_%{portname}*_mmedia
*.so.
*
362 %{_libdir}/libwx_%{portname}*_ogl
*.so.
*
363 %{_libdir}/libwx_%{portname}*_plot
*.so.
*
364 %{_libdir}/libwx_%{portname}*_stc
*.so.
*
365 %{_libdir}/libwx_%{portname}*_svg
*.so.
*
366 %{_libdir}/libwx_%{portname}*_xrc
*.so.
*
369 %defattr(-,root
,root
)
371 %dir %{_includedir}/wx
-*/wx
/animate
372 %{_includedir}/wx
-*/wx
/animate
/*
373 %{_libdir}/libwx_%{portname}*_animate
*.so
375 %dir %{_includedir}/wx
-*/wx
/deprecated
376 %{_includedir}/wx
-*/wx
/deprecated
/*
377 %{_libdir}/libwx_%{portname}*_deprecated
*.so
379 %dir %{_includedir}/wx
-*/wx
/fl
380 %{_includedir}/wx
-*/wx
/fl
/*
381 %{_libdir}/libwx_%{portname}*_fl
*.so
383 %dir %{_includedir}/wx
-*/wx
/gizmos
384 %{_includedir}/wx
-*/wx
/gizmos
/*
385 %{_libdir}/libwx_%{portname}*_gizmos
*.so
387 %dir %{_includedir}/wx
-*/wx
/mmedia
388 %{_includedir}/wx
-*/wx
/mmedia
/*
389 %{_libdir}/libwx_%{portname}*_mmedia
*.so
391 %dir %{_includedir}/wx
-*/wx
/ogl
392 %{_includedir}/wx
-*/wx
/ogl
/*
393 %{_libdir}/libwx_%{portname}*_ogl
*.so
395 %dir %{_includedir}/wx
-*/wx
/plot
396 %{_includedir}/wx
-*/wx
/plot
/*
397 %{_libdir}/libwx_%{portname}*_plot
*.so
399 %dir %{_includedir}/wx
-*/wx
/stc
400 %{_includedir}/wx
-*/wx
/stc
/*
401 %{_libdir}/libwx_%{portname}*_stc
*.so
403 %dir %{_includedir}/wx
-*/wx
/svg
404 %{_includedir}/wx
-*/wx
/svg
/*
405 %{_libdir}/libwx_%{portname}*_svg
*.so
407 %dir %{_includedir}/wx
-*/wx
/xrc
408 %{_includedir}/wx
-*/wx
/xrc
/*
409 %{_libdir}/libwx_%{portname}*_xrc
*.so