removed isql.h and isqlext.h from files.bkl too
[wxWidgets.git] / wxGTK.spec
1 %define _prefix /usr
2 %define ver 2.9.0
3 %define ver2 2.9
4 %define rel 1
5
6 # Configurable settings (use --with(out) {unicode,gtk2} on rpmbuild cmd line):
7 %define unicode 1
8 %{?_with_unicode: %{expand: %%define unicode 1}}
9 %{?_without_unicode: %{expand: %%define unicode 0}}
10
11 %define gtk2 1
12 %{?_with_gtk2: %{expand: %%define gtk2 1}}
13 %{?_without_gtk2: %{expand: %%define gtk2 0}}
14
15 # "buildname" needs to be e.g. gtk2ud for debug builds
16 %if %{gtk2}
17 %define gtkver 2
18 %define portname gtk2
19 %if %{unicode}
20 %define buildname gtk2u
21 %else
22 %define buildname gtk2
23 %endif
24 %else
25 %define gtkver 1.2
26 %define portname gtk
27 %define buildname gtk
28 %endif
29
30 %if %{unicode}
31 %define name wx-%{portname}-unicode
32 %define wxconfig %{portname}-unicode-release-%{ver2}
33 %define wxconfigstatic %{portname}-unicode-release-static-%{ver2}
34 %define wxconfiglink wx%{portname}u-%{ver2}-config
35 %else
36 %define name wx-%{portname}-ansi
37 %define wxconfig %{portname}-ansi-release-%{ver2}
38 %define wxconfigstatic %{portname}-ansi-release-static-%{ver2}
39 %define wxconfiglink wx%{portname}-%{ver2}-config
40 %endif
41
42 %if %{unicode}
43 %define wxbasename wx-base-unicode
44 %define wxbaseconfig base-unicode-release-%{ver2}
45 %define wxbaseconfiglink wxbaseu-%{ver2}-config
46 %else
47 %define wxbasename wx-base-ansi
48 %define wxbaseconfig base-ansi-release-%{ver2}
49 %define wxbaseconfiglink wxbase-%{ver2}-config
50 %endif
51
52 Summary: The GTK+ %{gtkver} port of the wxWidgets library
53 Name: %{name}
54 Version: %{ver}
55 Release: %{rel}
56 License: wxWindows Licence
57 Group: X11/Libraries
58 Source: wxGTK-%{ver}.tar.bz2
59 URL: http://www.wxwidgets.org
60 Packager: Vadim Zeitlin <vadim@wxwindows.org>
61 Prefix: %{_prefix}
62 BuildRoot: %{_tmppath}/%{name}-root
63 Requires: %{wxbasename} = %{ver}
64 %if %{portname} == gtk2
65 BuildRequires: gtk+-2.0-devel
66 %else
67 BuildRequires: gtk+-devel >= 1.2.0
68 %endif
69
70 BuildRequires: zlib-devel, libjpeg-devel, libpng-devel, libtiff-devel
71
72 # all packages providing an implementation of wxWidgets library (regardless of
73 # the toolkit used) should provide the (virtual) wxwin package, this makes it
74 # possible to require wxwin instead of requiring "wxgtk or wxmotif or wxuniv..."
75 Provides: wxwin
76 Provides: wxGTK
77
78 %description
79 wxWidgets is a free C++ library for cross-platform GUI development.
80 With wxWidgets, you can create applications for different GUIs (GTK+,
81 Motif, MS Windows, MacOS X, Windows CE, GPE) from the same source code.
82
83 %package -n wx-i18n
84 Summary: The translations for the wxWidgets library.
85 Group: X11/Libraries
86
87 %description -n wx-i18n
88 The translations files for the wxWidgets library.
89
90 %package devel
91 Summary: The GTK+ %{gtkver} port of the wxWidgets library
92 Group: X11/Libraries
93 Requires: %{name} = %{ver}
94 Requires: %{wxbasename}-devel = %{ver}
95 Provides: wxGTK-devel
96
97 %description devel
98 The GTK+ %{gtkver} port of the wxWidgets library, header files.
99
100 %package gl
101 Summary: The GTK+ %{gtkver} port of the wxWidgets library, OpenGL add-on.
102 Group: X11/Libraries
103 Requires: %{name} = %{ver}
104 Provides: wxGTK-gl
105
106 %description gl
107 OpenGL add-on library for wxGTK, the GTK+ %{gtkver} port of the wxWidgets library.
108
109 %package -n %{wxbasename}
110 Summary: wxBase library - non-GUI support classes of the wxWidgets toolkit
111 Group: Development/Libraries
112 Provides: wxBase
113
114 %description -n %{wxbasename}
115 wxBase is a collection of C++ classes providing basic data structures (strings,
116 lists, arrays), portable wrappers around many OS-specific funstions (file
117 operations, time/date manipulations, threads, processes, sockets, shared
118 library loading) as well as other utility classes (streams, archive and
119 compression). wxBase currently supports Win32, most Unix variants (Linux,
120 FreeBSD, Solaris, HP-UX) and MacOS X (Carbon and Mach-0).
121
122 %package -n %{wxbasename}-devel
123 Summary: wxBase library, header files.
124 Group: Development/Libraries
125 Provides: wxBase-devel
126
127 %description -n %{wxbasename}-devel
128 wxBase library - non-GUI support classes of the wxWidgets toolkit,
129 header files.
130
131 %package contrib
132 Summary: The GTK+ %{gtkver} port of the wxWidgets library, contributed libraries.
133 Group: X11/Libraries
134 Requires: %{name} = %{ver}
135
136 %description contrib
137 Contributed libraries for wxGTK, the GTK+ %{gtkver} port of the wxWidgets library.
138
139 %package contrib-devel
140 Summary: The GTK+ %{gtkver} port of the wxWidgets library
141 Group: X11/Libraries
142 Requires: %{name}-contrib = %{ver}
143 Requires: %{name}-devel = %{ver}
144
145 %description contrib-devel
146 Header files for contributed libraries for wxGTK, the GTK+ %{gtkver} port of the wxWidgets library.
147
148 %prep
149 %setup -q -n wxGTK-%{ver}
150
151 %build
152 if [ "$SMP" != "" ]; then
153 export MAKE="make -j$SMP"
154 else
155 export MAKE="make"
156 fi
157
158 mkdir obj-shared
159 cd obj-shared
160 ../configure --prefix=%{_prefix} \
161 %if ! %{gtk2}
162 --with-gtk=1 \
163 %else
164 --with-gtk=2 \
165 %endif
166 %if %{unicode}
167 --enable-unicode \
168 %else
169 --disable-unicode \
170 %endif
171 --with-opengl
172 $MAKE
173
174 cd contrib/src
175 $MAKE
176 cd ../../..
177
178 mkdir obj-static
179 cd obj-static
180 ../configure --prefix=%{_prefix} \
181 %if ! %{gtk2}
182 --with-gtk=1 \
183 %else
184 --with-gtk=2 \
185 %endif
186 --disable-shared \
187 %if %{unicode}
188 --enable-unicode \
189 %else
190 --disable-unicode \
191 %endif
192 --with-opengl
193 $MAKE
194
195 cd contrib/src
196 $MAKE
197 cd ../../..
198
199 make -C locale allmo
200
201 %install
202 rm -rf $RPM_BUILD_ROOT
203 (cd obj-static; make DESTDIR=$RPM_BUILD_ROOT prefix=%{_prefix} install)
204 (cd obj-shared; make DESTDIR=$RPM_BUILD_ROOT prefix=%{_prefix} install)
205
206 # --- wxBase headers list begins here ---
207 cat <<EOF >wxbase-headers.files
208 wx/afterstd.h
209 wx/app.h
210 wx/apptrait.h
211 wx/archive.h
212 wx/arrimpl.cpp
213 wx/arrstr.h
214 wx/atomic.h
215 wx/base64.h
216 wx/beforestd.h
217 wx/buffer.h
218 wx/build.h
219 wx/chartype.h
220 wx/chkconf.h
221 wx/clntdata.h
222 wx/cmdline.h
223 wx/confbase.h
224 wx/config.h
225 wx/convauto.h
226 wx/containr.h
227 wx/cpp.h
228 wx/crt.h
229 wx/datetime.h
230 wx/datstrm.h
231 wx/dde.h
232 wx/debug.h
233 wx/defs.h
234 wx/dir.h
235 wx/dlimpexp.h
236 wx/dynarray.h
237 wx/dynlib.h
238 wx/dynload.h
239 wx/encconv.h
240 wx/event.h
241 wx/except.h
242 wx/features.h
243 wx/flags.h
244 wx/ffile.h
245 wx/file.h
246 wx/fileconf.h
247 wx/filefn.h
248 wx/filename.h
249 wx/filesys.h
250 wx/fontenc.h
251 wx/fontmap.h
252 wx/fs_arc.h
253 wx/fs_filter.h
254 wx/fs_mem.h
255 wx/fs_zip.h
256 wx/hash.h
257 wx/hashmap.h
258 wx/hashset.h
259 wx/html/forcelnk.h
260 wx/iconloc.h
261 wx/init.h
262 wx/intl.h
263 wx/iosfwrap.h
264 wx/ioswrap.h
265 wx/ipc.h
266 wx/ipcbase.h
267 wx/link.h
268 wx/list.h
269 wx/listimpl.cpp
270 wx/log.h
271 wx/longlong.h
272 wx/math.h
273 wx/memconf.h
274 wx/memory.h
275 wx/memtext.h
276 wx/mimetype.h
277 wx/module.h
278 wx/msgout.h
279 wx/mstream.h
280 wx/object.h
281 wx/platform.h
282 wx/platinfo.h
283 wx/power.h
284 wx/process.h
285 wx/ptr_scpd.h
286 wx/recguard.h
287 wx/regex.h
288 wx/scopeguard.h
289 wx/snglinst.h
290 wx/sstream.h
291 wx/stack.h
292 wx/stackwalk.h
293 wx/stdpaths.h
294 wx/stockitem.h
295 wx/stopwatch.h
296 wx/strconv.h
297 wx/stream.h
298 wx/string.h
299 wx/stringimpl.h
300 wx/stringops.h
301 wx/strvararg.h
302 wx/sysopt.h
303 wx/tarstrm.h
304 wx/textbuf.h
305 wx/textfile.h
306 wx/thread.h
307 wx/thrimpl.cpp
308 wx/timer.h
309 wx/tokenzr.h
310 wx/txtstrm.h
311 wx/types.h
312 wx/unichar.h
313 wx/uri.h
314 wx/utils.h
315 wx/variant.h
316 wx/vector.h
317 wx/version.h
318 wx/volume.h
319 wx/wfstream.h
320 wx/wx.h
321 wx/wxchar.h
322 wx/wxcrt.h
323 wx/wxcrtbase.h
324 wx/wxcrtvararg.h
325 wx/wxprec.h
326 wx/xti.h
327 wx/xtistrm.h
328 wx/zipstrm.h
329 wx/zstream.h
330 wx/private/fdiodispatcher.h
331 wx/private/selectdispatcher.h
332 wx/unix/app.h
333 wx/unix/apptbase.h
334 wx/unix/apptrait.h
335 wx/unix/chkconf.h
336 wx/unix/execute.h
337 wx/unix/evtloop.h
338 wx/unix/mimetype.h
339 wx/unix/pipe.h
340 wx/unix/private.h
341 wx/unix/stackwalk.h
342 wx/unix/stdpaths.h
343 wx/fs_inet.h
344 wx/gsocket.h
345 wx/protocol/file.h
346 wx/protocol/ftp.h
347 wx/protocol/http.h
348 wx/protocol/protocol.h
349 wx/sckaddr.h
350 wx/sckipc.h
351 wx/sckstrm.h
352 wx/socket.h
353 wx/url.h
354 wx/unix/gsockunx.h
355 wx/xml/xml.h
356 wx/xtixml.h
357 EOF
358 # --- wxBase headers list ends here ---
359 cat <<EOF >wxbase-headers.paths
360 %{_includedir}/wx-%{ver2}/wx/afterstd.h
361 %{_includedir}/wx-%{ver2}/wx/app.h
362 %{_includedir}/wx-%{ver2}/wx/apptrait.h
363 %{_includedir}/wx-%{ver2}/wx/archive.h
364 %{_includedir}/wx-%{ver2}/wx/arrimpl.cpp
365 %{_includedir}/wx-%{ver2}/wx/arrstr.h
366 %{_includedir}/wx-%{ver2}/wx/beforestd.h
367 %{_includedir}/wx-%{ver2}/wx/buffer.h
368 %{_includedir}/wx-%{ver2}/wx/build.h
369 %{_includedir}/wx-%{ver2}/wx/chkconf.h
370 %{_includedir}/wx-%{ver2}/wx/clntdata.h
371 %{_includedir}/wx-%{ver2}/wx/cmdline.h
372 %{_includedir}/wx-%{ver2}/wx/confbase.h
373 %{_includedir}/wx-%{ver2}/wx/config.h
374 %{_includedir}/wx-%{ver2}/wx/containr.h
375 %{_includedir}/wx-%{ver2}/wx/convauto.h
376 %{_includedir}/wx-%{ver2}/wx/datetime.h
377 %{_includedir}/wx-%{ver2}/wx/datstrm.h
378 %{_includedir}/wx-%{ver2}/wx/dde.h
379 %{_includedir}/wx-%{ver2}/wx/debug.h
380 %{_includedir}/wx-%{ver2}/wx/defs.h
381 %{_includedir}/wx-%{ver2}/wx/dir.h
382 %{_includedir}/wx-%{ver2}/wx/dlimpexp.h
383 %{_includedir}/wx-%{ver2}/wx/dynarray.h
384 %{_includedir}/wx-%{ver2}/wx/dynlib.h
385 %{_includedir}/wx-%{ver2}/wx/dynload.h
386 %{_includedir}/wx-%{ver2}/wx/encconv.h
387 %{_includedir}/wx-%{ver2}/wx/event.h
388 %{_includedir}/wx-%{ver2}/wx/except.h
389 %{_includedir}/wx-%{ver2}/wx/features.h
390 %{_includedir}/wx-%{ver2}/wx/ffile.h
391 %{_includedir}/wx-%{ver2}/wx/file.h
392 %{_includedir}/wx-%{ver2}/wx/fileconf.h
393 %{_includedir}/wx-%{ver2}/wx/filefn.h
394 %{_includedir}/wx-%{ver2}/wx/filename.h
395 %{_includedir}/wx-%{ver2}/wx/filesys.h
396 %{_includedir}/wx-%{ver2}/wx/fontenc.h
397 %{_includedir}/wx-%{ver2}/wx/fontmap.h
398 %{_includedir}/wx-%{ver2}/wx/fs_mem.h
399 %{_includedir}/wx-%{ver2}/wx/fs_zip.h
400 %{_includedir}/wx-%{ver2}/wx/hash.h
401 %{_includedir}/wx-%{ver2}/wx/hashmap.h
402 %{_includedir}/wx-%{ver2}/wx/hashset.h
403 %{_includedir}/wx-%{ver2}/wx/html/forcelnk.h
404 %{_includedir}/wx-%{ver2}/wx/iconloc.h
405 %{_includedir}/wx-%{ver2}/wx/init.h
406 %{_includedir}/wx-%{ver2}/wx/intl.h
407 %{_includedir}/wx-%{ver2}/wx/iosfwrap.h
408 %{_includedir}/wx-%{ver2}/wx/ioswrap.h
409 %{_includedir}/wx-%{ver2}/wx/ipc.h
410 %{_includedir}/wx-%{ver2}/wx/ipcbase.h
411 %{_includedir}/wx-%{ver2}/wx/isql.h
412 %{_includedir}/wx-%{ver2}/wx/isqlext.h
413 %{_includedir}/wx-%{ver2}/wx/link.h
414 %{_includedir}/wx-%{ver2}/wx/list.h
415 %{_includedir}/wx-%{ver2}/wx/listimpl.cpp
416 %{_includedir}/wx-%{ver2}/wx/log.h
417 %{_includedir}/wx-%{ver2}/wx/longlong.h
418 %{_includedir}/wx-%{ver2}/wx/math.h
419 %{_includedir}/wx-%{ver2}/wx/memconf.h
420 %{_includedir}/wx-%{ver2}/wx/memory.h
421 %{_includedir}/wx-%{ver2}/wx/memtext.h
422 %{_includedir}/wx-%{ver2}/wx/mimetype.h
423 %{_includedir}/wx-%{ver2}/wx/module.h
424 %{_includedir}/wx-%{ver2}/wx/msgout.h
425 %{_includedir}/wx-%{ver2}/wx/mstream.h
426 %{_includedir}/wx-%{ver2}/wx/object.h
427 %{_includedir}/wx-%{ver2}/wx/platform.h
428 %{_includedir}/wx-%{ver2}/wx/power.h
429 %{_includedir}/wx-%{ver2}/wx/process.h
430 %{_includedir}/wx-%{ver2}/wx/ptr_scpd.h
431 %{_includedir}/wx-%{ver2}/wx/recguard.h
432 %{_includedir}/wx-%{ver2}/wx/regex.h
433 %{_includedir}/wx-%{ver2}/wx/scopeguard.h
434 %{_includedir}/wx-%{ver2}/wx/snglinst.h
435 %{_includedir}/wx-%{ver2}/wx/sstream.h
436 %{_includedir}/wx-%{ver2}/wx/stack.h
437 %{_includedir}/wx-%{ver2}/wx/stackwalk.h
438 %{_includedir}/wx-%{ver2}/wx/stdpaths.h
439 %{_includedir}/wx-%{ver2}/wx/stockitem.h
440 %{_includedir}/wx-%{ver2}/wx/stopwatch.h
441 %{_includedir}/wx-%{ver2}/wx/strconv.h
442 %{_includedir}/wx-%{ver2}/wx/stream.h
443 %{_includedir}/wx-%{ver2}/wx/string.h
444 %{_includedir}/wx-%{ver2}/wx/sysopt.h
445 %{_includedir}/wx-%{ver2}/wx/textbuf.h
446 %{_includedir}/wx-%{ver2}/wx/textfile.h
447 %{_includedir}/wx-%{ver2}/wx/thread.h
448 %{_includedir}/wx-%{ver2}/wx/thrimpl.cpp
449 %{_includedir}/wx-%{ver2}/wx/timer.h
450 %{_includedir}/wx-%{ver2}/wx/tokenzr.h
451 %{_includedir}/wx-%{ver2}/wx/txtstrm.h
452 %{_includedir}/wx-%{ver2}/wx/types.h
453 %{_includedir}/wx-%{ver2}/wx/uri.h
454 %{_includedir}/wx-%{ver2}/wx/utils.h
455 %{_includedir}/wx-%{ver2}/wx/variant.h
456 %{_includedir}/wx-%{ver2}/wx/vector.h
457 %{_includedir}/wx-%{ver2}/wx/version.h
458 %{_includedir}/wx-%{ver2}/wx/volume.h
459 %{_includedir}/wx-%{ver2}/wx/wfstream.h
460 %{_includedir}/wx-%{ver2}/wx/wx.h
461 %{_includedir}/wx-%{ver2}/wx/wxchar.h
462 %{_includedir}/wx-%{ver2}/wx/wxprec.h
463 %{_includedir}/wx-%{ver2}/wx/xti.h
464 %{_includedir}/wx-%{ver2}/wx/xtistrm.h
465 %{_includedir}/wx-%{ver2}/wx/zipstrm.h
466 %{_includedir}/wx-%{ver2}/wx/zstream.h
467 %{_includedir}/wx-%{ver2}/wx/fs_inet.h
468 %{_includedir}/wx-%{ver2}/wx/gsocket.h
469 %{_includedir}/wx-%{ver2}/wx/protocol/file.h
470 %{_includedir}/wx-%{ver2}/wx/protocol/ftp.h
471 %{_includedir}/wx-%{ver2}/wx/protocol/http.h
472 %{_includedir}/wx-%{ver2}/wx/protocol/protocol.h
473 %{_includedir}/wx-%{ver2}/wx/sckaddr.h
474 %{_includedir}/wx-%{ver2}/wx/sckipc.h
475 %{_includedir}/wx-%{ver2}/wx/sckstrm.h
476 %{_includedir}/wx-%{ver2}/wx/socket.h
477 %{_includedir}/wx-%{ver2}/wx/url.h
478 %{_includedir}/wx-%{ver2}/wx/xml/xml.h
479 %{_includedir}/wx-%{ver2}/wx/xtixml.h
480 %{_includedir}/wx-%{ver2}/wx/unix/apptbase.h
481 %{_includedir}/wx-%{ver2}/wx/unix/apptrait.h
482 %{_includedir}/wx-%{ver2}/wx/unix/execute.h
483 %{_includedir}/wx-%{ver2}/wx/unix/gsockunx.h
484 %{_includedir}/wx-%{ver2}/wx/unix/mimetype.h
485 %{_includedir}/wx-%{ver2}/wx/unix/pipe.h
486 %{_includedir}/wx-%{ver2}/wx/unix/private.h
487 %{_includedir}/wx-%{ver2}/wx/unix/stackwalk.h
488 %{_includedir}/wx-%{ver2}/wx/unix/stdpaths.h
489 EOF
490 # --- wxBase headers list ends here ---
491
492 # temporarily remove base headers
493 mkdir $RPM_BUILD_ROOT/_save_dir
494 cp -r $RPM_BUILD_ROOT%{_includedir}/wx-%{ver2} $RPM_BUILD_ROOT/_save_dir
495 for f in `cat wxbase-headers.files` ; do
496 rm -f $RPM_BUILD_ROOT%{_includedir}/wx-%{ver2}/$f
497 done
498 # list of all core headers:
499 find $RPM_BUILD_ROOT%{_includedir}/wx-%{ver2} -type f | sed -e "s,$RPM_BUILD_ROOT,,g" >core-headers.files
500 # move base headers (actually all headers) back again
501 cp -f -r $RPM_BUILD_ROOT/_save_dir/* $RPM_BUILD_ROOT%{_includedir}
502 rm -rf $RPM_BUILD_ROOT/_save_dir
503
504 # contrib stuff:
505 (cd obj-static/contrib; make DESTDIR=$RPM_BUILD_ROOT prefix=%{_prefix} install)
506 (cd obj-shared/contrib; make DESTDIR=$RPM_BUILD_ROOT prefix=%{_prefix} install)
507
508 # utils:
509 (cd obj-shared/utils/wxrc; make DESTDIR=$RPM_BUILD_ROOT prefix=%{_prefix} install)
510
511 # wx-config link is created during package installation, remove it for now
512 rm -f $RPM_BUILD_ROOT%{_bindir}/wx-config
513
514 %clean
515 rm -rf $RPM_BUILD_ROOT
516
517 %post
518 /sbin/ldconfig
519
520 %postun
521 /sbin/ldconfig
522
523 %post devel
524 # link wx-config when you install RPM.
525 %if %{unicode}
526 ln -sf %{_libdir}/wx/config/%{wxconfig} %{_bindir}/wx-config
527 %endif
528 # link wx-config with explicit name.
529 ln -sf %{_libdir}/wx/config/%{wxconfig} %{_bindir}/%{wxconfiglink}
530 /sbin/ldconfig
531
532 %postun devel
533 /sbin/ldconfig
534
535 %preun devel
536 %if %{unicode}
537 rm -f %{_bindir}/wx-config
538 %endif
539 rm -f %{_bindir}/%{wxconfiglink}
540
541 %post -n %{wxbasename}
542 /sbin/ldconfig
543
544 %postun -n %{wxbasename}
545 /sbin/ldconfig
546
547 %post -n %{wxbasename}-devel
548 # link wx-config with explicit name.
549 ln -sf %{_libdir}/wx/config/%{wxbaseconfig} %{_bindir}/%{wxbaseconfiglink}
550 /sbin/ldconfig
551
552 %postun -n %{wxbasename}-devel
553 /sbin/ldconfig
554
555 %preun -n %{wxbasename}-devel
556 rm -f %{_bindir}/%{wxbaseconfiglink}
557
558 %post gl
559 /sbin/ldconfig
560
561 %postun gl
562 /sbin/ldconfig
563
564 %post contrib
565 /sbin/ldconfig
566
567 %postun contrib
568 /sbin/ldconfig
569
570 %post contrib-devel
571 /sbin/ldconfig
572
573 %postun contrib-devel
574 /sbin/ldconfig
575
576 %files
577 %defattr(-,root,root)
578 %doc COPYING.LIB *.txt
579 %{_libdir}/libwx_%{buildname}_adv-%{ver2}.so.*
580 %{_libdir}/libwx_%{buildname}_aui-%{ver2}.so.*
581 %{_libdir}/libwx_%{buildname}_core-%{ver2}.so.*
582 %{_libdir}/libwx_%{buildname}_html-%{ver2}.so.*
583 %{_libdir}/libwx_%{buildname}_mmedia-%{ver2}.so.*
584 %{_libdir}/libwx_%{buildname}_qa-%{ver2}.so.*
585 %{_libdir}/libwx_%{buildname}_richtext-%{ver2}.so.*
586 %{_libdir}/libwx_%{buildname}_xrc-%{ver2}.so.*
587
588 %files -n wx-i18n
589 %defattr(-,root,root)
590 %{_datadir}/locale/*/LC_MESSAGES/*.mo
591
592 %files devel -f core-headers.files
593 %defattr(-,root,root)
594 # shared libs
595 %{_libdir}/libwx_%{buildname}_adv-%{ver2}.so
596 %{_libdir}/libwx_%{buildname}_aui-%{ver2}.so
597 %{_libdir}/libwx_%{buildname}_core-%{ver2}.so
598 %{_libdir}/libwx_%{buildname}_gl-%{ver2}.so
599 %{_libdir}/libwx_%{buildname}_html-%{ver2}.so
600 %{_libdir}/libwx_%{buildname}_mmedia-%{ver2}.so
601 %{_libdir}/libwx_%{buildname}_qa-%{ver2}.so
602 %{_libdir}/libwx_%{buildname}_richtext-%{ver2}.so
603 %{_libdir}/libwx_%{buildname}_xrc-%{ver2}.so
604 # static libs
605 %{_libdir}/libwx_%{buildname}_adv-%{ver2}.a
606 %{_libdir}/libwx_%{buildname}_aui-%{ver2}.a
607 %{_libdir}/libwx_%{buildname}_core-%{ver2}.a
608 %{_libdir}/libwx_%{buildname}_gl-%{ver2}.a
609 %{_libdir}/libwx_%{buildname}_html-%{ver2}.a
610 %{_libdir}/libwx_%{buildname}_qa-%{ver2}.a
611 %{_libdir}/libwx_%{buildname}_richtext-%{ver2}.a
612 %{_libdir}/libwx_%{buildname}_xrc-%{ver2}.a
613 %dir %{_libdir}/wx
614 %{_libdir}/wx/config/%{wxconfig}
615 %{_libdir}/wx/include/%{wxconfig}/wx/setup.h
616 %{_libdir}/wx/config/%{wxconfigstatic}
617 %{_libdir}/wx/include/%{wxconfigstatic}/wx/setup.h
618 %{_bindir}/wxrc*
619
620 %files -n %{wxbasename}
621 %defattr(-,root,root)
622 %{_libdir}/libwx_base*-%{ver2}.so.*
623
624 %files -n %{wxbasename}-devel -f wxbase-headers.paths
625 %defattr (-,root,root)
626 %dir %{_includedir}/wx-%{ver2}
627 %{_libdir}/libwx_base*-%{ver2}.so
628 %{_libdir}/libwx_base*-%{ver2}.a
629 %if %{unicode}
630 %{_libdir}/libwxregexu-%{ver2}.a
631 %endif
632 %dir %{_libdir}/wx
633 %{_datadir}/aclocal/*.m4
634 %{_datadir}/bakefile/presets/*
635
636 %files gl
637 %defattr(-,root,root)
638 %{_libdir}/libwx_%{buildname}_gl-%{ver2}.so.*
639
640 %files contrib
641 %defattr(-,root,root)
642 %{_libdir}/libwx_%{buildname}_animate-%{ver2}.so.*
643 %{_libdir}/libwx_%{buildname}_deprecated-%{ver2}.so.*
644 %{_libdir}/libwx_%{buildname}_fl-%{ver2}.so.*
645 %{_libdir}/libwx_%{buildname}_gizmos-%{ver2}.so.*
646 %{_libdir}/libwx_%{buildname}_gizmos_xrc-%{ver2}.so.*
647 %{_libdir}/libwx_%{buildname}_mmedia-%{ver2}.so.*
648 %{_libdir}/libwx_%{buildname}_ogl-%{ver2}.so.*
649 %{_libdir}/libwx_%{buildname}_plot-%{ver2}.so.*
650 %{_libdir}/libwx_%{buildname}_stc-%{ver2}.so.*
651 %{_libdir}/libwx_%{buildname}_svg-%{ver2}.so.*
652
653 # static libs
654 %{_libdir}/libwx_%{buildname}_animate-%{ver2}.a
655 %{_libdir}/libwx_%{buildname}_deprecated-%{ver2}.a
656 %{_libdir}/libwx_%{buildname}_fl-%{ver2}.a
657 %{_libdir}/libwx_%{buildname}_gizmos-%{ver2}.a
658 %{_libdir}/libwx_%{buildname}_gizmos_xrc-%{ver2}.a
659 %{_libdir}/libwx_%{buildname}_mmedia-%{ver2}.a
660 %{_libdir}/libwx_%{buildname}_ogl-%{ver2}.a
661 %{_libdir}/libwx_%{buildname}_plot-%{ver2}.a
662 %{_libdir}/libwx_%{buildname}_stc-%{ver2}.a
663 %{_libdir}/libwx_%{buildname}_svg-%{ver2}.a
664
665 %files contrib-devel
666 %defattr(-,root,root)
667 %dir %{_includedir}/wx-%{ver2}/wx/animate
668 %{_includedir}/wx-%{ver2}/wx/animate/*
669 %{_libdir}/libwx_%{buildname}_animate-%{ver2}.so
670
671 %dir %{_includedir}/wx-%{ver2}/wx/deprecated
672 %{_includedir}/wx-%{ver2}/wx/deprecated/*
673 %{_libdir}/libwx_%{buildname}_deprecated-%{ver2}.so
674
675 %dir %{_includedir}/wx-%{ver2}/wx/fl
676 %{_includedir}/wx-%{ver2}/wx/fl/*
677 %{_libdir}/libwx_%{buildname}_fl-%{ver2}.so
678
679 %dir %{_includedir}/wx-%{ver2}/wx/gizmos
680 %{_includedir}/wx-%{ver2}/wx/gizmos/*
681 %{_libdir}/libwx_%{buildname}_gizmos-%{ver2}.so
682 %{_libdir}/libwx_%{buildname}_gizmos_xrc-%{ver2}.so
683
684 %dir %{_includedir}/wx-%{ver2}/wx/mmedia
685 %{_includedir}/wx-%{ver2}/wx/mmedia/*
686 %{_libdir}/libwx_%{buildname}_mmedia-%{ver2}.so
687
688 %dir %{_includedir}/wx-%{ver2}/wx/ogl
689 %{_includedir}/wx-%{ver2}/wx/ogl/*
690 %{_libdir}/libwx_%{buildname}_ogl-%{ver2}.so
691
692 %dir %{_includedir}/wx-%{ver2}/wx/plot
693 %{_includedir}/wx-%{ver2}/wx/plot/*
694 %{_libdir}/libwx_%{buildname}_plot-%{ver2}.so
695
696 %dir %{_includedir}/wx-%{ver2}/wx/stc
697 %{_includedir}/wx-%{ver2}/wx/stc/*
698 %{_libdir}/libwx_%{buildname}_stc-%{ver2}.so
699
700 %dir %{_includedir}/wx-%{ver2}/wx/svg
701 %{_includedir}/wx-%{ver2}/wx/svg/*
702 %{_libdir}/libwx_%{buildname}_svg-%{ver2}.so