]> git.saurik.com Git - wxWidgets.git/blob - wxGTK.spec
don't move the file to itself in AC_OUTPUT, this allows to run config.status after...
[wxWidgets.git] / wxGTK.spec
1 %define pref /usr
2 %define ver 2.3.1
3 %define rel 1
4
5 Summary: The GTK+ 1.2 port of the wxWindows library
6 Name: wxGTK
7 Version: %{ver}
8 Release: %{rel}
9 Copyright: wxWindows Licence
10 Group: X11/Libraries
11 Source: wxGTK-%{ver}.tar.gz
12 URL: http://wxwindows.org
13 Packager: Vadim Zeitlin <vadim@wxwindows.org>
14 Prefix: %{pref}
15 BuildRoot: /var/tmp/%{name}-root
16
17 # all packages providing an implementation of wxWindows library (regardless of
18 # the toolkit used) should provide the (virtual) wxwin package, this makes it
19 # possible to require wxwin instead of requiring "wxgtk or wxmotif or wxqt..."
20 Provides: wxwin
21
22 # in addition, we should provide libwx_gtk as automatic generator only notices
23 # libwx_gtk-%{ver}-%{rel}
24 Provides: libwx_gtk.so
25 Provides: libwx_gtk-2.3.so
26
27 %description
28 wxWindows is a free C++ library for cross-platform GUI development.
29 With wxWindows, you can create applications for different GUIs (GTK+,
30 Motif/LessTif, MS Windows, Mac) from the same source code.
31
32 %package devel
33 Summary: The GTK+ 1.2 port of the wxWindows library
34 Group: X11/Libraries
35 Requires: wxGTK
36
37 %description devel
38 Header files for wxGTK, the GTK+ 1.2 port of the wxWindows library.
39
40 %package gl
41 Summary: The GTK+ 1.2 port of the wxWindows library, OpenGl add-on.
42 Group: X11/Libraries
43 Requires: wxGTK
44
45 %description gl
46 OpenGl add-on library for wxGTK, the GTK+ 1.2 port of the wxWindows library.
47
48 %prep
49 %setup -n wxGTK-%{ver}
50 ./configure --prefix=%{pref} --enable-burnt_name --with-odbc --with-opengl
51
52 %build
53 if [ "$SMP" != "" ]; then
54 export MAKE="make -j$SMP"
55 else
56 export MAKE="make"
57 fi
58 $MAKE
59
60 %install
61 rm -rf $RPM_BUILD_ROOT
62 make prefix=$RPM_BUILD_ROOT%{pref} install
63
64 %post
65 /sbin/ldconfig
66
67 %postun
68 /sbin/ldconfig
69
70 %files
71 %defattr(-, root, root)
72 %doc COPYING.LIB INSTALL.txt LICENCE.txt README.txt SYMBOLS.txt TODO.txt
73 %dir %{pref}/share/wx
74 %{pref}/share/wx/*
75 %attr(755, root, root) %{pref}/lib/libwx_gtk.*
76 %attr(755, root, root) %{pref}/lib/libwx_gtk-2.3.*
77
78 %files devel
79 %defattr(-,root,root)
80 %dir %{pref}/include/wx
81 %{pref}/include/wx/*
82 %dir %{pref}/lib/wx
83 %{pref}/lib/wx/*
84 %attr(755, root, root) %{pref}/bin/wxgtk-config
85 %attr(755, root, root) %{pref}/bin/wx-config
86
87 %files gl
88 %attr(755, root, root) %{pref}/lib/libwx_gtk_gl*
89
90