]> git.saurik.com Git - wxWidgets.git/blob - wxGTK.spec
clean up dust from uri tests
[wxWidgets.git] / wxGTK.spec
1 %define pref /usr
2 %define ver 2.5.3
3 %define ver2 2.5
4 %define rel 1
5
6 # Configurable settings (use --with(out) {unicode,gtk2} on rpmbuild cmd line):
7 %define unicode 0
8 %{?_with_unicode: %{expand: %%define unicode 1}}
9 %{?_without_unicode: %{expand: %%define unicode 0}}
10
11 %define gtk2 0
12 %{?_with_gtk2: %{expand: %%define gtk2 1}}
13 %{?_without_gtk2: %{expand: %%define gtk2 0}}
14
15 %if %{gtk2}
16 %define gtkver 2
17 %define portname gtk2
18 %else
19 %define gtkver 1.2
20 %define portname gtk
21 %endif
22
23 %if %{unicode}
24 %define name wx-%{portname}-unicode
25 %define wxbasename wx-base-unicode
26 %else
27 %define name wx-%{portname}
28 %define wxbasename wx-base
29 %endif
30
31 %if %{unicode}
32 %define wxconfigname wx%{portname}u-%{ver2}-config
33 %else
34 %define wxconfigname wx%{portname}-%{ver2}-config
35 %endif
36
37 Name: %{name}
38 Summary: The GTK+ %{gtkver} port of the wxWindows library
39 Version: %{ver}
40 Release: %{rel}
41 License: wxWindows Licence
42 Group: X11/Libraries
43 Source: wxGTK-%{ver}.tar.bz2
44 URL: http://www.wxwindows.org
45 Packager: Vadim Zeitlin <vadim@wxwindows.org>
46 Prefix: %{pref}
47 BuildRoot: /var/tmp/%{name}-root
48
49 # all packages providing an implementation of wxWindows library (regardless of
50 # the toolkit used) should provide the (virtual) wxwin package, this makes it
51 # possible to require wxwin instead of requiring "wxgtk or wxmotif or wxuniv..."
52 Provides: wxwin
53 Provides: wxGTK
54
55 # in addition, we should provide libwx_gtk as automatic generator only notices
56 # libwx_gtk-%{ver}-%{rel}
57 Provides: libwx_gtk.so
58 Provides: libwx_gtk-%{ver2}.so
59
60 Requires: %{wxbasename} = %{ver}
61
62 %description
63 wxWindows is a free C++ library for cross-platform GUI development.
64 With wxWindows, you can create applications for different GUIs (GTK+,
65 Motif/LessTif, MS Windows, Mac) from the same source code.
66
67 %package devel
68 Summary: The GTK+ %{gtkver} port of the wxWindows library
69 Group: X11/Libraries
70 Requires: %{name} = %{ver}
71 Requires: %{wxbasename}-devel = %{ver}
72 Provides: wxGTK-devel
73
74 %description devel
75 Header files for wxGTK, the GTK+ %{gtkver} port of the wxWindows library.
76
77 %package gl
78 Summary: The GTK+ %{gtkver} port of the wxWindows library, OpenGL add-on.
79 Group: X11/Libraries
80 Requires: %{name} = %{ver}
81
82 %description gl
83 OpenGL add-on library for wxGTK, the GTK+ %{gtkver} port of the wxWindows library.
84
85 %package static
86 Summary: wxGTK static libraries
87 Group: Development/Libraries
88 Requires: %{wxbasename}-static
89
90 %description static
91 Static libraries for wxGTK. You need them if you want to link statically against wxGTK.
92
93 %package contrib
94 Summary: The GTK+ %{gtkver} port of the wxWindows library, contributed libraries.
95 Group: X11/Libraries
96 Requires: %{name} = %{ver}
97
98 %description contrib
99 Contributed libraries for wxGTK, the GTK+ %{gtkver} port of the wxWindows library.
100
101 %package contrib-devel
102 Summary: The GTK+ %{gtkver} port of the wxWindows library
103 Group: X11/Libraries
104 Requires: %{name}-contrib = %{ver}
105 Requires: %{name}-devel = %{ver}
106
107 %description contrib-devel
108 Header files for contributed libraries for wxGTK, the GTK+ %{gtkver} port of the wxWindows library.
109
110 %prep
111 %setup -q -n wxGTK-%{ver}
112
113 %build
114 if [ "$SMP" != "" ]; then
115 export MAKE="make -j$SMP"
116 else
117 export MAKE="make"
118 fi
119
120 mkdir obj-shared
121 cd obj-shared
122 ../configure --prefix=%{pref} \
123 %if %{unicode}
124 --enable-unicode \
125 %else
126 --with-odbc \
127 %endif
128 %if %{gtk2}
129 --enable-gtk2 \
130 %endif
131 --with-opengl
132 $MAKE
133 cd contrib/src
134 $MAKE
135 cd ../../..
136
137 mkdir obj-static
138 cd obj-static
139 ../configure --prefix=%{pref} --disable-shared \
140 %if %{unicode}
141 --enable-unicode \
142 %else
143 --with-odbc \
144 %endif
145 %if %{gtk2}
146 --enable-gtk2 \
147 %endif
148 --with-opengl
149 $MAKE
150 cd ..
151
152 %install
153 rm -rf $RPM_BUILD_ROOT
154 (cd obj-static; make prefix=$RPM_BUILD_ROOT%{pref} install)
155 (cd obj-shared; make prefix=$RPM_BUILD_ROOT%{pref} install)
156
157 # Remove headers that are part of wx-base-devel:
158
159 # --- wxBase headers list begins here ---
160 cat <<EOF >wxbase-headers-list
161 wx/afterstd.h
162 wx/app.h
163 wx/apptrait.h
164 wx/arrimpl.cpp
165 wx/arrstr.h
166 wx/beforestd.h
167 wx/buffer.h
168 wx/build.h
169 wx/chkconf.h
170 wx/clntdata.h
171 wx/cmdline.h
172 wx/confbase.h
173 wx/config.h
174 wx/containr.h
175 wx/datetime.h
176 wx/datetime.inl
177 wx/datstrm.h
178 wx/dde.h
179 wx/debug.h
180 wx/defs.h
181 wx/dir.h
182 wx/dlimpexp.h
183 wx/dynarray.h
184 wx/dynlib.h
185 wx/dynload.h
186 wx/encconv.h
187 wx/event.h
188 wx/except.h
189 wx/features.h
190 wx/ffile.h
191 wx/file.h
192 wx/fileconf.h
193 wx/filefn.h
194 wx/filename.h
195 wx/filesys.h
196 wx/fontenc.h
197 wx/fontmap.h
198 wx/fs_mem.h
199 wx/fs_zip.h
200 wx/hash.h
201 wx/hashmap.h
202 wx/hashset.h
203 wx/iconloc.h
204 wx/init.h
205 wx/intl.h
206 wx/iosfwrap.h
207 wx/ioswrap.h
208 wx/ipc.h
209 wx/ipcbase.h
210 wx/isql.h
211 wx/isqlext.h
212 wx/list.h
213 wx/listimpl.cpp
214 wx/log.h
215 wx/longlong.h
216 wx/math.h
217 wx/memconf.h
218 wx/memory.h
219 wx/memtext.h
220 wx/mimetype.h
221 wx/module.h
222 wx/msgout.h
223 wx/msgout.h
224 wx/mstream.h
225 wx/object.h
226 wx/platform.h
227 wx/process.h
228 wx/ptr_scpd.h
229 wx/regex.h
230 wx/scopeguard.h
231 wx/snglinst.h
232 wx/sstream.h
233 wx/stack.h
234 wx/stdpaths.h
235 wx/stockitem.h
236 wx/stopwatch.h
237 wx/strconv.h
238 wx/stream.h
239 wx/string.h
240 wx/sysopt.h
241 wx/textbuf.h
242 wx/textfile.h
243 wx/thread.h
244 wx/thrimpl.cpp
245 wx/timer.h
246 wx/tokenzr.h
247 wx/txtstrm.h
248 wx/types.h
249 wx/uri.h
250 wx/utils.h
251 wx/variant.h
252 wx/vector.h
253 wx/version.h
254 wx/volume.h
255 wx/wfstream.h
256 wx/wx.h
257 wx/wxchar.h
258 wx/wxprec.h
259 wx/xti.h
260 wx/xtistrm.h
261 wx/zipstrm.h
262 wx/zstream.h
263 wx/msw/apptrait.h
264 wx/msw/apptbase.h
265 wx/msw/chkconf.h
266 wx/msw/crashrpt.h
267 wx/msw/dde.h
268 wx/msw/gccpriv.h
269 wx/msw/mimetype.h
270 wx/msw/winundef.h
271 wx/msw/wrapcctl.h
272 wx/msw/wrapwin.h
273 wx/fs_inet.h
274 wx/gsocket.h
275 wx/protocol/file.h
276 wx/protocol/ftp.h
277 wx/protocol/http.h
278 wx/protocol/protocol.h
279 wx/sckaddr.h
280 wx/sckipc.h
281 wx/sckstrm.h
282 wx/socket.h
283 wx/url.h
284 wx/msw/gsockmsw.h
285 wx/xml/xml.h
286 wx/xtixml.h
287 wx/db.h
288 wx/dbkeyg.h
289 wx/dbtable.h
290 EOF
291 # --- wxBase headers list ends here ---
292 for f in `cat wxbase-headers-list` ; do
293 rm -f $RPM_BUILD_ROOT%{_includedir}/wx-*/$f
294 done
295
296 # list of all core headers:
297 find $RPM_BUILD_ROOT/usr/include/wx -type f | sed -e "s,$RPM_BUILD_ROOT,,g" >core-headers.files
298
299 # contrib stuff:
300 (cd obj-shared/contrib/src; make prefix=$RPM_BUILD_ROOT%{pref} install)
301 (cd obj-shared/contrib/utils/wxrc; make prefix=$RPM_BUILD_ROOT%{pref} install)
302
303 # remove wxBase files so that RPM doesn't complain about unpackaged files:
304 rm -f $RPM_BUILD_ROOT%{_libdir}/libwx_base*
305 rm -f $RPM_BUILD_ROOT%{_datadir}/aclocal/*
306 rm -f $RPM_BUILD_ROOT%{_datadir}/locale/*/*/*
307
308 %clean
309 rm -rf $RPM_BUILD_ROOT
310
311 %post
312 /sbin/ldconfig
313
314 %postun
315 /sbin/ldconfig
316
317 %post gl
318 /sbin/ldconfig
319
320 %postun gl
321 /sbin/ldconfig
322
323
324 %files
325 %defattr(-,root,root)
326 %doc COPYING.LIB *.txt
327 %dir %{_datadir}/wx
328 %{_datadir}/wx/*
329 %{_libdir}/libwx_%{portname}*_core*.so.*
330 %{_libdir}/libwx_%{portname}*_html*.so.*
331 %{_libdir}/libwx_%{portname}*_adv*.so.*
332 %if !%{unicode}
333 %{_libdir}/libwx_%{portname}*_dbgrid*.so.*
334 %endif
335
336 %files devel -f core-headers.files
337 %defattr(-,root,root)
338 %{_libdir}/libwx_%{portname}*_core*.so
339 %{_libdir}/libwx_%{portname}*_html*.so
340 %{_libdir}/libwx_%{portname}*_adv*.so
341 %if !%{unicode}
342 %{_libdir}/libwx_%{portname}*_dbgrid*.so
343 %endif
344 %{_libdir}/libwx_%{portname}*_gl*.so
345 %dir %{_libdir}/wx
346 %{_libdir}/wx/*
347 %{_bindir}/%{wxconfigname}
348
349 %files gl
350 %defattr(-,root,root)
351 %{_libdir}/libwx_%{portname}*_gl*.so.*
352
353 %files static
354 %defattr (-,root,root)
355 %{_libdir}/libwx_gtk*.a
356
357 %files contrib
358 %defattr(-,root,root)
359 %{_libdir}/libwx_%{portname}*_animate*.so.*
360 %{_libdir}/libwx_%{portname}*_deprecated*.so.*
361 %{_libdir}/libwx_%{portname}*_fl*.so.*
362 %{_libdir}/libwx_%{portname}*_gizmos*.so.*
363 %{_libdir}/libwx_%{portname}*_mmedia*.so.*
364 %{_libdir}/libwx_%{portname}*_ogl*.so.*
365 %{_libdir}/libwx_%{portname}*_plot*.so.*
366 %{_libdir}/libwx_%{portname}*_stc*.so.*
367 %{_libdir}/libwx_%{portname}*_svg*.so.*
368 %{_libdir}/libwx_%{portname}*_xrc*.so.*
369
370 %files contrib-devel
371 %defattr(-,root,root)
372 %{_bindir}/wxrc
373 %dir %{_includedir}/wx-*/wx/animate
374 %{_includedir}/wx-*/wx/animate/*
375 %{_libdir}/libwx_%{portname}*_animate*.so
376
377 %dir %{_includedir}/wx-*/wx/deprecated
378 %{_includedir}/wx-*/wx/deprecated/*
379 %{_libdir}/libwx_%{portname}*_deprecated*.so
380
381 %dir %{_includedir}/wx-*/wx/fl
382 %{_includedir}/wx-*/wx/fl/*
383 %{_libdir}/libwx_%{portname}*_fl*.so
384
385 %dir %{_includedir}/wx-*/wx/gizmos
386 %{_includedir}/wx-*/wx/gizmos/*
387 %{_libdir}/libwx_%{portname}*_gizmos*.so
388
389 %dir %{_includedir}/wx-*/wx/mmedia
390 %{_includedir}/wx-*/wx/mmedia/*
391 %{_libdir}/libwx_%{portname}*_mmedia*.so
392
393 %dir %{_includedir}/wx-*/wx/ogl
394 %{_includedir}/wx-*/wx/ogl/*
395 %{_libdir}/libwx_%{portname}*_ogl*.so
396
397 %dir %{_includedir}/wx-*/wx/plot
398 %{_includedir}/wx-*/wx/plot/*
399 %{_libdir}/libwx_%{portname}*_plot*.so
400
401 %dir %{_includedir}/wx-*/wx/stc
402 %{_includedir}/wx-*/wx/stc/*
403 %{_libdir}/libwx_%{portname}*_stc*.so
404
405 %dir %{_includedir}/wx-*/wx/svg
406 %{_includedir}/wx-*/wx/svg/*
407 %{_libdir}/libwx_%{portname}*_svg*.so
408
409 %dir %{_includedir}/wx-*/wx/xrc
410 %{_includedir}/wx-*/wx/xrc/*
411 %{_libdir}/libwx_%{portname}*_xrc*.so