Changed version to 2.5.1
[wxWidgets.git] / wxBase.spec
1 %define pref /usr
2 %define ver 2.5.1
3 %define ver2 2.5
4 %define rel 1
5
6 # Configurable settings (use --with(out) unicode on rpmbuild command line):
7 %define unicode 0
8 %{?_with_unicode: %{expand: %%define unicode 1}}
9 %{?_without_unicode: %{expand: %%define unicode 0}}
10
11 %if %{unicode}
12 %define wxconfigname wxbaseu-%{ver2}-config
13 %else
14 %define wxconfigname wxbase-%{ver2}-config
15 %endif
16
17 %if %{unicode}
18 %define name wx-base-unicode
19 %else
20 %define name wx-base
21 %endif
22
23 Summary: wxBase library - non-GUI support classes of wxWindows toolkit
24 Name: %{name}
25 Version: %{ver}
26 Release: %{rel}
27 License: wxWindows Licence
28 Group: Development/Libraries
29 Source: wxBase-%{ver}.tar.bz2
30 URL: http://www.wxwindows.org
31 Packager: Vadim Zeitlin <vadim@wxwindows.org>
32 Prefix: %{pref}
33 BuildRoot: /var/tmp/%{name}-root
34 Provides: wxBase
35
36 %description
37 wxBase is a collection of C++ classes providing basic data structures (strings,
38 lists, arrays), powerful wxDateTime class for date manipulations, portable
39 wrappers around many OS-specific functions allowing to build the same program
40 under all supported folders, wxThread class for writing multithreaded programs
41 using either Win32 or POSIX threads and much more. wxBase currently supports
42 the following platforms: Win32, generic Unix (Linux, FreeBSD, Solaris, HP-UX,
43 ...) and BeOS.
44
45 %package devel
46 Summary: wxBase headers needed for developping with wxBase
47 Group: Development/Libraries
48 Requires: %{name} = %{ver}
49 Provides: wxBase-devel
50
51 %description devel
52 Header files for wxBase. You need them to develop programs using wxBase.
53
54 %package static
55 Summary: wxBase static libraries
56 Group: Development/Libraries
57
58 %description static
59 Static libraries for wxBase. You need them if you want to link statically against wxBase.
60
61 %prep
62 %setup -q -n wxBase-%{ver}
63
64 %build
65 if [ "$SMP" != "" ]; then
66 export MAKE="make -j$SMP"
67 else
68 export MAKE="make"
69 fi
70
71 mkdir obj-shared
72 cd obj-shared
73 ../configure --prefix=%{pref} --disable-gui \
74 %if %{unicode}
75 --enable-unicode \
76 %else
77 --with-odbc \
78 %endif
79 --disable-std_iostreams
80 $MAKE
81 cd ..
82
83 mkdir obj-static
84 cd obj-static
85 ../configure --prefix=%{pref} --disable-shared --disable-gui \
86 %if %{unicode}
87 --enable-unicode \
88 %else
89 --with-odbc \
90 %endif
91 --disable-std_iostreams
92 $MAKE
93 cd ..
94
95 %install
96 rm -rf $RPM_BUILD_ROOT
97 (cd obj-static ; make prefix=$RPM_BUILD_ROOT%{pref} install)
98 (cd obj-shared ; make prefix=$RPM_BUILD_ROOT%{pref} install)
99
100 %find_lang wxstd
101
102 %clean
103 rm -rf $RPM_BUILD_ROOT
104
105 %post
106 /sbin/ldconfig
107
108 %postun
109 /sbin/ldconfig
110
111 %post devel
112 # Install wx-config if there isn't any
113 if test ! -f %{_bindir}/wx-config ; then
114 ln -sf wxbase-%{ver2}-config %{_bindir}/wx-config
115 fi
116
117 %preun devel
118 # Remove wx-config if it points to this package
119 if test -f %{_bindir}/wx-config -a -f /usr/bin/md5sum ; then
120 SUM1=`md5sum %{_bindir}/wxbase-%{ver2}-config | cut -c 0-32`
121 SUM2=`md5sum %{_bindir}/wx-config | cut -c 0-32`
122 if test "x$SUM1" = "x$SUM2" ; then
123 rm -f %{_bindir}/wx-config
124 fi
125 fi
126
127 %files -f wxstd.lang
128 %defattr (-,root,root)
129 %doc COPYING.LIB *.txt
130 %{_libdir}/libwx_base*so.*
131
132 %files devel
133 %defattr (-,root,root)
134 %dir %{_includedir}/wx
135 %{_includedir}/wx/*
136 %{_libdir}/libwx_base*.so
137 %dir %{_libdir}/wx
138 %{_libdir}/wx/*
139 %{_bindir}/wxbase*-%{ver2}-config
140 %{_datadir}/aclocal/*.m4
141
142 %files static
143 %defattr (-,root,root)
144 %{_libdir}/lib*.a