Incremented version
[wxWidgets.git] / wxBase.spec
1 %define pref /usr
2 %define ver 2.5.3
3 %define ver2 2.5
4 %define rel 1
5
6 # Configurable settings (use --with(out) unicode on rpmbuild command line):
7 %define unicode 0
8 %{?_with_unicode: %{expand: %%define unicode 1}}
9 %{?_without_unicode: %{expand: %%define unicode 0}}
10
11 %if %{unicode}
12 %define wxconfigname wxbaseu-%{ver2}-config
13 %else
14 %define wxconfigname wxbase-%{ver2}-config
15 %endif
16
17 %if %{unicode}
18 %define name wx-base-unicode
19 %else
20 %define name wx-base
21 %endif
22
23 Summary: wxBase library - non-GUI support classes of wxWindows toolkit
24 Name: %{name}
25 Version: %{ver}
26 Release: %{rel}
27 License: wxWindows Licence
28 Group: Development/Libraries
29 Source: wxBase-%{ver}.tar.bz2
30 URL: http://www.wxwindows.org
31 Packager: Vadim Zeitlin <vadim@wxwindows.org>
32 Prefix: %{pref}
33 BuildRoot: /var/tmp/%{name}-root
34 Provides: wxBase
35
36 %description
37 wxBase is a collection of C++ classes providing basic data structures (strings,
38 lists, arrays), powerful wxDateTime class for date manipulations, portable
39 wrappers around many OS-specific functions allowing to build the same program
40 under all supported folders, wxThread class for writing multithreaded programs
41 using either Win32 or POSIX threads and much more. wxBase currently supports
42 the following platforms: Win32, generic Unix (Linux, FreeBSD, Solaris, HP-UX,
43 ...) and BeOS.
44
45 %package devel
46 Summary: wxBase headers needed for developping with wxBase
47 Group: Development/Libraries
48 Requires: %{name} = %{ver}
49 Provides: wxBase-devel
50
51 %description devel
52 Header files for wxBase. You need them to develop programs using wxBase.
53
54 %package static
55 Summary: wxBase static libraries
56 Group: Development/Libraries
57
58 %description static
59 Static libraries for wxBase. You need them if you want to link statically against wxBase.
60
61 %prep
62 %setup -q -n wxBase-%{ver}
63
64 %build
65 if [ "$SMP" != "" ]; then
66 export MAKE="make -j$SMP"
67 else
68 export MAKE="make"
69 fi
70
71 mkdir obj-shared
72 cd obj-shared
73 ../configure --prefix=%{pref} --disable-gui \
74 %if %{unicode}
75 --enable-unicode
76 %else
77 --with-odbc
78 %endif
79 $MAKE
80 cd ..
81
82 mkdir obj-static
83 cd obj-static
84 ../configure --prefix=%{pref} --disable-shared --disable-gui \
85 %if %{unicode}
86 --enable-unicode
87 %else
88 --with-odbc
89 %endif
90 $MAKE
91 cd ..
92
93 %install
94 rm -rf $RPM_BUILD_ROOT
95 (cd obj-static ; make prefix=$RPM_BUILD_ROOT%{pref} install)
96 (cd obj-shared ; make prefix=$RPM_BUILD_ROOT%{pref} install)
97
98 %find_lang wxstd
99
100 %clean
101 rm -rf $RPM_BUILD_ROOT
102
103 %post
104 /sbin/ldconfig
105
106 %postun
107 /sbin/ldconfig
108
109 %files -f wxstd.lang
110 %defattr (-,root,root)
111 %doc COPYING.LIB *.txt
112 %{_libdir}/libwx_base*so.*
113
114 %files devel
115 %defattr (-,root,root)
116 %dir %{_includedir}/wx-*
117 %{_includedir}/wx-*/*
118 %{_libdir}/libwx_base*.so
119 %dir %{_libdir}/wx
120 %{_libdir}/wx/*
121 %{_bindir}/wxbase*-%{ver2}-config
122 %{_bindir}/wx-config
123 %{_datadir}/aclocal/*.m4
124
125 %files static
126 %defattr (-,root,root)
127 %{_libdir}/lib*.a