1 # RPM .spec file for wxMotif. Based on the .spec file for wxGTK
2 # (c) by Robert Roebling. Modifications (c) 2000/03 by Robert Fendt.
4 # Note that this is NOT a relocatable package
10 %define portname motif
11 %define name wx
-%{portname}
12 %define wxbasename wx
-base
13 %define wxconfigname wx
%{portname}-%{ver2}-config
15 Summary: The Motif
/Lesstif port of the wxWindows library
19 License: wxWindows Licence
21 Source: wxMOTIF
-%{ver}.tar.bz2
22 URL: http
://www.wxwindows.org
23 Packager: Robert Fendt
<rfendt@myokay.net
>
24 BuildRoot: /tmp
/wxmotif_root
26 # all packages providing an implementation of wxWindows library (regardless of
27 # the toolkit used) should provide the (virtual) wxwin package, this makes it
28 # possible to require wxwin instead of requiring "wxgtk or wxmotif or wxuniv..."
33 Requires: %{wxbasename} = %{ver}
36 wxWindows is a free C
++ library
for cross
-platform GUI development.
37 With wxWindows
, you can create applications
for different GUIs
(GTK
+,
38 Motif
/LessTif
, MS Windows
, Mac
) from the same
source code.
41 Summary: The Motif
/Lesstif port of the wxWindows library
43 Requires: %{name} = %{ver}
44 Requires: %{wxbasename}-devel = %{ver}
47 Header files
for wxMotif
, the Motif
/Lesstif port of the wxWindows library.
50 Summary: The Motif
/Lesstif port of the wxWindows library
, OpenGL add
-on.
52 Requires: %{name} = %{ver}
55 OpenGL add
-on library
for wxMotif
, the Motif
/Lesstif port of the wxWindows library.
58 Summary: wxMotif static libraries
59 Group: Development
/Libraries
62 Static libraries
for wxMotif. You need them
if you want to link statically against wxMotif.
65 %setup -q
-n wxMOTIF
-%{ver}
68 if [ "$SMP"
!= ""
]; then
69 export MAKE
="
make -j$SMP"
76 ..
/configure
--prefix
=%{pref} --with
-odbc
--with
-opengl
--with
-motif
82 ..
/configure
--prefix
=%{pref} --disable
-shared
--with
-odbc
--with
-opengl
--with
-motif
87 rm -rf $RPM_BUILD_ROOT
88 (cd obj
-static
; make prefix
=$RPM_BUILD_ROOT
%{pref} install)
89 (cd obj
-shared
; make prefix
=$RPM_BUILD_ROOT
%{pref} install)
91 # Remove headers that are part of wx-base-devel:
93 # --- wxBase headers list begins here ---
94 cat
<<EOF
>wxbase
-headers
-list
208 wx
/protocol
/protocol.h
221 # --- wxBase headers list ends here ---
222 for f
in `cat wxbase
-headers
-list`
; do
223 rm -f $RPM_BUILD_ROOT
%{_includedir}/$f
226 # list of all core headers:
227 find $RPM_BUILD_ROOT
/usr
/include
/wx
-type f | sed
-e "s
,$RPM_BUILD_ROOT
,,g"
>core
-headers.files
229 # remove wxBase files so that RPM doesn't complain about unpackaged files:
230 rm -f $RPM_BUILD_ROOT
%{_libdir}/libwx_base
*
231 rm -f $RPM_BUILD_ROOT
%{_datadir}/aclocal
/*
232 rm -f $RPM_BUILD_ROOT
%{_datadir}/locale
/*/*/*
236 rm -rf $RPM_BUILD_ROOT
251 # Install wx-config if there isn't any
252 if test ! -f
%{_bindir}/wx
-config
; then
253 ln
-sf
%{wxconfigname} %{_bindir}/wx
-config
257 # Remove wx-config if it points to this package
258 if test -f
%{_bindir}/wx
-config
-a
-f
/usr
/bin
/md5sum
; then
259 SUM1
=`md5sum
%{_bindir}/%{wxconfigname} | cut
-c
0-32`
260 SUM2
=`md5sum
%{_bindir}/wx
-config | cut
-c
0-32`
261 if test "x$SUM1"
= "x$SUM2"
; then
262 rm -f
%{_bindir}/wx
-config
268 %defattr(-,root
,root
)
269 %doc COPYING.LIB
*.txt
272 %{_libdir}/libwx_%{portname}*_core
*.so.
*
273 %{_libdir}/libwx_%{portname}*_html
*.so.
*
274 %{_libdir}/libwx_%{portname}*_adv
*.so.
*
275 %{_libdir}/libwx_%{portname}*_dbgrid
*.so.
*
277 %files devel
-f core
-headers.files
278 %defattr(-,root
,root
)
279 %{_libdir}/libwx_%{portname}*_core
*.so
280 %{_libdir}/libwx_%{portname}*_html
*.so
281 %{_libdir}/libwx_%{portname}*_adv
*.so
282 %{_libdir}/libwx_%{portname}*_dbgrid
*.so
283 %{_libdir}/libwx_%{portname}*_gl
*.so
286 %{_bindir}/%{wxconfigname}
289 %defattr(-,root
,root
)
290 %{_libdir}/libwx_%{portname}*_gl
*.so.
*
293 %defattr (-,root
,root
)
294 %{_libdir}/libwx_%{portname}*.a