rebaked makefiles with 0.2.4
[wxWidgets.git] / wxX11.spec
1 %define pref /usr
2 %define ver 2.9.0
3 %define ver2 2.9
4 %define rel 1
5
6 # Configurable settings (use --with(out) unicode on rpmbuild cmd line):
7 %define unicode 0
8 %{?_with_unicode: %{expand: %%define unicode 1}}
9 %{?_without_unicode: %{expand: %%define unicode 0}}
10
11 %define portname x11univ
12
13 %if %{unicode}
14 %define wxbasename wx-base-unicode
15 %define name wx-%{portname}-unicode
16 %define wxconfig %{portname}-unicode-release-%{ver2}
17 %define wxconfiglink wx%{portname}u-%{ver2}-config
18 %else
19 %define wxbasename wx-base
20 %define name wx-%{portname}
21 %define wxconfig %{portname}-ansi-release-%{ver2}
22 %define wxconfiglink wx%{portname}-%{ver2}-config
23 %endif
24
25 Summary: The X11 port of the wxWidgets library
26 Name: %{name}
27 Version: %{ver}
28 Release: %{rel}
29 License: wxWindows Licence
30 Group: X11/Libraries
31 Source: wxX11-%{ver}.tar.bz2
32 URL: http://www.wxwidgets.org
33 Packager: Vadim Zeitlin <vadim@wxwindows.org>
34 Prefix: %{pref}
35 BuildRoot: %{_tmppath}/%{name}-root
36 Requires: %{wxbasename} = %{ver}
37
38 # all packages providing an implementation of wxWidgets library (regardless of
39 # the toolkit used) should provide the (virtual) wxwin package, this makes it
40 # possible to require wxwin instead of requiring "wxgtk or wxmotif or wxuniv..."
41 Provides: wxwin
42 Provides: wxX11
43
44 %description
45 wxWidgets is a free C++ library for cross-platform GUI development.
46 With wxWidgets, you can create applications for different GUIs (GTK+,
47 Motif/LessTif, MS Windows, Mac) from the same source code.
48
49 %package devel
50 Summary: The X11 port of the wxWidgets library
51 Group: X11/Libraries
52 Requires: %{name} = %{ver}
53 Requires: %{wxbasename}-devel = %{ver}
54
55 %description devel
56 Header files for wxX11, the X11 port of the wxWidgets library.
57
58 %package gl
59 Summary: The X11 port of the wxWidgets library, OpenGL add-on.
60 Group: X11/Libraries
61 Requires: %{name} = %{ver}
62
63 %description gl
64 OpenGL add-on library for wxX11, the X11 port of the wxWidgets library.
65
66 %package static
67 Summary: wxX11 static libraries
68 Group: Development/Libraries
69 Requires: %{wxbasename}-static
70 Requires: %{name}-devel = %{ver}
71
72 %description static
73 Static libraries for wxX11. You need them if you want to link statically against wxX11.
74
75 %package contrib
76 Summary: Contrib libraries for wxX11.
77 Group: X11/Libraries
78 Requires: %{name} = %{ver}
79
80 %description contrib
81 Contributed libraries for wxX11.
82
83 %package contrib-devel
84 Summary: Contrib libraries for wxX11.
85 Group: X11/Libraries
86 Requires: %{name}-contrib = %{ver}
87 Requires: %{name}-devel = %{ver}
88
89 %description contrib-devel
90 Header files for contributed libraries for wxX11.
91
92 %prep
93 %setup -q -n wxX11-%{ver}
94
95 %build
96 if [ "$SMP" != "" ]; then
97 export MAKE="make -j$SMP"
98 else
99 export MAKE="make"
100 fi
101
102 mkdir obj-shared
103 cd obj-shared
104 ../configure --prefix=%{pref} --with-x11 \
105 %if %{unicode}
106 --enable-unicode \
107 %else
108 --disable-unicode \
109 %endif
110 $MAKE
111
112 cd contrib/src
113 $MAKE
114 cd ../../..
115
116 mkdir obj-static
117 cd obj-static
118 ../configure --prefix=%{pref} --with-x11 --disable-shared \
119 %if %{unicode}
120 --enable-unicode \
121 %else
122 --disable-unicode \
123 %endif
124 --with-opengl
125 $MAKE
126 cd ..
127
128 %install
129 rm -rf $RPM_BUILD_ROOT
130 (cd obj-static; make prefix=$RPM_BUILD_ROOT%{pref} install)
131 (cd obj-shared; make prefix=$RPM_BUILD_ROOT%{pref} install)
132
133 # Remove headers that are part of wx-base-devel:
134
135 # --- wxBase headers list begins here ---
136 cat <<EOF >wxbase-headers.files
137 wx/afterstd.h
138 wx/app.h
139 wx/apptrait.h
140 wx/archive.h
141 wx/arrimpl.cpp
142 wx/arrstr.h
143 wx/atomic.h
144 wx/base64.h
145 wx/beforestd.h
146 wx/buffer.h
147 wx/build.h
148 wx/chartype.h
149 wx/chkconf.h
150 wx/clntdata.h
151 wx/cmdargs.h
152 wx/cmdline.h
153 wx/confbase.h
154 wx/config.h
155 wx/convauto.h
156 wx/containr.h
157 wx/cpp.h
158 wx/crt.h
159 wx/datetime.h
160 wx/datstrm.h
161 wx/dde.h
162 wx/debug.h
163 wx/defs.h
164 wx/dir.h
165 wx/dlimpexp.h
166 wx/dlist.h
167 wx/dynarray.h
168 wx/dynlib.h
169 wx/dynload.h
170 wx/encconv.h
171 wx/event.h
172 wx/except.h
173 wx/features.h
174 wx/flags.h
175 wx/ffile.h
176 wx/file.h
177 wx/fileconf.h
178 wx/filefn.h
179 wx/filename.h
180 wx/filesys.h
181 wx/fontenc.h
182 wx/fontmap.h
183 wx/fs_arc.h
184 wx/fs_filter.h
185 wx/fs_mem.h
186 wx/fs_zip.h
187 wx/hash.h
188 wx/hashmap.h
189 wx/hashset.h
190 wx/html/forcelnk.h
191 wx/iconloc.h
192 wx/init.h
193 wx/intl.h
194 wx/iosfwrap.h
195 wx/ioswrap.h
196 wx/ipc.h
197 wx/ipcbase.h
198 wx/kbdstate.h
199 wx/link.h
200 wx/list.h
201 wx/listimpl.cpp
202 wx/log.h
203 wx/longlong.h
204 wx/math.h
205 wx/memconf.h
206 wx/memory.h
207 wx/memtext.h
208 wx/mimetype.h
209 wx/module.h
210 wx/mousestate.h
211 wx/msgout.h
212 wx/mstream.h
213 wx/object.h
214 wx/platform.h
215 wx/platinfo.h
216 wx/power.h
217 wx/process.h
218 wx/ptr_scpd.h
219 wx/ptr_shrd.h
220 wx/recguard.h
221 wx/regex.h
222 wx/scopeguard.h
223 wx/snglinst.h
224 wx/sstream.h
225 wx/stack.h
226 wx/stackwalk.h
227 wx/stdpaths.h
228 wx/stockitem.h
229 wx/stopwatch.h
230 wx/strconv.h
231 wx/stream.h
232 wx/string.h
233 wx/stringimpl.h
234 wx/stringops.h
235 wx/strvararg.h
236 wx/sysopt.h
237 wx/tarstrm.h
238 wx/textbuf.h
239 wx/textfile.h
240 wx/thread.h
241 wx/thrimpl.cpp
242 wx/timer.h
243 wx/tokenzr.h
244 wx/tracker.h
245 wx/txtstrm.h
246 wx/types.h
247 wx/unichar.h
248 wx/uri.h
249 wx/ustring.h
250 wx/utils.h
251 wx/variant.h
252 wx/vector.h
253 wx/version.h
254 wx/volume.h
255 wx/weakref.h
256 wx/wfstream.h
257 wx/wx.h
258 wx/wxchar.h
259 wx/wxcrt.h
260 wx/wxcrtbase.h
261 wx/wxcrtvararg.h
262 wx/wxprec.h
263 wx/xlocale.h
264 wx/xti.h
265 wx/xtistrm.h
266 wx/zipstrm.h
267 wx/zstream.h
268 wx/meta/convertible.h
269 wx/meta/if.h
270 wx/meta/int2type.h
271 wx/meta/movable.h
272 wx/private/fdiodispatcher.h
273 wx/private/selectdispatcher.h
274 wx/unix/app.h
275 wx/unix/apptbase.h
276 wx/unix/apptrait.h
277 wx/unix/chkconf.h
278 wx/unix/evtloop.h
279 wx/unix/pipe.h
280 wx/unix/stdpaths.h
281 wx/unix/stackwalk.h
282 wx/unix/tls.h
283 wx/unix/execute.h
284 wx/unix/mimetype.h
285 wx/unix/private.h
286 wx/private/gsocketiohandler.h
287 wx/fs_inet.h
288 wx/gsocket.h
289 wx/protocol/file.h
290 wx/protocol/ftp.h
291 wx/protocol/http.h
292 wx/protocol/protocol.h
293 wx/sckaddr.h
294 wx/sckipc.h
295 wx/sckstrm.h
296 wx/socket.h
297 wx/url.h
298 wx/unix/gsockunx.h
299 wx/xml/xml.h
300 wx/xtixml.h
301 EOF
302 # --- wxBase headers list ends here ---
303 for f in `cat wxbase-headers-list` ; do
304 rm -f $RPM_BUILD_ROOT%{_includedir}/wx-%{ver2}/$f
305 done
306
307 # list of all core headers:
308 find $RPM_BUILD_ROOT%{_includedir}/wx-%{ver2} -type f | sed -e "s,$RPM_BUILD_ROOT,,g" >core-headers.files
309
310 # contrib stuff:
311 (cd obj-shared/contrib/src; make prefix=$RPM_BUILD_ROOT%{pref} install)
312 (cd obj-shared/utils/wxrc; make prefix=$RPM_BUILD_ROOT%{pref} install)
313
314 # remove wxBase files so that RPM doesn't complain about unpackaged files:
315 rm -f $RPM_BUILD_ROOT%{_libdir}/libwx_base*
316 %if %{unicode}
317 rm -f $RPM_BUILD_ROOT%{_libdir}/libwxregexu-%{ver2}.a
318 %endif
319 rm -f $RPM_BUILD_ROOT%{_datadir}/aclocal/*
320 rm -f $RPM_BUILD_ROOT%{_datadir}/locale/*/*/*
321
322 %clean
323 rm -rf $RPM_BUILD_ROOT
324
325 %post
326 /sbin/ldconfig
327
328 %postun
329 /sbin/ldconfig
330
331 %post devel
332 # link wx-config when you install RPM.
333 ln -sf %{_libdir}/wx/config/%{wxconfig} %{_bindir}/wx-config
334 # link wx-config with explicit name.
335 ln -sf %{_libdir}/wx/config/%{wxconfig} %{_bindir}/%{wxconfiglink}
336 /sbin/ldconfig
337
338 %postun devel
339 /sbin/ldconfig
340
341 %preun devel
342 if test -f %{_bindir}/wx-config -a -f /usr/bin/md5sum ; then
343 SUM1=`md5sum %{_libdir}/wx/config/%{wxconfig} | cut -c 0-32`
344 SUM2=`md5sum %{_bindir}/wx-config | cut -c 0-32`
345 if test "x$SUM1" = "x$SUM2" ; then
346 rm -f %{_bindir}/wx-config
347 fi
348 fi
349 rm -f %{_bindir}/%{wxconfiglink}
350
351 %post gl
352 /sbin/ldconfig
353
354 %postun gl
355 /sbin/ldconfig
356
357 %post contrib
358 /sbin/ldconfig
359
360 %postun contrib
361 /sbin/ldconfig
362
363 %post contrib-devel
364 /sbin/ldconfig
365
366 %postun contrib-devel
367 /sbin/ldconfig
368
369 %files
370 %defattr(-,root,root)
371 %doc COPYING.LIB *.txt
372 %{_libdir}/libwx_%{portname}*_adv-%{ver2}.so.*
373 %{_libdir}/libwx_%{portname}*_core-%{ver2}.so.*
374 %{_libdir}/libwx_%{portname}*_html-%{ver2}.so.*
375 %{_libdir}/libwx_%{portname}*_media-%{ver2}.so.*
376 %{_libdir}/libwx_%{portname}*_qa-%{ver2}.so.*
377 %{_libdir}/libwx_%{portname}*_xrc-%{ver2}.so.*
378
379
380 %files devel -f core-headers.files
381 %defattr(-,root,root)
382 %{_libdir}/libwx_%{portname}*_adv-%{ver2}.so
383 %{_libdir}/libwx_%{portname}*_core-%{ver2}.so
384 %{_libdir}/libwx_%{portname}*_gl-%{ver2}.so
385 %{_libdir}/libwx_%{portname}*_html-%{ver2}.so
386 %{_libdir}/libwx_%{portname}*_media-%{ver2}.so
387 %{_libdir}/libwx_%{portname}*_qa-%{ver2}.so
388 %{_libdir}/libwx_%{portname}*_xrc-%{ver2}.so
389 %dir %{_libdir}/wx
390 %{_libdir}/wx/*
391 %{_bindir}/wxrc*
392
393 %files gl
394 %defattr(-,root,root)
395 %{_libdir}/libwx_%{portname}*_gl-%{ver2}.so.*
396
397 %files static
398 %defattr (-,root,root)
399 %{_libdir}/libwx_%{portname}*_*-%{ver2}.a
400
401 %files contrib
402 %defattr(-,root,root)
403 %{_libdir}/libwx_%{portname}*_animate-%{ver2}.so.*
404 %{_libdir}/libwx_%{portname}*_deprecated-%{ver2}.so.*
405 %{_libdir}/libwx_%{portname}*_fl-%{ver2}.so.*
406 %{_libdir}/libwx_%{portname}*_gizmos-%{ver2}.so.*
407 %{_libdir}/libwx_%{portname}*_mmedia-%{ver2}.so.*
408 %{_libdir}/libwx_%{portname}*_ogl-%{ver2}.so.*
409 %{_libdir}/libwx_%{portname}*_plot-%{ver2}.so.*
410 %{_libdir}/libwx_%{portname}*_stc-%{ver2}.so.*
411 %{_libdir}/libwx_%{portname}*_svg-%{ver2}.so.*
412
413 %files contrib-devel
414 %defattr(-,root,root)
415 %dir %{_includedir}/wx-%{ver2}/wx/animate
416 %{_includedir}/wx-%{ver2}/wx/animate/*
417 %{_libdir}/libwx_%{portname}*_animate-%{ver2}.so
418
419 %dir %{_includedir}/wx-%{ver2}/wx/deprecated
420 %{_includedir}/wx-%{ver2}/wx/deprecated/*
421 %{_libdir}/libwx_%{portname}*_deprecated-%{ver2}.so
422
423 %dir %{_includedir}/wx-%{ver2}/wx/fl
424 %{_includedir}/wx-%{ver2}/wx/fl/*
425 %{_libdir}/libwx_%{portname}*_fl-%{ver2}.so
426
427 %dir %{_includedir}/wx-%{ver2}/wx/gizmos
428 %{_includedir}/wx-%{ver2}/wx/gizmos/*
429 %{_libdir}/libwx_%{portname}*_gizmos-%{ver2}.so
430
431 %dir %{_includedir}/wx-%{ver2}/wx/mmedia
432 %{_includedir}/wx-%{ver2}/wx/mmedia/*
433 %{_libdir}/libwx_%{portname}*_mmedia-%{ver2}.so
434
435 %dir %{_includedir}/wx-%{ver2}/wx/ogl
436 %{_includedir}/wx-%{ver2}/wx/ogl/*
437 %{_libdir}/libwx_%{portname}*_ogl-%{ver2}.so
438
439 %dir %{_includedir}/wx-%{ver2}/wx/plot
440 %{_includedir}/wx-%{ver2}/wx/plot/*
441 %{_libdir}/libwx_%{portname}*_plot-%{ver2}.so
442
443 %dir %{_includedir}/wx-%{ver2}/wx/stc
444 %{_includedir}/wx-%{ver2}/wx/stc/*
445 %{_libdir}/libwx_%{portname}*_stc-%{ver2}.so
446
447 %dir %{_includedir}/wx-%{ver2}/wx/svg
448 %{_includedir}/wx-%{ver2}/wx/svg/*
449 %{_libdir}/libwx_%{portname}*_svg-%{ver2}.so