6 # Configurable settings (use --with(out) {unicode,gtk2} on rpmbuild cmd line):
8 %{?_with_unicode: %{expand: %%define unicode 1}}
9 %{?_without_unicode: %{expand: %%define unicode 0}}
12 %{?_with_gtk2: %{expand: %%define gtk2 1}}
13 %{?_without_gtk2: %{expand: %%define gtk2 0}}
15 # "buildname" needs to be e.g. gtk2ud for debug builds
20 %define buildname gtk2u
22 %define buildname gtk2
31 %define name wx
-%{portname}-unicode
32 %define wxconfig
%{portname}-unicode-release-%{ver2}
33 %define wxconfigstatic
%{portname}-unicode-release-static-%{ver2}
34 %define wxconfiglink wx
%{portname}u-%{ver2}-config
36 %define name wx
-%{portname}-ansi
37 %define wxconfig
%{portname}-ansi-release-%{ver2}
38 %define wxconfigstatic
%{portname}-ansi-release-static-%{ver2}
39 %define wxconfiglink wx
%{portname}-%{ver2}-config
43 %define wxbasename wx
-base
-unicode
44 %define wxbaseconfig base
-unicode
-release
-%{ver2}
45 %define wxbaseconfiglink wxbaseu
-%{ver2}-config
47 %define wxbasename wx
-base
-ansi
48 %define wxbaseconfig base
-ansi
-release
-%{ver2}
49 %define wxbaseconfiglink wxbase
-%{ver2}-config
52 Summary: The GTK
+ %{gtkver} port of the wxWidgets library
56 License: wxWindows Licence
58 Source: wxGTK
-%{ver}.tar.bz2
59 URL: http
://www.wxwidgets.org
60 Packager: Vadim Zeitlin
<vadim@wxwindows.org
>
62 BuildRoot: %{_tmppath}/%{name}-root
63 Requires: %{wxbasename} = %{ver}
64 %if %{portname} == gtk2
65 BuildRequires
: gtk
+-2.0-devel
67 BuildRequires
: gtk
+-devel
>= 1.2.0
70 BuildRequires
: zlib
-devel
, libjpeg
-devel
, libpng
-devel
, libtiff
-devel
72 # all packages providing an implementation of wxWidgets library (regardless of
73 # the toolkit used) should provide the (virtual) wxwin package, this makes it
74 # possible to require wxwin instead of requiring "wxgtk or wxmotif or wxuniv..."
79 wxWidgets is a free C
++ library
for cross
-platform GUI development.
80 With wxWidgets
, you can create applications
for different GUIs
(GTK
+,
81 Motif
, MS Windows
, MacOS X
, Windows CE
, GPE
) from the same
source code.
84 Summary: The translations
for the wxWidgets library.
87 %description -n wx
-i18n
88 The translations files
for the wxWidgets library.
91 Summary: The GTK
+ %{gtkver} port of the wxWidgets library
93 Requires: %{name} = %{ver}
94 Requires: %{wxbasename}-devel = %{ver}
98 The GTK
+ %{gtkver} port of the wxWidgets library
, header files.
101 Summary: The GTK
+ %{gtkver} port of the wxWidgets library
, OpenGL add
-on.
103 Requires: %{name} = %{ver}
107 OpenGL add
-on library
for wxGTK
, the GTK
+ %{gtkver} port of the wxWidgets library.
109 %package -n
%{wxbasename}
110 Summary: wxBase library
- non
-GUI support classes of the wxWidgets toolkit
111 Group: Development
/Libraries
114 %description -n
%{wxbasename}
115 wxBase is a collection of C
++ classes providing basic data structures
(strings
,
116 lists
, arrays
), portable wrappers around many OS
-specific funstions
(file
117 operations
, time/date manipulations
, threads
, processes
, sockets
, shared
118 library loading
) as well as other utility classes
(streams
, archive and
119 compression
). wxBase currently supports Win32
, most Unix variants
(Linux
,
120 FreeBSD
, Solaris
, HP
-UX
) and MacOS X
(Carbon and Mach
-0).
122 %package -n
%{wxbasename}-devel
123 Summary: wxBase library
, header files.
124 Group: Development
/Libraries
125 Provides: wxBase
-devel
127 %description -n
%{wxbasename}-devel
128 wxBase library
- non
-GUI support classes of the wxWidgets toolkit
,
132 Summary: The GTK
+ %{gtkver} port of the wxWidgets library
, contributed libraries.
134 Requires: %{name} = %{ver}
137 Contributed libraries
for wxGTK
, the GTK
+ %{gtkver} port of the wxWidgets library.
139 %package contrib
-devel
140 Summary: The GTK
+ %{gtkver} port of the wxWidgets library
142 Requires: %{name}-contrib = %{ver}
143 Requires: %{name}-devel = %{ver}
145 %description contrib
-devel
146 Header files
for contributed libraries
for wxGTK
, the GTK
+ %{gtkver} port of the wxWidgets library.
149 %setup -q
-n wxGTK
-%{ver}
152 if [ "$SMP"
!= ""
]; then
153 export MAKE
="
make -j$SMP"
160 ..
/configure
--prefix
=%{_prefix} \
181 ..
/configure
--prefix
=%{_prefix} \
204 rm -rf $RPM_BUILD_ROOT
205 (cd obj
-static
; make DESTDIR
=$RPM_BUILD_ROOT prefix
=%{_prefix} install)
206 (cd obj
-shared
; make DESTDIR
=$RPM_BUILD_ROOT prefix
=%{_prefix} install)
208 # --- wxBase headers list begins here ---
209 cat
<<EOF
>wxbase
-headers.files
331 wx
/protocol
/protocol.h
344 # --- wxBase headers list ends here ---
345 cat
<<EOF
>wxbase
-headers.paths
346 %{_includedir}/wx-%{ver2}/wx
/afterstd.h
347 %{_includedir}/wx-%{ver2}/wx
/app.h
348 %{_includedir}/wx-%{ver2}/wx
/apptrait.h
349 %{_includedir}/wx-%{ver2}/wx
/archive.h
350 %{_includedir}/wx-%{ver2}/wx
/arrimpl.cpp
351 %{_includedir}/wx-%{ver2}/wx
/arrstr.h
352 %{_includedir}/wx-%{ver2}/wx
/beforestd.h
353 %{_includedir}/wx-%{ver2}/wx
/buffer.h
354 %{_includedir}/wx-%{ver2}/wx
/build.h
355 %{_includedir}/wx-%{ver2}/wx
/chkconf.h
356 %{_includedir}/wx-%{ver2}/wx
/clntdata.h
357 %{_includedir}/wx-%{ver2}/wx
/cmdline.h
358 %{_includedir}/wx-%{ver2}/wx
/confbase.h
359 %{_includedir}/wx-%{ver2}/wx
/config.h
360 %{_includedir}/wx-%{ver2}/wx
/containr.h
361 %{_includedir}/wx-%{ver2}/wx
/convauto.h
362 %{_includedir}/wx-%{ver2}/wx
/datetime.h
363 %{_includedir}/wx-%{ver2}/wx
/datstrm.h
364 %{_includedir}/wx-%{ver2}/wx
/dde.h
365 %{_includedir}/wx-%{ver2}/wx
/debug.h
366 %{_includedir}/wx-%{ver2}/wx
/defs.h
367 %{_includedir}/wx-%{ver2}/wx
/dir.h
368 %{_includedir}/wx-%{ver2}/wx
/dlimpexp.h
369 %{_includedir}/wx-%{ver2}/wx
/dynarray.h
370 %{_includedir}/wx-%{ver2}/wx
/dynlib.h
371 %{_includedir}/wx-%{ver2}/wx
/dynload.h
372 %{_includedir}/wx-%{ver2}/wx
/encconv.h
373 %{_includedir}/wx-%{ver2}/wx
/event.h
374 %{_includedir}/wx-%{ver2}/wx
/except.h
375 %{_includedir}/wx-%{ver2}/wx
/features.h
376 %{_includedir}/wx-%{ver2}/wx
/ffile.h
377 %{_includedir}/wx-%{ver2}/wx
/file.h
378 %{_includedir}/wx-%{ver2}/wx
/fileconf.h
379 %{_includedir}/wx-%{ver2}/wx
/filefn.h
380 %{_includedir}/wx-%{ver2}/wx
/filename.h
381 %{_includedir}/wx-%{ver2}/wx
/filesys.h
382 %{_includedir}/wx-%{ver2}/wx
/fontenc.h
383 %{_includedir}/wx-%{ver2}/wx
/fontmap.h
384 %{_includedir}/wx-%{ver2}/wx
/fs_mem.h
385 %{_includedir}/wx-%{ver2}/wx
/fs_zip.h
386 %{_includedir}/wx-%{ver2}/wx
/hash.h
387 %{_includedir}/wx-%{ver2}/wx
/hashmap.h
388 %{_includedir}/wx-%{ver2}/wx
/hashset.h
389 %{_includedir}/wx-%{ver2}/wx
/html
/forcelnk.h
390 %{_includedir}/wx-%{ver2}/wx
/iconloc.h
391 %{_includedir}/wx-%{ver2}/wx
/init.h
392 %{_includedir}/wx-%{ver2}/wx
/intl.h
393 %{_includedir}/wx-%{ver2}/wx
/iosfwrap.h
394 %{_includedir}/wx-%{ver2}/wx
/ioswrap.h
395 %{_includedir}/wx-%{ver2}/wx
/ipc.h
396 %{_includedir}/wx-%{ver2}/wx
/ipcbase.h
397 %{_includedir}/wx-%{ver2}/wx
/isql.h
398 %{_includedir}/wx-%{ver2}/wx
/isqlext.h
399 %{_includedir}/wx-%{ver2}/wx
/link.h
400 %{_includedir}/wx-%{ver2}/wx
/list.h
401 %{_includedir}/wx-%{ver2}/wx
/listimpl.cpp
402 %{_includedir}/wx-%{ver2}/wx
/log.h
403 %{_includedir}/wx-%{ver2}/wx
/longlong.h
404 %{_includedir}/wx-%{ver2}/wx
/math.h
405 %{_includedir}/wx-%{ver2}/wx
/memconf.h
406 %{_includedir}/wx-%{ver2}/wx
/memory.h
407 %{_includedir}/wx-%{ver2}/wx
/memtext.h
408 %{_includedir}/wx-%{ver2}/wx
/mimetype.h
409 %{_includedir}/wx-%{ver2}/wx
/module.h
410 %{_includedir}/wx-%{ver2}/wx
/msgout.h
411 %{_includedir}/wx-%{ver2}/wx
/mstream.h
412 %{_includedir}/wx-%{ver2}/wx
/object.h
413 %{_includedir}/wx-%{ver2}/wx
/platform.h
414 %{_includedir}/wx-%{ver2}/wx
/power.h
415 %{_includedir}/wx-%{ver2}/wx
/process.h
416 %{_includedir}/wx-%{ver2}/wx
/ptr_scpd.h
417 %{_includedir}/wx-%{ver2}/wx
/recguard.h
418 %{_includedir}/wx-%{ver2}/wx
/regex.h
419 %{_includedir}/wx-%{ver2}/wx
/scopeguard.h
420 %{_includedir}/wx-%{ver2}/wx
/snglinst.h
421 %{_includedir}/wx-%{ver2}/wx
/sstream.h
422 %{_includedir}/wx-%{ver2}/wx
/stack.h
423 %{_includedir}/wx-%{ver2}/wx
/stackwalk.h
424 %{_includedir}/wx-%{ver2}/wx
/stdpaths.h
425 %{_includedir}/wx-%{ver2}/wx
/stockitem.h
426 %{_includedir}/wx-%{ver2}/wx
/stopwatch.h
427 %{_includedir}/wx-%{ver2}/wx
/strconv.h
428 %{_includedir}/wx-%{ver2}/wx
/stream.h
429 %{_includedir}/wx-%{ver2}/wx
/string.h
430 %{_includedir}/wx-%{ver2}/wx
/sysopt.h
431 %{_includedir}/wx-%{ver2}/wx
/textbuf.h
432 %{_includedir}/wx-%{ver2}/wx
/textfile.h
433 %{_includedir}/wx-%{ver2}/wx
/thread.h
434 %{_includedir}/wx-%{ver2}/wx
/thrimpl.cpp
435 %{_includedir}/wx-%{ver2}/wx
/timer.h
436 %{_includedir}/wx-%{ver2}/wx
/tokenzr.h
437 %{_includedir}/wx-%{ver2}/wx
/txtstrm.h
438 %{_includedir}/wx-%{ver2}/wx
/types.h
439 %{_includedir}/wx-%{ver2}/wx
/uri.h
440 %{_includedir}/wx-%{ver2}/wx
/utils.h
441 %{_includedir}/wx-%{ver2}/wx
/variant.h
442 %{_includedir}/wx-%{ver2}/wx
/vector.h
443 %{_includedir}/wx-%{ver2}/wx
/version.h
444 %{_includedir}/wx-%{ver2}/wx
/volume.h
445 %{_includedir}/wx-%{ver2}/wx
/wfstream.h
446 %{_includedir}/wx-%{ver2}/wx
/wx.h
447 %{_includedir}/wx-%{ver2}/wx
/wxchar.h
448 %{_includedir}/wx-%{ver2}/wx
/wxprec.h
449 %{_includedir}/wx-%{ver2}/wx
/xti.h
450 %{_includedir}/wx-%{ver2}/wx
/xtistrm.h
451 %{_includedir}/wx-%{ver2}/wx
/zipstrm.h
452 %{_includedir}/wx-%{ver2}/wx
/zstream.h
453 %{_includedir}/wx-%{ver2}/wx
/fs_inet.h
454 %{_includedir}/wx-%{ver2}/wx
/gsocket.h
455 %{_includedir}/wx-%{ver2}/wx
/protocol
/file.h
456 %{_includedir}/wx-%{ver2}/wx
/protocol
/ftp.h
457 %{_includedir}/wx-%{ver2}/wx
/protocol
/http.h
458 %{_includedir}/wx-%{ver2}/wx
/protocol
/protocol.h
459 %{_includedir}/wx-%{ver2}/wx
/sckaddr.h
460 %{_includedir}/wx-%{ver2}/wx
/sckipc.h
461 %{_includedir}/wx-%{ver2}/wx
/sckstrm.h
462 %{_includedir}/wx-%{ver2}/wx
/socket.h
463 %{_includedir}/wx-%{ver2}/wx
/url.h
464 %{_includedir}/wx-%{ver2}/wx
/xml
/xml.h
465 %{_includedir}/wx-%{ver2}/wx
/xtixml.h
466 %{_includedir}/wx-%{ver2}/wx
/db.h
467 %{_includedir}/wx-%{ver2}/wx
/dbkeyg.h
468 %{_includedir}/wx-%{ver2}/wx
/dbtable.h
469 %{_includedir}/wx-%{ver2}/wx
/unix
/apptbase.h
470 %{_includedir}/wx-%{ver2}/wx
/unix
/apptrait.h
471 %{_includedir}/wx-%{ver2}/wx
/unix
/execute.h
472 %{_includedir}/wx-%{ver2}/wx
/unix
/gsockunx.h
473 %{_includedir}/wx-%{ver2}/wx
/unix
/mimetype.h
474 %{_includedir}/wx-%{ver2}/wx
/unix
/pipe.h
475 %{_includedir}/wx-%{ver2}/wx
/unix
/private.h
476 %{_includedir}/wx-%{ver2}/wx
/unix
/stackwalk.h
477 %{_includedir}/wx-%{ver2}/wx
/unix
/stdpaths.h
479 # --- wxBase headers list ends here ---
481 # temporarily remove base headers
482 mkdir $RPM_BUILD_ROOT
/_save_dir
483 cp
-r $RPM_BUILD_ROOT
%{_includedir}/wx-%{ver2} $RPM_BUILD_ROOT
/_save_dir
484 for f
in `cat wxbase
-headers.files`
; do
485 rm -f $RPM_BUILD_ROOT
%{_includedir}/wx-%{ver2}/$f
487 # list of all core headers:
488 find $RPM_BUILD_ROOT
%{_includedir}/wx-%{ver2} -type f | sed
-e "s
,$RPM_BUILD_ROOT
,,g"
>core
-headers.files
489 # move base headers (actually all headers) back again
490 cp
-f
-r $RPM_BUILD_ROOT
/_save_dir
/* $RPM_BUILD_ROOT
%{_includedir}
491 rm -rf $RPM_BUILD_ROOT
/_save_dir
494 (cd obj
-static
/contrib
; make DESTDIR
=$RPM_BUILD_ROOT prefix
=%{_prefix} install)
495 (cd obj
-shared
/contrib
; make DESTDIR
=$RPM_BUILD_ROOT prefix
=%{_prefix} install)
498 (cd obj
-shared
/utils
/wxrc
; make DESTDIR
=$RPM_BUILD_ROOT prefix
=%{_prefix} install)
500 # wx-config link is created during package installation, remove it for now
501 rm -f $RPM_BUILD_ROOT
%{_bindir}/wx
-config
504 rm -rf $RPM_BUILD_ROOT
513 # link wx-config when you install RPM.
515 ln
-sf
%{_libdir}/wx/config/%{wxconfig} %{_bindir}/wx
-config
517 # link wx-config with explicit name.
518 ln
-sf
%{_libdir}/wx/config/%{wxconfig} %{_bindir}/%{wxconfiglink}
526 rm -f
%{_bindir}/wx
-config
528 rm -f
%{_bindir}/%{wxconfiglink}
530 %post -n
%{wxbasename}
533 %postun -n
%{wxbasename}
536 %post -n
%{wxbasename}-devel
537 # link wx-config with explicit name.
538 ln
-sf
%{_libdir}/wx/config/%{wxbaseconfig} %{_bindir}/%{wxbaseconfiglink}
541 %postun -n
%{wxbasename}-devel
544 %preun -n
%{wxbasename}-devel
545 rm -f
%{_bindir}/%{wxbaseconfiglink}
562 %postun contrib
-devel
566 %defattr(-,root
,root
)
567 %doc COPYING.LIB
*.txt
568 %{_libdir}/libwx_%{buildname}_adv-%{ver2}.so.
*
569 %{_libdir}/libwx_%{buildname}_aui-%{ver2}.so.
*
570 %{_libdir}/libwx_%{buildname}_core-%{ver2}.so.
*
572 %{_libdir}/libwx_%{buildname}_dbgrid-%{ver2}.so.
*
574 %{_libdir}/libwx_%{buildname}_html-%{ver2}.so.
*
575 %{_libdir}/libwx_%{buildname}_mmedia-%{ver2}.so.
*
576 %{_libdir}/libwx_%{buildname}_qa-%{ver2}.so.
*
577 %{_libdir}/libwx_%{buildname}_richtext-%{ver2}.so.
*
578 %{_libdir}/libwx_%{buildname}_xrc-%{ver2}.so.
*
581 %defattr(-,root
,root
)
582 %{_datadir}/locale
/*/LC_MESSAGES
/*.mo
584 %files devel
-f core
-headers.files
585 %defattr(-,root
,root
)
587 %{_libdir}/libwx_%{buildname}_adv-%{ver2}.so
588 %{_libdir}/libwx_%{buildname}_aui-%{ver2}.so
589 %{_libdir}/libwx_%{buildname}_core-%{ver2}.so
591 %{_libdir}/libwx_%{buildname}_dbgrid-%{ver2}.so
593 %{_libdir}/libwx_%{buildname}_gl-%{ver2}.so
594 %{_libdir}/libwx_%{buildname}_html-%{ver2}.so
595 %{_libdir}/libwx_%{buildname}_mmedia-%{ver2}.so
596 %{_libdir}/libwx_%{buildname}_qa-%{ver2}.so
597 %{_libdir}/libwx_%{buildname}_richtext-%{ver2}.so
598 %{_libdir}/libwx_%{buildname}_xrc-%{ver2}.so
600 %{_libdir}/libwx_%{buildname}_adv-%{ver2}.a
601 %{_libdir}/libwx_%{buildname}_aui-%{ver2}.a
602 %{_libdir}/libwx_%{buildname}_core-%{ver2}.a
604 %{_libdir}/libwx_%{buildname}_dbgrid-%{ver2}.a
606 %{_libdir}/libwx_%{buildname}_gl-%{ver2}.a
607 %{_libdir}/libwx_%{buildname}_html-%{ver2}.a
608 %{_libdir}/libwx_%{buildname}_qa-%{ver2}.a
609 %{_libdir}/libwx_%{buildname}_richtext-%{ver2}.a
610 %{_libdir}/libwx_%{buildname}_xrc-%{ver2}.a
612 %{_libdir}/wx/config/%{wxconfig}
613 %{_libdir}/wx/include/%{wxconfig}/wx
/setup.h
614 %{_libdir}/wx/config/%{wxconfigstatic}
615 %{_libdir}/wx/include/%{wxconfigstatic}/wx
/setup.h
618 %files -n
%{wxbasename}
619 %defattr(-,root
,root
)
620 %{_libdir}/libwx_base*-%{ver2}.so.
*
622 %files -n
%{wxbasename}-devel
-f wxbase
-headers.paths
623 %defattr (-,root
,root
)
624 %dir %{_includedir}/wx-%{ver2}
625 %{_libdir}/libwx_base*-%{ver2}.so
626 %{_libdir}/libwx_base*-%{ver2}.a
628 %{_libdir}/libwxregexu-%{ver2}.a
631 %{_datadir}/aclocal
/*.m4
632 %{_datadir}/bakefile
/presets
/*
635 %defattr(-,root
,root
)
636 %{_libdir}/libwx_%{buildname}_gl-%{ver2}.so.
*
639 %defattr(-,root
,root
)
640 %{_libdir}/libwx_%{buildname}_animate-%{ver2}.so.
*
641 %{_libdir}/libwx_%{buildname}_deprecated-%{ver2}.so.
*
642 %{_libdir}/libwx_%{buildname}_fl-%{ver2}.so.
*
643 %{_libdir}/libwx_%{buildname}_gizmos-%{ver2}.so.
*
644 %{_libdir}/libwx_%{buildname}_gizmos_xrc-%{ver2}.so.
*
645 %{_libdir}/libwx_%{buildname}_mmedia-%{ver2}.so.
*
646 %{_libdir}/libwx_%{buildname}_ogl-%{ver2}.so.
*
647 %{_libdir}/libwx_%{buildname}_plot-%{ver2}.so.
*
648 %{_libdir}/libwx_%{buildname}_stc-%{ver2}.so.
*
649 %{_libdir}/libwx_%{buildname}_svg-%{ver2}.so.
*
652 %{_libdir}/libwx_%{buildname}_animate-%{ver2}.a
653 %{_libdir}/libwx_%{buildname}_deprecated-%{ver2}.a
654 %{_libdir}/libwx_%{buildname}_fl-%{ver2}.a
655 %{_libdir}/libwx_%{buildname}_gizmos-%{ver2}.a
656 %{_libdir}/libwx_%{buildname}_gizmos_xrc-%{ver2}.a
657 %{_libdir}/libwx_%{buildname}_mmedia-%{ver2}.a
658 %{_libdir}/libwx_%{buildname}_ogl-%{ver2}.a
659 %{_libdir}/libwx_%{buildname}_plot-%{ver2}.a
660 %{_libdir}/libwx_%{buildname}_stc-%{ver2}.a
661 %{_libdir}/libwx_%{buildname}_svg-%{ver2}.a
664 %defattr(-,root
,root
)
665 %dir %{_includedir}/wx-%{ver2}/wx
/animate
666 %{_includedir}/wx-%{ver2}/wx
/animate
/*
667 %{_libdir}/libwx_%{buildname}_animate-%{ver2}.so
669 %dir %{_includedir}/wx-%{ver2}/wx
/deprecated
670 %{_includedir}/wx-%{ver2}/wx
/deprecated
/*
671 %{_libdir}/libwx_%{buildname}_deprecated-%{ver2}.so
673 %dir %{_includedir}/wx-%{ver2}/wx
/fl
674 %{_includedir}/wx-%{ver2}/wx
/fl
/*
675 %{_libdir}/libwx_%{buildname}_fl-%{ver2}.so
677 %dir %{_includedir}/wx-%{ver2}/wx
/gizmos
678 %{_includedir}/wx-%{ver2}/wx
/gizmos
/*
679 %{_libdir}/libwx_%{buildname}_gizmos-%{ver2}.so
680 %{_libdir}/libwx_%{buildname}_gizmos_xrc-%{ver2}.so
682 %dir %{_includedir}/wx-%{ver2}/wx
/mmedia
683 %{_includedir}/wx-%{ver2}/wx
/mmedia
/*
684 %{_libdir}/libwx_%{buildname}_mmedia-%{ver2}.so
686 %dir %{_includedir}/wx-%{ver2}/wx
/ogl
687 %{_includedir}/wx-%{ver2}/wx
/ogl
/*
688 %{_libdir}/libwx_%{buildname}_ogl-%{ver2}.so
690 %dir %{_includedir}/wx-%{ver2}/wx
/plot
691 %{_includedir}/wx-%{ver2}/wx
/plot
/*
692 %{_libdir}/libwx_%{buildname}_plot-%{ver2}.so
694 %dir %{_includedir}/wx-%{ver2}/wx
/stc
695 %{_includedir}/wx-%{ver2}/wx
/stc
/*
696 %{_libdir}/libwx_%{buildname}_stc-%{ver2}.so
698 %dir %{_includedir}/wx-%{ver2}/wx
/svg
699 %{_includedir}/wx-%{ver2}/wx
/svg
/*
700 %{_libdir}/libwx_%{buildname}_svg-%{ver2}.so