7 %define name wx
-%{portname}
8 %define wxbasename wx
-base
10 %define wxconfig
%{portname}-ansi-release-%{ver2}
11 %define wxconfiglink wx
%{portname}-%{ver2}-config
13 Summary: The Motif
/Lesstif port of the wxWidgets library
17 License: wxWindows Licence
19 Source: wxMotif
-%{ver}.tar.bz2
20 URL: http
://www.wxwidgets.org
21 Packager: wxWidgets developers
<wx
-dev@lists.wxwidgets.org
>
22 BuildRoot: %{_tmppath}/%{name}-root
23 Requires: %{wxbasename} = %{ver}
25 # all packages providing an implementation of wxWidgets library (regardless of
26 # the toolkit used) should provide the (virtual) wxwin package, this makes it
27 # possible to require wxwin instead of requiring "wxgtk or wxmotif or wxuniv..."
32 wxWidgets is a free C
++ library
for cross
-platform GUI development.
33 With wxWidgets
, you can create applications
for different GUIs
(GTK
+,
34 Motif
/LessTif
, MS Windows
, Mac
) from the same
source code.
37 Summary: The Motif
/Lesstif port of the wxWidgets library
39 Requires: %{name} = %{ver}
40 Requires: %{wxbasename}-devel = %{ver}
43 Header files
for wxMotif
, the Motif
/Lesstif port of the wxWidgets library.
46 Summary: The Motif
/Lesstif port of the wxWidgets library
, OpenGL add
-on.
48 Requires: %{name} = %{ver}
51 OpenGL add
-on library
for wxMotif
, the Motif
/Lesstif port of the wxWidgets library.
54 Summary: wxMotif static libraries
55 Group: Development
/Libraries
56 Requires: %{wxbasename}-static
57 Requires: %{name}-devel = %{ver}
60 Static libraries
for wxMotif. You need them
if you want to link statically against wxMotif.
63 Summary: Contrib libraries
for wxMotif
65 Requires: %{name} = %{ver}
68 Contrib libraries
for wxMotif
70 %package contrib
-devel
71 Summary: Contrib libraries
for wxMotif
73 Requires: %{name}-contrib = %{ver}
74 Requires: %{name}-devel = %{ver}
76 %description contrib
-devel
77 Header files
for contributed libraries
for wxMotif.
80 %setup -q
-n wxMotif
-%{ver}
83 if [ "$SMP"
!= ""
]; then
84 export MAKE
="
make -j$SMP"
91 ..
/configure
--prefix
=%{pref} --with
-motif
--with
-odbc
--with
-opengl
100 ..
/configure
--prefix
=%{pref} --with
-motif
--disable
-shared
--with
-odbc
--with
-opengl
105 rm -rf $RPM_BUILD_ROOT
106 (cd obj
-static
; make prefix
=$RPM_BUILD_ROOT
%{pref} install)
107 (cd obj
-shared
; make prefix
=$RPM_BUILD_ROOT
%{pref} install)
109 # Remove headers that are part of wx-base-devel:
111 # --- wxBase headers list begins here ---
112 cat
<<EOF
>wxbase
-headers.files
228 wx
/protocol
/protocol.h
241 # --- wxBase headers list ends here ---
242 for f
in `cat wxbase
-headers
-list`
; do
243 rm -f $RPM_BUILD_ROOT
%{_includedir}/wx-%{ver2}/$f
246 # list of all core headers:
247 find $RPM_BUILD_ROOT
%{_includedir}/wx-%{ver2} -type f | sed
-e "s
,$RPM_BUILD_ROOT
,,g"
>core
-headers.files
250 (cd obj
-shared
/contrib
/src
; make prefix
=$RPM_BUILD_ROOT
%{pref} install)
251 (cd obj
-shared
/utils
/wxrc
; make prefix
=$RPM_BUILD_ROOT
%{pref} install)
253 # remove wxBase files so that RPM doesn't complain about unpackaged files:
254 rm -f $RPM_BUILD_ROOT
%{_libdir}/libwx_base
*
255 rm -f $RPM_BUILD_ROOT
%{_datadir}/aclocal
/*
256 rm -f $RPM_BUILD_ROOT
%{_datadir}/locale
/*/*/*
259 rm -rf $RPM_BUILD_ROOT
268 # link wx-config when you install RPM.
269 ln
-sf
%{_libdir}/wx/config/%{wxconfig} %{_bindir}/wx
-config
270 # link wx-config with explicit name.
271 ln
-sf
%{_libdir}/wx/config/%{wxconfig} %{_bindir}/%{wxconfiglink}
278 if test -f
%{_bindir}/wx
-config
-a
-f
/usr
/bin
/md5sum
; then
279 SUM1
=`md5sum
%{_libdir}/wx/config/%{wxconfig} | cut
-c
0-32`
280 SUM2
=`md5sum
%{_bindir}/wx
-config | cut
-c
0-32`
281 if test "x$SUM1"
= "x$SUM2"
; then
282 rm -f
%{_bindir}/wx
-config
285 rm -f
%{_bindir}/%{wxconfiglink}
302 %postun contrib
-devel
306 %defattr(-,root
,root
)
307 %doc COPYING.LIB
*.txt
308 %{_libdir}/libwx_%{portname}*_adv-%{ver2}.so.
*
309 %{_libdir}/libwx_%{portname}*_core-%{ver2}.so.
*
310 %{_libdir}/libwx_%{portname}*_dbgrid-%{ver2}.so.
*
311 %{_libdir}/libwx_%{portname}*_html-%{ver2}.so.
*
312 %{_libdir}/libwx_%{portname}*_media-%{ver2}.so.
*
313 %{_libdir}/libwx_%{portname}*_qa-%{ver2}.so.
*
314 %{_libdir}/libwx_%{portname}*_xrc-%{ver2}.so.
*
317 %files devel
-f core
-headers.files
318 %defattr(-,root
,root
)
319 %{_libdir}/libwx_%{portname}*_adv-%{ver2}.so
320 %{_libdir}/libwx_%{portname}*_core-%{ver2}.so
321 %{_libdir}/libwx_%{portname}*_dbgrid-%{ver2}.so
322 %{_libdir}/libwx_%{portname}*_gl-%{ver2}.so
323 %{_libdir}/libwx_%{portname}*_html-%{ver2}.so
324 %{_libdir}/libwx_%{portname}*_media-%{ver2}.so
325 %{_libdir}/libwx_%{portname}*_qa-%{ver2}.so
326 %{_libdir}/libwx_%{portname}*_xrc-%{ver2}.so
332 %defattr(-,root
,root
)
333 %{_libdir}/libwx_%{portname}*_gl-%{ver2}.so.
*
336 %defattr (-,root
,root
)
337 %{_libdir}/libwx_%{portname}*_*-%{ver2}.a
340 %defattr(-,root
,root
)
341 %{_libdir}/libwx_%{portname}*_animate-%{ver2}.so.
*
342 %{_libdir}/libwx_%{portname}*_deprecated-%{ver2}.so.
*
343 %{_libdir}/libwx_%{portname}*_fl-%{ver2}.so.
*
344 %{_libdir}/libwx_%{portname}*_gizmos-%{ver2}.so.
*
345 %{_libdir}/libwx_%{portname}*_mmedia-%{ver2}.so.
*
346 %{_libdir}/libwx_%{portname}*_ogl-%{ver2}.so.
*
347 %{_libdir}/libwx_%{portname}*_plot-%{ver2}.so.
*
348 %{_libdir}/libwx_%{portname}*_stc-%{ver2}.so.
*
349 %{_libdir}/libwx_%{portname}*_svg-%{ver2}.so.
*
352 %defattr(-,root
,root
)
353 %dir %{_includedir}/wx-%{ver2}/wx
/animate
354 %{_includedir}/wx-%{ver2}/wx
/animate
/*
355 %{_libdir}/libwx_%{portname}*_animate-%{ver2}.so
357 %dir %{_includedir}/wx-%{ver2}/wx
/deprecated
358 %{_includedir}/wx-%{ver2}/wx
/deprecated
/*
359 %{_libdir}/libwx_%{portname}*_deprecated-%{ver2}.so
361 %dir %{_includedir}/wx-%{ver2}/wx
/fl
362 %{_includedir}/wx-%{ver2}/wx
/fl
/*
363 %{_libdir}/libwx_%{portname}*_fl-%{ver2}.so
365 %dir %{_includedir}/wx-%{ver2}/wx
/gizmos
366 %{_includedir}/wx-%{ver2}/wx
/gizmos
/*
367 %{_libdir}/libwx_%{portname}*_gizmos-%{ver2}.so
369 %dir %{_includedir}/wx-%{ver2}/wx
/mmedia
370 %{_includedir}/wx-%{ver2}/wx
/mmedia
/*
371 %{_libdir}/libwx_%{portname}*_mmedia-%{ver2}.so
373 %dir %{_includedir}/wx-%{ver2}/wx
/ogl
374 %{_includedir}/wx-%{ver2}/wx
/ogl
/*
375 %{_libdir}/libwx_%{portname}*_ogl-%{ver2}.so
377 %dir %{_includedir}/wx-%{ver2}/wx
/plot
378 %{_includedir}/wx-%{ver2}/wx
/plot
/*
379 %{_libdir}/libwx_%{portname}*_plot-%{ver2}.so
381 %dir %{_includedir}/wx-%{ver2}/wx
/stc
382 %{_includedir}/wx-%{ver2}/wx
/stc
/*
383 %{_libdir}/libwx_%{portname}*_stc-%{ver2}.so
385 %dir %{_includedir}/wx-%{ver2}/wx
/svg
386 %{_includedir}/wx-%{ver2}/wx
/svg
/*
387 %{_libdir}/libwx_%{portname}*_svg-%{ver2}.so