fixes for RPM generation after Ron's changes
[wxWidgets.git] / wxBase.spec
1 %define pref /usr
2 %define ver 2.3.1
3 %define ver2 2.3
4 %define rel 1
5
6 Summary: wxBase library - non-GUI support classes of wxWindows toolkit
7 Name: wxBase
8 Version: %{ver}
9 Release: %{rel}
10 Copyright: wxWindows Licence
11 Group: Development/Libraries
12 Source: wxBase-%{ver}.tar.bz2
13 URL: http://www.wxwindows.org
14 Packager: Vadim Zeitlin <vadim@wxwindows.org>
15 Prefix: %{pref}
16 BuildRoot: /var/tmp/%{name}-root
17
18 %description
19 wxBase is a collection of C++ classes providing basic data structures (strings,
20 lists, arrays), powerful wxDateTime class for date manipulations, portable
21 wrappers around many OS-specific functions allowing to build the same program
22 under all supported folders, wxThread class for writing multithreaded programs
23 using either Win32 or POSIX threads and much more. wxBase currently supports
24 the following platforms: Win32, generic Unix (Linux, FreeBSD, Solaris, HP-UX,
25 ...) and BeOS.
26
27 %package devel
28 Summary: wxBase headers needed for developping with wxBase
29 Group: Development/Libraries
30 Requires: wxBase
31
32 %description devel
33 Header files for wxBase. You need them to develop programs using wxBase.
34
35 %prep
36 %setup -n wxBase-%{ver}
37 ./configure --prefix=%{pref} --enable-soname --disable-gui --disable-std_iostreams
38
39 %build
40 if [ "$SMP" != "" ]; then
41 export MAKE="make -j$SMP"
42 else
43 export MAKE="make"
44 fi
45 $MAKE
46
47 %install
48 rm -rf $RPM_BUILD_ROOT
49 make prefix=$RPM_BUILD_ROOT%{pref} install
50
51 %clean
52 rm -rf $RPM_BUILD_ROOT
53
54 %post
55 /sbin/ldconfig
56
57 %postun
58 /sbin/ldconfig
59
60 %files
61 %defattr (644, root, root, 755)
62 %doc COPYING.LIB LICENCE.txt README.txt SYMBOLS.txt
63 %attr(755, -, -) %{pref}/lib/libwx_base*
64
65 %files devel -f src/rpmfiles.lst
66 %dir %{pref}/lib/wx
67 %dir %{pref}/lib/wx/include
68 %dir %{pref}/lib/wx/include/wx
69 %dir %{pref}/lib/wx/include/wx/base
70 %{pref}/lib/wx/include/wx/base/setup.h
71 %defattr (644, root, root, 755)
72 %attr(755, -, -) %{pref}/bin/wxbase-%{ver2}-config
73 %attr(755, -, -) %{pref}/bin/wx-config
74