no need for --enable-soname anymore
[wxWidgets.git] / wxBase.spec
1 %define pref /usr
2 %define ver 2.5.0
3 %define ver2 2.5
4 %define rel 1
5
6 Summary: wxBase library - non-GUI support classes of wxWindows toolkit
7 Name: wxBase
8 Version: %{ver}
9 Release: %{rel}
10 Copyright: wxWindows Licence
11 Group: Development/Libraries
12 Source: wxBase-%{ver}.tar.bz2
13 URL: http://www.wxwindows.org
14 Packager: Vadim Zeitlin <vadim@wxwindows.org>
15 Prefix: %{pref}
16 BuildRoot: /var/tmp/%{name}-root
17
18 %description
19 wxBase is a collection of C++ classes providing basic data structures (strings,
20 lists, arrays), powerful wxDateTime class for date manipulations, portable
21 wrappers around many OS-specific functions allowing to build the same program
22 under all supported folders, wxThread class for writing multithreaded programs
23 using either Win32 or POSIX threads and much more. wxBase currently supports
24 the following platforms: Win32, generic Unix (Linux, FreeBSD, Solaris, HP-UX,
25 ...) and BeOS.
26
27 %package devel
28 Summary: wxBase headers needed for developping with wxBase
29 Group: Development/Libraries
30 Requires: wxBase = %{ver}
31
32 %description devel
33 Header files for wxBase. You need them to develop programs using wxBase.
34
35 %package static
36 Summary: wxBase static libraries
37 Group: Development/Libraries
38
39 %description static
40 Static libraries for wxBase. You need them if you want to link statically against wxBase.
41
42 %prep
43 %setup -n wxBase-%{ver}
44
45 %build
46 if [ "$SMP" != "" ]; then
47 export MAKE="make -j$SMP"
48 else
49 export MAKE="make"
50 fi
51
52 mkdir obj-shared
53 cd obj-shared
54 ../configure --prefix=%{pref} --disable-gui --disable-std_iostreams
55 $MAKE
56 cd ..
57
58 mkdir obj-static
59 cd obj-static
60 ../configure --prefix=%{pref} --disable-shared --disable-gui --disable-std_iostreams
61 $MAKE
62 cd ..
63
64 %install
65 rm -rf $RPM_BUILD_ROOT
66 (cd obj-static ; make prefix=$RPM_BUILD_ROOT%{pref} install)
67 (cd obj-shared ; make prefix=$RPM_BUILD_ROOT%{pref} install)
68
69 %find_lang wxstd
70
71 %clean
72 rm -rf $RPM_BUILD_ROOT
73
74 %post
75 /sbin/ldconfig
76
77 %postun
78 /sbin/ldconfig
79
80 %post devel
81 # Install wx-config if there isn't any
82 if test ! -f %{_bindir}/wx-config ; then
83 ln -sf wxbase-%{ver2}-config %{_bindir}/wx-config
84 fi
85
86 %preun devel
87 # Remove wx-config if it points to this package
88 if test -f %{_bindir}/wx-config -a -f /usr/bin/md5sum ; then
89 SUM1=`md5sum %{_bindir}/wxbase-%{ver2}-config | cut -c 0-32`
90 SUM2=`md5sum %{_bindir}/wx-config | cut -c 0-32`
91 if test "x$SUM1" = "x$SUM2" ; then
92 rm -f %{_bindir}/wx-config
93 fi
94 fi
95
96 %files -f wxstd.lang
97 %defattr (-,root,root)
98 %doc COPYING.LIB *.txt
99 %{_libdir}/libwx_base*so.*
100
101 %files devel
102 %defattr (-,root,root)
103 %dir %{_includedir}/wx
104 %{_includedir}/wx/*
105 %{_libdir}/libwx_base*.so
106 %dir %{_libdir}/wx
107 %{_libdir}/wx/*
108 %{_bindir}/wxbase-%{ver2}-config
109 %{_datadir}/aclocal/*.m4
110
111 %files static
112 %defattr (-,root,root)
113 %{_libdir}/lib*.a