removed non-existent wx/meta/defs.h
[wxWidgets.git] / wxX11.spec
1 %define pref /usr
2 %define ver 2.9.0
3 %define ver2 2.9
4 %define rel 1
5
6 # Configurable settings (use --with(out) unicode on rpmbuild cmd line):
7 %define unicode 0
8 %{?_with_unicode: %{expand: %%define unicode 1}}
9 %{?_without_unicode: %{expand: %%define unicode 0}}
10
11 %define portname x11univ
12
13 %if %{unicode}
14 %define wxbasename wx-base-unicode
15 %define name wx-%{portname}-unicode
16 %define wxconfig %{portname}-unicode-release-%{ver2}
17 %define wxconfiglink wx%{portname}u-%{ver2}-config
18 %else
19 %define wxbasename wx-base
20 %define name wx-%{portname}
21 %define wxconfig %{portname}-ansi-release-%{ver2}
22 %define wxconfiglink wx%{portname}-%{ver2}-config
23 %endif
24
25 Summary: The X11 port of the wxWidgets library
26 Name: %{name}
27 Version: %{ver}
28 Release: %{rel}
29 License: wxWindows Licence
30 Group: X11/Libraries
31 Source: wxX11-%{ver}.tar.bz2
32 URL: http://www.wxwidgets.org
33 Packager: Vadim Zeitlin <vadim@wxwindows.org>
34 Prefix: %{pref}
35 BuildRoot: %{_tmppath}/%{name}-root
36 Requires: %{wxbasename} = %{ver}
37
38 # all packages providing an implementation of wxWidgets library (regardless of
39 # the toolkit used) should provide the (virtual) wxwin package, this makes it
40 # possible to require wxwin instead of requiring "wxgtk or wxmotif or wxuniv..."
41 Provides: wxwin
42 Provides: wxX11
43
44 %description
45 wxWidgets is a free C++ library for cross-platform GUI development.
46 With wxWidgets, you can create applications for different GUIs (GTK+,
47 Motif/LessTif, MS Windows, Mac) from the same source code.
48
49 %package devel
50 Summary: The X11 port of the wxWidgets library
51 Group: X11/Libraries
52 Requires: %{name} = %{ver}
53 Requires: %{wxbasename}-devel = %{ver}
54
55 %description devel
56 Header files for wxX11, the X11 port of the wxWidgets library.
57
58 %package gl
59 Summary: The X11 port of the wxWidgets library, OpenGL add-on.
60 Group: X11/Libraries
61 Requires: %{name} = %{ver}
62
63 %description gl
64 OpenGL add-on library for wxX11, the X11 port of the wxWidgets library.
65
66 %package static
67 Summary: wxX11 static libraries
68 Group: Development/Libraries
69 Requires: %{wxbasename}-static
70 Requires: %{name}-devel = %{ver}
71
72 %description static
73 Static libraries for wxX11. You need them if you want to link statically against wxX11.
74
75 %package contrib
76 Summary: Contrib libraries for wxX11.
77 Group: X11/Libraries
78 Requires: %{name} = %{ver}
79
80 %description contrib
81 Contributed libraries for wxX11.
82
83 %package contrib-devel
84 Summary: Contrib libraries for wxX11.
85 Group: X11/Libraries
86 Requires: %{name}-contrib = %{ver}
87 Requires: %{name}-devel = %{ver}
88
89 %description contrib-devel
90 Header files for contributed libraries for wxX11.
91
92 %prep
93 %setup -q -n wxX11-%{ver}
94
95 %build
96 if [ "$SMP" != "" ]; then
97 export MAKE="make -j$SMP"
98 else
99 export MAKE="make"
100 fi
101
102 mkdir obj-shared
103 cd obj-shared
104 ../configure --prefix=%{pref} --with-x11 \
105 %if %{unicode}
106 --enable-unicode \
107 %else
108 --disable-unicode \
109 %endif
110 $MAKE
111
112 cd contrib/src
113 $MAKE
114 cd ../../..
115
116 mkdir obj-static
117 cd obj-static
118 ../configure --prefix=%{pref} --with-x11 --disable-shared \
119 %if %{unicode}
120 --enable-unicode \
121 %else
122 --disable-unicode \
123 %endif
124 --with-opengl
125 $MAKE
126 cd ..
127
128 %install
129 rm -rf $RPM_BUILD_ROOT
130 (cd obj-static; make prefix=$RPM_BUILD_ROOT%{pref} install)
131 (cd obj-shared; make prefix=$RPM_BUILD_ROOT%{pref} install)
132
133 # Remove headers that are part of wx-base-devel:
134
135 # --- wxBase headers list begins here ---
136 cat <<EOF >wxbase-headers.files
137 wx/afterstd.h
138 wx/app.h
139 wx/apptrait.h
140 wx/archive.h
141 wx/arrimpl.cpp
142 wx/arrstr.h
143 wx/atomic.h
144 wx/base64.h
145 wx/beforestd.h
146 wx/buffer.h
147 wx/build.h
148 wx/chartype.h
149 wx/chkconf.h
150 wx/clntdata.h
151 wx/cmdargs.h
152 wx/cmdline.h
153 wx/confbase.h
154 wx/config.h
155 wx/convauto.h
156 wx/containr.h
157 wx/cpp.h
158 wx/crt.h
159 wx/datetime.h
160 wx/datstrm.h
161 wx/dde.h
162 wx/debug.h
163 wx/defs.h
164 wx/dir.h
165 wx/dlimpexp.h
166 wx/dynarray.h
167 wx/dynlib.h
168 wx/dynload.h
169 wx/encconv.h
170 wx/event.h
171 wx/except.h
172 wx/features.h
173 wx/flags.h
174 wx/ffile.h
175 wx/file.h
176 wx/fileconf.h
177 wx/filefn.h
178 wx/filename.h
179 wx/filesys.h
180 wx/fontenc.h
181 wx/fontmap.h
182 wx/fs_arc.h
183 wx/fs_filter.h
184 wx/fs_mem.h
185 wx/fs_zip.h
186 wx/hash.h
187 wx/hashmap.h
188 wx/hashset.h
189 wx/html/forcelnk.h
190 wx/iconloc.h
191 wx/init.h
192 wx/intl.h
193 wx/iosfwrap.h
194 wx/ioswrap.h
195 wx/ipc.h
196 wx/ipcbase.h
197 wx/link.h
198 wx/list.h
199 wx/listimpl.cpp
200 wx/log.h
201 wx/longlong.h
202 wx/math.h
203 wx/memconf.h
204 wx/memory.h
205 wx/memtext.h
206 wx/mimetype.h
207 wx/module.h
208 wx/msgout.h
209 wx/mstream.h
210 wx/object.h
211 wx/platform.h
212 wx/platinfo.h
213 wx/power.h
214 wx/process.h
215 wx/ptr_scpd.h
216 wx/ptr_shrd.h
217 wx/recguard.h
218 wx/regex.h
219 wx/scopeguard.h
220 wx/snglinst.h
221 wx/sstream.h
222 wx/stack.h
223 wx/stackwalk.h
224 wx/stdpaths.h
225 wx/stockitem.h
226 wx/stopwatch.h
227 wx/strconv.h
228 wx/stream.h
229 wx/string.h
230 wx/stringimpl.h
231 wx/stringops.h
232 wx/strvararg.h
233 wx/sysopt.h
234 wx/tarstrm.h
235 wx/textbuf.h
236 wx/textfile.h
237 wx/thread.h
238 wx/thrimpl.cpp
239 wx/timer.h
240 wx/tokenzr.h
241 wx/tracker.h
242 wx/txtstrm.h
243 wx/types.h
244 wx/unichar.h
245 wx/uri.h
246 wx/utils.h
247 wx/variant.h
248 wx/vector.h
249 wx/version.h
250 wx/volume.h
251 wx/weakref.h
252 wx/wfstream.h
253 wx/wx.h
254 wx/wxchar.h
255 wx/wxcrt.h
256 wx/wxcrtbase.h
257 wx/wxcrtvararg.h
258 wx/wxprec.h
259 wx/xti.h
260 wx/xtistrm.h
261 wx/zipstrm.h
262 wx/zstream.h
263 wx/meta/convertible.h
264 wx/meta/int2type.h
265 wx/private/fdiodispatcher.h
266 wx/private/selectdispatcher.h
267 wx/unix/app.h
268 wx/unix/apptbase.h
269 wx/unix/apptrait.h
270 wx/unix/chkconf.h
271 wx/unix/evtloop.h
272 wx/unix/pipe.h
273 wx/unix/stdpaths.h
274 wx/unix/execute.h
275 wx/unix/mimetype.h
276 wx/unix/private.h
277 wx/private/gsocketiohandler.h
278 wx/unix/stackwalk.h
279 wx/fs_inet.h
280 wx/gsocket.h
281 wx/protocol/file.h
282 wx/protocol/ftp.h
283 wx/protocol/http.h
284 wx/protocol/protocol.h
285 wx/sckaddr.h
286 wx/sckipc.h
287 wx/sckstrm.h
288 wx/socket.h
289 wx/url.h
290 wx/unix/gsockunx.h
291 wx/xml/xml.h
292 wx/xtixml.h
293 EOF
294 # --- wxBase headers list ends here ---
295 for f in `cat wxbase-headers-list` ; do
296 rm -f $RPM_BUILD_ROOT%{_includedir}/wx-%{ver2}/$f
297 done
298
299 # list of all core headers:
300 find $RPM_BUILD_ROOT%{_includedir}/wx-%{ver2} -type f | sed -e "s,$RPM_BUILD_ROOT,,g" >core-headers.files
301
302 # contrib stuff:
303 (cd obj-shared/contrib/src; make prefix=$RPM_BUILD_ROOT%{pref} install)
304 (cd obj-shared/utils/wxrc; make prefix=$RPM_BUILD_ROOT%{pref} install)
305
306 # remove wxBase files so that RPM doesn't complain about unpackaged files:
307 rm -f $RPM_BUILD_ROOT%{_libdir}/libwx_base*
308 %if %{unicode}
309 rm -f $RPM_BUILD_ROOT%{_libdir}/libwxregexu-%{ver2}.a
310 %endif
311 rm -f $RPM_BUILD_ROOT%{_datadir}/aclocal/*
312 rm -f $RPM_BUILD_ROOT%{_datadir}/locale/*/*/*
313
314 %clean
315 rm -rf $RPM_BUILD_ROOT
316
317 %post
318 /sbin/ldconfig
319
320 %postun
321 /sbin/ldconfig
322
323 %post devel
324 # link wx-config when you install RPM.
325 ln -sf %{_libdir}/wx/config/%{wxconfig} %{_bindir}/wx-config
326 # link wx-config with explicit name.
327 ln -sf %{_libdir}/wx/config/%{wxconfig} %{_bindir}/%{wxconfiglink}
328 /sbin/ldconfig
329
330 %postun devel
331 /sbin/ldconfig
332
333 %preun devel
334 if test -f %{_bindir}/wx-config -a -f /usr/bin/md5sum ; then
335 SUM1=`md5sum %{_libdir}/wx/config/%{wxconfig} | cut -c 0-32`
336 SUM2=`md5sum %{_bindir}/wx-config | cut -c 0-32`
337 if test "x$SUM1" = "x$SUM2" ; then
338 rm -f %{_bindir}/wx-config
339 fi
340 fi
341 rm -f %{_bindir}/%{wxconfiglink}
342
343 %post gl
344 /sbin/ldconfig
345
346 %postun gl
347 /sbin/ldconfig
348
349 %post contrib
350 /sbin/ldconfig
351
352 %postun contrib
353 /sbin/ldconfig
354
355 %post contrib-devel
356 /sbin/ldconfig
357
358 %postun contrib-devel
359 /sbin/ldconfig
360
361 %files
362 %defattr(-,root,root)
363 %doc COPYING.LIB *.txt
364 %{_libdir}/libwx_%{portname}*_adv-%{ver2}.so.*
365 %{_libdir}/libwx_%{portname}*_core-%{ver2}.so.*
366 %{_libdir}/libwx_%{portname}*_html-%{ver2}.so.*
367 %{_libdir}/libwx_%{portname}*_media-%{ver2}.so.*
368 %{_libdir}/libwx_%{portname}*_qa-%{ver2}.so.*
369 %{_libdir}/libwx_%{portname}*_xrc-%{ver2}.so.*
370
371
372 %files devel -f core-headers.files
373 %defattr(-,root,root)
374 %{_libdir}/libwx_%{portname}*_adv-%{ver2}.so
375 %{_libdir}/libwx_%{portname}*_core-%{ver2}.so
376 %{_libdir}/libwx_%{portname}*_gl-%{ver2}.so
377 %{_libdir}/libwx_%{portname}*_html-%{ver2}.so
378 %{_libdir}/libwx_%{portname}*_media-%{ver2}.so
379 %{_libdir}/libwx_%{portname}*_qa-%{ver2}.so
380 %{_libdir}/libwx_%{portname}*_xrc-%{ver2}.so
381 %dir %{_libdir}/wx
382 %{_libdir}/wx/*
383 %{_bindir}/wxrc*
384
385 %files gl
386 %defattr(-,root,root)
387 %{_libdir}/libwx_%{portname}*_gl-%{ver2}.so.*
388
389 %files static
390 %defattr (-,root,root)
391 %{_libdir}/libwx_%{portname}*_*-%{ver2}.a
392
393 %files contrib
394 %defattr(-,root,root)
395 %{_libdir}/libwx_%{portname}*_animate-%{ver2}.so.*
396 %{_libdir}/libwx_%{portname}*_deprecated-%{ver2}.so.*
397 %{_libdir}/libwx_%{portname}*_fl-%{ver2}.so.*
398 %{_libdir}/libwx_%{portname}*_gizmos-%{ver2}.so.*
399 %{_libdir}/libwx_%{portname}*_mmedia-%{ver2}.so.*
400 %{_libdir}/libwx_%{portname}*_ogl-%{ver2}.so.*
401 %{_libdir}/libwx_%{portname}*_plot-%{ver2}.so.*
402 %{_libdir}/libwx_%{portname}*_stc-%{ver2}.so.*
403 %{_libdir}/libwx_%{portname}*_svg-%{ver2}.so.*
404
405 %files contrib-devel
406 %defattr(-,root,root)
407 %dir %{_includedir}/wx-%{ver2}/wx/animate
408 %{_includedir}/wx-%{ver2}/wx/animate/*
409 %{_libdir}/libwx_%{portname}*_animate-%{ver2}.so
410
411 %dir %{_includedir}/wx-%{ver2}/wx/deprecated
412 %{_includedir}/wx-%{ver2}/wx/deprecated/*
413 %{_libdir}/libwx_%{portname}*_deprecated-%{ver2}.so
414
415 %dir %{_includedir}/wx-%{ver2}/wx/fl
416 %{_includedir}/wx-%{ver2}/wx/fl/*
417 %{_libdir}/libwx_%{portname}*_fl-%{ver2}.so
418
419 %dir %{_includedir}/wx-%{ver2}/wx/gizmos
420 %{_includedir}/wx-%{ver2}/wx/gizmos/*
421 %{_libdir}/libwx_%{portname}*_gizmos-%{ver2}.so
422
423 %dir %{_includedir}/wx-%{ver2}/wx/mmedia
424 %{_includedir}/wx-%{ver2}/wx/mmedia/*
425 %{_libdir}/libwx_%{portname}*_mmedia-%{ver2}.so
426
427 %dir %{_includedir}/wx-%{ver2}/wx/ogl
428 %{_includedir}/wx-%{ver2}/wx/ogl/*
429 %{_libdir}/libwx_%{portname}*_ogl-%{ver2}.so
430
431 %dir %{_includedir}/wx-%{ver2}/wx/plot
432 %{_includedir}/wx-%{ver2}/wx/plot/*
433 %{_libdir}/libwx_%{portname}*_plot-%{ver2}.so
434
435 %dir %{_includedir}/wx-%{ver2}/wx/stc
436 %{_includedir}/wx-%{ver2}/wx/stc/*
437 %{_libdir}/libwx_%{portname}*_stc-%{ver2}.so
438
439 %dir %{_includedir}/wx-%{ver2}/wx/svg
440 %{_includedir}/wx-%{ver2}/wx/svg/*
441 %{_libdir}/libwx_%{portname}*_svg-%{ver2}.so