Rebake to add wx/meta/implicitconversion.h to the makefiles.
[wxWidgets.git] / wxGTK.spec
1 %define _prefix /usr
2 %define ver 2.9.2
3 %define ver2 2.9
4 %define rel 1
5
6 # Configurable settings (use --with(out) {unicode,gtk2} on rpmbuild cmd line):
7 %define unicode 1
8 %{?_with_unicode: %{expand: %%define unicode 1}}
9 %{?_without_unicode: %{expand: %%define unicode 0}}
10
11 %define gtk2 1
12 %{?_with_gtk2: %{expand: %%define gtk2 1}}
13 %{?_without_gtk2: %{expand: %%define gtk2 0}}
14
15 # "buildname" needs to be e.g. gtk2ud for debug builds
16 %if %{gtk2}
17 %define gtkver 2
18 %define portname gtk2
19 %if %{unicode}
20 %define buildname gtk2u
21 %else
22 %define buildname gtk2
23 %endif
24 %else
25 %define gtkver 1.2
26 %define portname gtk
27 %define buildname gtk
28 %endif
29
30 %if %{unicode}
31 %define name wx-%{portname}-unicode
32 %define wxconfig %{portname}-unicode-%{ver2}
33 %define wxconfigstatic %{portname}-unicode-static-%{ver2}
34 %define wxconfiglink wx%{portname}u-%{ver2}-config
35 %else
36 %define name wx-%{portname}-ansi
37 %define wxconfig %{portname}-ansi-%{ver2}
38 %define wxconfigstatic %{portname}-ansi-static-%{ver2}
39 %define wxconfiglink wx%{portname}-%{ver2}-config
40 %endif
41
42 %if %{unicode}
43 %define wxbasename wx-base-unicode
44 %define wxbaseconfig base-unicode-%{ver2}
45 %define wxbaseconfiglink wxbaseu-%{ver2}-config
46 %else
47 %define wxbasename wx-base-ansi
48 %define wxbaseconfig base-ansi-%{ver2}
49 %define wxbaseconfiglink wxbase-%{ver2}-config
50 %endif
51
52 Summary: The GTK+ %{gtkver} port of the wxWidgets library
53 Name: %{name}
54 Version: %{ver}
55 Release: %{rel}
56 License: wxWindows Licence
57 Group: X11/Libraries
58 Source: wxGTK-%{ver}.tar.bz2
59 URL: http://www.wxwidgets.org
60 Packager: Vadim Zeitlin <vadim@wxwindows.org>
61 Prefix: %{_prefix}
62 BuildRoot: %{_tmppath}/%{name}-root
63 Requires: %{wxbasename} = %{ver}
64 %if %{portname} == gtk2
65 BuildRequires: gtk2-devel
66 %else
67 BuildRequires: gtk+-devel >= 1.2.0
68 %endif
69
70 BuildRequires: zlib-devel, libjpeg-devel, libpng-devel, libtiff-devel
71
72 # all packages providing an implementation of wxWidgets library (regardless of
73 # the toolkit used) should provide the (virtual) wxwin package, this makes it
74 # possible to require wxwin instead of requiring "wxgtk or wxmotif or wxuniv..."
75 Provides: wxwin
76 Provides: wxGTK
77
78 %description
79 wxWidgets is a free C++ library for cross-platform GUI development.
80 With wxWidgets, you can create applications for different GUIs (GTK+,
81 Motif, MS Windows, MacOS X, Windows CE, GPE) from the same source code.
82
83 %package -n wx-i18n
84 Summary: The translations for the wxWidgets library.
85 Group: X11/Libraries
86
87 %description -n wx-i18n
88 The translations files for the wxWidgets library.
89
90 %package devel
91 Summary: The GTK+ %{gtkver} port of the wxWidgets library
92 Group: X11/Libraries
93 Requires: %{name} = %{ver}
94 Requires: %{wxbasename}-devel = %{ver}
95 Provides: wxGTK-devel
96
97 %description devel
98 The GTK+ %{gtkver} port of the wxWidgets library, header files.
99
100 %package gl
101 Summary: The GTK+ %{gtkver} port of the wxWidgets library, OpenGL add-on.
102 Group: X11/Libraries
103 Requires: %{name} = %{ver}
104 Provides: wxGTK-gl
105
106 %description gl
107 OpenGL add-on library for wxGTK, the GTK+ %{gtkver} port of the wxWidgets library.
108
109 %package -n %{wxbasename}
110 Summary: wxBase library - non-GUI support classes of the wxWidgets toolkit
111 Group: Development/Libraries
112 Provides: wxBase
113
114 %description -n %{wxbasename}
115 wxBase is a collection of C++ classes providing basic data structures (strings,
116 lists, arrays), portable wrappers around many OS-specific funstions (file
117 operations, time/date manipulations, threads, processes, sockets, shared
118 library loading) as well as other utility classes (streams, archive and
119 compression). wxBase currently supports Win32, most Unix variants (Linux,
120 FreeBSD, Solaris, HP-UX) and MacOS X (Carbon and Mach-0).
121
122 %package -n %{wxbasename}-devel
123 Summary: wxBase library, header files.
124 Group: Development/Libraries
125 Provides: wxBase-devel
126
127 %description -n %{wxbasename}-devel
128 wxBase library - non-GUI support classes of the wxWidgets toolkit,
129 header files.
130
131 %prep
132 %setup -q -n wxGTK-%{ver}
133
134 %build
135 if [ "$SMP" != "" ]; then
136 export MAKE="make -j$SMP"
137 else
138 export MAKE="make"
139 fi
140
141 mkdir obj-shared
142 cd obj-shared
143 ../configure --prefix=%{_prefix} --libdir=%{_libdir} \
144 %if ! %{gtk2}
145 --with-gtk=1 \
146 %else
147 --with-gtk=2 \
148 %endif
149 %if %{unicode}
150 --enable-unicode \
151 %else
152 --disable-unicode \
153 %endif
154 --with-opengl \
155 --with-gnomeprint \
156 --enable-mediactrl
157 $MAKE
158
159 cd ..
160
161 mkdir obj-static
162 cd obj-static
163 ../configure --prefix=%{_prefix} --libdir=%{_libdir} \
164 %if ! %{gtk2}
165 --with-gtk=1 \
166 %else
167 --with-gtk=2 \
168 %endif
169 --disable-shared \
170 %if %{unicode}
171 --enable-unicode \
172 %else
173 --disable-unicode \
174 %endif
175 --with-opengl \
176 --with-gnomeprint \
177 --enable-mediactrl
178 $MAKE
179
180 cd ..
181
182 make -C locale allmo
183
184 %install
185 rm -rf $RPM_BUILD_ROOT
186 (cd obj-static; make DESTDIR=$RPM_BUILD_ROOT prefix=%{_prefix} install)
187 (cd obj-shared; make DESTDIR=$RPM_BUILD_ROOT prefix=%{_prefix} install)
188
189 # --- wxBase headers list begins here ---
190 cat <<EOF >wxbase-headers.files
191 wx/afterstd.h
192 wx/any.h
193 wx/anystr.h
194 wx/app.h
195 wx/apptrait.h
196 wx/archive.h
197 wx/arrimpl.cpp
198 wx/arrstr.h
199 wx/atomic.h
200 wx/base64.h
201 wx/beforestd.h
202 wx/buffer.h
203 wx/build.h
204 wx/chartype.h
205 wx/checkeddelete.h
206 wx/chkconf.h
207 wx/clntdata.h
208 wx/cmdargs.h
209 wx/cmdline.h
210 wx/confbase.h
211 wx/config.h
212 wx/convauto.h
213 wx/containr.h
214 wx/cpp.h
215 wx/crt.h
216 wx/datetime.h
217 wx/datstrm.h
218 wx/dde.h
219 wx/debug.h
220 wx/defs.h
221 wx/dir.h
222 wx/dlimpexp.h
223 wx/dlist.h
224 wx/dynarray.h
225 wx/dynlib.h
226 wx/dynload.h
227 wx/encconv.h
228 wx/event.h
229 wx/evtloop.h
230 wx/except.h
231 wx/features.h
232 wx/flags.h
233 wx/ffile.h
234 wx/file.h
235 wx/fileconf.h
236 wx/filefn.h
237 wx/filename.h
238 wx/filesys.h
239 wx/fontenc.h
240 wx/fontmap.h
241 wx/fs_arc.h
242 wx/fs_filter.h
243 wx/fs_mem.h
244 wx/fs_zip.h
245 wx/hash.h
246 wx/hashmap.h
247 wx/hashset.h
248 wx/html/forcelnk.h
249 wx/iconloc.h
250 wx/init.h
251 wx/intl.h
252 wx/iosfwrap.h
253 wx/ioswrap.h
254 wx/ipc.h
255 wx/ipcbase.h
256 wx/kbdstate.h
257 wx/language.h
258 wx/link.h
259 wx/list.h
260 wx/listimpl.cpp
261 wx/log.h
262 wx/longlong.h
263 wx/math.h
264 wx/memconf.h
265 wx/memory.h
266 wx/memtext.h
267 wx/mimetype.h
268 wx/module.h
269 wx/mousestate.h
270 wx/msgout.h
271 wx/msgqueue.h
272 wx/mstream.h
273 wx/object.h
274 wx/platform.h
275 wx/platinfo.h
276 wx/power.h
277 wx/process.h
278 wx/ptr_scpd.h
279 wx/ptr_shrd.h
280 wx/recguard.h
281 wx/regex.h
282 wx/scopedarray.h
283 wx/scopedptr.h
284 wx/scopeguard.h
285 wx/sharedptr.h
286 wx/snglinst.h
287 wx/sstream.h
288 wx/stack.h
289 wx/stackwalk.h
290 wx/stdpaths.h
291 wx/stdstream.h
292 wx/stockitem.h
293 wx/stopwatch.h
294 wx/strconv.h
295 wx/stream.h
296 wx/string.h
297 wx/stringimpl.h
298 wx/stringops.h
299 wx/strvararg.h
300 wx/sysopt.h
301 wx/tarstrm.h
302 wx/textbuf.h
303 wx/textfile.h
304 wx/thread.h
305 wx/thrimpl.cpp
306 wx/timer.h
307 wx/tls.h
308 wx/tokenzr.h
309 wx/tracker.h
310 wx/translation.h
311 wx/txtstrm.h
312 wx/typeinfo.h
313 wx/types.h
314 wx/unichar.h
315 wx/uri.h
316 wx/ustring.h
317 wx/utils.h
318 wx/variant.h
319 wx/vector.h
320 wx/version.h
321 wx/volume.h
322 wx/weakref.h
323 wx/wfstream.h
324 wx/wx.h
325 wx/wxchar.h
326 wx/wxcrt.h
327 wx/wxcrtbase.h
328 wx/wxcrtvararg.h
329 wx/wxprec.h
330 wx/xlocale.h
331 wx/xti.h
332 wx/xtistrm.h
333 wx/zipstrm.h
334 wx/zstream.h
335 wx/meta/convertible.h
336 wx/meta/if.h
337 wx/meta/implicitconversion.h
338 wx/meta/int2type.h
339 wx/meta/movable.h
340 wx/meta/pod.h
341 wx/fswatcher.h
342 wx/generic/fswatcher.h
343 wx/unix/app.h
344 wx/unix/apptbase.h
345 wx/unix/apptrait.h
346 wx/unix/chkconf.h
347 wx/unix/evtloop.h
348 wx/unix/evtloopsrc.h
349 wx/unix/pipe.h
350 wx/unix/stdpaths.h
351 wx/unix/stackwalk.h
352 wx/unix/tls.h
353 wx/unix/fswatcher_kqueue.h
354 wx/unix/execute.h
355 wx/unix/mimetype.h
356 wx/unix/fswatcher_inotify.h
357 wx/fs_inet.h
358 wx/protocol/file.h
359 wx/protocol/ftp.h
360 wx/protocol/http.h
361 wx/protocol/log.h
362 wx/protocol/protocol.h
363 wx/sckaddr.h
364 wx/sckipc.h
365 wx/sckstrm.h
366 wx/socket.h
367 wx/url.h
368 wx/xml/xml.h
369 wx/xtixml.h
370 EOF
371 # --- wxBase headers list ends here ---
372
373 # --- wxBase headers list with paths ---
374 sed -e 's@^@%{_includedir}/wx-%{ver2}/@' wxbase-headers.files > wxbase-headers.paths
375
376
377 # temporarily remove base headers
378 mkdir $RPM_BUILD_ROOT/_save_dir
379 cp -r $RPM_BUILD_ROOT%{_includedir}/wx-%{ver2} $RPM_BUILD_ROOT/_save_dir
380 for f in `cat wxbase-headers.files` ; do
381 rm -f $RPM_BUILD_ROOT%{_includedir}/wx-%{ver2}/$f
382 done
383 # list of all core headers:
384 find $RPM_BUILD_ROOT%{_includedir}/wx-%{ver2} -type f | sed -e "s,$RPM_BUILD_ROOT,,g" >core-headers.files
385 # move base headers (actually all headers) back again
386 cp -f -r $RPM_BUILD_ROOT/_save_dir/* $RPM_BUILD_ROOT%{_includedir}
387 rm -rf $RPM_BUILD_ROOT/_save_dir
388
389 # utils:
390 (cd obj-shared/utils/wxrc; make DESTDIR=$RPM_BUILD_ROOT prefix=%{_prefix} install)
391
392 # wx-config link is created during package installation, remove it for now
393 rm -f $RPM_BUILD_ROOT%{_bindir}/wx-config
394
395 %clean
396 rm -rf $RPM_BUILD_ROOT
397
398 %post
399 /sbin/ldconfig
400
401 %postun
402 /sbin/ldconfig
403
404 %post devel
405 # link wx-config when you install RPM.
406 %if %{unicode}
407 ln -sf %{_libdir}/wx/config/%{wxconfig} %{_bindir}/wx-config
408 %endif
409 # link wx-config with explicit name.
410 ln -sf %{_libdir}/wx/config/%{wxconfig} %{_bindir}/%{wxconfiglink}
411 /sbin/ldconfig
412
413 %postun devel
414 /sbin/ldconfig
415
416 %preun devel
417 %if %{unicode}
418 rm -f %{_bindir}/wx-config
419 %endif
420 rm -f %{_bindir}/%{wxconfiglink}
421
422 %post -n %{wxbasename}
423 /sbin/ldconfig
424
425 %postun -n %{wxbasename}
426 /sbin/ldconfig
427
428 %post -n %{wxbasename}-devel
429 # link wx-config with explicit name.
430 ln -sf %{_libdir}/wx/config/%{wxbaseconfig} %{_bindir}/%{wxbaseconfiglink}
431 /sbin/ldconfig
432
433 %postun -n %{wxbasename}-devel
434 /sbin/ldconfig
435
436 %preun -n %{wxbasename}-devel
437 rm -f %{_bindir}/%{wxbaseconfiglink}
438
439 %post gl
440 /sbin/ldconfig
441
442 %postun gl
443 /sbin/ldconfig
444
445 %files
446 %defattr(-,root,root)
447 %doc COPYING.LIB *.txt
448 %{_libdir}/libwx_%{buildname}_adv-%{ver2}.so.*
449 %{_libdir}/libwx_%{buildname}_aui-%{ver2}.so.*
450 %{_libdir}/libwx_%{buildname}_core-%{ver2}.so.*
451 %{_libdir}/libwx_%{buildname}_html-%{ver2}.so.*
452 %{_libdir}/libwx_%{buildname}_media-%{ver2}.so.*
453 %{_libdir}/libwx_%{buildname}_propgrid-%{ver2}.so.*
454 %{_libdir}/libwx_%{buildname}_qa-%{ver2}.so.*
455 %{_libdir}/libwx_%{buildname}_ribbon-%{ver2}.so.*
456 %{_libdir}/libwx_%{buildname}_richtext-%{ver2}.so.*
457 %{_libdir}/libwx_%{buildname}_stc-%{ver2}.so.*
458 %{_libdir}/libwx_%{buildname}_xrc-%{ver2}.so.*
459
460 %files -n wx-i18n
461 %defattr(-,root,root)
462 %{_datadir}/locale/*/LC_MESSAGES/*.mo
463
464 %files devel -f core-headers.files
465 %defattr(-,root,root)
466 # shared libs
467 %{_libdir}/libwx_%{buildname}_adv-%{ver2}.so
468 %{_libdir}/libwx_%{buildname}_aui-%{ver2}.so
469 %{_libdir}/libwx_%{buildname}_core-%{ver2}.so
470 %{_libdir}/libwx_%{buildname}_gl-%{ver2}.so
471 %{_libdir}/libwx_%{buildname}_html-%{ver2}.so
472 %{_libdir}/libwx_%{buildname}_media-%{ver2}.so
473 %{_libdir}/libwx_%{buildname}_propgrid-%{ver2}.so
474 %{_libdir}/libwx_%{buildname}_qa-%{ver2}.so
475 %{_libdir}/libwx_%{buildname}_ribbon-%{ver2}.so
476 %{_libdir}/libwx_%{buildname}_richtext-%{ver2}.so
477 %{_libdir}/libwx_%{buildname}_stc-%{ver2}.so
478 %{_libdir}/libwx_%{buildname}_xrc-%{ver2}.so
479 # static libs
480 %{_libdir}/libwx_%{buildname}_adv-%{ver2}.a
481 %{_libdir}/libwx_%{buildname}_aui-%{ver2}.a
482 %{_libdir}/libwx_%{buildname}_core-%{ver2}.a
483 %{_libdir}/libwx_%{buildname}_gl-%{ver2}.a
484 %{_libdir}/libwx_%{buildname}_html-%{ver2}.a
485 %{_libdir}/libwx_%{buildname}_media-%{ver2}.a
486 %{_libdir}/libwx_%{buildname}_propgrid-%{ver2}.a
487 %{_libdir}/libwx_%{buildname}_qa-%{ver2}.a
488 %{_libdir}/libwx_%{buildname}_ribbon-%{ver2}.a
489 %{_libdir}/libwx_%{buildname}_richtext-%{ver2}.a
490 %{_libdir}/libwx_%{buildname}_stc-%{ver2}.a
491 %{_libdir}/libwx_%{buildname}_xrc-%{ver2}.a
492 %dir %{_libdir}/wx
493 %{_libdir}/wx/config/%{wxconfig}
494 %{_libdir}/wx/include/%{wxconfig}/wx/setup.h
495 %{_libdir}/wx/config/%{wxconfigstatic}
496 %{_libdir}/wx/include/%{wxconfigstatic}/wx/setup.h
497 %{_bindir}/wxrc*
498
499 %files -n %{wxbasename}
500 %defattr(-,root,root)
501 %{_libdir}/libwx_base*-%{ver2}.so.*
502
503 %files -n %{wxbasename}-devel -f wxbase-headers.paths
504 %defattr (-,root,root)
505 %dir %{_includedir}/wx-%{ver2}
506 %{_libdir}/libwx_base*-%{ver2}.so
507 %{_libdir}/libwx_base*-%{ver2}.a
508 %if %{unicode}
509 %{_libdir}/libwxregexu-%{ver2}.a
510 %endif
511 %{_libdir}/libwxscintilla-%{ver2}.a
512 %dir %{_libdir}/wx
513 %{_datadir}/aclocal/*.m4
514 %{_datadir}/bakefile/presets/*
515
516 %files gl
517 %defattr(-,root,root)
518 %{_libdir}/libwx_%{buildname}_gl-%{ver2}.so.*