Added typeinfo.h which implements wxTypeId, using C++ RTTI if available. wxAny and...
[wxWidgets.git] / wxGTK.spec
1 %define _prefix /usr
2 %define ver 2.9.1
3 %define ver2 2.9
4 %define rel 1
5
6 # Configurable settings (use --with(out) {unicode,gtk2} on rpmbuild cmd line):
7 %define unicode 1
8 %{?_with_unicode: %{expand: %%define unicode 1}}
9 %{?_without_unicode: %{expand: %%define unicode 0}}
10
11 %define gtk2 1
12 %{?_with_gtk2: %{expand: %%define gtk2 1}}
13 %{?_without_gtk2: %{expand: %%define gtk2 0}}
14
15 # "buildname" needs to be e.g. gtk2ud for debug builds
16 %if %{gtk2}
17 %define gtkver 2
18 %define portname gtk2
19 %if %{unicode}
20 %define buildname gtk2u
21 %else
22 %define buildname gtk2
23 %endif
24 %else
25 %define gtkver 1.2
26 %define portname gtk
27 %define buildname gtk
28 %endif
29
30 %if %{unicode}
31 %define name wx-%{portname}-unicode
32 %define wxconfig %{portname}-unicode-release-%{ver2}
33 %define wxconfigstatic %{portname}-unicode-release-static-%{ver2}
34 %define wxconfiglink wx%{portname}u-%{ver2}-config
35 %else
36 %define name wx-%{portname}-ansi
37 %define wxconfig %{portname}-ansi-release-%{ver2}
38 %define wxconfigstatic %{portname}-ansi-release-static-%{ver2}
39 %define wxconfiglink wx%{portname}-%{ver2}-config
40 %endif
41
42 %if %{unicode}
43 %define wxbasename wx-base-unicode
44 %define wxbaseconfig base-unicode-release-%{ver2}
45 %define wxbaseconfiglink wxbaseu-%{ver2}-config
46 %else
47 %define wxbasename wx-base-ansi
48 %define wxbaseconfig base-ansi-release-%{ver2}
49 %define wxbaseconfiglink wxbase-%{ver2}-config
50 %endif
51
52 Summary: The GTK+ %{gtkver} port of the wxWidgets library
53 Name: %{name}
54 Version: %{ver}
55 Release: %{rel}
56 License: wxWindows Licence
57 Group: X11/Libraries
58 Source: wxGTK-%{ver}.tar.bz2
59 URL: http://www.wxwidgets.org
60 Packager: Vadim Zeitlin <vadim@wxwindows.org>
61 Prefix: %{_prefix}
62 BuildRoot: %{_tmppath}/%{name}-root
63 Requires: %{wxbasename} = %{ver}
64 %if %{portname} == gtk2
65 BuildRequires: gtk+-2.0-devel
66 %else
67 BuildRequires: gtk+-devel >= 1.2.0
68 %endif
69
70 BuildRequires: zlib-devel, libjpeg-devel, libpng-devel, libtiff-devel
71
72 # all packages providing an implementation of wxWidgets library (regardless of
73 # the toolkit used) should provide the (virtual) wxwin package, this makes it
74 # possible to require wxwin instead of requiring "wxgtk or wxmotif or wxuniv..."
75 Provides: wxwin
76 Provides: wxGTK
77
78 %description
79 wxWidgets is a free C++ library for cross-platform GUI development.
80 With wxWidgets, you can create applications for different GUIs (GTK+,
81 Motif, MS Windows, MacOS X, Windows CE, GPE) from the same source code.
82
83 %package -n wx-i18n
84 Summary: The translations for the wxWidgets library.
85 Group: X11/Libraries
86
87 %description -n wx-i18n
88 The translations files for the wxWidgets library.
89
90 %package devel
91 Summary: The GTK+ %{gtkver} port of the wxWidgets library
92 Group: X11/Libraries
93 Requires: %{name} = %{ver}
94 Requires: %{wxbasename}-devel = %{ver}
95 Provides: wxGTK-devel
96
97 %description devel
98 The GTK+ %{gtkver} port of the wxWidgets library, header files.
99
100 %package gl
101 Summary: The GTK+ %{gtkver} port of the wxWidgets library, OpenGL add-on.
102 Group: X11/Libraries
103 Requires: %{name} = %{ver}
104 Provides: wxGTK-gl
105
106 %description gl
107 OpenGL add-on library for wxGTK, the GTK+ %{gtkver} port of the wxWidgets library.
108
109 %package -n %{wxbasename}
110 Summary: wxBase library - non-GUI support classes of the wxWidgets toolkit
111 Group: Development/Libraries
112 Provides: wxBase
113
114 %description -n %{wxbasename}
115 wxBase is a collection of C++ classes providing basic data structures (strings,
116 lists, arrays), portable wrappers around many OS-specific funstions (file
117 operations, time/date manipulations, threads, processes, sockets, shared
118 library loading) as well as other utility classes (streams, archive and
119 compression). wxBase currently supports Win32, most Unix variants (Linux,
120 FreeBSD, Solaris, HP-UX) and MacOS X (Carbon and Mach-0).
121
122 %package -n %{wxbasename}-devel
123 Summary: wxBase library, header files.
124 Group: Development/Libraries
125 Provides: wxBase-devel
126
127 %description -n %{wxbasename}-devel
128 wxBase library - non-GUI support classes of the wxWidgets toolkit,
129 header files.
130
131 %package contrib
132 Summary: The GTK+ %{gtkver} port of the wxWidgets library, contributed libraries.
133 Group: X11/Libraries
134 Requires: %{name} = %{ver}
135
136 %description contrib
137 Contributed libraries for wxGTK, the GTK+ %{gtkver} port of the wxWidgets library.
138
139 %package contrib-devel
140 Summary: The GTK+ %{gtkver} port of the wxWidgets library
141 Group: X11/Libraries
142 Requires: %{name}-contrib = %{ver}
143 Requires: %{name}-devel = %{ver}
144
145 %description contrib-devel
146 Header files for contributed libraries for wxGTK, the GTK+ %{gtkver} port of the wxWidgets library.
147
148 %prep
149 %setup -q -n wxGTK-%{ver}
150
151 %build
152 if [ "$SMP" != "" ]; then
153 export MAKE="make -j$SMP"
154 else
155 export MAKE="make"
156 fi
157
158 mkdir obj-shared
159 cd obj-shared
160 ../configure --prefix=%{_prefix} \
161 %if ! %{gtk2}
162 --with-gtk=1 \
163 %else
164 --with-gtk=2 \
165 %endif
166 %if %{unicode}
167 --enable-unicode \
168 %else
169 --disable-unicode \
170 %endif
171 --with-opengl
172 $MAKE
173
174 cd contrib/src
175 $MAKE
176 cd ../../..
177
178 mkdir obj-static
179 cd obj-static
180 ../configure --prefix=%{_prefix} \
181 %if ! %{gtk2}
182 --with-gtk=1 \
183 %else
184 --with-gtk=2 \
185 %endif
186 --disable-shared \
187 %if %{unicode}
188 --enable-unicode \
189 %else
190 --disable-unicode \
191 %endif
192 --with-opengl
193 $MAKE
194
195 cd contrib/src
196 $MAKE
197 cd ../../..
198
199 make -C locale allmo
200
201 %install
202 rm -rf $RPM_BUILD_ROOT
203 (cd obj-static; make DESTDIR=$RPM_BUILD_ROOT prefix=%{_prefix} install)
204 (cd obj-shared; make DESTDIR=$RPM_BUILD_ROOT prefix=%{_prefix} install)
205
206 # --- wxBase headers list begins here ---
207 cat <<EOF >wxbase-headers.files
208 wx/afterstd.h
209 wx/any.h
210 wx/anystr.h
211 wx/app.h
212 wx/apptrait.h
213 wx/archive.h
214 wx/arrimpl.cpp
215 wx/arrstr.h
216 wx/atomic.h
217 wx/base64.h
218 wx/beforestd.h
219 wx/buffer.h
220 wx/build.h
221 wx/chartype.h
222 wx/checkeddelete.h
223 wx/chkconf.h
224 wx/clntdata.h
225 wx/cmdargs.h
226 wx/cmdline.h
227 wx/confbase.h
228 wx/config.h
229 wx/convauto.h
230 wx/containr.h
231 wx/cpp.h
232 wx/crt.h
233 wx/datetime.h
234 wx/datstrm.h
235 wx/dde.h
236 wx/debug.h
237 wx/defs.h
238 wx/dir.h
239 wx/dlimpexp.h
240 wx/dlist.h
241 wx/dynarray.h
242 wx/dynlib.h
243 wx/dynload.h
244 wx/encconv.h
245 wx/event.h
246 wx/except.h
247 wx/features.h
248 wx/flags.h
249 wx/ffile.h
250 wx/file.h
251 wx/fileconf.h
252 wx/filefn.h
253 wx/filename.h
254 wx/filesys.h
255 wx/fontenc.h
256 wx/fontmap.h
257 wx/fs_arc.h
258 wx/fs_filter.h
259 wx/fs_mem.h
260 wx/fs_zip.h
261 wx/hash.h
262 wx/hashmap.h
263 wx/hashset.h
264 wx/html/forcelnk.h
265 wx/iconloc.h
266 wx/init.h
267 wx/intl.h
268 wx/iosfwrap.h
269 wx/ioswrap.h
270 wx/ipc.h
271 wx/ipcbase.h
272 wx/kbdstate.h
273 wx/link.h
274 wx/list.h
275 wx/listimpl.cpp
276 wx/log.h
277 wx/longlong.h
278 wx/math.h
279 wx/memconf.h
280 wx/memory.h
281 wx/memtext.h
282 wx/mimetype.h
283 wx/module.h
284 wx/mousestate.h
285 wx/msgout.h
286 wx/mstream.h
287 wx/object.h
288 wx/platform.h
289 wx/platinfo.h
290 wx/power.h
291 wx/process.h
292 wx/ptr_scpd.h
293 wx/ptr_shrd.h
294 wx/recguard.h
295 wx/regex.h
296 wx/scopedarray.h
297 wx/scopedptr.h
298 wx/scopeguard.h
299 wx/sharedptr.h
300 wx/snglinst.h
301 wx/sstream.h
302 wx/stack.h
303 wx/stackwalk.h
304 wx/stdpaths.h
305 wx/stdstream.h
306 wx/stockitem.h
307 wx/stopwatch.h
308 wx/strconv.h
309 wx/stream.h
310 wx/string.h
311 wx/stringimpl.h
312 wx/stringops.h
313 wx/strvararg.h
314 wx/sysopt.h
315 wx/tarstrm.h
316 wx/textbuf.h
317 wx/textfile.h
318 wx/thread.h
319 wx/thrimpl.cpp
320 wx/timer.h
321 wx/tls.h
322 wx/tokenzr.h
323 wx/tracker.h
324 wx/txtstrm.h
325 wx/typeinfo.h
326 wx/types.h
327 wx/unichar.h
328 wx/uri.h
329 wx/ustring.h
330 wx/utils.h
331 wx/variant.h
332 wx/vector.h
333 wx/version.h
334 wx/volume.h
335 wx/weakref.h
336 wx/wfstream.h
337 wx/wx.h
338 wx/wxchar.h
339 wx/wxcrt.h
340 wx/wxcrtbase.h
341 wx/wxcrtvararg.h
342 wx/wxprec.h
343 wx/xlocale.h
344 wx/xti.h
345 wx/xtistrm.h
346 wx/zipstrm.h
347 wx/zstream.h
348 wx/meta/convertible.h
349 wx/meta/if.h
350 wx/meta/int2type.h
351 wx/meta/movable.h
352 wx/fswatcher.h
353 wx/generic/fswatcher.h
354 wx/unix/app.h
355 wx/unix/apptbase.h
356 wx/unix/apptrait.h
357 wx/unix/chkconf.h
358 wx/unix/evtloop.h
359 wx/unix/evtloopsrc.h
360 wx/unix/pipe.h
361 wx/unix/stdpaths.h
362 wx/unix/stackwalk.h
363 wx/unix/tls.h
364 wx/unix/fswatcher_kqueue.h
365 wx/unix/execute.h
366 wx/unix/mimetype.h
367 wx/unix/fswatcher_inotify.h
368 wx/fs_inet.h
369 wx/protocol/file.h
370 wx/protocol/ftp.h
371 wx/protocol/http.h
372 wx/protocol/log.h
373 wx/protocol/protocol.h
374 wx/sckaddr.h
375 wx/sckipc.h
376 wx/sckstrm.h
377 wx/socket.h
378 wx/url.h
379 wx/xml/xml.h
380 wx/xtixml.h
381 EOF
382 # --- wxBase headers list ends here ---
383 cat <<EOF >wxbase-headers.paths
384 %{_includedir}/wx-%{ver2}/wx/afterstd.h
385 %{_includedir}/wx-%{ver2}/wx/app.h
386 %{_includedir}/wx-%{ver2}/wx/apptrait.h
387 %{_includedir}/wx-%{ver2}/wx/archive.h
388 %{_includedir}/wx-%{ver2}/wx/arrimpl.cpp
389 %{_includedir}/wx-%{ver2}/wx/arrstr.h
390 %{_includedir}/wx-%{ver2}/wx/beforestd.h
391 %{_includedir}/wx-%{ver2}/wx/buffer.h
392 %{_includedir}/wx-%{ver2}/wx/build.h
393 %{_includedir}/wx-%{ver2}/wx/chkconf.h
394 %{_includedir}/wx-%{ver2}/wx/clntdata.h
395 %{_includedir}/wx-%{ver2}/wx/cmdline.h
396 %{_includedir}/wx-%{ver2}/wx/confbase.h
397 %{_includedir}/wx-%{ver2}/wx/config.h
398 %{_includedir}/wx-%{ver2}/wx/containr.h
399 %{_includedir}/wx-%{ver2}/wx/convauto.h
400 %{_includedir}/wx-%{ver2}/wx/datetime.h
401 %{_includedir}/wx-%{ver2}/wx/datstrm.h
402 %{_includedir}/wx-%{ver2}/wx/dde.h
403 %{_includedir}/wx-%{ver2}/wx/debug.h
404 %{_includedir}/wx-%{ver2}/wx/defs.h
405 %{_includedir}/wx-%{ver2}/wx/dir.h
406 %{_includedir}/wx-%{ver2}/wx/dlimpexp.h
407 %{_includedir}/wx-%{ver2}/wx/dynarray.h
408 %{_includedir}/wx-%{ver2}/wx/dynlib.h
409 %{_includedir}/wx-%{ver2}/wx/dynload.h
410 %{_includedir}/wx-%{ver2}/wx/encconv.h
411 %{_includedir}/wx-%{ver2}/wx/event.h
412 %{_includedir}/wx-%{ver2}/wx/except.h
413 %{_includedir}/wx-%{ver2}/wx/features.h
414 %{_includedir}/wx-%{ver2}/wx/ffile.h
415 %{_includedir}/wx-%{ver2}/wx/file.h
416 %{_includedir}/wx-%{ver2}/wx/fileconf.h
417 %{_includedir}/wx-%{ver2}/wx/filefn.h
418 %{_includedir}/wx-%{ver2}/wx/filename.h
419 %{_includedir}/wx-%{ver2}/wx/filesys.h
420 %{_includedir}/wx-%{ver2}/wx/fontenc.h
421 %{_includedir}/wx-%{ver2}/wx/fontmap.h
422 %{_includedir}/wx-%{ver2}/wx/fs_mem.h
423 %{_includedir}/wx-%{ver2}/wx/fs_zip.h
424 %{_includedir}/wx-%{ver2}/wx/hash.h
425 %{_includedir}/wx-%{ver2}/wx/hashmap.h
426 %{_includedir}/wx-%{ver2}/wx/hashset.h
427 %{_includedir}/wx-%{ver2}/wx/html/forcelnk.h
428 %{_includedir}/wx-%{ver2}/wx/iconloc.h
429 %{_includedir}/wx-%{ver2}/wx/init.h
430 %{_includedir}/wx-%{ver2}/wx/intl.h
431 %{_includedir}/wx-%{ver2}/wx/iosfwrap.h
432 %{_includedir}/wx-%{ver2}/wx/ioswrap.h
433 %{_includedir}/wx-%{ver2}/wx/ipc.h
434 %{_includedir}/wx-%{ver2}/wx/ipcbase.h
435 %{_includedir}/wx-%{ver2}/wx/isql.h
436 %{_includedir}/wx-%{ver2}/wx/isqlext.h
437 %{_includedir}/wx-%{ver2}/wx/link.h
438 %{_includedir}/wx-%{ver2}/wx/list.h
439 %{_includedir}/wx-%{ver2}/wx/listimpl.cpp
440 %{_includedir}/wx-%{ver2}/wx/log.h
441 %{_includedir}/wx-%{ver2}/wx/longlong.h
442 %{_includedir}/wx-%{ver2}/wx/math.h
443 %{_includedir}/wx-%{ver2}/wx/memconf.h
444 %{_includedir}/wx-%{ver2}/wx/memory.h
445 %{_includedir}/wx-%{ver2}/wx/memtext.h
446 %{_includedir}/wx-%{ver2}/wx/mimetype.h
447 %{_includedir}/wx-%{ver2}/wx/module.h
448 %{_includedir}/wx-%{ver2}/wx/msgout.h
449 %{_includedir}/wx-%{ver2}/wx/mstream.h
450 %{_includedir}/wx-%{ver2}/wx/object.h
451 %{_includedir}/wx-%{ver2}/wx/platform.h
452 %{_includedir}/wx-%{ver2}/wx/power.h
453 %{_includedir}/wx-%{ver2}/wx/process.h
454 %{_includedir}/wx-%{ver2}/wx/ptr_scpd.h
455 %{_includedir}/wx-%{ver2}/wx/recguard.h
456 %{_includedir}/wx-%{ver2}/wx/regex.h
457 %{_includedir}/wx-%{ver2}/wx/scopeguard.h
458 %{_includedir}/wx-%{ver2}/wx/snglinst.h
459 %{_includedir}/wx-%{ver2}/wx/sstream.h
460 %{_includedir}/wx-%{ver2}/wx/stack.h
461 %{_includedir}/wx-%{ver2}/wx/stackwalk.h
462 %{_includedir}/wx-%{ver2}/wx/stdpaths.h
463 %{_includedir}/wx-%{ver2}/wx/stockitem.h
464 %{_includedir}/wx-%{ver2}/wx/stopwatch.h
465 %{_includedir}/wx-%{ver2}/wx/strconv.h
466 %{_includedir}/wx-%{ver2}/wx/stream.h
467 %{_includedir}/wx-%{ver2}/wx/string.h
468 %{_includedir}/wx-%{ver2}/wx/sysopt.h
469 %{_includedir}/wx-%{ver2}/wx/textbuf.h
470 %{_includedir}/wx-%{ver2}/wx/textfile.h
471 %{_includedir}/wx-%{ver2}/wx/thread.h
472 %{_includedir}/wx-%{ver2}/wx/thrimpl.cpp
473 %{_includedir}/wx-%{ver2}/wx/timer.h
474 %{_includedir}/wx-%{ver2}/wx/tokenzr.h
475 %{_includedir}/wx-%{ver2}/wx/txtstrm.h
476 %{_includedir}/wx-%{ver2}/wx/types.h
477 %{_includedir}/wx-%{ver2}/wx/uri.h
478 %{_includedir}/wx-%{ver2}/wx/utils.h
479 %{_includedir}/wx-%{ver2}/wx/variant.h
480 %{_includedir}/wx-%{ver2}/wx/vector.h
481 %{_includedir}/wx-%{ver2}/wx/version.h
482 %{_includedir}/wx-%{ver2}/wx/volume.h
483 %{_includedir}/wx-%{ver2}/wx/wfstream.h
484 %{_includedir}/wx-%{ver2}/wx/wx.h
485 %{_includedir}/wx-%{ver2}/wx/wxchar.h
486 %{_includedir}/wx-%{ver2}/wx/wxprec.h
487 %{_includedir}/wx-%{ver2}/wx/xti.h
488 %{_includedir}/wx-%{ver2}/wx/xtistrm.h
489 %{_includedir}/wx-%{ver2}/wx/zipstrm.h
490 %{_includedir}/wx-%{ver2}/wx/zstream.h
491 %{_includedir}/wx-%{ver2}/wx/fs_inet.h
492 %{_includedir}/wx-%{ver2}/wx/gsocket.h
493 %{_includedir}/wx-%{ver2}/wx/protocol/file.h
494 %{_includedir}/wx-%{ver2}/wx/protocol/ftp.h
495 %{_includedir}/wx-%{ver2}/wx/protocol/http.h
496 %{_includedir}/wx-%{ver2}/wx/protocol/protocol.h
497 %{_includedir}/wx-%{ver2}/wx/sckaddr.h
498 %{_includedir}/wx-%{ver2}/wx/sckipc.h
499 %{_includedir}/wx-%{ver2}/wx/sckstrm.h
500 %{_includedir}/wx-%{ver2}/wx/socket.h
501 %{_includedir}/wx-%{ver2}/wx/url.h
502 %{_includedir}/wx-%{ver2}/wx/xml/xml.h
503 %{_includedir}/wx-%{ver2}/wx/xtixml.h
504 %{_includedir}/wx-%{ver2}/wx/unix/apptbase.h
505 %{_includedir}/wx-%{ver2}/wx/unix/apptrait.h
506 %{_includedir}/wx-%{ver2}/wx/unix/execute.h
507 %{_includedir}/wx-%{ver2}/wx/unix/gsockunx.h
508 %{_includedir}/wx-%{ver2}/wx/unix/mimetype.h
509 %{_includedir}/wx-%{ver2}/wx/unix/pipe.h
510 %{_includedir}/wx-%{ver2}/wx/unix/private.h
511 %{_includedir}/wx-%{ver2}/wx/unix/stackwalk.h
512 %{_includedir}/wx-%{ver2}/wx/unix/stdpaths.h
513 EOF
514 # --- wxBase headers list ends here ---
515
516 # temporarily remove base headers
517 mkdir $RPM_BUILD_ROOT/_save_dir
518 cp -r $RPM_BUILD_ROOT%{_includedir}/wx-%{ver2} $RPM_BUILD_ROOT/_save_dir
519 for f in `cat wxbase-headers.files` ; do
520 rm -f $RPM_BUILD_ROOT%{_includedir}/wx-%{ver2}/$f
521 done
522 # list of all core headers:
523 find $RPM_BUILD_ROOT%{_includedir}/wx-%{ver2} -type f | sed -e "s,$RPM_BUILD_ROOT,,g" >core-headers.files
524 # move base headers (actually all headers) back again
525 cp -f -r $RPM_BUILD_ROOT/_save_dir/* $RPM_BUILD_ROOT%{_includedir}
526 rm -rf $RPM_BUILD_ROOT/_save_dir
527
528 # contrib stuff:
529 (cd obj-static/contrib; make DESTDIR=$RPM_BUILD_ROOT prefix=%{_prefix} install)
530 (cd obj-shared/contrib; make DESTDIR=$RPM_BUILD_ROOT prefix=%{_prefix} install)
531
532 # utils:
533 (cd obj-shared/utils/wxrc; make DESTDIR=$RPM_BUILD_ROOT prefix=%{_prefix} install)
534
535 # wx-config link is created during package installation, remove it for now
536 rm -f $RPM_BUILD_ROOT%{_bindir}/wx-config
537
538 %clean
539 rm -rf $RPM_BUILD_ROOT
540
541 %post
542 /sbin/ldconfig
543
544 %postun
545 /sbin/ldconfig
546
547 %post devel
548 # link wx-config when you install RPM.
549 %if %{unicode}
550 ln -sf %{_libdir}/wx/config/%{wxconfig} %{_bindir}/wx-config
551 %endif
552 # link wx-config with explicit name.
553 ln -sf %{_libdir}/wx/config/%{wxconfig} %{_bindir}/%{wxconfiglink}
554 /sbin/ldconfig
555
556 %postun devel
557 /sbin/ldconfig
558
559 %preun devel
560 %if %{unicode}
561 rm -f %{_bindir}/wx-config
562 %endif
563 rm -f %{_bindir}/%{wxconfiglink}
564
565 %post -n %{wxbasename}
566 /sbin/ldconfig
567
568 %postun -n %{wxbasename}
569 /sbin/ldconfig
570
571 %post -n %{wxbasename}-devel
572 # link wx-config with explicit name.
573 ln -sf %{_libdir}/wx/config/%{wxbaseconfig} %{_bindir}/%{wxbaseconfiglink}
574 /sbin/ldconfig
575
576 %postun -n %{wxbasename}-devel
577 /sbin/ldconfig
578
579 %preun -n %{wxbasename}-devel
580 rm -f %{_bindir}/%{wxbaseconfiglink}
581
582 %post gl
583 /sbin/ldconfig
584
585 %postun gl
586 /sbin/ldconfig
587
588 %post contrib
589 /sbin/ldconfig
590
591 %postun contrib
592 /sbin/ldconfig
593
594 %post contrib-devel
595 /sbin/ldconfig
596
597 %postun contrib-devel
598 /sbin/ldconfig
599
600 %files
601 %defattr(-,root,root)
602 %doc COPYING.LIB *.txt
603 %{_libdir}/libwx_%{buildname}_adv-%{ver2}.so.*
604 %{_libdir}/libwx_%{buildname}_aui-%{ver2}.so.*
605 %{_libdir}/libwx_%{buildname}_core-%{ver2}.so.*
606 %{_libdir}/libwx_%{buildname}_html-%{ver2}.so.*
607 %{_libdir}/libwx_%{buildname}_mmedia-%{ver2}.so.*
608 %{_libdir}/libwx_%{buildname}_qa-%{ver2}.so.*
609 %{_libdir}/libwx_%{buildname}_richtext-%{ver2}.so.*
610 %{_libdir}/libwx_%{buildname}_xrc-%{ver2}.so.*
611
612 %files -n wx-i18n
613 %defattr(-,root,root)
614 %{_datadir}/locale/*/LC_MESSAGES/*.mo
615
616 %files devel -f core-headers.files
617 %defattr(-,root,root)
618 # shared libs
619 %{_libdir}/libwx_%{buildname}_adv-%{ver2}.so
620 %{_libdir}/libwx_%{buildname}_aui-%{ver2}.so
621 %{_libdir}/libwx_%{buildname}_core-%{ver2}.so
622 %{_libdir}/libwx_%{buildname}_gl-%{ver2}.so
623 %{_libdir}/libwx_%{buildname}_html-%{ver2}.so
624 %{_libdir}/libwx_%{buildname}_mmedia-%{ver2}.so
625 %{_libdir}/libwx_%{buildname}_qa-%{ver2}.so
626 %{_libdir}/libwx_%{buildname}_richtext-%{ver2}.so
627 %{_libdir}/libwx_%{buildname}_xrc-%{ver2}.so
628 # static libs
629 %{_libdir}/libwx_%{buildname}_adv-%{ver2}.a
630 %{_libdir}/libwx_%{buildname}_aui-%{ver2}.a
631 %{_libdir}/libwx_%{buildname}_core-%{ver2}.a
632 %{_libdir}/libwx_%{buildname}_gl-%{ver2}.a
633 %{_libdir}/libwx_%{buildname}_html-%{ver2}.a
634 %{_libdir}/libwx_%{buildname}_qa-%{ver2}.a
635 %{_libdir}/libwx_%{buildname}_richtext-%{ver2}.a
636 %{_libdir}/libwx_%{buildname}_xrc-%{ver2}.a
637 %dir %{_libdir}/wx
638 %{_libdir}/wx/config/%{wxconfig}
639 %{_libdir}/wx/include/%{wxconfig}/wx/setup.h
640 %{_libdir}/wx/config/%{wxconfigstatic}
641 %{_libdir}/wx/include/%{wxconfigstatic}/wx/setup.h
642 %{_bindir}/wxrc*
643
644 %files -n %{wxbasename}
645 %defattr(-,root,root)
646 %{_libdir}/libwx_base*-%{ver2}.so.*
647
648 %files -n %{wxbasename}-devel -f wxbase-headers.paths
649 %defattr (-,root,root)
650 %dir %{_includedir}/wx-%{ver2}
651 %{_libdir}/libwx_base*-%{ver2}.so
652 %{_libdir}/libwx_base*-%{ver2}.a
653 %if %{unicode}
654 %{_libdir}/libwxregexu-%{ver2}.a
655 %endif
656 %dir %{_libdir}/wx
657 %{_datadir}/aclocal/*.m4
658 %{_datadir}/bakefile/presets/*
659
660 %files gl
661 %defattr(-,root,root)
662 %{_libdir}/libwx_%{buildname}_gl-%{ver2}.so.*
663
664 %files contrib
665 %defattr(-,root,root)
666 %{_libdir}/libwx_%{buildname}_animate-%{ver2}.so.*
667 %{_libdir}/libwx_%{buildname}_deprecated-%{ver2}.so.*
668 %{_libdir}/libwx_%{buildname}_fl-%{ver2}.so.*
669 %{_libdir}/libwx_%{buildname}_gizmos-%{ver2}.so.*
670 %{_libdir}/libwx_%{buildname}_gizmos_xrc-%{ver2}.so.*
671 %{_libdir}/libwx_%{buildname}_mmedia-%{ver2}.so.*
672 %{_libdir}/libwx_%{buildname}_ogl-%{ver2}.so.*
673 %{_libdir}/libwx_%{buildname}_plot-%{ver2}.so.*
674 %{_libdir}/libwx_%{buildname}_stc-%{ver2}.so.*
675 %{_libdir}/libwx_%{buildname}_svg-%{ver2}.so.*
676
677 # static libs
678 %{_libdir}/libwx_%{buildname}_animate-%{ver2}.a
679 %{_libdir}/libwx_%{buildname}_deprecated-%{ver2}.a
680 %{_libdir}/libwx_%{buildname}_fl-%{ver2}.a
681 %{_libdir}/libwx_%{buildname}_gizmos-%{ver2}.a
682 %{_libdir}/libwx_%{buildname}_gizmos_xrc-%{ver2}.a
683 %{_libdir}/libwx_%{buildname}_mmedia-%{ver2}.a
684 %{_libdir}/libwx_%{buildname}_ogl-%{ver2}.a
685 %{_libdir}/libwx_%{buildname}_plot-%{ver2}.a
686 %{_libdir}/libwx_%{buildname}_stc-%{ver2}.a
687 %{_libdir}/libwx_%{buildname}_svg-%{ver2}.a
688
689 %files contrib-devel
690 %defattr(-,root,root)
691 %dir %{_includedir}/wx-%{ver2}/wx/animate
692 %{_includedir}/wx-%{ver2}/wx/animate/*
693 %{_libdir}/libwx_%{buildname}_animate-%{ver2}.so
694
695 %dir %{_includedir}/wx-%{ver2}/wx/deprecated
696 %{_includedir}/wx-%{ver2}/wx/deprecated/*
697 %{_libdir}/libwx_%{buildname}_deprecated-%{ver2}.so
698
699 %dir %{_includedir}/wx-%{ver2}/wx/fl
700 %{_includedir}/wx-%{ver2}/wx/fl/*
701 %{_libdir}/libwx_%{buildname}_fl-%{ver2}.so
702
703 %dir %{_includedir}/wx-%{ver2}/wx/gizmos
704 %{_includedir}/wx-%{ver2}/wx/gizmos/*
705 %{_libdir}/libwx_%{buildname}_gizmos-%{ver2}.so
706 %{_libdir}/libwx_%{buildname}_gizmos_xrc-%{ver2}.so
707
708 %dir %{_includedir}/wx-%{ver2}/wx/mmedia
709 %{_includedir}/wx-%{ver2}/wx/mmedia/*
710 %{_libdir}/libwx_%{buildname}_mmedia-%{ver2}.so
711
712 %dir %{_includedir}/wx-%{ver2}/wx/ogl
713 %{_includedir}/wx-%{ver2}/wx/ogl/*
714 %{_libdir}/libwx_%{buildname}_ogl-%{ver2}.so
715
716 %dir %{_includedir}/wx-%{ver2}/wx/plot
717 %{_includedir}/wx-%{ver2}/wx/plot/*
718 %{_libdir}/libwx_%{buildname}_plot-%{ver2}.so
719
720 %dir %{_includedir}/wx-%{ver2}/wx/stc
721 %{_includedir}/wx-%{ver2}/wx/stc/*
722 %{_libdir}/libwx_%{buildname}_stc-%{ver2}.so
723
724 %dir %{_includedir}/wx-%{ver2}/wx/svg
725 %{_includedir}/wx-%{ver2}/wx/svg/*
726 %{_libdir}/libwx_%{buildname}_svg-%{ver2}.so