]> git.saurik.com Git - wxWidgets.git/blob - wxGTK.spec
added unit tests for decoding invalid base64 strings; corrected bugs exposed by them
[wxWidgets.git] / wxGTK.spec
1 %define _prefix /usr
2 %define ver 2.9.0
3 %define ver2 2.9
4 %define rel 1
5
6 # Configurable settings (use --with(out) {unicode,gtk2} on rpmbuild cmd line):
7 %define unicode 1
8 %{?_with_unicode: %{expand: %%define unicode 1}}
9 %{?_without_unicode: %{expand: %%define unicode 0}}
10
11 %define gtk2 1
12 %{?_with_gtk2: %{expand: %%define gtk2 1}}
13 %{?_without_gtk2: %{expand: %%define gtk2 0}}
14
15 # "buildname" needs to be e.g. gtk2ud for debug builds
16 %if %{gtk2}
17 %define gtkver 2
18 %define portname gtk2
19 %if %{unicode}
20 %define buildname gtk2u
21 %else
22 %define buildname gtk2
23 %endif
24 %else
25 %define gtkver 1.2
26 %define portname gtk
27 %define buildname gtk
28 %endif
29
30 %if %{unicode}
31 %define name wx-%{portname}-unicode
32 %define wxconfig %{portname}-unicode-release-%{ver2}
33 %define wxconfigstatic %{portname}-unicode-release-static-%{ver2}
34 %define wxconfiglink wx%{portname}u-%{ver2}-config
35 %else
36 %define name wx-%{portname}-ansi
37 %define wxconfig %{portname}-ansi-release-%{ver2}
38 %define wxconfigstatic %{portname}-ansi-release-static-%{ver2}
39 %define wxconfiglink wx%{portname}-%{ver2}-config
40 %endif
41
42 %if %{unicode}
43 %define wxbasename wx-base-unicode
44 %define wxbaseconfig base-unicode-release-%{ver2}
45 %define wxbaseconfiglink wxbaseu-%{ver2}-config
46 %else
47 %define wxbasename wx-base-ansi
48 %define wxbaseconfig base-ansi-release-%{ver2}
49 %define wxbaseconfiglink wxbase-%{ver2}-config
50 %endif
51
52 Summary: The GTK+ %{gtkver} port of the wxWidgets library
53 Name: %{name}
54 Version: %{ver}
55 Release: %{rel}
56 License: wxWindows Licence
57 Group: X11/Libraries
58 Source: wxGTK-%{ver}.tar.bz2
59 URL: http://www.wxwidgets.org
60 Packager: Vadim Zeitlin <vadim@wxwindows.org>
61 Prefix: %{_prefix}
62 BuildRoot: %{_tmppath}/%{name}-root
63 Requires: %{wxbasename} = %{ver}
64 %if %{portname} == gtk2
65 BuildRequires: gtk+-2.0-devel
66 %else
67 BuildRequires: gtk+-devel >= 1.2.0
68 %endif
69
70 BuildRequires: zlib-devel, libjpeg-devel, libpng-devel, libtiff-devel
71
72 # all packages providing an implementation of wxWidgets library (regardless of
73 # the toolkit used) should provide the (virtual) wxwin package, this makes it
74 # possible to require wxwin instead of requiring "wxgtk or wxmotif or wxuniv..."
75 Provides: wxwin
76 Provides: wxGTK
77
78 %description
79 wxWidgets is a free C++ library for cross-platform GUI development.
80 With wxWidgets, you can create applications for different GUIs (GTK+,
81 Motif, MS Windows, MacOS X, Windows CE, GPE) from the same source code.
82
83 %package -n wx-i18n
84 Summary: The translations for the wxWidgets library.
85 Group: X11/Libraries
86
87 %description -n wx-i18n
88 The translations files for the wxWidgets library.
89
90 %package devel
91 Summary: The GTK+ %{gtkver} port of the wxWidgets library
92 Group: X11/Libraries
93 Requires: %{name} = %{ver}
94 Requires: %{wxbasename}-devel = %{ver}
95 Provides: wxGTK-devel
96
97 %description devel
98 The GTK+ %{gtkver} port of the wxWidgets library, header files.
99
100 %package gl
101 Summary: The GTK+ %{gtkver} port of the wxWidgets library, OpenGL add-on.
102 Group: X11/Libraries
103 Requires: %{name} = %{ver}
104 Provides: wxGTK-gl
105
106 %description gl
107 OpenGL add-on library for wxGTK, the GTK+ %{gtkver} port of the wxWidgets library.
108
109 %package -n %{wxbasename}
110 Summary: wxBase library - non-GUI support classes of the wxWidgets toolkit
111 Group: Development/Libraries
112 Provides: wxBase
113
114 %description -n %{wxbasename}
115 wxBase is a collection of C++ classes providing basic data structures (strings,
116 lists, arrays), portable wrappers around many OS-specific funstions (file
117 operations, time/date manipulations, threads, processes, sockets, shared
118 library loading) as well as other utility classes (streams, archive and
119 compression). wxBase currently supports Win32, most Unix variants (Linux,
120 FreeBSD, Solaris, HP-UX) and MacOS X (Carbon and Mach-0).
121
122 %package -n %{wxbasename}-devel
123 Summary: wxBase library, header files.
124 Group: Development/Libraries
125 Provides: wxBase-devel
126
127 %description -n %{wxbasename}-devel
128 wxBase library - non-GUI support classes of the wxWidgets toolkit,
129 header files.
130
131 %package contrib
132 Summary: The GTK+ %{gtkver} port of the wxWidgets library, contributed libraries.
133 Group: X11/Libraries
134 Requires: %{name} = %{ver}
135
136 %description contrib
137 Contributed libraries for wxGTK, the GTK+ %{gtkver} port of the wxWidgets library.
138
139 %package contrib-devel
140 Summary: The GTK+ %{gtkver} port of the wxWidgets library
141 Group: X11/Libraries
142 Requires: %{name}-contrib = %{ver}
143 Requires: %{name}-devel = %{ver}
144
145 %description contrib-devel
146 Header files for contributed libraries for wxGTK, the GTK+ %{gtkver} port of the wxWidgets library.
147
148 %prep
149 %setup -q -n wxGTK-%{ver}
150
151 %build
152 if [ "$SMP" != "" ]; then
153 export MAKE="make -j$SMP"
154 else
155 export MAKE="make"
156 fi
157
158 mkdir obj-shared
159 cd obj-shared
160 ../configure --prefix=%{_prefix} \
161 %if ! %{gtk2}
162 --with-gtk=1 \
163 %else
164 --with-gtk=2 \
165 %endif
166 %if %{unicode}
167 --enable-unicode \
168 %else
169 --disable-unicode \
170 %endif
171 --with-opengl
172 $MAKE
173
174 cd contrib/src
175 $MAKE
176 cd ../../..
177
178 mkdir obj-static
179 cd obj-static
180 ../configure --prefix=%{_prefix} \
181 %if ! %{gtk2}
182 --with-gtk=1 \
183 %else
184 --with-gtk=2 \
185 %endif
186 --disable-shared \
187 %if %{unicode}
188 --enable-unicode \
189 %else
190 --disable-unicode \
191 %endif
192 --with-opengl
193 $MAKE
194
195 cd contrib/src
196 $MAKE
197 cd ../../..
198
199 make -C locale allmo
200
201 %install
202 rm -rf $RPM_BUILD_ROOT
203 (cd obj-static; make DESTDIR=$RPM_BUILD_ROOT prefix=%{_prefix} install)
204 (cd obj-shared; make DESTDIR=$RPM_BUILD_ROOT prefix=%{_prefix} install)
205
206 # --- wxBase headers list begins here ---
207 cat <<EOF >wxbase-headers.files
208 wx/afterstd.h
209 wx/app.h
210 wx/apptrait.h
211 wx/archive.h
212 wx/arrimpl.cpp
213 wx/arrstr.h
214 wx/atomic.h
215 wx/base64.h
216 wx/beforestd.h
217 wx/buffer.h
218 wx/build.h
219 wx/chartype.h
220 wx/chkconf.h
221 wx/clntdata.h
222 wx/cmdargs.h
223 wx/cmdline.h
224 wx/confbase.h
225 wx/config.h
226 wx/convauto.h
227 wx/containr.h
228 wx/cpp.h
229 wx/crt.h
230 wx/datetime.h
231 wx/datstrm.h
232 wx/dde.h
233 wx/debug.h
234 wx/defs.h
235 wx/dir.h
236 wx/dlimpexp.h
237 wx/dynarray.h
238 wx/dynlib.h
239 wx/dynload.h
240 wx/encconv.h
241 wx/event.h
242 wx/except.h
243 wx/features.h
244 wx/flags.h
245 wx/ffile.h
246 wx/file.h
247 wx/fileconf.h
248 wx/filefn.h
249 wx/filename.h
250 wx/filesys.h
251 wx/fontenc.h
252 wx/fontmap.h
253 wx/fs_arc.h
254 wx/fs_filter.h
255 wx/fs_mem.h
256 wx/fs_zip.h
257 wx/hash.h
258 wx/hashmap.h
259 wx/hashset.h
260 wx/html/forcelnk.h
261 wx/iconloc.h
262 wx/init.h
263 wx/intl.h
264 wx/iosfwrap.h
265 wx/ioswrap.h
266 wx/ipc.h
267 wx/ipcbase.h
268 wx/link.h
269 wx/list.h
270 wx/listimpl.cpp
271 wx/log.h
272 wx/longlong.h
273 wx/math.h
274 wx/memconf.h
275 wx/memory.h
276 wx/memtext.h
277 wx/mimetype.h
278 wx/module.h
279 wx/msgout.h
280 wx/mstream.h
281 wx/object.h
282 wx/platform.h
283 wx/platinfo.h
284 wx/power.h
285 wx/process.h
286 wx/ptr_scpd.h
287 wx/ptr_shrd.h
288 wx/recguard.h
289 wx/regex.h
290 wx/scopeguard.h
291 wx/snglinst.h
292 wx/sstream.h
293 wx/stack.h
294 wx/stackwalk.h
295 wx/stdpaths.h
296 wx/stockitem.h
297 wx/stopwatch.h
298 wx/strconv.h
299 wx/stream.h
300 wx/string.h
301 wx/stringimpl.h
302 wx/stringops.h
303 wx/strvararg.h
304 wx/sysopt.h
305 wx/tarstrm.h
306 wx/textbuf.h
307 wx/textfile.h
308 wx/thread.h
309 wx/thrimpl.cpp
310 wx/timer.h
311 wx/tokenzr.h
312 wx/tracker.h
313 wx/txtstrm.h
314 wx/types.h
315 wx/unichar.h
316 wx/uri.h
317 wx/utils.h
318 wx/variant.h
319 wx/vector.h
320 wx/version.h
321 wx/volume.h
322 wx/weakref.h
323 wx/wfstream.h
324 wx/wx.h
325 wx/wxchar.h
326 wx/wxcrt.h
327 wx/wxcrtbase.h
328 wx/wxcrtvararg.h
329 wx/wxprec.h
330 wx/xti.h
331 wx/xtistrm.h
332 wx/zipstrm.h
333 wx/zstream.h
334 wx/meta/convertible.h
335 wx/meta/defs.h
336 wx/meta/int2type.h
337 wx/private/fdiodispatcher.h
338 wx/private/selectdispatcher.h
339 wx/unix/app.h
340 wx/unix/apptbase.h
341 wx/unix/apptrait.h
342 wx/unix/chkconf.h
343 wx/unix/evtloop.h
344 wx/unix/pipe.h
345 wx/unix/stdpaths.h
346 wx/unix/execute.h
347 wx/unix/mimetype.h
348 wx/unix/private.h
349 wx/private/gsocketiohandler.h
350 wx/unix/stackwalk.h
351 wx/fs_inet.h
352 wx/gsocket.h
353 wx/protocol/file.h
354 wx/protocol/ftp.h
355 wx/protocol/http.h
356 wx/protocol/protocol.h
357 wx/sckaddr.h
358 wx/sckipc.h
359 wx/sckstrm.h
360 wx/socket.h
361 wx/url.h
362 wx/unix/gsockunx.h
363 wx/xml/xml.h
364 wx/xtixml.h
365 EOF
366 # --- wxBase headers list ends here ---
367 cat <<EOF >wxbase-headers.paths
368 %{_includedir}/wx-%{ver2}/wx/afterstd.h
369 %{_includedir}/wx-%{ver2}/wx/app.h
370 %{_includedir}/wx-%{ver2}/wx/apptrait.h
371 %{_includedir}/wx-%{ver2}/wx/archive.h
372 %{_includedir}/wx-%{ver2}/wx/arrimpl.cpp
373 %{_includedir}/wx-%{ver2}/wx/arrstr.h
374 %{_includedir}/wx-%{ver2}/wx/beforestd.h
375 %{_includedir}/wx-%{ver2}/wx/buffer.h
376 %{_includedir}/wx-%{ver2}/wx/build.h
377 %{_includedir}/wx-%{ver2}/wx/chkconf.h
378 %{_includedir}/wx-%{ver2}/wx/clntdata.h
379 %{_includedir}/wx-%{ver2}/wx/cmdline.h
380 %{_includedir}/wx-%{ver2}/wx/confbase.h
381 %{_includedir}/wx-%{ver2}/wx/config.h
382 %{_includedir}/wx-%{ver2}/wx/containr.h
383 %{_includedir}/wx-%{ver2}/wx/convauto.h
384 %{_includedir}/wx-%{ver2}/wx/datetime.h
385 %{_includedir}/wx-%{ver2}/wx/datstrm.h
386 %{_includedir}/wx-%{ver2}/wx/dde.h
387 %{_includedir}/wx-%{ver2}/wx/debug.h
388 %{_includedir}/wx-%{ver2}/wx/defs.h
389 %{_includedir}/wx-%{ver2}/wx/dir.h
390 %{_includedir}/wx-%{ver2}/wx/dlimpexp.h
391 %{_includedir}/wx-%{ver2}/wx/dynarray.h
392 %{_includedir}/wx-%{ver2}/wx/dynlib.h
393 %{_includedir}/wx-%{ver2}/wx/dynload.h
394 %{_includedir}/wx-%{ver2}/wx/encconv.h
395 %{_includedir}/wx-%{ver2}/wx/event.h
396 %{_includedir}/wx-%{ver2}/wx/except.h
397 %{_includedir}/wx-%{ver2}/wx/features.h
398 %{_includedir}/wx-%{ver2}/wx/ffile.h
399 %{_includedir}/wx-%{ver2}/wx/file.h
400 %{_includedir}/wx-%{ver2}/wx/fileconf.h
401 %{_includedir}/wx-%{ver2}/wx/filefn.h
402 %{_includedir}/wx-%{ver2}/wx/filename.h
403 %{_includedir}/wx-%{ver2}/wx/filesys.h
404 %{_includedir}/wx-%{ver2}/wx/fontenc.h
405 %{_includedir}/wx-%{ver2}/wx/fontmap.h
406 %{_includedir}/wx-%{ver2}/wx/fs_mem.h
407 %{_includedir}/wx-%{ver2}/wx/fs_zip.h
408 %{_includedir}/wx-%{ver2}/wx/hash.h
409 %{_includedir}/wx-%{ver2}/wx/hashmap.h
410 %{_includedir}/wx-%{ver2}/wx/hashset.h
411 %{_includedir}/wx-%{ver2}/wx/html/forcelnk.h
412 %{_includedir}/wx-%{ver2}/wx/iconloc.h
413 %{_includedir}/wx-%{ver2}/wx/init.h
414 %{_includedir}/wx-%{ver2}/wx/intl.h
415 %{_includedir}/wx-%{ver2}/wx/iosfwrap.h
416 %{_includedir}/wx-%{ver2}/wx/ioswrap.h
417 %{_includedir}/wx-%{ver2}/wx/ipc.h
418 %{_includedir}/wx-%{ver2}/wx/ipcbase.h
419 %{_includedir}/wx-%{ver2}/wx/isql.h
420 %{_includedir}/wx-%{ver2}/wx/isqlext.h
421 %{_includedir}/wx-%{ver2}/wx/link.h
422 %{_includedir}/wx-%{ver2}/wx/list.h
423 %{_includedir}/wx-%{ver2}/wx/listimpl.cpp
424 %{_includedir}/wx-%{ver2}/wx/log.h
425 %{_includedir}/wx-%{ver2}/wx/longlong.h
426 %{_includedir}/wx-%{ver2}/wx/math.h
427 %{_includedir}/wx-%{ver2}/wx/memconf.h
428 %{_includedir}/wx-%{ver2}/wx/memory.h
429 %{_includedir}/wx-%{ver2}/wx/memtext.h
430 %{_includedir}/wx-%{ver2}/wx/mimetype.h
431 %{_includedir}/wx-%{ver2}/wx/module.h
432 %{_includedir}/wx-%{ver2}/wx/msgout.h
433 %{_includedir}/wx-%{ver2}/wx/mstream.h
434 %{_includedir}/wx-%{ver2}/wx/object.h
435 %{_includedir}/wx-%{ver2}/wx/platform.h
436 %{_includedir}/wx-%{ver2}/wx/power.h
437 %{_includedir}/wx-%{ver2}/wx/process.h
438 %{_includedir}/wx-%{ver2}/wx/ptr_scpd.h
439 %{_includedir}/wx-%{ver2}/wx/recguard.h
440 %{_includedir}/wx-%{ver2}/wx/regex.h
441 %{_includedir}/wx-%{ver2}/wx/scopeguard.h
442 %{_includedir}/wx-%{ver2}/wx/snglinst.h
443 %{_includedir}/wx-%{ver2}/wx/sstream.h
444 %{_includedir}/wx-%{ver2}/wx/stack.h
445 %{_includedir}/wx-%{ver2}/wx/stackwalk.h
446 %{_includedir}/wx-%{ver2}/wx/stdpaths.h
447 %{_includedir}/wx-%{ver2}/wx/stockitem.h
448 %{_includedir}/wx-%{ver2}/wx/stopwatch.h
449 %{_includedir}/wx-%{ver2}/wx/strconv.h
450 %{_includedir}/wx-%{ver2}/wx/stream.h
451 %{_includedir}/wx-%{ver2}/wx/string.h
452 %{_includedir}/wx-%{ver2}/wx/sysopt.h
453 %{_includedir}/wx-%{ver2}/wx/textbuf.h
454 %{_includedir}/wx-%{ver2}/wx/textfile.h
455 %{_includedir}/wx-%{ver2}/wx/thread.h
456 %{_includedir}/wx-%{ver2}/wx/thrimpl.cpp
457 %{_includedir}/wx-%{ver2}/wx/timer.h
458 %{_includedir}/wx-%{ver2}/wx/tokenzr.h
459 %{_includedir}/wx-%{ver2}/wx/txtstrm.h
460 %{_includedir}/wx-%{ver2}/wx/types.h
461 %{_includedir}/wx-%{ver2}/wx/uri.h
462 %{_includedir}/wx-%{ver2}/wx/utils.h
463 %{_includedir}/wx-%{ver2}/wx/variant.h
464 %{_includedir}/wx-%{ver2}/wx/vector.h
465 %{_includedir}/wx-%{ver2}/wx/version.h
466 %{_includedir}/wx-%{ver2}/wx/volume.h
467 %{_includedir}/wx-%{ver2}/wx/wfstream.h
468 %{_includedir}/wx-%{ver2}/wx/wx.h
469 %{_includedir}/wx-%{ver2}/wx/wxchar.h
470 %{_includedir}/wx-%{ver2}/wx/wxprec.h
471 %{_includedir}/wx-%{ver2}/wx/xti.h
472 %{_includedir}/wx-%{ver2}/wx/xtistrm.h
473 %{_includedir}/wx-%{ver2}/wx/zipstrm.h
474 %{_includedir}/wx-%{ver2}/wx/zstream.h
475 %{_includedir}/wx-%{ver2}/wx/fs_inet.h
476 %{_includedir}/wx-%{ver2}/wx/gsocket.h
477 %{_includedir}/wx-%{ver2}/wx/protocol/file.h
478 %{_includedir}/wx-%{ver2}/wx/protocol/ftp.h
479 %{_includedir}/wx-%{ver2}/wx/protocol/http.h
480 %{_includedir}/wx-%{ver2}/wx/protocol/protocol.h
481 %{_includedir}/wx-%{ver2}/wx/sckaddr.h
482 %{_includedir}/wx-%{ver2}/wx/sckipc.h
483 %{_includedir}/wx-%{ver2}/wx/sckstrm.h
484 %{_includedir}/wx-%{ver2}/wx/socket.h
485 %{_includedir}/wx-%{ver2}/wx/url.h
486 %{_includedir}/wx-%{ver2}/wx/xml/xml.h
487 %{_includedir}/wx-%{ver2}/wx/xtixml.h
488 %{_includedir}/wx-%{ver2}/wx/unix/apptbase.h
489 %{_includedir}/wx-%{ver2}/wx/unix/apptrait.h
490 %{_includedir}/wx-%{ver2}/wx/unix/execute.h
491 %{_includedir}/wx-%{ver2}/wx/unix/gsockunx.h
492 %{_includedir}/wx-%{ver2}/wx/unix/mimetype.h
493 %{_includedir}/wx-%{ver2}/wx/unix/pipe.h
494 %{_includedir}/wx-%{ver2}/wx/unix/private.h
495 %{_includedir}/wx-%{ver2}/wx/unix/stackwalk.h
496 %{_includedir}/wx-%{ver2}/wx/unix/stdpaths.h
497 EOF
498 # --- wxBase headers list ends here ---
499
500 # temporarily remove base headers
501 mkdir $RPM_BUILD_ROOT/_save_dir
502 cp -r $RPM_BUILD_ROOT%{_includedir}/wx-%{ver2} $RPM_BUILD_ROOT/_save_dir
503 for f in `cat wxbase-headers.files` ; do
504 rm -f $RPM_BUILD_ROOT%{_includedir}/wx-%{ver2}/$f
505 done
506 # list of all core headers:
507 find $RPM_BUILD_ROOT%{_includedir}/wx-%{ver2} -type f | sed -e "s,$RPM_BUILD_ROOT,,g" >core-headers.files
508 # move base headers (actually all headers) back again
509 cp -f -r $RPM_BUILD_ROOT/_save_dir/* $RPM_BUILD_ROOT%{_includedir}
510 rm -rf $RPM_BUILD_ROOT/_save_dir
511
512 # contrib stuff:
513 (cd obj-static/contrib; make DESTDIR=$RPM_BUILD_ROOT prefix=%{_prefix} install)
514 (cd obj-shared/contrib; make DESTDIR=$RPM_BUILD_ROOT prefix=%{_prefix} install)
515
516 # utils:
517 (cd obj-shared/utils/wxrc; make DESTDIR=$RPM_BUILD_ROOT prefix=%{_prefix} install)
518
519 # wx-config link is created during package installation, remove it for now
520 rm -f $RPM_BUILD_ROOT%{_bindir}/wx-config
521
522 %clean
523 rm -rf $RPM_BUILD_ROOT
524
525 %post
526 /sbin/ldconfig
527
528 %postun
529 /sbin/ldconfig
530
531 %post devel
532 # link wx-config when you install RPM.
533 %if %{unicode}
534 ln -sf %{_libdir}/wx/config/%{wxconfig} %{_bindir}/wx-config
535 %endif
536 # link wx-config with explicit name.
537 ln -sf %{_libdir}/wx/config/%{wxconfig} %{_bindir}/%{wxconfiglink}
538 /sbin/ldconfig
539
540 %postun devel
541 /sbin/ldconfig
542
543 %preun devel
544 %if %{unicode}
545 rm -f %{_bindir}/wx-config
546 %endif
547 rm -f %{_bindir}/%{wxconfiglink}
548
549 %post -n %{wxbasename}
550 /sbin/ldconfig
551
552 %postun -n %{wxbasename}
553 /sbin/ldconfig
554
555 %post -n %{wxbasename}-devel
556 # link wx-config with explicit name.
557 ln -sf %{_libdir}/wx/config/%{wxbaseconfig} %{_bindir}/%{wxbaseconfiglink}
558 /sbin/ldconfig
559
560 %postun -n %{wxbasename}-devel
561 /sbin/ldconfig
562
563 %preun -n %{wxbasename}-devel
564 rm -f %{_bindir}/%{wxbaseconfiglink}
565
566 %post gl
567 /sbin/ldconfig
568
569 %postun gl
570 /sbin/ldconfig
571
572 %post contrib
573 /sbin/ldconfig
574
575 %postun contrib
576 /sbin/ldconfig
577
578 %post contrib-devel
579 /sbin/ldconfig
580
581 %postun contrib-devel
582 /sbin/ldconfig
583
584 %files
585 %defattr(-,root,root)
586 %doc COPYING.LIB *.txt
587 %{_libdir}/libwx_%{buildname}_adv-%{ver2}.so.*
588 %{_libdir}/libwx_%{buildname}_aui-%{ver2}.so.*
589 %{_libdir}/libwx_%{buildname}_core-%{ver2}.so.*
590 %{_libdir}/libwx_%{buildname}_html-%{ver2}.so.*
591 %{_libdir}/libwx_%{buildname}_mmedia-%{ver2}.so.*
592 %{_libdir}/libwx_%{buildname}_qa-%{ver2}.so.*
593 %{_libdir}/libwx_%{buildname}_richtext-%{ver2}.so.*
594 %{_libdir}/libwx_%{buildname}_xrc-%{ver2}.so.*
595
596 %files -n wx-i18n
597 %defattr(-,root,root)
598 %{_datadir}/locale/*/LC_MESSAGES/*.mo
599
600 %files devel -f core-headers.files
601 %defattr(-,root,root)
602 # shared libs
603 %{_libdir}/libwx_%{buildname}_adv-%{ver2}.so
604 %{_libdir}/libwx_%{buildname}_aui-%{ver2}.so
605 %{_libdir}/libwx_%{buildname}_core-%{ver2}.so
606 %{_libdir}/libwx_%{buildname}_gl-%{ver2}.so
607 %{_libdir}/libwx_%{buildname}_html-%{ver2}.so
608 %{_libdir}/libwx_%{buildname}_mmedia-%{ver2}.so
609 %{_libdir}/libwx_%{buildname}_qa-%{ver2}.so
610 %{_libdir}/libwx_%{buildname}_richtext-%{ver2}.so
611 %{_libdir}/libwx_%{buildname}_xrc-%{ver2}.so
612 # static libs
613 %{_libdir}/libwx_%{buildname}_adv-%{ver2}.a
614 %{_libdir}/libwx_%{buildname}_aui-%{ver2}.a
615 %{_libdir}/libwx_%{buildname}_core-%{ver2}.a
616 %{_libdir}/libwx_%{buildname}_gl-%{ver2}.a
617 %{_libdir}/libwx_%{buildname}_html-%{ver2}.a
618 %{_libdir}/libwx_%{buildname}_qa-%{ver2}.a
619 %{_libdir}/libwx_%{buildname}_richtext-%{ver2}.a
620 %{_libdir}/libwx_%{buildname}_xrc-%{ver2}.a
621 %dir %{_libdir}/wx
622 %{_libdir}/wx/config/%{wxconfig}
623 %{_libdir}/wx/include/%{wxconfig}/wx/setup.h
624 %{_libdir}/wx/config/%{wxconfigstatic}
625 %{_libdir}/wx/include/%{wxconfigstatic}/wx/setup.h
626 %{_bindir}/wxrc*
627
628 %files -n %{wxbasename}
629 %defattr(-,root,root)
630 %{_libdir}/libwx_base*-%{ver2}.so.*
631
632 %files -n %{wxbasename}-devel -f wxbase-headers.paths
633 %defattr (-,root,root)
634 %dir %{_includedir}/wx-%{ver2}
635 %{_libdir}/libwx_base*-%{ver2}.so
636 %{_libdir}/libwx_base*-%{ver2}.a
637 %if %{unicode}
638 %{_libdir}/libwxregexu-%{ver2}.a
639 %endif
640 %dir %{_libdir}/wx
641 %{_datadir}/aclocal/*.m4
642 %{_datadir}/bakefile/presets/*
643
644 %files gl
645 %defattr(-,root,root)
646 %{_libdir}/libwx_%{buildname}_gl-%{ver2}.so.*
647
648 %files contrib
649 %defattr(-,root,root)
650 %{_libdir}/libwx_%{buildname}_animate-%{ver2}.so.*
651 %{_libdir}/libwx_%{buildname}_deprecated-%{ver2}.so.*
652 %{_libdir}/libwx_%{buildname}_fl-%{ver2}.so.*
653 %{_libdir}/libwx_%{buildname}_gizmos-%{ver2}.so.*
654 %{_libdir}/libwx_%{buildname}_gizmos_xrc-%{ver2}.so.*
655 %{_libdir}/libwx_%{buildname}_mmedia-%{ver2}.so.*
656 %{_libdir}/libwx_%{buildname}_ogl-%{ver2}.so.*
657 %{_libdir}/libwx_%{buildname}_plot-%{ver2}.so.*
658 %{_libdir}/libwx_%{buildname}_stc-%{ver2}.so.*
659 %{_libdir}/libwx_%{buildname}_svg-%{ver2}.so.*
660
661 # static libs
662 %{_libdir}/libwx_%{buildname}_animate-%{ver2}.a
663 %{_libdir}/libwx_%{buildname}_deprecated-%{ver2}.a
664 %{_libdir}/libwx_%{buildname}_fl-%{ver2}.a
665 %{_libdir}/libwx_%{buildname}_gizmos-%{ver2}.a
666 %{_libdir}/libwx_%{buildname}_gizmos_xrc-%{ver2}.a
667 %{_libdir}/libwx_%{buildname}_mmedia-%{ver2}.a
668 %{_libdir}/libwx_%{buildname}_ogl-%{ver2}.a
669 %{_libdir}/libwx_%{buildname}_plot-%{ver2}.a
670 %{_libdir}/libwx_%{buildname}_stc-%{ver2}.a
671 %{_libdir}/libwx_%{buildname}_svg-%{ver2}.a
672
673 %files contrib-devel
674 %defattr(-,root,root)
675 %dir %{_includedir}/wx-%{ver2}/wx/animate
676 %{_includedir}/wx-%{ver2}/wx/animate/*
677 %{_libdir}/libwx_%{buildname}_animate-%{ver2}.so
678
679 %dir %{_includedir}/wx-%{ver2}/wx/deprecated
680 %{_includedir}/wx-%{ver2}/wx/deprecated/*
681 %{_libdir}/libwx_%{buildname}_deprecated-%{ver2}.so
682
683 %dir %{_includedir}/wx-%{ver2}/wx/fl
684 %{_includedir}/wx-%{ver2}/wx/fl/*
685 %{_libdir}/libwx_%{buildname}_fl-%{ver2}.so
686
687 %dir %{_includedir}/wx-%{ver2}/wx/gizmos
688 %{_includedir}/wx-%{ver2}/wx/gizmos/*
689 %{_libdir}/libwx_%{buildname}_gizmos-%{ver2}.so
690 %{_libdir}/libwx_%{buildname}_gizmos_xrc-%{ver2}.so
691
692 %dir %{_includedir}/wx-%{ver2}/wx/mmedia
693 %{_includedir}/wx-%{ver2}/wx/mmedia/*
694 %{_libdir}/libwx_%{buildname}_mmedia-%{ver2}.so
695
696 %dir %{_includedir}/wx-%{ver2}/wx/ogl
697 %{_includedir}/wx-%{ver2}/wx/ogl/*
698 %{_libdir}/libwx_%{buildname}_ogl-%{ver2}.so
699
700 %dir %{_includedir}/wx-%{ver2}/wx/plot
701 %{_includedir}/wx-%{ver2}/wx/plot/*
702 %{_libdir}/libwx_%{buildname}_plot-%{ver2}.so
703
704 %dir %{_includedir}/wx-%{ver2}/wx/stc
705 %{_includedir}/wx-%{ver2}/wx/stc/*
706 %{_libdir}/libwx_%{buildname}_stc-%{ver2}.so
707
708 %dir %{_includedir}/wx-%{ver2}/wx/svg
709 %{_includedir}/wx-%{ver2}/wx/svg/*
710 %{_libdir}/libwx_%{buildname}_svg-%{ver2}.so