6 # Configurable settings (use --with(out) unicode on rpmbuild cmd line):
8 %{?_with_unicode: %{expand: %%define unicode 1}}
9 %{?_without_unicode: %{expand: %%define unicode 0}}
11 %define portname x11univ
14 %define wxbasename wx
-base
-unicode
15 %define name wx
-%{portname}-unicode
16 %define wxconfig
%{portname}-unicode-%{ver2}
17 %define wxconfiglink wx
%{portname}u-%{ver2}-config
19 %define wxbasename wx
-base
20 %define name wx
-%{portname}
21 %define wxconfig
%{portname}-ansi-%{ver2}
22 %define wxconfiglink wx
%{portname}-%{ver2}-config
25 Summary: The X11 port of the wxWidgets library
29 License: wxWindows Licence
31 Source: wxX11
-%{ver}.tar.bz2
32 URL: http
://www.wxwidgets.org
33 Packager: Vadim Zeitlin
<vadim@wxwindows.org
>
35 BuildRoot: %{_tmppath}/%{name}-root
36 Requires: %{wxbasename} = %{ver}
38 # all packages providing an implementation of wxWidgets library (regardless of
39 # the toolkit used) should provide the (virtual) wxwin package, this makes it
40 # possible to require wxwin instead of requiring "wxgtk or wxmotif or wxuniv..."
45 wxWidgets is a free C
++ library
for cross
-platform GUI development.
46 With wxWidgets
, you can create applications
for different GUIs
(GTK
+,
47 Motif
/LessTif
, MS Windows
, Mac
) from the same
source code.
50 Summary: The X11 port of the wxWidgets library
52 Requires: %{name} = %{ver}
53 Requires: %{wxbasename}-devel = %{ver}
56 Header files
for wxX11
, the X11 port of the wxWidgets library.
59 Summary: The X11 port of the wxWidgets library
, OpenGL add
-on.
61 Requires: %{name} = %{ver}
64 OpenGL add
-on library
for wxX11
, the X11 port of the wxWidgets library.
67 Summary: wxX11 static libraries
68 Group: Development
/Libraries
69 Requires: %{wxbasename}-static
70 Requires: %{name}-devel = %{ver}
73 Static libraries
for wxX11. You need them
if you want to link statically against wxX11.
76 %setup -q
-n wxX11
-%{ver}
79 if [ "$SMP"
!= ""
]; then
80 export MAKE
="
make -j$SMP"
87 ..
/configure
--prefix
=%{pref} --with
-x11 \
98 ..
/configure
--prefix
=%{pref} --with
-x11
--disable
-shared \
109 rm -rf $RPM_BUILD_ROOT
110 (cd obj
-static
; make prefix
=$RPM_BUILD_ROOT
%{pref} install)
111 (cd obj
-shared
; make prefix
=$RPM_BUILD_ROOT
%{pref} install)
113 # Remove headers that are part of wx-base-devel:
115 # --- wxBase headers list begins here ---
116 cat
<<EOF
>wxbase
-headers.files
272 wx
/meta
/convertible.h
274 wx
/meta
/implicitconversion.h
280 wx
/generic
/fswatcher.h
291 wx
/unix
/fswatcher_kqueue.h
294 wx
/unix
/fswatcher_inotify.h
300 wx
/protocol
/protocol.h
309 # --- wxBase headers list ends here ---
310 for f
in `cat wxbase
-headers
-list`
; do
311 rm -f $RPM_BUILD_ROOT
%{_includedir}/wx-%{ver2}/$f
314 # list of all core headers:
315 find $RPM_BUILD_ROOT
%{_includedir}/wx-%{ver2} -type f | sed
-e "s
,$RPM_BUILD_ROOT
,,g"
>core
-headers.files
317 # remove wxBase files so that RPM doesn't complain about unpackaged files:
318 rm -f $RPM_BUILD_ROOT
%{_libdir}/libwx_base
*
320 rm -f $RPM_BUILD_ROOT
%{_libdir}/libwxregexu-%{ver2}.a
322 rm -f $RPM_BUILD_ROOT
%{_datadir}/aclocal
/*
323 rm -f $RPM_BUILD_ROOT
%{_datadir}/locale
/*/*/*
326 rm -rf $RPM_BUILD_ROOT
335 # link wx-config when you install RPM.
336 ln
-sf
%{_libdir}/wx/config/%{wxconfig} %{_bindir}/wx
-config
337 # link wx-config with explicit name.
338 ln
-sf
%{_libdir}/wx/config/%{wxconfig} %{_bindir}/%{wxconfiglink}
345 if test -f
%{_bindir}/wx
-config
-a
-f
/usr
/bin
/md5sum
; then
346 SUM1
=`md5sum
%{_libdir}/wx/config/%{wxconfig} | cut
-c
0-32`
347 SUM2
=`md5sum
%{_bindir}/wx
-config | cut
-c
0-32`
348 if test "x$SUM1"
= "x$SUM2"
; then
349 rm -f
%{_bindir}/wx
-config
352 rm -f
%{_bindir}/%{wxconfiglink}
361 %defattr(-,root
,root
)
362 %doc COPYING.LIB
*.txt
363 %{_libdir}/libwx_%{portname}*_adv-%{ver2}.so.
*
364 %{_libdir}/libwx_%{portname}*_core-%{ver2}.so.
*
365 %{_libdir}/libwx_%{portname}*_html-%{ver2}.so.
*
366 %{_libdir}/libwx_%{portname}*_media-%{ver2}.so.
*
367 %{_libdir}/libwx_%{portname}*_qa-%{ver2}.so.
*
368 %{_libdir}/libwx_%{portname}*_xrc-%{ver2}.so.
*
371 %files devel
-f core
-headers.files
372 %defattr(-,root
,root
)
373 %{_libdir}/libwx_%{portname}*_adv-%{ver2}.so
374 %{_libdir}/libwx_%{portname}*_core-%{ver2}.so
375 %{_libdir}/libwx_%{portname}*_gl-%{ver2}.so
376 %{_libdir}/libwx_%{portname}*_html-%{ver2}.so
377 %{_libdir}/libwx_%{portname}*_media-%{ver2}.so
378 %{_libdir}/libwx_%{portname}*_qa-%{ver2}.so
379 %{_libdir}/libwx_%{portname}*_xrc-%{ver2}.so
385 %defattr(-,root
,root
)
386 %{_libdir}/libwx_%{portname}*_gl-%{ver2}.so.
*
389 %defattr (-,root
,root
)
390 %{_libdir}/libwx_%{portname}*_*-%{ver2}.a