7 %define name wx
-%{portname}
8 %define wxbasename wx
-base
10 %define wxconfig
%{portname}-ansi-release-%{ver2}
11 %define wxconfiglink wx
%{portname}-%{ver2}-config
13 Summary: The Motif
/Lesstif port of the wxWidgets library
17 License: wxWindows Licence
19 Source: wxMotif
-%{ver}.tar.bz2
20 URL: http
://www.wxwidgets.org
21 Packager: wxWidgets developers
<wx
-dev@lists.wxwidgets.org
>
22 BuildRoot: %{_tmppath}/%{name}-root
23 Requires: %{wxbasename} = %{ver}
25 # all packages providing an implementation of wxWidgets library (regardless of
26 # the toolkit used) should provide the (virtual) wxwin package, this makes it
27 # possible to require wxwin instead of requiring "wxgtk or wxmotif or wxuniv..."
32 wxWidgets is a free C
++ library
for cross
-platform GUI development.
33 With wxWidgets
, you can create applications
for different GUIs
(GTK
+,
34 Motif
/LessTif
, MS Windows
, Mac
) from the same
source code.
37 Summary: The Motif
/Lesstif port of the wxWidgets library
39 Requires: %{name} = %{ver}
40 Requires: %{wxbasename}-devel = %{ver}
43 Header files
for wxMotif
, the Motif
/Lesstif port of the wxWidgets library.
46 Summary: The Motif
/Lesstif port of the wxWidgets library
, OpenGL add
-on.
48 Requires: %{name} = %{ver}
51 OpenGL add
-on library
for wxMotif
, the Motif
/Lesstif port of the wxWidgets library.
54 Summary: wxMotif static libraries
55 Group: Development
/Libraries
56 Requires: %{wxbasename}-static
57 Requires: %{name}-devel = %{ver}
60 Static libraries
for wxMotif. You need them
if you want to link statically against wxMotif.
63 Summary: Contrib libraries
for wxMotif
65 Requires: %{name} = %{ver}
68 Contrib libraries
for wxMotif
70 %package contrib
-devel
71 Summary: Contrib libraries
for wxMotif
73 Requires: %{name}-contrib = %{ver}
74 Requires: %{name}-devel = %{ver}
76 %description contrib
-devel
77 Header files
for contributed libraries
for wxMotif.
80 %setup -q
-n wxMotif
-%{ver}
83 if [ "$SMP"
!= ""
]; then
84 export MAKE
="
make -j$SMP"
91 ..
/configure
--prefix
=%{pref} --with
-motif
--with
-opengl
100 ..
/configure
--prefix
=%{pref} --with
-motif
--disable
-shared
--with
-opengl
105 rm -rf $RPM_BUILD_ROOT
106 (cd obj
-static
; make prefix
=$RPM_BUILD_ROOT
%{pref} install)
107 (cd obj
-shared
; make prefix
=$RPM_BUILD_ROOT
%{pref} install)
109 # Remove headers that are part of wx-base-devel:
111 # --- wxBase headers list begins here ---
112 cat
<<EOF
>wxbase
-headers.files
256 wx
/meta
/convertible.h
261 wx
/generic
/fswatcher.h
272 wx
/unix
/fswatcher_kqueue.h
275 wx
/unix
/fswatcher_inotify.h
281 wx
/protocol
/protocol.h
290 # --- wxBase headers list ends here ---
291 for f
in `cat wxbase
-headers
-list`
; do
292 rm -f $RPM_BUILD_ROOT
%{_includedir}/wx-%{ver2}/$f
295 # list of all core headers:
296 find $RPM_BUILD_ROOT
%{_includedir}/wx-%{ver2} -type f | sed
-e "s
,$RPM_BUILD_ROOT
,,g"
>core
-headers.files
299 (cd obj
-shared
/contrib
/src
; make prefix
=$RPM_BUILD_ROOT
%{pref} install)
300 (cd obj
-shared
/utils
/wxrc
; make prefix
=$RPM_BUILD_ROOT
%{pref} install)
302 # remove wxBase files so that RPM doesn't complain about unpackaged files:
303 rm -f $RPM_BUILD_ROOT
%{_libdir}/libwx_base
*
304 rm -f $RPM_BUILD_ROOT
%{_datadir}/aclocal
/*
305 rm -f $RPM_BUILD_ROOT
%{_datadir}/locale
/*/*/*
308 rm -rf $RPM_BUILD_ROOT
317 # link wx-config when you install RPM.
318 ln
-sf
%{_libdir}/wx/config/%{wxconfig} %{_bindir}/wx
-config
319 # link wx-config with explicit name.
320 ln
-sf
%{_libdir}/wx/config/%{wxconfig} %{_bindir}/%{wxconfiglink}
327 if test -f
%{_bindir}/wx
-config
-a
-f
/usr
/bin
/md5sum
; then
328 SUM1
=`md5sum
%{_libdir}/wx/config/%{wxconfig} | cut
-c
0-32`
329 SUM2
=`md5sum
%{_bindir}/wx
-config | cut
-c
0-32`
330 if test "x$SUM1"
= "x$SUM2"
; then
331 rm -f
%{_bindir}/wx
-config
334 rm -f
%{_bindir}/%{wxconfiglink}
351 %postun contrib
-devel
355 %defattr(-,root
,root
)
356 %doc COPYING.LIB
*.txt
357 %{_libdir}/libwx_%{portname}*_adv-%{ver2}.so.
*
358 %{_libdir}/libwx_%{portname}*_core-%{ver2}.so.
*
359 %{_libdir}/libwx_%{portname}*_html-%{ver2}.so.
*
360 %{_libdir}/libwx_%{portname}*_media-%{ver2}.so.
*
361 %{_libdir}/libwx_%{portname}*_qa-%{ver2}.so.
*
362 %{_libdir}/libwx_%{portname}*_xrc-%{ver2}.so.
*
365 %files devel
-f core
-headers.files
366 %defattr(-,root
,root
)
367 %{_libdir}/libwx_%{portname}*_adv-%{ver2}.so
368 %{_libdir}/libwx_%{portname}*_core-%{ver2}.so
369 %{_libdir}/libwx_%{portname}*_gl-%{ver2}.so
370 %{_libdir}/libwx_%{portname}*_html-%{ver2}.so
371 %{_libdir}/libwx_%{portname}*_media-%{ver2}.so
372 %{_libdir}/libwx_%{portname}*_qa-%{ver2}.so
373 %{_libdir}/libwx_%{portname}*_xrc-%{ver2}.so
379 %defattr(-,root
,root
)
380 %{_libdir}/libwx_%{portname}*_gl-%{ver2}.so.
*
383 %defattr (-,root
,root
)
384 %{_libdir}/libwx_%{portname}*_*-%{ver2}.a
387 %defattr(-,root
,root
)
388 %{_libdir}/libwx_%{portname}*_animate-%{ver2}.so.
*
389 %{_libdir}/libwx_%{portname}*_deprecated-%{ver2}.so.
*
390 %{_libdir}/libwx_%{portname}*_fl-%{ver2}.so.
*
391 %{_libdir}/libwx_%{portname}*_gizmos-%{ver2}.so.
*
392 %{_libdir}/libwx_%{portname}*_mmedia-%{ver2}.so.
*
393 %{_libdir}/libwx_%{portname}*_ogl-%{ver2}.so.
*
394 %{_libdir}/libwx_%{portname}*_plot-%{ver2}.so.
*
395 %{_libdir}/libwx_%{portname}*_stc-%{ver2}.so.
*
396 %{_libdir}/libwx_%{portname}*_svg-%{ver2}.so.
*
399 %defattr(-,root
,root
)
400 %dir %{_includedir}/wx-%{ver2}/wx
/animate
401 %{_includedir}/wx-%{ver2}/wx
/animate
/*
402 %{_libdir}/libwx_%{portname}*_animate-%{ver2}.so
404 %dir %{_includedir}/wx-%{ver2}/wx
/deprecated
405 %{_includedir}/wx-%{ver2}/wx
/deprecated
/*
406 %{_libdir}/libwx_%{portname}*_deprecated-%{ver2}.so
408 %dir %{_includedir}/wx-%{ver2}/wx
/fl
409 %{_includedir}/wx-%{ver2}/wx
/fl
/*
410 %{_libdir}/libwx_%{portname}*_fl-%{ver2}.so
412 %dir %{_includedir}/wx-%{ver2}/wx
/gizmos
413 %{_includedir}/wx-%{ver2}/wx
/gizmos
/*
414 %{_libdir}/libwx_%{portname}*_gizmos-%{ver2}.so
416 %dir %{_includedir}/wx-%{ver2}/wx
/mmedia
417 %{_includedir}/wx-%{ver2}/wx
/mmedia
/*
418 %{_libdir}/libwx_%{portname}*_mmedia-%{ver2}.so
420 %dir %{_includedir}/wx-%{ver2}/wx
/ogl
421 %{_includedir}/wx-%{ver2}/wx
/ogl
/*
422 %{_libdir}/libwx_%{portname}*_ogl-%{ver2}.so
424 %dir %{_includedir}/wx-%{ver2}/wx
/plot
425 %{_includedir}/wx-%{ver2}/wx
/plot
/*
426 %{_libdir}/libwx_%{portname}*_plot-%{ver2}.so
428 %dir %{_includedir}/wx-%{ver2}/wx
/stc
429 %{_includedir}/wx-%{ver2}/wx
/stc
/*
430 %{_libdir}/libwx_%{portname}*_stc-%{ver2}.so
432 %dir %{_includedir}/wx-%{ver2}/wx
/svg
433 %{_includedir}/wx-%{ver2}/wx
/svg
/*
434 %{_libdir}/libwx_%{portname}*_svg-%{ver2}.so