Rebake everything using bakefile 0.2.7.
[wxWidgets.git] / wxMotif.spec
1 %define pref /usr
2 %define ver 2.9.1
3 %define ver2 2.9
4 %define rel 1
5
6 %define portname motif
7 %define name wx-%{portname}
8 %define wxbasename wx-base
9
10 %define wxconfig %{portname}-ansi-release-%{ver2}
11 %define wxconfiglink wx%{portname}-%{ver2}-config
12
13 Summary: The Motif/Lesstif port of the wxWidgets library
14 Name: %{name}
15 Version: %{ver}
16 Release: %{rel}
17 License: wxWindows Licence
18 Group: X11/Libraries
19 Source: wxMotif-%{ver}.tar.bz2
20 URL: http://www.wxwidgets.org
21 Packager: wxWidgets developers <wx-dev@lists.wxwidgets.org>
22 BuildRoot: %{_tmppath}/%{name}-root
23 Requires: %{wxbasename} = %{ver}
24
25 # all packages providing an implementation of wxWidgets library (regardless of
26 # the toolkit used) should provide the (virtual) wxwin package, this makes it
27 # possible to require wxwin instead of requiring "wxgtk or wxmotif or wxuniv..."
28 Provides: wxwin
29 Provides: wxMotif
30
31 %description
32 wxWidgets is a free C++ library for cross-platform GUI development.
33 With wxWidgets, you can create applications for different GUIs (GTK+,
34 Motif/LessTif, MS Windows, Mac) from the same source code.
35
36 %package devel
37 Summary: The Motif/Lesstif port of the wxWidgets library
38 Group: X11/Libraries
39 Requires: %{name} = %{ver}
40 Requires: %{wxbasename}-devel = %{ver}
41
42 %description devel
43 Header files for wxMotif, the Motif/Lesstif port of the wxWidgets library.
44
45 %package gl
46 Summary: The Motif/Lesstif port of the wxWidgets library, OpenGL add-on.
47 Group: X11/Libraries
48 Requires: %{name} = %{ver}
49
50 %description gl
51 OpenGL add-on library for wxMotif, the Motif/Lesstif port of the wxWidgets library.
52
53 %package static
54 Summary: wxMotif static libraries
55 Group: Development/Libraries
56 Requires: %{wxbasename}-static
57 Requires: %{name}-devel = %{ver}
58
59 %description static
60 Static libraries for wxMotif. You need them if you want to link statically against wxMotif.
61
62 %package contrib
63 Summary: Contrib libraries for wxMotif
64 Group: X11/Libraries
65 Requires: %{name} = %{ver}
66
67 %description contrib
68 Contrib libraries for wxMotif
69
70 %package contrib-devel
71 Summary: Contrib libraries for wxMotif
72 Group: X11/Libraries
73 Requires: %{name}-contrib = %{ver}
74 Requires: %{name}-devel = %{ver}
75
76 %description contrib-devel
77 Header files for contributed libraries for wxMotif.
78
79 %prep
80 %setup -q -n wxMotif-%{ver}
81
82 %build
83 if [ "$SMP" != "" ]; then
84 export MAKE="make -j$SMP"
85 else
86 export MAKE="make"
87 fi
88
89 mkdir obj-shared
90 cd obj-shared
91 ../configure --prefix=%{pref} --with-motif --with-opengl
92 $MAKE
93
94 cd contrib/src
95 $MAKE
96 cd ../../..
97
98 mkdir obj-static
99 cd obj-static
100 ../configure --prefix=%{pref} --with-motif --disable-shared --with-opengl
101 $MAKE
102 cd ..
103
104 %install
105 rm -rf $RPM_BUILD_ROOT
106 (cd obj-static; make prefix=$RPM_BUILD_ROOT%{pref} install)
107 (cd obj-shared; make prefix=$RPM_BUILD_ROOT%{pref} install)
108
109 # Remove headers that are part of wx-base-devel:
110
111 # --- wxBase headers list begins here ---
112 cat <<EOF >wxbase-headers.files
113 wx/afterstd.h
114 wx/any.h
115 wx/anystr.h
116 wx/app.h
117 wx/apptrait.h
118 wx/archive.h
119 wx/arrimpl.cpp
120 wx/arrstr.h
121 wx/atomic.h
122 wx/base64.h
123 wx/beforestd.h
124 wx/buffer.h
125 wx/build.h
126 wx/chartype.h
127 wx/checkeddelete.h
128 wx/chkconf.h
129 wx/clntdata.h
130 wx/cmdargs.h
131 wx/cmdline.h
132 wx/confbase.h
133 wx/config.h
134 wx/convauto.h
135 wx/containr.h
136 wx/cpp.h
137 wx/crt.h
138 wx/datetime.h
139 wx/datstrm.h
140 wx/dde.h
141 wx/debug.h
142 wx/defs.h
143 wx/dir.h
144 wx/dlimpexp.h
145 wx/dlist.h
146 wx/dynarray.h
147 wx/dynlib.h
148 wx/dynload.h
149 wx/encconv.h
150 wx/event.h
151 wx/except.h
152 wx/features.h
153 wx/flags.h
154 wx/ffile.h
155 wx/file.h
156 wx/fileconf.h
157 wx/filefn.h
158 wx/filename.h
159 wx/filesys.h
160 wx/fontenc.h
161 wx/fontmap.h
162 wx/fs_arc.h
163 wx/fs_filter.h
164 wx/fs_mem.h
165 wx/fs_zip.h
166 wx/hash.h
167 wx/hashmap.h
168 wx/hashset.h
169 wx/html/forcelnk.h
170 wx/iconloc.h
171 wx/init.h
172 wx/intl.h
173 wx/iosfwrap.h
174 wx/ioswrap.h
175 wx/ipc.h
176 wx/ipcbase.h
177 wx/kbdstate.h
178 wx/link.h
179 wx/list.h
180 wx/listimpl.cpp
181 wx/log.h
182 wx/longlong.h
183 wx/math.h
184 wx/memconf.h
185 wx/memory.h
186 wx/memtext.h
187 wx/mimetype.h
188 wx/module.h
189 wx/mousestate.h
190 wx/msgout.h
191 wx/mstream.h
192 wx/object.h
193 wx/platform.h
194 wx/platinfo.h
195 wx/power.h
196 wx/process.h
197 wx/ptr_scpd.h
198 wx/ptr_shrd.h
199 wx/recguard.h
200 wx/regex.h
201 wx/scopedarray.h
202 wx/scopedptr.h
203 wx/scopeguard.h
204 wx/sharedptr.h
205 wx/snglinst.h
206 wx/sstream.h
207 wx/stack.h
208 wx/stackwalk.h
209 wx/stdpaths.h
210 wx/stdstream.h
211 wx/stockitem.h
212 wx/stopwatch.h
213 wx/strconv.h
214 wx/stream.h
215 wx/string.h
216 wx/stringimpl.h
217 wx/stringops.h
218 wx/strvararg.h
219 wx/sysopt.h
220 wx/tarstrm.h
221 wx/textbuf.h
222 wx/textfile.h
223 wx/thread.h
224 wx/thrimpl.cpp
225 wx/timer.h
226 wx/tls.h
227 wx/tokenzr.h
228 wx/tracker.h
229 wx/txtstrm.h
230 wx/types.h
231 wx/unichar.h
232 wx/uri.h
233 wx/ustring.h
234 wx/utils.h
235 wx/variant.h
236 wx/vector.h
237 wx/version.h
238 wx/volume.h
239 wx/weakref.h
240 wx/wfstream.h
241 wx/wx.h
242 wx/wxchar.h
243 wx/wxcrt.h
244 wx/wxcrtbase.h
245 wx/wxcrtvararg.h
246 wx/wxprec.h
247 wx/xlocale.h
248 wx/xti.h
249 wx/xtistrm.h
250 wx/zipstrm.h
251 wx/zstream.h
252 wx/meta/convertible.h
253 wx/meta/if.h
254 wx/meta/int2type.h
255 wx/meta/movable.h
256 wx/fswatcher.h
257 wx/generic/fswatcher.h
258 wx/unix/app.h
259 wx/unix/apptbase.h
260 wx/unix/apptrait.h
261 wx/unix/chkconf.h
262 wx/unix/evtloop.h
263 wx/unix/evtloopsrc.h
264 wx/unix/pipe.h
265 wx/unix/stdpaths.h
266 wx/unix/stackwalk.h
267 wx/unix/tls.h
268 wx/unix/fswatcher_kqueue.h
269 wx/unix/execute.h
270 wx/unix/mimetype.h
271 wx/unix/fswatcher_inotify.h
272 wx/fs_inet.h
273 wx/protocol/file.h
274 wx/protocol/ftp.h
275 wx/protocol/http.h
276 wx/protocol/log.h
277 wx/protocol/protocol.h
278 wx/sckaddr.h
279 wx/sckipc.h
280 wx/sckstrm.h
281 wx/socket.h
282 wx/url.h
283 wx/xml/xml.h
284 wx/xtixml.h
285 EOF
286 # --- wxBase headers list ends here ---
287 for f in `cat wxbase-headers-list` ; do
288 rm -f $RPM_BUILD_ROOT%{_includedir}/wx-%{ver2}/$f
289 done
290
291 # list of all core headers:
292 find $RPM_BUILD_ROOT%{_includedir}/wx-%{ver2} -type f | sed -e "s,$RPM_BUILD_ROOT,,g" >core-headers.files
293
294 # contrib stuff:
295 (cd obj-shared/contrib/src; make prefix=$RPM_BUILD_ROOT%{pref} install)
296 (cd obj-shared/utils/wxrc; make prefix=$RPM_BUILD_ROOT%{pref} install)
297
298 # remove wxBase files so that RPM doesn't complain about unpackaged files:
299 rm -f $RPM_BUILD_ROOT%{_libdir}/libwx_base*
300 rm -f $RPM_BUILD_ROOT%{_datadir}/aclocal/*
301 rm -f $RPM_BUILD_ROOT%{_datadir}/locale/*/*/*
302
303 %clean
304 rm -rf $RPM_BUILD_ROOT
305
306 %post
307 /sbin/ldconfig
308
309 %postun
310 /sbin/ldconfig
311
312 %post devel
313 # link wx-config when you install RPM.
314 ln -sf %{_libdir}/wx/config/%{wxconfig} %{_bindir}/wx-config
315 # link wx-config with explicit name.
316 ln -sf %{_libdir}/wx/config/%{wxconfig} %{_bindir}/%{wxconfiglink}
317 /sbin/ldconfig
318
319 %postun devel
320 /sbin/ldconfig
321
322 %preun devel
323 if test -f %{_bindir}/wx-config -a -f /usr/bin/md5sum ; then
324 SUM1=`md5sum %{_libdir}/wx/config/%{wxconfig} | cut -c 0-32`
325 SUM2=`md5sum %{_bindir}/wx-config | cut -c 0-32`
326 if test "x$SUM1" = "x$SUM2" ; then
327 rm -f %{_bindir}/wx-config
328 fi
329 fi
330 rm -f %{_bindir}/%{wxconfiglink}
331
332 %post gl
333 /sbin/ldconfig
334
335 %postun gl
336 /sbin/ldconfig
337
338 %post contrib
339 /sbin/ldconfig
340
341 %postun contrib
342 /sbin/ldconfig
343
344 %post contrib-devel
345 /sbin/ldconfig
346
347 %postun contrib-devel
348 /sbin/ldconfig
349
350 %files
351 %defattr(-,root,root)
352 %doc COPYING.LIB *.txt
353 %{_libdir}/libwx_%{portname}*_adv-%{ver2}.so.*
354 %{_libdir}/libwx_%{portname}*_core-%{ver2}.so.*
355 %{_libdir}/libwx_%{portname}*_html-%{ver2}.so.*
356 %{_libdir}/libwx_%{portname}*_media-%{ver2}.so.*
357 %{_libdir}/libwx_%{portname}*_qa-%{ver2}.so.*
358 %{_libdir}/libwx_%{portname}*_xrc-%{ver2}.so.*
359
360
361 %files devel -f core-headers.files
362 %defattr(-,root,root)
363 %{_libdir}/libwx_%{portname}*_adv-%{ver2}.so
364 %{_libdir}/libwx_%{portname}*_core-%{ver2}.so
365 %{_libdir}/libwx_%{portname}*_gl-%{ver2}.so
366 %{_libdir}/libwx_%{portname}*_html-%{ver2}.so
367 %{_libdir}/libwx_%{portname}*_media-%{ver2}.so
368 %{_libdir}/libwx_%{portname}*_qa-%{ver2}.so
369 %{_libdir}/libwx_%{portname}*_xrc-%{ver2}.so
370 %dir %{_libdir}/wx
371 %{_libdir}/wx/*
372 %{_bindir}/wxrc*
373
374 %files gl
375 %defattr(-,root,root)
376 %{_libdir}/libwx_%{portname}*_gl-%{ver2}.so.*
377
378 %files static
379 %defattr (-,root,root)
380 %{_libdir}/libwx_%{portname}*_*-%{ver2}.a
381
382 %files contrib
383 %defattr(-,root,root)
384 %{_libdir}/libwx_%{portname}*_animate-%{ver2}.so.*
385 %{_libdir}/libwx_%{portname}*_deprecated-%{ver2}.so.*
386 %{_libdir}/libwx_%{portname}*_fl-%{ver2}.so.*
387 %{_libdir}/libwx_%{portname}*_gizmos-%{ver2}.so.*
388 %{_libdir}/libwx_%{portname}*_mmedia-%{ver2}.so.*
389 %{_libdir}/libwx_%{portname}*_ogl-%{ver2}.so.*
390 %{_libdir}/libwx_%{portname}*_plot-%{ver2}.so.*
391 %{_libdir}/libwx_%{portname}*_stc-%{ver2}.so.*
392 %{_libdir}/libwx_%{portname}*_svg-%{ver2}.so.*
393
394 %files contrib-devel
395 %defattr(-,root,root)
396 %dir %{_includedir}/wx-%{ver2}/wx/animate
397 %{_includedir}/wx-%{ver2}/wx/animate/*
398 %{_libdir}/libwx_%{portname}*_animate-%{ver2}.so
399
400 %dir %{_includedir}/wx-%{ver2}/wx/deprecated
401 %{_includedir}/wx-%{ver2}/wx/deprecated/*
402 %{_libdir}/libwx_%{portname}*_deprecated-%{ver2}.so
403
404 %dir %{_includedir}/wx-%{ver2}/wx/fl
405 %{_includedir}/wx-%{ver2}/wx/fl/*
406 %{_libdir}/libwx_%{portname}*_fl-%{ver2}.so
407
408 %dir %{_includedir}/wx-%{ver2}/wx/gizmos
409 %{_includedir}/wx-%{ver2}/wx/gizmos/*
410 %{_libdir}/libwx_%{portname}*_gizmos-%{ver2}.so
411
412 %dir %{_includedir}/wx-%{ver2}/wx/mmedia
413 %{_includedir}/wx-%{ver2}/wx/mmedia/*
414 %{_libdir}/libwx_%{portname}*_mmedia-%{ver2}.so
415
416 %dir %{_includedir}/wx-%{ver2}/wx/ogl
417 %{_includedir}/wx-%{ver2}/wx/ogl/*
418 %{_libdir}/libwx_%{portname}*_ogl-%{ver2}.so
419
420 %dir %{_includedir}/wx-%{ver2}/wx/plot
421 %{_includedir}/wx-%{ver2}/wx/plot/*
422 %{_libdir}/libwx_%{portname}*_plot-%{ver2}.so
423
424 %dir %{_includedir}/wx-%{ver2}/wx/stc
425 %{_includedir}/wx-%{ver2}/wx/stc/*
426 %{_libdir}/libwx_%{portname}*_stc-%{ver2}.so
427
428 %dir %{_includedir}/wx-%{ver2}/wx/svg
429 %{_includedir}/wx-%{ver2}/wx/svg/*
430 %{_libdir}/libwx_%{portname}*_svg-%{ver2}.so