6 # Configurable settings (use --with(out) {unicode,gtk2} on rpmbuild cmd line):
8 %{?_with_unicode: %{expand: %%define unicode 1}}
9 %{?_without_unicode: %{expand: %%define unicode 0}}
12 %{?_with_gtk2: %{expand: %%define gtk2 1}}
13 %{?_without_gtk2: %{expand: %%define gtk2 0}}
15 # "buildname" needs to be e.g. gtk2ud for debug builds
20 %define buildname gtk2u
22 %define buildname gtk2
31 %define name wx
-%{portname}-unicode
32 %define wxconfig
%{portname}-unicode-release-%{ver2}
33 %define wxconfigstatic
%{portname}-unicode-release-static-%{ver2}
34 %define wxconfiglink wx
%{portname}u-%{ver2}-config
36 %define name wx
-%{portname}-ansi
37 %define wxconfig
%{portname}-ansi-release-%{ver2}
38 %define wxconfigstatic
%{portname}-ansi-release-static-%{ver2}
39 %define wxconfiglink wx
%{portname}-%{ver2}-config
43 %define wxbasename wx
-base
-unicode
44 %define wxbaseconfig base
-unicode
-release
-%{ver2}
45 %define wxbaseconfiglink wxbaseu
-%{ver2}-config
47 %define wxbasename wx
-base
-ansi
48 %define wxbaseconfig base
-ansi
-release
-%{ver2}
49 %define wxbaseconfiglink wxbase
-%{ver2}-config
52 Summary: The GTK
+ %{gtkver} port of the wxWidgets library
56 License: wxWindows Licence
58 Source: wxGTK
-%{ver}.tar.bz2
59 URL: http
://www.wxwidgets.org
60 Packager: Vadim Zeitlin
<vadim@wxwindows.org
>
62 BuildRoot: %{_tmppath}/%{name}-root
63 Requires: %{wxbasename} = %{ver}
64 %if %{portname} == gtk2
65 BuildRequires
: gtk
+-2.0-devel
67 BuildRequires
: gtk
+-devel
>= 1.2.0
70 BuildRequires
: zlib
-devel
, libjpeg
-devel
, libpng
-devel
, libtiff
-devel
72 # all packages providing an implementation of wxWidgets library (regardless of
73 # the toolkit used) should provide the (virtual) wxwin package, this makes it
74 # possible to require wxwin instead of requiring "wxgtk or wxmotif or wxuniv..."
79 wxWidgets is a free C
++ library
for cross
-platform GUI development.
80 With wxWidgets
, you can create applications
for different GUIs
(GTK
+,
81 Motif
, MS Windows
, MacOS X
, Windows CE
, GPE
) from the same
source code.
84 Summary: The translations
for the wxWidgets library.
87 %description -n wx
-i18n
88 The translations files
for the wxWidgets library.
91 Summary: The GTK
+ %{gtkver} port of the wxWidgets library
93 Requires: %{name} = %{ver}
94 Requires: %{wxbasename}-devel = %{ver}
98 The GTK
+ %{gtkver} port of the wxWidgets library
, header files.
101 Summary: The GTK
+ %{gtkver} port of the wxWidgets library
, OpenGL add
-on.
103 Requires: %{name} = %{ver}
107 OpenGL add
-on library
for wxGTK
, the GTK
+ %{gtkver} port of the wxWidgets library.
109 %package -n
%{wxbasename}
110 Summary: wxBase library
- non
-GUI support classes of the wxWidgets toolkit
111 Group: Development
/Libraries
114 %description -n
%{wxbasename}
115 wxBase is a collection of C
++ classes providing basic data structures
(strings
,
116 lists
, arrays
), portable wrappers around many OS
-specific funstions
(file
117 operations
, time/date manipulations
, threads
, processes
, sockets
, shared
118 library loading
) as well as other utility classes
(streams
, archive and
119 compression
). wxBase currently supports Win32
, most Unix variants
(Linux
,
120 FreeBSD
, Solaris
, HP
-UX
) and MacOS X
(Carbon and Mach
-0).
122 %package -n
%{wxbasename}-devel
123 Summary: wxBase library
, header files.
124 Group: Development
/Libraries
125 Provides: wxBase
-devel
127 %description -n
%{wxbasename}-devel
128 wxBase library
- non
-GUI support classes of the wxWidgets toolkit
,
132 Summary: The GTK
+ %{gtkver} port of the wxWidgets library
, contributed libraries.
134 Requires: %{name} = %{ver}
137 Contributed libraries
for wxGTK
, the GTK
+ %{gtkver} port of the wxWidgets library.
139 %package contrib
-devel
140 Summary: The GTK
+ %{gtkver} port of the wxWidgets library
142 Requires: %{name}-contrib = %{ver}
143 Requires: %{name}-devel = %{ver}
145 %description contrib
-devel
146 Header files
for contributed libraries
for wxGTK
, the GTK
+ %{gtkver} port of the wxWidgets library.
149 %setup -q
-n wxGTK
-%{ver}
152 if [ "$SMP"
!= ""
]; then
153 export MAKE
="
make -j$SMP"
160 ..
/configure
--prefix
=%{_prefix} \
180 ..
/configure
--prefix
=%{_prefix} \
202 rm -rf $RPM_BUILD_ROOT
203 (cd obj
-static
; make DESTDIR
=$RPM_BUILD_ROOT prefix
=%{_prefix} install)
204 (cd obj
-shared
; make DESTDIR
=$RPM_BUILD_ROOT prefix
=%{_prefix} install)
206 # --- wxBase headers list begins here ---
207 cat
<<EOF
>wxbase
-headers.files
347 wx
/meta
/convertible.h
367 wx
/protocol
/protocol.h
376 # --- wxBase headers list ends here ---
377 cat
<<EOF
>wxbase
-headers.paths
378 %{_includedir}/wx-%{ver2}/wx
/afterstd.h
379 %{_includedir}/wx-%{ver2}/wx
/app.h
380 %{_includedir}/wx-%{ver2}/wx
/apptrait.h
381 %{_includedir}/wx-%{ver2}/wx
/archive.h
382 %{_includedir}/wx-%{ver2}/wx
/arrimpl.cpp
383 %{_includedir}/wx-%{ver2}/wx
/arrstr.h
384 %{_includedir}/wx-%{ver2}/wx
/beforestd.h
385 %{_includedir}/wx-%{ver2}/wx
/buffer.h
386 %{_includedir}/wx-%{ver2}/wx
/build.h
387 %{_includedir}/wx-%{ver2}/wx
/chkconf.h
388 %{_includedir}/wx-%{ver2}/wx
/clntdata.h
389 %{_includedir}/wx-%{ver2}/wx
/cmdline.h
390 %{_includedir}/wx-%{ver2}/wx
/confbase.h
391 %{_includedir}/wx-%{ver2}/wx
/config.h
392 %{_includedir}/wx-%{ver2}/wx
/containr.h
393 %{_includedir}/wx-%{ver2}/wx
/convauto.h
394 %{_includedir}/wx-%{ver2}/wx
/datetime.h
395 %{_includedir}/wx-%{ver2}/wx
/datstrm.h
396 %{_includedir}/wx-%{ver2}/wx
/dde.h
397 %{_includedir}/wx-%{ver2}/wx
/debug.h
398 %{_includedir}/wx-%{ver2}/wx
/defs.h
399 %{_includedir}/wx-%{ver2}/wx
/dir.h
400 %{_includedir}/wx-%{ver2}/wx
/dlimpexp.h
401 %{_includedir}/wx-%{ver2}/wx
/dynarray.h
402 %{_includedir}/wx-%{ver2}/wx
/dynlib.h
403 %{_includedir}/wx-%{ver2}/wx
/dynload.h
404 %{_includedir}/wx-%{ver2}/wx
/encconv.h
405 %{_includedir}/wx-%{ver2}/wx
/event.h
406 %{_includedir}/wx-%{ver2}/wx
/except.h
407 %{_includedir}/wx-%{ver2}/wx
/features.h
408 %{_includedir}/wx-%{ver2}/wx
/ffile.h
409 %{_includedir}/wx-%{ver2}/wx
/file.h
410 %{_includedir}/wx-%{ver2}/wx
/fileconf.h
411 %{_includedir}/wx-%{ver2}/wx
/filefn.h
412 %{_includedir}/wx-%{ver2}/wx
/filename.h
413 %{_includedir}/wx-%{ver2}/wx
/filesys.h
414 %{_includedir}/wx-%{ver2}/wx
/fontenc.h
415 %{_includedir}/wx-%{ver2}/wx
/fontmap.h
416 %{_includedir}/wx-%{ver2}/wx
/fs_mem.h
417 %{_includedir}/wx-%{ver2}/wx
/fs_zip.h
418 %{_includedir}/wx-%{ver2}/wx
/hash.h
419 %{_includedir}/wx-%{ver2}/wx
/hashmap.h
420 %{_includedir}/wx-%{ver2}/wx
/hashset.h
421 %{_includedir}/wx-%{ver2}/wx
/html
/forcelnk.h
422 %{_includedir}/wx-%{ver2}/wx
/iconloc.h
423 %{_includedir}/wx-%{ver2}/wx
/init.h
424 %{_includedir}/wx-%{ver2}/wx
/intl.h
425 %{_includedir}/wx-%{ver2}/wx
/iosfwrap.h
426 %{_includedir}/wx-%{ver2}/wx
/ioswrap.h
427 %{_includedir}/wx-%{ver2}/wx
/ipc.h
428 %{_includedir}/wx-%{ver2}/wx
/ipcbase.h
429 %{_includedir}/wx-%{ver2}/wx
/isql.h
430 %{_includedir}/wx-%{ver2}/wx
/isqlext.h
431 %{_includedir}/wx-%{ver2}/wx
/link.h
432 %{_includedir}/wx-%{ver2}/wx
/list.h
433 %{_includedir}/wx-%{ver2}/wx
/listimpl.cpp
434 %{_includedir}/wx-%{ver2}/wx
/log.h
435 %{_includedir}/wx-%{ver2}/wx
/longlong.h
436 %{_includedir}/wx-%{ver2}/wx
/math.h
437 %{_includedir}/wx-%{ver2}/wx
/memconf.h
438 %{_includedir}/wx-%{ver2}/wx
/memory.h
439 %{_includedir}/wx-%{ver2}/wx
/memtext.h
440 %{_includedir}/wx-%{ver2}/wx
/mimetype.h
441 %{_includedir}/wx-%{ver2}/wx
/module.h
442 %{_includedir}/wx-%{ver2}/wx
/msgout.h
443 %{_includedir}/wx-%{ver2}/wx
/mstream.h
444 %{_includedir}/wx-%{ver2}/wx
/object.h
445 %{_includedir}/wx-%{ver2}/wx
/platform.h
446 %{_includedir}/wx-%{ver2}/wx
/power.h
447 %{_includedir}/wx-%{ver2}/wx
/process.h
448 %{_includedir}/wx-%{ver2}/wx
/ptr_scpd.h
449 %{_includedir}/wx-%{ver2}/wx
/recguard.h
450 %{_includedir}/wx-%{ver2}/wx
/regex.h
451 %{_includedir}/wx-%{ver2}/wx
/scopeguard.h
452 %{_includedir}/wx-%{ver2}/wx
/snglinst.h
453 %{_includedir}/wx-%{ver2}/wx
/sstream.h
454 %{_includedir}/wx-%{ver2}/wx
/stack.h
455 %{_includedir}/wx-%{ver2}/wx
/stackwalk.h
456 %{_includedir}/wx-%{ver2}/wx
/stdpaths.h
457 %{_includedir}/wx-%{ver2}/wx
/stockitem.h
458 %{_includedir}/wx-%{ver2}/wx
/stopwatch.h
459 %{_includedir}/wx-%{ver2}/wx
/strconv.h
460 %{_includedir}/wx-%{ver2}/wx
/stream.h
461 %{_includedir}/wx-%{ver2}/wx
/string.h
462 %{_includedir}/wx-%{ver2}/wx
/sysopt.h
463 %{_includedir}/wx-%{ver2}/wx
/textbuf.h
464 %{_includedir}/wx-%{ver2}/wx
/textfile.h
465 %{_includedir}/wx-%{ver2}/wx
/thread.h
466 %{_includedir}/wx-%{ver2}/wx
/thrimpl.cpp
467 %{_includedir}/wx-%{ver2}/wx
/timer.h
468 %{_includedir}/wx-%{ver2}/wx
/tokenzr.h
469 %{_includedir}/wx-%{ver2}/wx
/txtstrm.h
470 %{_includedir}/wx-%{ver2}/wx
/types.h
471 %{_includedir}/wx-%{ver2}/wx
/uri.h
472 %{_includedir}/wx-%{ver2}/wx
/utils.h
473 %{_includedir}/wx-%{ver2}/wx
/variant.h
474 %{_includedir}/wx-%{ver2}/wx
/vector.h
475 %{_includedir}/wx-%{ver2}/wx
/version.h
476 %{_includedir}/wx-%{ver2}/wx
/volume.h
477 %{_includedir}/wx-%{ver2}/wx
/wfstream.h
478 %{_includedir}/wx-%{ver2}/wx
/wx.h
479 %{_includedir}/wx-%{ver2}/wx
/wxchar.h
480 %{_includedir}/wx-%{ver2}/wx
/wxprec.h
481 %{_includedir}/wx-%{ver2}/wx
/xti.h
482 %{_includedir}/wx-%{ver2}/wx
/xtistrm.h
483 %{_includedir}/wx-%{ver2}/wx
/zipstrm.h
484 %{_includedir}/wx-%{ver2}/wx
/zstream.h
485 %{_includedir}/wx-%{ver2}/wx
/fs_inet.h
486 %{_includedir}/wx-%{ver2}/wx
/gsocket.h
487 %{_includedir}/wx-%{ver2}/wx
/protocol
/file.h
488 %{_includedir}/wx-%{ver2}/wx
/protocol
/ftp.h
489 %{_includedir}/wx-%{ver2}/wx
/protocol
/http.h
490 %{_includedir}/wx-%{ver2}/wx
/protocol
/protocol.h
491 %{_includedir}/wx-%{ver2}/wx
/sckaddr.h
492 %{_includedir}/wx-%{ver2}/wx
/sckipc.h
493 %{_includedir}/wx-%{ver2}/wx
/sckstrm.h
494 %{_includedir}/wx-%{ver2}/wx
/socket.h
495 %{_includedir}/wx-%{ver2}/wx
/url.h
496 %{_includedir}/wx-%{ver2}/wx
/xml
/xml.h
497 %{_includedir}/wx-%{ver2}/wx
/xtixml.h
498 %{_includedir}/wx-%{ver2}/wx
/unix
/apptbase.h
499 %{_includedir}/wx-%{ver2}/wx
/unix
/apptrait.h
500 %{_includedir}/wx-%{ver2}/wx
/unix
/execute.h
501 %{_includedir}/wx-%{ver2}/wx
/unix
/gsockunx.h
502 %{_includedir}/wx-%{ver2}/wx
/unix
/mimetype.h
503 %{_includedir}/wx-%{ver2}/wx
/unix
/pipe.h
504 %{_includedir}/wx-%{ver2}/wx
/unix
/private.h
505 %{_includedir}/wx-%{ver2}/wx
/unix
/stackwalk.h
506 %{_includedir}/wx-%{ver2}/wx
/unix
/stdpaths.h
508 # --- wxBase headers list ends here ---
510 # temporarily remove base headers
511 mkdir $RPM_BUILD_ROOT
/_save_dir
512 cp
-r $RPM_BUILD_ROOT
%{_includedir}/wx-%{ver2} $RPM_BUILD_ROOT
/_save_dir
513 for f
in `cat wxbase
-headers.files`
; do
514 rm -f $RPM_BUILD_ROOT
%{_includedir}/wx-%{ver2}/$f
516 # list of all core headers:
517 find $RPM_BUILD_ROOT
%{_includedir}/wx-%{ver2} -type f | sed
-e "s
,$RPM_BUILD_ROOT
,,g"
>core
-headers.files
518 # move base headers (actually all headers) back again
519 cp
-f
-r $RPM_BUILD_ROOT
/_save_dir
/* $RPM_BUILD_ROOT
%{_includedir}
520 rm -rf $RPM_BUILD_ROOT
/_save_dir
523 (cd obj
-static
/contrib
; make DESTDIR
=$RPM_BUILD_ROOT prefix
=%{_prefix} install)
524 (cd obj
-shared
/contrib
; make DESTDIR
=$RPM_BUILD_ROOT prefix
=%{_prefix} install)
527 (cd obj
-shared
/utils
/wxrc
; make DESTDIR
=$RPM_BUILD_ROOT prefix
=%{_prefix} install)
529 # wx-config link is created during package installation, remove it for now
530 rm -f $RPM_BUILD_ROOT
%{_bindir}/wx
-config
533 rm -rf $RPM_BUILD_ROOT
542 # link wx-config when you install RPM.
544 ln
-sf
%{_libdir}/wx/config/%{wxconfig} %{_bindir}/wx
-config
546 # link wx-config with explicit name.
547 ln
-sf
%{_libdir}/wx/config/%{wxconfig} %{_bindir}/%{wxconfiglink}
555 rm -f
%{_bindir}/wx
-config
557 rm -f
%{_bindir}/%{wxconfiglink}
559 %post -n
%{wxbasename}
562 %postun -n
%{wxbasename}
565 %post -n
%{wxbasename}-devel
566 # link wx-config with explicit name.
567 ln
-sf
%{_libdir}/wx/config/%{wxbaseconfig} %{_bindir}/%{wxbaseconfiglink}
570 %postun -n
%{wxbasename}-devel
573 %preun -n
%{wxbasename}-devel
574 rm -f
%{_bindir}/%{wxbaseconfiglink}
591 %postun contrib
-devel
595 %defattr(-,root
,root
)
596 %doc COPYING.LIB
*.txt
597 %{_libdir}/libwx_%{buildname}_adv-%{ver2}.so.
*
598 %{_libdir}/libwx_%{buildname}_aui-%{ver2}.so.
*
599 %{_libdir}/libwx_%{buildname}_core-%{ver2}.so.
*
600 %{_libdir}/libwx_%{buildname}_html-%{ver2}.so.
*
601 %{_libdir}/libwx_%{buildname}_mmedia-%{ver2}.so.
*
602 %{_libdir}/libwx_%{buildname}_qa-%{ver2}.so.
*
603 %{_libdir}/libwx_%{buildname}_richtext-%{ver2}.so.
*
604 %{_libdir}/libwx_%{buildname}_xrc-%{ver2}.so.
*
607 %defattr(-,root
,root
)
608 %{_datadir}/locale
/*/LC_MESSAGES
/*.mo
610 %files devel
-f core
-headers.files
611 %defattr(-,root
,root
)
613 %{_libdir}/libwx_%{buildname}_adv-%{ver2}.so
614 %{_libdir}/libwx_%{buildname}_aui-%{ver2}.so
615 %{_libdir}/libwx_%{buildname}_core-%{ver2}.so
616 %{_libdir}/libwx_%{buildname}_gl-%{ver2}.so
617 %{_libdir}/libwx_%{buildname}_html-%{ver2}.so
618 %{_libdir}/libwx_%{buildname}_mmedia-%{ver2}.so
619 %{_libdir}/libwx_%{buildname}_qa-%{ver2}.so
620 %{_libdir}/libwx_%{buildname}_richtext-%{ver2}.so
621 %{_libdir}/libwx_%{buildname}_xrc-%{ver2}.so
623 %{_libdir}/libwx_%{buildname}_adv-%{ver2}.a
624 %{_libdir}/libwx_%{buildname}_aui-%{ver2}.a
625 %{_libdir}/libwx_%{buildname}_core-%{ver2}.a
626 %{_libdir}/libwx_%{buildname}_gl-%{ver2}.a
627 %{_libdir}/libwx_%{buildname}_html-%{ver2}.a
628 %{_libdir}/libwx_%{buildname}_qa-%{ver2}.a
629 %{_libdir}/libwx_%{buildname}_richtext-%{ver2}.a
630 %{_libdir}/libwx_%{buildname}_xrc-%{ver2}.a
632 %{_libdir}/wx/config/%{wxconfig}
633 %{_libdir}/wx/include/%{wxconfig}/wx
/setup.h
634 %{_libdir}/wx/config/%{wxconfigstatic}
635 %{_libdir}/wx/include/%{wxconfigstatic}/wx
/setup.h
638 %files -n
%{wxbasename}
639 %defattr(-,root
,root
)
640 %{_libdir}/libwx_base*-%{ver2}.so.
*
642 %files -n
%{wxbasename}-devel
-f wxbase
-headers.paths
643 %defattr (-,root
,root
)
644 %dir %{_includedir}/wx-%{ver2}
645 %{_libdir}/libwx_base*-%{ver2}.so
646 %{_libdir}/libwx_base*-%{ver2}.a
648 %{_libdir}/libwxregexu-%{ver2}.a
651 %{_datadir}/aclocal
/*.m4
652 %{_datadir}/bakefile
/presets
/*
655 %defattr(-,root
,root
)
656 %{_libdir}/libwx_%{buildname}_gl-%{ver2}.so.
*
659 %defattr(-,root
,root
)
660 %{_libdir}/libwx_%{buildname}_animate-%{ver2}.so.
*
661 %{_libdir}/libwx_%{buildname}_deprecated-%{ver2}.so.
*
662 %{_libdir}/libwx_%{buildname}_fl-%{ver2}.so.
*
663 %{_libdir}/libwx_%{buildname}_gizmos-%{ver2}.so.
*
664 %{_libdir}/libwx_%{buildname}_gizmos_xrc-%{ver2}.so.
*
665 %{_libdir}/libwx_%{buildname}_mmedia-%{ver2}.so.
*
666 %{_libdir}/libwx_%{buildname}_ogl-%{ver2}.so.
*
667 %{_libdir}/libwx_%{buildname}_plot-%{ver2}.so.
*
668 %{_libdir}/libwx_%{buildname}_stc-%{ver2}.so.
*
669 %{_libdir}/libwx_%{buildname}_svg-%{ver2}.so.
*
672 %{_libdir}/libwx_%{buildname}_animate-%{ver2}.a
673 %{_libdir}/libwx_%{buildname}_deprecated-%{ver2}.a
674 %{_libdir}/libwx_%{buildname}_fl-%{ver2}.a
675 %{_libdir}/libwx_%{buildname}_gizmos-%{ver2}.a
676 %{_libdir}/libwx_%{buildname}_gizmos_xrc-%{ver2}.a
677 %{_libdir}/libwx_%{buildname}_mmedia-%{ver2}.a
678 %{_libdir}/libwx_%{buildname}_ogl-%{ver2}.a
679 %{_libdir}/libwx_%{buildname}_plot-%{ver2}.a
680 %{_libdir}/libwx_%{buildname}_stc-%{ver2}.a
681 %{_libdir}/libwx_%{buildname}_svg-%{ver2}.a
684 %defattr(-,root
,root
)
685 %dir %{_includedir}/wx-%{ver2}/wx
/animate
686 %{_includedir}/wx-%{ver2}/wx
/animate
/*
687 %{_libdir}/libwx_%{buildname}_animate-%{ver2}.so
689 %dir %{_includedir}/wx-%{ver2}/wx
/deprecated
690 %{_includedir}/wx-%{ver2}/wx
/deprecated
/*
691 %{_libdir}/libwx_%{buildname}_deprecated-%{ver2}.so
693 %dir %{_includedir}/wx-%{ver2}/wx
/fl
694 %{_includedir}/wx-%{ver2}/wx
/fl
/*
695 %{_libdir}/libwx_%{buildname}_fl-%{ver2}.so
697 %dir %{_includedir}/wx-%{ver2}/wx
/gizmos
698 %{_includedir}/wx-%{ver2}/wx
/gizmos
/*
699 %{_libdir}/libwx_%{buildname}_gizmos-%{ver2}.so
700 %{_libdir}/libwx_%{buildname}_gizmos_xrc-%{ver2}.so
702 %dir %{_includedir}/wx-%{ver2}/wx
/mmedia
703 %{_includedir}/wx-%{ver2}/wx
/mmedia
/*
704 %{_libdir}/libwx_%{buildname}_mmedia-%{ver2}.so
706 %dir %{_includedir}/wx-%{ver2}/wx
/ogl
707 %{_includedir}/wx-%{ver2}/wx
/ogl
/*
708 %{_libdir}/libwx_%{buildname}_ogl-%{ver2}.so
710 %dir %{_includedir}/wx-%{ver2}/wx
/plot
711 %{_includedir}/wx-%{ver2}/wx
/plot
/*
712 %{_libdir}/libwx_%{buildname}_plot-%{ver2}.so
714 %dir %{_includedir}/wx-%{ver2}/wx
/stc
715 %{_includedir}/wx-%{ver2}/wx
/stc
/*
716 %{_libdir}/libwx_%{buildname}_stc-%{ver2}.so
718 %dir %{_includedir}/wx-%{ver2}/wx
/svg
719 %{_includedir}/wx-%{ver2}/wx
/svg
/*
720 %{_libdir}/libwx_%{buildname}_svg-%{ver2}.so