6 # Configurable settings (use --with(out) unicode on rpmbuild cmd line):
8 %{?_with_unicode: %{expand: %%define unicode 1}}
9 %{?_without_unicode: %{expand: %%define unicode 0}}
13 %define name wx
-%{portname}-unicode
14 %define wxbasename wx
-base
-unicode
16 %define name wx
-%{portname}
17 %define wxbasename wx
-base
21 %define wxconfigname wx
%{portname}univu-%{ver2}-config
23 %define wxconfigname wx
%{portname}univ-%{ver2}-config
26 Summary: The X11 port of the wxWindows library
30 License: wxWindows Licence
32 Source: wxX11
-%{ver}.tar.bz2
33 URL: http
://www.wxwindows.org
34 Packager: Vadim Zeitlin
<vadim@wxwindows.org
>
36 BuildRoot: /var
/tmp
/%{name}-root
38 # all packages providing an implementation of wxWindows library (regardless of
39 # the toolkit used) should provide the (virtual) wxwin package, this makes it
40 # possible to require wxwin instead of requiring "wxgtk or wxmotif or wxuniv..."
43 # in addition, we should provide libwx_gtk as automatic generator only notices
44 # libwx_gtk-%{ver}-%{rel}
45 Provides: libwx_x11.so
46 Provides: libwx_x11
-%{ver2}.so
49 Requires: %{wxbasename} = %{ver}
50 BuildRequires
: %{wxbasename}-devel = %{ver}
53 wxWindows is a free C
++ library
for cross
-platform GUI development.
54 With wxWindows
, you can create applications
for different GUIs
(GTK
+,
55 Motif
/LessTif
, MS Windows
, Mac
) from the same
source code.
58 Summary: The X11 port of the wxWindows library
60 Requires: %{name} = %{ver}
61 Requires: %{wxbasename}-devel = %{ver}
64 Header files
for wxX11
, the X11 port of the wxWindows library.
67 Summary: The X11 port of the wxWindows library
, OpenGL add
-on.
69 Requires: %{name} = %{ver}
72 OpenGL add
-on library
for wxX11
, the X11 port of the wxWindows library.
75 Summary: wxX11 static libraries
76 Group: Development
/Libraries
79 Static libraries
for wxX11. You need them
if you want to link statically against wxX11.
82 Summary: Contrib libraries
for wxX11.
84 Requires: %{name} = %{ver}
87 Contributed libraries
for wxX11.
89 %package contrib
-devel
90 Summary: Contrib libraries
for wxX11.
92 Requires: %{name}-contrib = %{ver}
93 Requires: %{name}-devel = %{ver}
95 %description contrib
-devel
96 Header files
for contributed libraries
for wxX11.
99 %setup -q
-n wxX11
-%{ver}
102 if [ "$SMP"
!= ""
]; then
103 export MAKE
="
make -j$SMP"
110 ..
/configure
--prefix
=%{pref} --with
-x11 \
124 ..
/configure
--prefix
=%{pref} --with
-x11
--disable
-shared \
135 rm -rf $RPM_BUILD_ROOT
136 (cd obj
-static
; make prefix
=$RPM_BUILD_ROOT
%{pref} install)
137 (cd obj
-shared
; make prefix
=$RPM_BUILD_ROOT
%{pref} install)
139 # Remove headers that are part of wx-base-devel:
142 for f
in `rpm
-ql
%{wxbasename}-devel | sed
-e 's
,\
(.
*\
),.\
1,g'`
; do
143 if test -f $f
; then rm -f $f
; fi
147 # list of all core headers:
148 find $RPM_BUILD_ROOT
/usr
/include
/wx
-type f | sed
-e "s
,$RPM_BUILD_ROOT
,,g"
>core
-headers.files
151 (cd obj
-shared
/contrib
/src
; make prefix
=$RPM_BUILD_ROOT
%{pref} install)
152 (cd obj
-shared
/contrib
/utils
/wxrc
; make prefix
=$RPM_BUILD_ROOT
%{pref} install)
155 rm -rf $RPM_BUILD_ROOT
170 # Install wx-config if there isn't any
171 if test ! -f
%{_bindir}/wx
-config
; then
172 ln
-sf
%{wxconfigname} %{_bindir}/wx
-config
176 # Remove wx-config if it points to this package
177 if test -f
%{_bindir}/wx
-config
-a
-f
/usr
/bin
/md5sum
; then
178 SUM1
=`md5sum
%{_bindir}/%{wxconfigname} | cut
-c
0-32`
179 SUM2
=`md5sum
%{_bindir}/wx
-config | cut
-c
0-32`
180 if test "x$SUM1"
= "x$SUM2"
; then
181 rm -f
%{_bindir}/wx
-config
187 %defattr(-,root
,root
)
188 %doc COPYING.LIB
*.txt
191 %{_libdir}/libwx_%{portname}*_core
*.so.
*
192 %{_libdir}/libwx_%{portname}*_html
*.so.
*
193 %{_libdir}/libwx_%{portname}*_adv
*.so.
*
195 %{_libdir}/libwx_%{portname}*_dbgrid
*.so.
*
198 %files devel
-f core
-headers.files
199 %defattr(-,root
,root
)
200 %{_libdir}/libwx_%{portname}*_core
*.so
201 %{_libdir}/libwx_%{portname}*_html
*.so
202 %{_libdir}/libwx_%{portname}*_adv
*.so
204 %{_libdir}/libwx_%{portname}*_dbgrid
*.so
206 %{_libdir}/libwx_%{portname}*_gl
*.so
209 %{_bindir}/%{wxconfigname}
212 %defattr(-,root
,root
)
213 %{_libdir}/libwx_%{portname}*_gl
*.so.
*
216 %defattr (-,root
,root
)
217 %{_libdir}/libwx_%{portname}*.a
220 %defattr(-,root
,root
)
221 %{_libdir}/libwx_%{portname}*_animate
*.so.
*
222 %{_libdir}/libwx_%{portname}*_deprecated
*.so.
*
223 %{_libdir}/libwx_%{portname}*_fl
*.so.
*
224 %{_libdir}/libwx_%{portname}*_gizmos
*.so.
*
225 %{_libdir}/libwx_%{portname}*_mmedia
*.so.
*
227 %{_libdir}/libwx_%{portname}*_ogl
*.so.
*
229 %{_libdir}/libwx_%{portname}*_plot
*.so.
*
230 %{_libdir}/libwx_%{portname}*_stc
*.so.
*
231 %{_libdir}/libwx_%{portname}*_svg
*.so.
*
232 %{_libdir}/libwx_%{portname}*_xrc
*.so.
*
235 %defattr(-,root
,root
)
237 %dir %{_includedir}/wx
/animate
238 %{_includedir}/wx
/animate
/*
239 %{_libdir}/libwx_%{portname}*_animate
*.so
241 %dir %{_includedir}/wx
/deprecated
242 %{_includedir}/wx
/deprecated
/*
243 %{_libdir}/libwx_%{portname}*_deprecated
*.so
245 %dir %{_includedir}/wx
/fl
246 %{_includedir}/wx
/fl
/*
247 %{_libdir}/libwx_%{portname}*_fl
*.so
249 %dir %{_includedir}/wx
/gizmos
250 %{_includedir}/wx
/gizmos
/*
251 %{_libdir}/libwx_%{portname}*_gizmos
*.so
253 %dir %{_includedir}/wx
/mmedia
254 %{_includedir}/wx
/mmedia
/*
255 %{_libdir}/libwx_%{portname}*_mmedia
*.so
258 %dir %{_includedir}/wx
/ogl
259 %{_includedir}/wx
/ogl
/*
260 %{_libdir}/libwx_%{portname}*_ogl
*.so
263 %dir %{_includedir}/wx
/plot
264 %{_includedir}/wx
/plot
/*
265 %{_libdir}/libwx_%{portname}*_plot
*.so
267 %dir %{_includedir}/wx
/stc
268 %{_includedir}/wx
/stc
/*
269 %{_libdir}/libwx_%{portname}*_stc
*.so
271 %dir %{_includedir}/wx
/svg
272 %{_includedir}/wx
/svg
/*
273 %{_libdir}/libwx_%{portname}*_svg
*.so
275 %dir %{_includedir}/wx
/xrc
276 %{_includedir}/wx
/xrc
/*
277 %{_libdir}/libwx_%{portname}*_xrc
*.so