add wxXLocale class and wxIsxxx_l() and wxToxxx_l() functions (heavily modified and...
[wxWidgets.git] / wxMotif.spec
1 %define pref /usr
2 %define ver 2.9.0
3 %define ver2 2.9
4 %define rel 1
5
6 %define portname motif
7 %define name wx-%{portname}
8 %define wxbasename wx-base
9
10 %define wxconfig %{portname}-ansi-release-%{ver2}
11 %define wxconfiglink wx%{portname}-%{ver2}-config
12
13 Summary: The Motif/Lesstif port of the wxWidgets library
14 Name: %{name}
15 Version: %{ver}
16 Release: %{rel}
17 License: wxWindows Licence
18 Group: X11/Libraries
19 Source: wxMotif-%{ver}.tar.bz2
20 URL: http://www.wxwidgets.org
21 Packager: wxWidgets developers <wx-dev@lists.wxwidgets.org>
22 BuildRoot: %{_tmppath}/%{name}-root
23 Requires: %{wxbasename} = %{ver}
24
25 # all packages providing an implementation of wxWidgets library (regardless of
26 # the toolkit used) should provide the (virtual) wxwin package, this makes it
27 # possible to require wxwin instead of requiring "wxgtk or wxmotif or wxuniv..."
28 Provides: wxwin
29 Provides: wxMotif
30
31 %description
32 wxWidgets is a free C++ library for cross-platform GUI development.
33 With wxWidgets, you can create applications for different GUIs (GTK+,
34 Motif/LessTif, MS Windows, Mac) from the same source code.
35
36 %package devel
37 Summary: The Motif/Lesstif port of the wxWidgets library
38 Group: X11/Libraries
39 Requires: %{name} = %{ver}
40 Requires: %{wxbasename}-devel = %{ver}
41
42 %description devel
43 Header files for wxMotif, the Motif/Lesstif port of the wxWidgets library.
44
45 %package gl
46 Summary: The Motif/Lesstif port of the wxWidgets library, OpenGL add-on.
47 Group: X11/Libraries
48 Requires: %{name} = %{ver}
49
50 %description gl
51 OpenGL add-on library for wxMotif, the Motif/Lesstif port of the wxWidgets library.
52
53 %package static
54 Summary: wxMotif static libraries
55 Group: Development/Libraries
56 Requires: %{wxbasename}-static
57 Requires: %{name}-devel = %{ver}
58
59 %description static
60 Static libraries for wxMotif. You need them if you want to link statically against wxMotif.
61
62 %package contrib
63 Summary: Contrib libraries for wxMotif
64 Group: X11/Libraries
65 Requires: %{name} = %{ver}
66
67 %description contrib
68 Contrib libraries for wxMotif
69
70 %package contrib-devel
71 Summary: Contrib libraries for wxMotif
72 Group: X11/Libraries
73 Requires: %{name}-contrib = %{ver}
74 Requires: %{name}-devel = %{ver}
75
76 %description contrib-devel
77 Header files for contributed libraries for wxMotif.
78
79 %prep
80 %setup -q -n wxMotif-%{ver}
81
82 %build
83 if [ "$SMP" != "" ]; then
84 export MAKE="make -j$SMP"
85 else
86 export MAKE="make"
87 fi
88
89 mkdir obj-shared
90 cd obj-shared
91 ../configure --prefix=%{pref} --with-motif --with-opengl
92 $MAKE
93
94 cd contrib/src
95 $MAKE
96 cd ../../..
97
98 mkdir obj-static
99 cd obj-static
100 ../configure --prefix=%{pref} --with-motif --disable-shared --with-opengl
101 $MAKE
102 cd ..
103
104 %install
105 rm -rf $RPM_BUILD_ROOT
106 (cd obj-static; make prefix=$RPM_BUILD_ROOT%{pref} install)
107 (cd obj-shared; make prefix=$RPM_BUILD_ROOT%{pref} install)
108
109 # Remove headers that are part of wx-base-devel:
110
111 # --- wxBase headers list begins here ---
112 cat <<EOF >wxbase-headers.files
113 wx/afterstd.h
114 wx/app.h
115 wx/apptrait.h
116 wx/archive.h
117 wx/arrimpl.cpp
118 wx/arrstr.h
119 wx/atomic.h
120 wx/base64.h
121 wx/beforestd.h
122 wx/buffer.h
123 wx/build.h
124 wx/chartype.h
125 wx/chkconf.h
126 wx/clntdata.h
127 wx/cmdargs.h
128 wx/cmdline.h
129 wx/confbase.h
130 wx/config.h
131 wx/convauto.h
132 wx/containr.h
133 wx/cpp.h
134 wx/crt.h
135 wx/datetime.h
136 wx/datstrm.h
137 wx/dde.h
138 wx/debug.h
139 wx/defs.h
140 wx/dir.h
141 wx/dlimpexp.h
142 wx/dynarray.h
143 wx/dynlib.h
144 wx/dynload.h
145 wx/encconv.h
146 wx/event.h
147 wx/except.h
148 wx/features.h
149 wx/flags.h
150 wx/ffile.h
151 wx/file.h
152 wx/fileconf.h
153 wx/filefn.h
154 wx/filename.h
155 wx/filesys.h
156 wx/fontenc.h
157 wx/fontmap.h
158 wx/fs_arc.h
159 wx/fs_filter.h
160 wx/fs_mem.h
161 wx/fs_zip.h
162 wx/hash.h
163 wx/hashmap.h
164 wx/hashset.h
165 wx/html/forcelnk.h
166 wx/iconloc.h
167 wx/init.h
168 wx/intl.h
169 wx/iosfwrap.h
170 wx/ioswrap.h
171 wx/ipc.h
172 wx/ipcbase.h
173 wx/link.h
174 wx/list.h
175 wx/listimpl.cpp
176 wx/log.h
177 wx/longlong.h
178 wx/math.h
179 wx/memconf.h
180 wx/memory.h
181 wx/memtext.h
182 wx/mimetype.h
183 wx/module.h
184 wx/msgout.h
185 wx/mstream.h
186 wx/object.h
187 wx/platform.h
188 wx/platinfo.h
189 wx/power.h
190 wx/process.h
191 wx/ptr_scpd.h
192 wx/ptr_shrd.h
193 wx/recguard.h
194 wx/regex.h
195 wx/scopeguard.h
196 wx/snglinst.h
197 wx/sstream.h
198 wx/stack.h
199 wx/stackwalk.h
200 wx/stdpaths.h
201 wx/stockitem.h
202 wx/stopwatch.h
203 wx/strconv.h
204 wx/stream.h
205 wx/string.h
206 wx/stringimpl.h
207 wx/stringops.h
208 wx/strvararg.h
209 wx/sysopt.h
210 wx/tarstrm.h
211 wx/textbuf.h
212 wx/textfile.h
213 wx/thread.h
214 wx/thrimpl.cpp
215 wx/timer.h
216 wx/tokenzr.h
217 wx/tracker.h
218 wx/txtstrm.h
219 wx/types.h
220 wx/unichar.h
221 wx/uri.h
222 wx/utils.h
223 wx/variant.h
224 wx/vector.h
225 wx/version.h
226 wx/volume.h
227 wx/weakref.h
228 wx/wfstream.h
229 wx/wx.h
230 wx/wxchar.h
231 wx/wxcrt.h
232 wx/wxcrtbase.h
233 wx/wxcrtvararg.h
234 wx/wxprec.h
235 wx/xlocale.h
236 wx/xti.h
237 wx/xtistrm.h
238 wx/zipstrm.h
239 wx/zstream.h
240 wx/meta/convertible.h
241 wx/meta/if.h
242 wx/meta/int2type.h
243 wx/meta/movable.h
244 wx/private/fdiodispatcher.h
245 wx/private/selectdispatcher.h
246 wx/unix/app.h
247 wx/unix/apptbase.h
248 wx/unix/apptrait.h
249 wx/unix/chkconf.h
250 wx/unix/evtloop.h
251 wx/unix/pipe.h
252 wx/unix/stdpaths.h
253 wx/unix/stackwalk.h
254 wx/unix/execute.h
255 wx/unix/mimetype.h
256 wx/unix/private.h
257 wx/private/gsocketiohandler.h
258 wx/fs_inet.h
259 wx/gsocket.h
260 wx/protocol/file.h
261 wx/protocol/ftp.h
262 wx/protocol/http.h
263 wx/protocol/protocol.h
264 wx/sckaddr.h
265 wx/sckipc.h
266 wx/sckstrm.h
267 wx/socket.h
268 wx/url.h
269 wx/unix/gsockunx.h
270 wx/xml/xml.h
271 wx/xtixml.h
272 EOF
273 # --- wxBase headers list ends here ---
274 for f in `cat wxbase-headers-list` ; do
275 rm -f $RPM_BUILD_ROOT%{_includedir}/wx-%{ver2}/$f
276 done
277
278 # list of all core headers:
279 find $RPM_BUILD_ROOT%{_includedir}/wx-%{ver2} -type f | sed -e "s,$RPM_BUILD_ROOT,,g" >core-headers.files
280
281 # contrib stuff:
282 (cd obj-shared/contrib/src; make prefix=$RPM_BUILD_ROOT%{pref} install)
283 (cd obj-shared/utils/wxrc; make prefix=$RPM_BUILD_ROOT%{pref} install)
284
285 # remove wxBase files so that RPM doesn't complain about unpackaged files:
286 rm -f $RPM_BUILD_ROOT%{_libdir}/libwx_base*
287 rm -f $RPM_BUILD_ROOT%{_datadir}/aclocal/*
288 rm -f $RPM_BUILD_ROOT%{_datadir}/locale/*/*/*
289
290 %clean
291 rm -rf $RPM_BUILD_ROOT
292
293 %post
294 /sbin/ldconfig
295
296 %postun
297 /sbin/ldconfig
298
299 %post devel
300 # link wx-config when you install RPM.
301 ln -sf %{_libdir}/wx/config/%{wxconfig} %{_bindir}/wx-config
302 # link wx-config with explicit name.
303 ln -sf %{_libdir}/wx/config/%{wxconfig} %{_bindir}/%{wxconfiglink}
304 /sbin/ldconfig
305
306 %postun devel
307 /sbin/ldconfig
308
309 %preun devel
310 if test -f %{_bindir}/wx-config -a -f /usr/bin/md5sum ; then
311 SUM1=`md5sum %{_libdir}/wx/config/%{wxconfig} | cut -c 0-32`
312 SUM2=`md5sum %{_bindir}/wx-config | cut -c 0-32`
313 if test "x$SUM1" = "x$SUM2" ; then
314 rm -f %{_bindir}/wx-config
315 fi
316 fi
317 rm -f %{_bindir}/%{wxconfiglink}
318
319 %post gl
320 /sbin/ldconfig
321
322 %postun gl
323 /sbin/ldconfig
324
325 %post contrib
326 /sbin/ldconfig
327
328 %postun contrib
329 /sbin/ldconfig
330
331 %post contrib-devel
332 /sbin/ldconfig
333
334 %postun contrib-devel
335 /sbin/ldconfig
336
337 %files
338 %defattr(-,root,root)
339 %doc COPYING.LIB *.txt
340 %{_libdir}/libwx_%{portname}*_adv-%{ver2}.so.*
341 %{_libdir}/libwx_%{portname}*_core-%{ver2}.so.*
342 %{_libdir}/libwx_%{portname}*_html-%{ver2}.so.*
343 %{_libdir}/libwx_%{portname}*_media-%{ver2}.so.*
344 %{_libdir}/libwx_%{portname}*_qa-%{ver2}.so.*
345 %{_libdir}/libwx_%{portname}*_xrc-%{ver2}.so.*
346
347
348 %files devel -f core-headers.files
349 %defattr(-,root,root)
350 %{_libdir}/libwx_%{portname}*_adv-%{ver2}.so
351 %{_libdir}/libwx_%{portname}*_core-%{ver2}.so
352 %{_libdir}/libwx_%{portname}*_gl-%{ver2}.so
353 %{_libdir}/libwx_%{portname}*_html-%{ver2}.so
354 %{_libdir}/libwx_%{portname}*_media-%{ver2}.so
355 %{_libdir}/libwx_%{portname}*_qa-%{ver2}.so
356 %{_libdir}/libwx_%{portname}*_xrc-%{ver2}.so
357 %dir %{_libdir}/wx
358 %{_libdir}/wx/*
359 %{_bindir}/wxrc*
360
361 %files gl
362 %defattr(-,root,root)
363 %{_libdir}/libwx_%{portname}*_gl-%{ver2}.so.*
364
365 %files static
366 %defattr (-,root,root)
367 %{_libdir}/libwx_%{portname}*_*-%{ver2}.a
368
369 %files contrib
370 %defattr(-,root,root)
371 %{_libdir}/libwx_%{portname}*_animate-%{ver2}.so.*
372 %{_libdir}/libwx_%{portname}*_deprecated-%{ver2}.so.*
373 %{_libdir}/libwx_%{portname}*_fl-%{ver2}.so.*
374 %{_libdir}/libwx_%{portname}*_gizmos-%{ver2}.so.*
375 %{_libdir}/libwx_%{portname}*_mmedia-%{ver2}.so.*
376 %{_libdir}/libwx_%{portname}*_ogl-%{ver2}.so.*
377 %{_libdir}/libwx_%{portname}*_plot-%{ver2}.so.*
378 %{_libdir}/libwx_%{portname}*_stc-%{ver2}.so.*
379 %{_libdir}/libwx_%{portname}*_svg-%{ver2}.so.*
380
381 %files contrib-devel
382 %defattr(-,root,root)
383 %dir %{_includedir}/wx-%{ver2}/wx/animate
384 %{_includedir}/wx-%{ver2}/wx/animate/*
385 %{_libdir}/libwx_%{portname}*_animate-%{ver2}.so
386
387 %dir %{_includedir}/wx-%{ver2}/wx/deprecated
388 %{_includedir}/wx-%{ver2}/wx/deprecated/*
389 %{_libdir}/libwx_%{portname}*_deprecated-%{ver2}.so
390
391 %dir %{_includedir}/wx-%{ver2}/wx/fl
392 %{_includedir}/wx-%{ver2}/wx/fl/*
393 %{_libdir}/libwx_%{portname}*_fl-%{ver2}.so
394
395 %dir %{_includedir}/wx-%{ver2}/wx/gizmos
396 %{_includedir}/wx-%{ver2}/wx/gizmos/*
397 %{_libdir}/libwx_%{portname}*_gizmos-%{ver2}.so
398
399 %dir %{_includedir}/wx-%{ver2}/wx/mmedia
400 %{_includedir}/wx-%{ver2}/wx/mmedia/*
401 %{_libdir}/libwx_%{portname}*_mmedia-%{ver2}.so
402
403 %dir %{_includedir}/wx-%{ver2}/wx/ogl
404 %{_includedir}/wx-%{ver2}/wx/ogl/*
405 %{_libdir}/libwx_%{portname}*_ogl-%{ver2}.so
406
407 %dir %{_includedir}/wx-%{ver2}/wx/plot
408 %{_includedir}/wx-%{ver2}/wx/plot/*
409 %{_libdir}/libwx_%{portname}*_plot-%{ver2}.so
410
411 %dir %{_includedir}/wx-%{ver2}/wx/stc
412 %{_includedir}/wx-%{ver2}/wx/stc/*
413 %{_libdir}/libwx_%{portname}*_stc-%{ver2}.so
414
415 %dir %{_includedir}/wx-%{ver2}/wx/svg
416 %{_includedir}/wx-%{ver2}/wx/svg/*
417 %{_libdir}/libwx_%{portname}*_svg-%{ver2}.so