regenerated makefiles with bkl-0.2.3
[wxWidgets.git] / wxGTK.spec
1 %define _prefix /usr
2 %define ver 2.9.0
3 %define ver2 2.9
4 %define rel 1
5
6 # Configurable settings (use --with(out) {unicode,gtk2} on rpmbuild cmd line):
7 %define unicode 1
8 %{?_with_unicode: %{expand: %%define unicode 1}}
9 %{?_without_unicode: %{expand: %%define unicode 0}}
10
11 %define gtk2 1
12 %{?_with_gtk2: %{expand: %%define gtk2 1}}
13 %{?_without_gtk2: %{expand: %%define gtk2 0}}
14
15 # "buildname" needs to be e.g. gtk2ud for debug builds
16 %if %{gtk2}
17 %define gtkver 2
18 %define portname gtk2
19 %if %{unicode}
20 %define buildname gtk2u
21 %else
22 %define buildname gtk2
23 %endif
24 %else
25 %define gtkver 1.2
26 %define portname gtk
27 %define buildname gtk
28 %endif
29
30 %if %{unicode}
31 %define name wx-%{portname}-unicode
32 %define wxconfig %{portname}-unicode-release-%{ver2}
33 %define wxconfigstatic %{portname}-unicode-release-static-%{ver2}
34 %define wxconfiglink wx%{portname}u-%{ver2}-config
35 %else
36 %define name wx-%{portname}-ansi
37 %define wxconfig %{portname}-ansi-release-%{ver2}
38 %define wxconfigstatic %{portname}-ansi-release-static-%{ver2}
39 %define wxconfiglink wx%{portname}-%{ver2}-config
40 %endif
41
42 %if %{unicode}
43 %define wxbasename wx-base-unicode
44 %define wxbaseconfig base-unicode-release-%{ver2}
45 %define wxbaseconfiglink wxbaseu-%{ver2}-config
46 %else
47 %define wxbasename wx-base-ansi
48 %define wxbaseconfig base-ansi-release-%{ver2}
49 %define wxbaseconfiglink wxbase-%{ver2}-config
50 %endif
51
52 Summary: The GTK+ %{gtkver} port of the wxWidgets library
53 Name: %{name}
54 Version: %{ver}
55 Release: %{rel}
56 License: wxWindows Licence
57 Group: X11/Libraries
58 Source: wxGTK-%{ver}.tar.bz2
59 URL: http://www.wxwidgets.org
60 Packager: Vadim Zeitlin <vadim@wxwindows.org>
61 Prefix: %{_prefix}
62 BuildRoot: %{_tmppath}/%{name}-root
63 Requires: %{wxbasename} = %{ver}
64 %if %{portname} == gtk2
65 BuildRequires: gtk+-2.0-devel
66 %else
67 BuildRequires: gtk+-devel >= 1.2.0
68 %endif
69
70 BuildRequires: zlib-devel, libjpeg-devel, libpng-devel, libtiff-devel
71
72 # all packages providing an implementation of wxWidgets library (regardless of
73 # the toolkit used) should provide the (virtual) wxwin package, this makes it
74 # possible to require wxwin instead of requiring "wxgtk or wxmotif or wxuniv..."
75 Provides: wxwin
76 Provides: wxGTK
77
78 %description
79 wxWidgets is a free C++ library for cross-platform GUI development.
80 With wxWidgets, you can create applications for different GUIs (GTK+,
81 Motif, MS Windows, MacOS X, Windows CE, GPE) from the same source code.
82
83 %package -n wx-i18n
84 Summary: The translations for the wxWidgets library.
85 Group: X11/Libraries
86
87 %description -n wx-i18n
88 The translations files for the wxWidgets library.
89
90 %package devel
91 Summary: The GTK+ %{gtkver} port of the wxWidgets library
92 Group: X11/Libraries
93 Requires: %{name} = %{ver}
94 Requires: %{wxbasename}-devel = %{ver}
95 Provides: wxGTK-devel
96
97 %description devel
98 The GTK+ %{gtkver} port of the wxWidgets library, header files.
99
100 %package gl
101 Summary: The GTK+ %{gtkver} port of the wxWidgets library, OpenGL add-on.
102 Group: X11/Libraries
103 Requires: %{name} = %{ver}
104 Provides: wxGTK-gl
105
106 %description gl
107 OpenGL add-on library for wxGTK, the GTK+ %{gtkver} port of the wxWidgets library.
108
109 %package -n %{wxbasename}
110 Summary: wxBase library - non-GUI support classes of the wxWidgets toolkit
111 Group: Development/Libraries
112 Provides: wxBase
113
114 %description -n %{wxbasename}
115 wxBase is a collection of C++ classes providing basic data structures (strings,
116 lists, arrays), portable wrappers around many OS-specific funstions (file
117 operations, time/date manipulations, threads, processes, sockets, shared
118 library loading) as well as other utility classes (streams, archive and
119 compression). wxBase currently supports Win32, most Unix variants (Linux,
120 FreeBSD, Solaris, HP-UX) and MacOS X (Carbon and Mach-0).
121
122 %package -n %{wxbasename}-devel
123 Summary: wxBase library, header files.
124 Group: Development/Libraries
125 Provides: wxBase-devel
126
127 %description -n %{wxbasename}-devel
128 wxBase library - non-GUI support classes of the wxWidgets toolkit,
129 header files.
130
131 %package contrib
132 Summary: The GTK+ %{gtkver} port of the wxWidgets library, contributed libraries.
133 Group: X11/Libraries
134 Requires: %{name} = %{ver}
135
136 %description contrib
137 Contributed libraries for wxGTK, the GTK+ %{gtkver} port of the wxWidgets library.
138
139 %package contrib-devel
140 Summary: The GTK+ %{gtkver} port of the wxWidgets library
141 Group: X11/Libraries
142 Requires: %{name}-contrib = %{ver}
143 Requires: %{name}-devel = %{ver}
144
145 %description contrib-devel
146 Header files for contributed libraries for wxGTK, the GTK+ %{gtkver} port of the wxWidgets library.
147
148 %prep
149 %setup -q -n wxGTK-%{ver}
150
151 %build
152 if [ "$SMP" != "" ]; then
153 export MAKE="make -j$SMP"
154 else
155 export MAKE="make"
156 fi
157
158 mkdir obj-shared
159 cd obj-shared
160 ../configure --prefix=%{_prefix} \
161 %if ! %{gtk2}
162 --with-gtk=1 \
163 %else
164 --with-gtk=2 \
165 %endif
166 %if %{unicode}
167 --enable-unicode \
168 %else
169 --disable-unicode \
170 %endif
171 --with-opengl
172 $MAKE
173
174 cd contrib/src
175 $MAKE
176 cd ../../..
177
178 mkdir obj-static
179 cd obj-static
180 ../configure --prefix=%{_prefix} \
181 %if ! %{gtk2}
182 --with-gtk=1 \
183 %else
184 --with-gtk=2 \
185 %endif
186 --disable-shared \
187 %if %{unicode}
188 --enable-unicode \
189 %else
190 --disable-unicode \
191 %endif
192 --with-opengl
193 $MAKE
194
195 cd contrib/src
196 $MAKE
197 cd ../../..
198
199 make -C locale allmo
200
201 %install
202 rm -rf $RPM_BUILD_ROOT
203 (cd obj-static; make DESTDIR=$RPM_BUILD_ROOT prefix=%{_prefix} install)
204 (cd obj-shared; make DESTDIR=$RPM_BUILD_ROOT prefix=%{_prefix} install)
205
206 # --- wxBase headers list begins here ---
207 cat <<EOF >wxbase-headers.files
208 wx/afterstd.h
209 wx/app.h
210 wx/apptrait.h
211 wx/archive.h
212 wx/arrimpl.cpp
213 wx/arrstr.h
214 wx/atomic.h
215 wx/base64.h
216 wx/beforestd.h
217 wx/buffer.h
218 wx/build.h
219 wx/chartype.h
220 wx/chkconf.h
221 wx/clntdata.h
222 wx/cmdargs.h
223 wx/cmdline.h
224 wx/confbase.h
225 wx/config.h
226 wx/convauto.h
227 wx/containr.h
228 wx/cpp.h
229 wx/crt.h
230 wx/datetime.h
231 wx/datstrm.h
232 wx/dde.h
233 wx/debug.h
234 wx/defs.h
235 wx/dir.h
236 wx/dlimpexp.h
237 wx/dynarray.h
238 wx/dynlib.h
239 wx/dynload.h
240 wx/encconv.h
241 wx/event.h
242 wx/except.h
243 wx/features.h
244 wx/flags.h
245 wx/ffile.h
246 wx/file.h
247 wx/fileconf.h
248 wx/filefn.h
249 wx/filename.h
250 wx/filesys.h
251 wx/fontenc.h
252 wx/fontmap.h
253 wx/fs_arc.h
254 wx/fs_filter.h
255 wx/fs_mem.h
256 wx/fs_zip.h
257 wx/hash.h
258 wx/hashmap.h
259 wx/hashset.h
260 wx/html/forcelnk.h
261 wx/iconloc.h
262 wx/init.h
263 wx/intl.h
264 wx/iosfwrap.h
265 wx/ioswrap.h
266 wx/ipc.h
267 wx/ipcbase.h
268 wx/link.h
269 wx/list.h
270 wx/listimpl.cpp
271 wx/log.h
272 wx/longlong.h
273 wx/math.h
274 wx/memconf.h
275 wx/memory.h
276 wx/memtext.h
277 wx/mimetype.h
278 wx/module.h
279 wx/msgout.h
280 wx/mstream.h
281 wx/object.h
282 wx/platform.h
283 wx/platinfo.h
284 wx/power.h
285 wx/process.h
286 wx/ptr_scpd.h
287 wx/ptr_shrd.h
288 wx/recguard.h
289 wx/regex.h
290 wx/scopeguard.h
291 wx/snglinst.h
292 wx/sstream.h
293 wx/stack.h
294 wx/stackwalk.h
295 wx/stdpaths.h
296 wx/stockitem.h
297 wx/stopwatch.h
298 wx/strconv.h
299 wx/stream.h
300 wx/string.h
301 wx/stringimpl.h
302 wx/stringops.h
303 wx/strvararg.h
304 wx/sysopt.h
305 wx/tarstrm.h
306 wx/textbuf.h
307 wx/textfile.h
308 wx/thread.h
309 wx/thrimpl.cpp
310 wx/timer.h
311 wx/tokenzr.h
312 wx/tracker.h
313 wx/txtstrm.h
314 wx/types.h
315 wx/unichar.h
316 wx/uri.h
317 wx/utils.h
318 wx/variant.h
319 wx/vector.h
320 wx/version.h
321 wx/volume.h
322 wx/weakref.h
323 wx/wfstream.h
324 wx/wx.h
325 wx/wxchar.h
326 wx/wxcrt.h
327 wx/wxcrtbase.h
328 wx/wxcrtvararg.h
329 wx/wxprec.h
330 wx/xti.h
331 wx/xtistrm.h
332 wx/zipstrm.h
333 wx/zstream.h
334 wx/meta/convertible.h
335 wx/meta/if.h
336 wx/meta/int2type.h
337 wx/meta/movable.h
338 wx/private/fdiodispatcher.h
339 wx/private/selectdispatcher.h
340 wx/unix/app.h
341 wx/unix/apptbase.h
342 wx/unix/apptrait.h
343 wx/unix/chkconf.h
344 wx/unix/evtloop.h
345 wx/unix/pipe.h
346 wx/unix/stdpaths.h
347 wx/unix/execute.h
348 wx/unix/mimetype.h
349 wx/unix/private.h
350 wx/private/gsocketiohandler.h
351 wx/unix/stackwalk.h
352 wx/fs_inet.h
353 wx/gsocket.h
354 wx/protocol/file.h
355 wx/protocol/ftp.h
356 wx/protocol/http.h
357 wx/protocol/protocol.h
358 wx/sckaddr.h
359 wx/sckipc.h
360 wx/sckstrm.h
361 wx/socket.h
362 wx/url.h
363 wx/unix/gsockunx.h
364 wx/xml/xml.h
365 wx/xtixml.h
366 EOF
367 # --- wxBase headers list ends here ---
368 cat <<EOF >wxbase-headers.paths
369 %{_includedir}/wx-%{ver2}/wx/afterstd.h
370 %{_includedir}/wx-%{ver2}/wx/app.h
371 %{_includedir}/wx-%{ver2}/wx/apptrait.h
372 %{_includedir}/wx-%{ver2}/wx/archive.h
373 %{_includedir}/wx-%{ver2}/wx/arrimpl.cpp
374 %{_includedir}/wx-%{ver2}/wx/arrstr.h
375 %{_includedir}/wx-%{ver2}/wx/beforestd.h
376 %{_includedir}/wx-%{ver2}/wx/buffer.h
377 %{_includedir}/wx-%{ver2}/wx/build.h
378 %{_includedir}/wx-%{ver2}/wx/chkconf.h
379 %{_includedir}/wx-%{ver2}/wx/clntdata.h
380 %{_includedir}/wx-%{ver2}/wx/cmdline.h
381 %{_includedir}/wx-%{ver2}/wx/confbase.h
382 %{_includedir}/wx-%{ver2}/wx/config.h
383 %{_includedir}/wx-%{ver2}/wx/containr.h
384 %{_includedir}/wx-%{ver2}/wx/convauto.h
385 %{_includedir}/wx-%{ver2}/wx/datetime.h
386 %{_includedir}/wx-%{ver2}/wx/datstrm.h
387 %{_includedir}/wx-%{ver2}/wx/dde.h
388 %{_includedir}/wx-%{ver2}/wx/debug.h
389 %{_includedir}/wx-%{ver2}/wx/defs.h
390 %{_includedir}/wx-%{ver2}/wx/dir.h
391 %{_includedir}/wx-%{ver2}/wx/dlimpexp.h
392 %{_includedir}/wx-%{ver2}/wx/dynarray.h
393 %{_includedir}/wx-%{ver2}/wx/dynlib.h
394 %{_includedir}/wx-%{ver2}/wx/dynload.h
395 %{_includedir}/wx-%{ver2}/wx/encconv.h
396 %{_includedir}/wx-%{ver2}/wx/event.h
397 %{_includedir}/wx-%{ver2}/wx/except.h
398 %{_includedir}/wx-%{ver2}/wx/features.h
399 %{_includedir}/wx-%{ver2}/wx/ffile.h
400 %{_includedir}/wx-%{ver2}/wx/file.h
401 %{_includedir}/wx-%{ver2}/wx/fileconf.h
402 %{_includedir}/wx-%{ver2}/wx/filefn.h
403 %{_includedir}/wx-%{ver2}/wx/filename.h
404 %{_includedir}/wx-%{ver2}/wx/filesys.h
405 %{_includedir}/wx-%{ver2}/wx/fontenc.h
406 %{_includedir}/wx-%{ver2}/wx/fontmap.h
407 %{_includedir}/wx-%{ver2}/wx/fs_mem.h
408 %{_includedir}/wx-%{ver2}/wx/fs_zip.h
409 %{_includedir}/wx-%{ver2}/wx/hash.h
410 %{_includedir}/wx-%{ver2}/wx/hashmap.h
411 %{_includedir}/wx-%{ver2}/wx/hashset.h
412 %{_includedir}/wx-%{ver2}/wx/html/forcelnk.h
413 %{_includedir}/wx-%{ver2}/wx/iconloc.h
414 %{_includedir}/wx-%{ver2}/wx/init.h
415 %{_includedir}/wx-%{ver2}/wx/intl.h
416 %{_includedir}/wx-%{ver2}/wx/iosfwrap.h
417 %{_includedir}/wx-%{ver2}/wx/ioswrap.h
418 %{_includedir}/wx-%{ver2}/wx/ipc.h
419 %{_includedir}/wx-%{ver2}/wx/ipcbase.h
420 %{_includedir}/wx-%{ver2}/wx/isql.h
421 %{_includedir}/wx-%{ver2}/wx/isqlext.h
422 %{_includedir}/wx-%{ver2}/wx/link.h
423 %{_includedir}/wx-%{ver2}/wx/list.h
424 %{_includedir}/wx-%{ver2}/wx/listimpl.cpp
425 %{_includedir}/wx-%{ver2}/wx/log.h
426 %{_includedir}/wx-%{ver2}/wx/longlong.h
427 %{_includedir}/wx-%{ver2}/wx/math.h
428 %{_includedir}/wx-%{ver2}/wx/memconf.h
429 %{_includedir}/wx-%{ver2}/wx/memory.h
430 %{_includedir}/wx-%{ver2}/wx/memtext.h
431 %{_includedir}/wx-%{ver2}/wx/mimetype.h
432 %{_includedir}/wx-%{ver2}/wx/module.h
433 %{_includedir}/wx-%{ver2}/wx/msgout.h
434 %{_includedir}/wx-%{ver2}/wx/mstream.h
435 %{_includedir}/wx-%{ver2}/wx/object.h
436 %{_includedir}/wx-%{ver2}/wx/platform.h
437 %{_includedir}/wx-%{ver2}/wx/power.h
438 %{_includedir}/wx-%{ver2}/wx/process.h
439 %{_includedir}/wx-%{ver2}/wx/ptr_scpd.h
440 %{_includedir}/wx-%{ver2}/wx/recguard.h
441 %{_includedir}/wx-%{ver2}/wx/regex.h
442 %{_includedir}/wx-%{ver2}/wx/scopeguard.h
443 %{_includedir}/wx-%{ver2}/wx/snglinst.h
444 %{_includedir}/wx-%{ver2}/wx/sstream.h
445 %{_includedir}/wx-%{ver2}/wx/stack.h
446 %{_includedir}/wx-%{ver2}/wx/stackwalk.h
447 %{_includedir}/wx-%{ver2}/wx/stdpaths.h
448 %{_includedir}/wx-%{ver2}/wx/stockitem.h
449 %{_includedir}/wx-%{ver2}/wx/stopwatch.h
450 %{_includedir}/wx-%{ver2}/wx/strconv.h
451 %{_includedir}/wx-%{ver2}/wx/stream.h
452 %{_includedir}/wx-%{ver2}/wx/string.h
453 %{_includedir}/wx-%{ver2}/wx/sysopt.h
454 %{_includedir}/wx-%{ver2}/wx/textbuf.h
455 %{_includedir}/wx-%{ver2}/wx/textfile.h
456 %{_includedir}/wx-%{ver2}/wx/thread.h
457 %{_includedir}/wx-%{ver2}/wx/thrimpl.cpp
458 %{_includedir}/wx-%{ver2}/wx/timer.h
459 %{_includedir}/wx-%{ver2}/wx/tokenzr.h
460 %{_includedir}/wx-%{ver2}/wx/txtstrm.h
461 %{_includedir}/wx-%{ver2}/wx/types.h
462 %{_includedir}/wx-%{ver2}/wx/uri.h
463 %{_includedir}/wx-%{ver2}/wx/utils.h
464 %{_includedir}/wx-%{ver2}/wx/variant.h
465 %{_includedir}/wx-%{ver2}/wx/vector.h
466 %{_includedir}/wx-%{ver2}/wx/version.h
467 %{_includedir}/wx-%{ver2}/wx/volume.h
468 %{_includedir}/wx-%{ver2}/wx/wfstream.h
469 %{_includedir}/wx-%{ver2}/wx/wx.h
470 %{_includedir}/wx-%{ver2}/wx/wxchar.h
471 %{_includedir}/wx-%{ver2}/wx/wxprec.h
472 %{_includedir}/wx-%{ver2}/wx/xti.h
473 %{_includedir}/wx-%{ver2}/wx/xtistrm.h
474 %{_includedir}/wx-%{ver2}/wx/zipstrm.h
475 %{_includedir}/wx-%{ver2}/wx/zstream.h
476 %{_includedir}/wx-%{ver2}/wx/fs_inet.h
477 %{_includedir}/wx-%{ver2}/wx/gsocket.h
478 %{_includedir}/wx-%{ver2}/wx/protocol/file.h
479 %{_includedir}/wx-%{ver2}/wx/protocol/ftp.h
480 %{_includedir}/wx-%{ver2}/wx/protocol/http.h
481 %{_includedir}/wx-%{ver2}/wx/protocol/protocol.h
482 %{_includedir}/wx-%{ver2}/wx/sckaddr.h
483 %{_includedir}/wx-%{ver2}/wx/sckipc.h
484 %{_includedir}/wx-%{ver2}/wx/sckstrm.h
485 %{_includedir}/wx-%{ver2}/wx/socket.h
486 %{_includedir}/wx-%{ver2}/wx/url.h
487 %{_includedir}/wx-%{ver2}/wx/xml/xml.h
488 %{_includedir}/wx-%{ver2}/wx/xtixml.h
489 %{_includedir}/wx-%{ver2}/wx/unix/apptbase.h
490 %{_includedir}/wx-%{ver2}/wx/unix/apptrait.h
491 %{_includedir}/wx-%{ver2}/wx/unix/execute.h
492 %{_includedir}/wx-%{ver2}/wx/unix/gsockunx.h
493 %{_includedir}/wx-%{ver2}/wx/unix/mimetype.h
494 %{_includedir}/wx-%{ver2}/wx/unix/pipe.h
495 %{_includedir}/wx-%{ver2}/wx/unix/private.h
496 %{_includedir}/wx-%{ver2}/wx/unix/stackwalk.h
497 %{_includedir}/wx-%{ver2}/wx/unix/stdpaths.h
498 EOF
499 # --- wxBase headers list ends here ---
500
501 # temporarily remove base headers
502 mkdir $RPM_BUILD_ROOT/_save_dir
503 cp -r $RPM_BUILD_ROOT%{_includedir}/wx-%{ver2} $RPM_BUILD_ROOT/_save_dir
504 for f in `cat wxbase-headers.files` ; do
505 rm -f $RPM_BUILD_ROOT%{_includedir}/wx-%{ver2}/$f
506 done
507 # list of all core headers:
508 find $RPM_BUILD_ROOT%{_includedir}/wx-%{ver2} -type f | sed -e "s,$RPM_BUILD_ROOT,,g" >core-headers.files
509 # move base headers (actually all headers) back again
510 cp -f -r $RPM_BUILD_ROOT/_save_dir/* $RPM_BUILD_ROOT%{_includedir}
511 rm -rf $RPM_BUILD_ROOT/_save_dir
512
513 # contrib stuff:
514 (cd obj-static/contrib; make DESTDIR=$RPM_BUILD_ROOT prefix=%{_prefix} install)
515 (cd obj-shared/contrib; make DESTDIR=$RPM_BUILD_ROOT prefix=%{_prefix} install)
516
517 # utils:
518 (cd obj-shared/utils/wxrc; make DESTDIR=$RPM_BUILD_ROOT prefix=%{_prefix} install)
519
520 # wx-config link is created during package installation, remove it for now
521 rm -f $RPM_BUILD_ROOT%{_bindir}/wx-config
522
523 %clean
524 rm -rf $RPM_BUILD_ROOT
525
526 %post
527 /sbin/ldconfig
528
529 %postun
530 /sbin/ldconfig
531
532 %post devel
533 # link wx-config when you install RPM.
534 %if %{unicode}
535 ln -sf %{_libdir}/wx/config/%{wxconfig} %{_bindir}/wx-config
536 %endif
537 # link wx-config with explicit name.
538 ln -sf %{_libdir}/wx/config/%{wxconfig} %{_bindir}/%{wxconfiglink}
539 /sbin/ldconfig
540
541 %postun devel
542 /sbin/ldconfig
543
544 %preun devel
545 %if %{unicode}
546 rm -f %{_bindir}/wx-config
547 %endif
548 rm -f %{_bindir}/%{wxconfiglink}
549
550 %post -n %{wxbasename}
551 /sbin/ldconfig
552
553 %postun -n %{wxbasename}
554 /sbin/ldconfig
555
556 %post -n %{wxbasename}-devel
557 # link wx-config with explicit name.
558 ln -sf %{_libdir}/wx/config/%{wxbaseconfig} %{_bindir}/%{wxbaseconfiglink}
559 /sbin/ldconfig
560
561 %postun -n %{wxbasename}-devel
562 /sbin/ldconfig
563
564 %preun -n %{wxbasename}-devel
565 rm -f %{_bindir}/%{wxbaseconfiglink}
566
567 %post gl
568 /sbin/ldconfig
569
570 %postun gl
571 /sbin/ldconfig
572
573 %post contrib
574 /sbin/ldconfig
575
576 %postun contrib
577 /sbin/ldconfig
578
579 %post contrib-devel
580 /sbin/ldconfig
581
582 %postun contrib-devel
583 /sbin/ldconfig
584
585 %files
586 %defattr(-,root,root)
587 %doc COPYING.LIB *.txt
588 %{_libdir}/libwx_%{buildname}_adv-%{ver2}.so.*
589 %{_libdir}/libwx_%{buildname}_aui-%{ver2}.so.*
590 %{_libdir}/libwx_%{buildname}_core-%{ver2}.so.*
591 %{_libdir}/libwx_%{buildname}_html-%{ver2}.so.*
592 %{_libdir}/libwx_%{buildname}_mmedia-%{ver2}.so.*
593 %{_libdir}/libwx_%{buildname}_qa-%{ver2}.so.*
594 %{_libdir}/libwx_%{buildname}_richtext-%{ver2}.so.*
595 %{_libdir}/libwx_%{buildname}_xrc-%{ver2}.so.*
596
597 %files -n wx-i18n
598 %defattr(-,root,root)
599 %{_datadir}/locale/*/LC_MESSAGES/*.mo
600
601 %files devel -f core-headers.files
602 %defattr(-,root,root)
603 # shared libs
604 %{_libdir}/libwx_%{buildname}_adv-%{ver2}.so
605 %{_libdir}/libwx_%{buildname}_aui-%{ver2}.so
606 %{_libdir}/libwx_%{buildname}_core-%{ver2}.so
607 %{_libdir}/libwx_%{buildname}_gl-%{ver2}.so
608 %{_libdir}/libwx_%{buildname}_html-%{ver2}.so
609 %{_libdir}/libwx_%{buildname}_mmedia-%{ver2}.so
610 %{_libdir}/libwx_%{buildname}_qa-%{ver2}.so
611 %{_libdir}/libwx_%{buildname}_richtext-%{ver2}.so
612 %{_libdir}/libwx_%{buildname}_xrc-%{ver2}.so
613 # static libs
614 %{_libdir}/libwx_%{buildname}_adv-%{ver2}.a
615 %{_libdir}/libwx_%{buildname}_aui-%{ver2}.a
616 %{_libdir}/libwx_%{buildname}_core-%{ver2}.a
617 %{_libdir}/libwx_%{buildname}_gl-%{ver2}.a
618 %{_libdir}/libwx_%{buildname}_html-%{ver2}.a
619 %{_libdir}/libwx_%{buildname}_qa-%{ver2}.a
620 %{_libdir}/libwx_%{buildname}_richtext-%{ver2}.a
621 %{_libdir}/libwx_%{buildname}_xrc-%{ver2}.a
622 %dir %{_libdir}/wx
623 %{_libdir}/wx/config/%{wxconfig}
624 %{_libdir}/wx/include/%{wxconfig}/wx/setup.h
625 %{_libdir}/wx/config/%{wxconfigstatic}
626 %{_libdir}/wx/include/%{wxconfigstatic}/wx/setup.h
627 %{_bindir}/wxrc*
628
629 %files -n %{wxbasename}
630 %defattr(-,root,root)
631 %{_libdir}/libwx_base*-%{ver2}.so.*
632
633 %files -n %{wxbasename}-devel -f wxbase-headers.paths
634 %defattr (-,root,root)
635 %dir %{_includedir}/wx-%{ver2}
636 %{_libdir}/libwx_base*-%{ver2}.so
637 %{_libdir}/libwx_base*-%{ver2}.a
638 %if %{unicode}
639 %{_libdir}/libwxregexu-%{ver2}.a
640 %endif
641 %dir %{_libdir}/wx
642 %{_datadir}/aclocal/*.m4
643 %{_datadir}/bakefile/presets/*
644
645 %files gl
646 %defattr(-,root,root)
647 %{_libdir}/libwx_%{buildname}_gl-%{ver2}.so.*
648
649 %files contrib
650 %defattr(-,root,root)
651 %{_libdir}/libwx_%{buildname}_animate-%{ver2}.so.*
652 %{_libdir}/libwx_%{buildname}_deprecated-%{ver2}.so.*
653 %{_libdir}/libwx_%{buildname}_fl-%{ver2}.so.*
654 %{_libdir}/libwx_%{buildname}_gizmos-%{ver2}.so.*
655 %{_libdir}/libwx_%{buildname}_gizmos_xrc-%{ver2}.so.*
656 %{_libdir}/libwx_%{buildname}_mmedia-%{ver2}.so.*
657 %{_libdir}/libwx_%{buildname}_ogl-%{ver2}.so.*
658 %{_libdir}/libwx_%{buildname}_plot-%{ver2}.so.*
659 %{_libdir}/libwx_%{buildname}_stc-%{ver2}.so.*
660 %{_libdir}/libwx_%{buildname}_svg-%{ver2}.so.*
661
662 # static libs
663 %{_libdir}/libwx_%{buildname}_animate-%{ver2}.a
664 %{_libdir}/libwx_%{buildname}_deprecated-%{ver2}.a
665 %{_libdir}/libwx_%{buildname}_fl-%{ver2}.a
666 %{_libdir}/libwx_%{buildname}_gizmos-%{ver2}.a
667 %{_libdir}/libwx_%{buildname}_gizmos_xrc-%{ver2}.a
668 %{_libdir}/libwx_%{buildname}_mmedia-%{ver2}.a
669 %{_libdir}/libwx_%{buildname}_ogl-%{ver2}.a
670 %{_libdir}/libwx_%{buildname}_plot-%{ver2}.a
671 %{_libdir}/libwx_%{buildname}_stc-%{ver2}.a
672 %{_libdir}/libwx_%{buildname}_svg-%{ver2}.a
673
674 %files contrib-devel
675 %defattr(-,root,root)
676 %dir %{_includedir}/wx-%{ver2}/wx/animate
677 %{_includedir}/wx-%{ver2}/wx/animate/*
678 %{_libdir}/libwx_%{buildname}_animate-%{ver2}.so
679
680 %dir %{_includedir}/wx-%{ver2}/wx/deprecated
681 %{_includedir}/wx-%{ver2}/wx/deprecated/*
682 %{_libdir}/libwx_%{buildname}_deprecated-%{ver2}.so
683
684 %dir %{_includedir}/wx-%{ver2}/wx/fl
685 %{_includedir}/wx-%{ver2}/wx/fl/*
686 %{_libdir}/libwx_%{buildname}_fl-%{ver2}.so
687
688 %dir %{_includedir}/wx-%{ver2}/wx/gizmos
689 %{_includedir}/wx-%{ver2}/wx/gizmos/*
690 %{_libdir}/libwx_%{buildname}_gizmos-%{ver2}.so
691 %{_libdir}/libwx_%{buildname}_gizmos_xrc-%{ver2}.so
692
693 %dir %{_includedir}/wx-%{ver2}/wx/mmedia
694 %{_includedir}/wx-%{ver2}/wx/mmedia/*
695 %{_libdir}/libwx_%{buildname}_mmedia-%{ver2}.so
696
697 %dir %{_includedir}/wx-%{ver2}/wx/ogl
698 %{_includedir}/wx-%{ver2}/wx/ogl/*
699 %{_libdir}/libwx_%{buildname}_ogl-%{ver2}.so
700
701 %dir %{_includedir}/wx-%{ver2}/wx/plot
702 %{_includedir}/wx-%{ver2}/wx/plot/*
703 %{_libdir}/libwx_%{buildname}_plot-%{ver2}.so
704
705 %dir %{_includedir}/wx-%{ver2}/wx/stc
706 %{_includedir}/wx-%{ver2}/wx/stc/*
707 %{_libdir}/libwx_%{buildname}_stc-%{ver2}.so
708
709 %dir %{_includedir}/wx-%{ver2}/wx/svg
710 %{_includedir}/wx-%{ver2}/wx/svg/*
711 %{_libdir}/libwx_%{buildname}_svg-%{ver2}.so