]> git.saurik.com Git - wxWidgets.git/blob - wxGTK.spec
extremely dumb script to create wxBase distrib
[wxWidgets.git] / wxGTK.spec
1 %define pref /usr
2 %define ver 2.3.2
3 %define ver2 2.3
4 %define rel 1
5
6 Summary: The GTK+ 1.2 port of the wxWindows library
7 Name: wxGTK
8 Version: %{ver}
9 Release: %{rel}
10 Copyright: wxWindows Licence
11 Group: X11/Libraries
12 Source: wxGTK-%{ver}.tar.bz2
13 URL: http://www.wxwindows.org
14 Packager: Vadim Zeitlin <vadim@wxwindows.org>
15 Prefix: %{pref}
16 BuildRoot: /var/tmp/%{name}-root
17
18 # all packages providing an implementation of wxWindows library (regardless of
19 # the toolkit used) should provide the (virtual) wxwin package, this makes it
20 # possible to require wxwin instead of requiring "wxgtk or wxmotif or wxuniv..."
21 Provides: wxwin
22
23 # in addition, we should provide libwx_gtk as automatic generator only notices
24 # libwx_gtk-%{ver}-%{rel}
25 Provides: libwx_gtk.so
26 Provides: libwx_gtk-%{ver2}.so
27
28 %description
29 wxWindows is a free C++ library for cross-platform GUI development.
30 With wxWindows, you can create applications for different GUIs (GTK+,
31 Motif/LessTif, MS Windows, Mac) from the same source code.
32
33 %package devel
34 Summary: The GTK+ 1.2 port of the wxWindows library
35 Group: X11/Libraries
36 Requires: wxGTK = %{ver}
37
38 %description devel
39 Header files for wxGTK, the GTK+ 1.2 port of the wxWindows library.
40
41 %package gl
42 Summary: The GTK+ 1.2 port of the wxWindows library, OpenGL add-on.
43 Group: X11/Libraries
44 Requires: wxGTK = %{ver}
45
46 %description gl
47 OpenGL add-on library for wxGTK, the GTK+ 1.2 port of the wxWindows library.
48
49 %package static
50 Summary: wxGTK static libraries
51 Group: Development/Libraries
52
53 %description static
54 Static libraries for wxGTK. You need them if you want to link statically against wxGTK.
55
56 %prep
57 %setup -n wxGTK-%{ver}
58
59 %build
60 if [ "$SMP" != "" ]; then
61 export MAKE="make -j$SMP"
62 else
63 export MAKE="make"
64 fi
65
66 (cd locale; make allmo)
67
68 mkdir obj-shared
69 cd obj-shared
70 ../configure --prefix=%{pref} --enable-soname --with-odbc --with-opengl
71 $MAKE
72 cd ..
73
74 mkdir obj-static
75 cd obj-static
76 ../configure --prefix=%{pref} --disable-shared --with-odbc --with-opengl
77 $MAKE
78 cd ..
79
80 %install
81 rm -rf $RPM_BUILD_ROOT
82 (cd obj-static; make prefix=$RPM_BUILD_ROOT%{pref} install)
83 (cd obj-shared; make prefix=$RPM_BUILD_ROOT%{pref} install)
84
85 %find_lang wxstd
86
87 %post
88 /sbin/ldconfig
89
90 %postun
91 /sbin/ldconfig
92
93 %post gl
94 /sbin/ldconfig
95
96 %postun gl
97 /sbin/ldconfig
98
99 %post devel
100 # Install wx-config if there isn't any
101 if test ! -f %{_bindir}/wx-config ; then
102 ln -sf wxgtk-%{ver2}-config %{_bindir}/wx-config
103 fi
104
105 %preun devel
106 # Remove wx-config if it points to this package
107 if test -f %{_bindir}/wx-config -a -f /usr/bin/md5sum ; then
108 SUM1=`md5sum %{_bindir}/wxgtk-%{ver2}-config | cut -c 0-32`
109 SUM2=`md5sum %{_bindir}/wx-config | cut -c 0-32`
110 if test "x$SUM1" = "x$SUM2" ; then
111 rm -f %{_bindir}/wx-config
112 fi
113 fi
114
115
116 %files -f wxstd.lang
117 %defattr(-,root,root)
118 %doc COPYING.LIB *.txt
119 %dir %{_datadir}/wx
120 %{_datadir}/wx/*
121 %{_libdir}/libwx_gtk-%{ver2}*.so.*
122
123 %files devel
124 %defattr(-,root,root)
125 %{_libdir}/libwx_gtk-%{ver2}*.so
126 %dir %{_includedir}/wx
127 %{_includedir}/wx/*
128 %dir %{_libdir}/wx
129 %{_libdir}/wx/*
130 %{_bindir}/wxgtk-%{ver2}-config
131 %{_datadir}/aclocal/*.m4
132
133 %files gl
134 %defattr(-,root,root)
135 %{_libdir}/libwx_gtk_gl*
136
137 %files static
138 %defattr (-,root,root)
139 %{_libdir}/lib*.a