Document domain parameter of wxTranslations::GetTranslatedString().
[wxWidgets.git] / wxGTK.spec
1 %define _prefix /usr
2 %define ver 3.0.0
3 %define ver2 3.0
4 %define rel 1
5 # version for package name according to OpenSuse policy:
6 # http://en.opensuse.org/openSUSE:Shared_library_packaging_policy
7 %define sver 2_9-5
8
9 # Configurable settings (use --with(out) {unicode,gtk2} on rpmbuild cmd line):
10 %define unicode 1
11 %{?_with_unicode: %{expand: %%define unicode 1}}
12 %{?_without_unicode: %{expand: %%define unicode 0}}
13
14 %define gtk2 1
15 %{?_with_gtk2: %{expand: %%define gtk2 1}}
16 %{?_without_gtk2: %{expand: %%define gtk2 0}}
17
18 # "buildname" needs to be e.g. gtk2ud for debug builds
19 %if %{gtk2}
20 %define gtkver 2
21 %define portname gtk2
22 %if %{unicode}
23 %define buildname gtk2u
24 %else
25 %define buildname gtk2
26 %endif
27 %else
28 %define gtkver 1.2
29 %define portname gtk
30 %define buildname gtk
31 %endif
32
33 %if %{unicode}
34 %define name wx-%{portname}-unicode
35 %define wxconfig %{portname}-unicode-%{ver2}
36 %define wxconfigstatic %{portname}-unicode-static-%{ver2}
37 %define wxconfiglink wx%{portname}u-%{ver2}-config
38 %else
39 %define name wx-%{portname}-ansi
40 %define wxconfig %{portname}-ansi-%{ver2}
41 %define wxconfigstatic %{portname}-ansi-static-%{ver2}
42 %define wxconfiglink wx%{portname}-%{ver2}-config
43 %endif
44
45 %if %{unicode}
46 %define wxbasename wx-base-unicode
47 %define wxbaseconfig base-unicode-%{ver2}
48 %define wxbaseconfiglink wxbaseu-%{ver2}-config
49 %else
50 %define wxbasename wx-base-ansi
51 %define wxbaseconfig base-ansi-%{ver2}
52 %define wxbaseconfiglink wxbase-%{ver2}-config
53 %endif
54
55 %if 0%{?suse_version}
56 # avoiding shlib-policy-name-error: Your package contains a single shared
57 # library but is not named after its SONAME.
58 %define glname libwx_%{buildname}_gl-%{sver}
59 %else
60 %define glname %{name}-gl
61 %endif
62
63 Summary: The GTK+ %{gtkver} port of the wxWidgets library
64 Name: %{name}
65 Version: %{ver}
66 Release: %{rel}
67 License: wxWindows Licence
68 Group: System/Libraries
69 Source: wxWidgets-%{ver}.tar.bz2
70 URL: http://www.wxwidgets.org
71 Prefix: %{_prefix}
72 BuildRoot: %{_tmppath}/%{name}-root
73 Requires: %{wxbasename} = %{ver}
74 %if %{portname} == gtk2
75 BuildRequires: gtk2-devel
76 %else
77 BuildRequires: gtk+-devel >= 1.2.0
78 %endif
79
80 BuildRequires: zlib-devel, libjpeg-devel, libpng-devel, libtiff-devel
81 # on RedHat 5 default GCC 4.1.2 crashes during compilation
82 %if 0%{?rhel} == 5
83 BuildRequires: gcc44-c++
84 %else
85 BuildRequires: gcc-c++
86 %endif
87
88 %if 0%{?suse_version}
89 BuildRequires: libexpat-devel, Mesa-devel, xorg-x11-libSM-devel
90 BuildRequires: gstreamer-0_10-devel, gstreamer-0_10-plugins-base-devel
91 %else
92 %if 0%{?mandriva_version}
93 BuildRequires: libexpat-devel, libmesaglu-devel, libsm-devel
94 # For now disabling mediactrl
95 # FIXME: How to resolve OBS Mandriva dependecies for these?
96 #BuildRequires: libgstreamer-devel, libgstreamer-plugins-base-devel
97 %else
98 BuildRequires: expat-devel, libGLU-devel, libSM-devel
99 BuildRequires: gstreamer-devel, gstreamer-plugins-base-devel
100 %endif
101 %endif
102
103 # all packages providing an implementation of wxWidgets library (regardless of
104 # the toolkit used) should provide the (virtual) wxwin package, this makes it
105 # possible to require wxwin instead of requiring "wxgtk or wxmotif or wxuniv..."
106 Provides: wxwin = %{version}
107 Provides: wxGTK = %{version}
108
109 %description
110 wxWidgets is a free C++ library for cross-platform GUI development.
111 With wxWidgets, you can create applications for different GUIs (GTK+,
112 Motif, MS Windows, MacOS X, Windows CE, GPE) from the same source code.
113
114 %package -n wx-i18n
115 Summary: The translations for the wxWidgets library
116 Group: System/Libraries
117
118 %description -n wx-i18n
119 The translations files for the wxWidgets library.
120
121 %package devel
122 Summary: The GTK+ %{gtkver} port of the wxWidgets library
123 Group: Development/Libraries
124 Requires: %{name} = %{ver}
125 Requires: %{glname} = %{ver}
126 Requires: %{wxbasename}-devel = %{ver}
127 Provides: wxGTK-devel = %{version}
128
129 %description devel
130 The GTK+ %{gtkver} port of the wxWidgets library, header files.
131
132 %package -n %{glname}
133 Summary: The GTK+ %{gtkver} port of the wxWidgets library, OpenGL add-on
134 Group: System/Libraries
135 Requires: %{name} = %{ver}
136 Provides: wxGTK-gl = %{version}
137
138 %description -n %{glname}
139 OpenGL add-on library for wxGTK, the GTK+ %{gtkver} port of the wxWidgets library.
140
141 %package -n %{wxbasename}
142 Summary: wxBase library - non-GUI support classes of the wxWidgets toolkit
143 Group: Development/Libraries
144 Provides: wxBase = %{version}
145
146 %description -n %{wxbasename}
147 wxBase is a collection of C++ classes providing basic data structures (strings,
148 lists, arrays), portable wrappers around many OS-specific funstions (file
149 operations, time/date manipulations, threads, processes, sockets, shared
150 library loading) as well as other utility classes (streams, archive and
151 compression). wxBase currently supports Win32, most Unix variants (Linux,
152 FreeBSD, Solaris, HP-UX) and MacOS X (Carbon and Mach-0).
153
154 %package -n %{wxbasename}-devel
155 Summary: wxBase library, header files
156 Group: Development/Libraries
157 Provides: wxBase-devel = %{version}
158
159 %description -n %{wxbasename}-devel
160 wxBase library - non-GUI support classes of the wxWidgets toolkit,
161 header files.
162
163 %prep
164 %setup -q -n wxWidgets-%{ver}
165
166 %build
167
168 %if 0%{?rhel} == 5
169 export CC=gcc44
170 export CXX=g++44
171 %endif
172 # if it's not set OpenSuse warns: "compiled without RPM_OPT_FLAGS"
173 export CFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing"
174 export CXXFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing"
175
176 mkdir obj-shared
177 cd obj-shared
178 ../configure --prefix=%{_prefix} --libdir=%{_libdir} --disable-rpath \
179 %if ! %{gtk2}
180 --with-gtk=1 \
181 %else
182 --with-gtk=2 \
183 %endif
184 %if %{unicode}
185 --enable-unicode \
186 %else
187 --disable-unicode \
188 %endif
189 %if ! 0%{?mandriva_version}
190 --enable-mediactrl \
191 %endif
192 --with-opengl
193 make %{?_smp_mflags}
194
195 cd ..
196
197 mkdir obj-static
198 cd obj-static
199 ../configure --prefix=%{_prefix} --libdir=%{_libdir} --disable-rpath \
200 %if ! %{gtk2}
201 --with-gtk=1 \
202 %else
203 --with-gtk=2 \
204 %endif
205 --disable-shared \
206 %if %{unicode}
207 --enable-unicode \
208 %else
209 --disable-unicode \
210 %endif
211 %if ! 0%{?mandriva_version}
212 --enable-mediactrl \
213 %endif
214 --with-opengl
215 make %{?_smp_mflags}
216
217 cd ..
218
219 make -C locale allmo
220
221 %install
222 rm -rf $RPM_BUILD_ROOT
223 (cd obj-static; make DESTDIR=$RPM_BUILD_ROOT prefix=%{_prefix} install)
224 (cd obj-shared; make DESTDIR=$RPM_BUILD_ROOT prefix=%{_prefix} install)
225
226 # --- wxBase headers list begins here ---
227 cat <<EOF >wxbase-headers.files
228 wx/afterstd.h
229 wx/any.h
230 wx/anystr.h
231 wx/app.h
232 wx/apptrait.h
233 wx/archive.h
234 wx/arrimpl.cpp
235 wx/arrstr.h
236 wx/atomic.h
237 wx/base64.h
238 wx/beforestd.h
239 wx/buffer.h
240 wx/build.h
241 wx/chartype.h
242 wx/checkeddelete.h
243 wx/chkconf.h
244 wx/clntdata.h
245 wx/cmdargs.h
246 wx/cmdline.h
247 wx/compiler.h
248 wx/confbase.h
249 wx/config.h
250 wx/convauto.h
251 wx/containr.h
252 wx/cpp.h
253 wx/crt.h
254 wx/datetime.h
255 wx/datstrm.h
256 wx/dde.h
257 wx/debug.h
258 wx/defs.h
259 wx/dir.h
260 wx/dlimpexp.h
261 wx/dlist.h
262 wx/dynarray.h
263 wx/dynlib.h
264 wx/dynload.h
265 wx/encconv.h
266 wx/event.h
267 wx/eventfilter.h
268 wx/evtloop.h
269 wx/except.h
270 wx/features.h
271 wx/flags.h
272 wx/ffile.h
273 wx/file.h
274 wx/fileconf.h
275 wx/filefn.h
276 wx/filename.h
277 wx/filesys.h
278 wx/fontenc.h
279 wx/fontmap.h
280 wx/fs_arc.h
281 wx/fs_filter.h
282 wx/fs_mem.h
283 wx/fs_zip.h
284 wx/hash.h
285 wx/hashmap.h
286 wx/hashset.h
287 wx/html/forcelnk.h
288 wx/iconloc.h
289 wx/init.h
290 wx/intl.h
291 wx/iosfwrap.h
292 wx/ioswrap.h
293 wx/ipc.h
294 wx/ipcbase.h
295 wx/kbdstate.h
296 wx/language.h
297 wx/link.h
298 wx/list.h
299 wx/listimpl.cpp
300 wx/log.h
301 wx/longlong.h
302 wx/math.h
303 wx/memconf.h
304 wx/memory.h
305 wx/memtext.h
306 wx/mimetype.h
307 wx/module.h
308 wx/mousestate.h
309 wx/msgout.h
310 wx/msgqueue.h
311 wx/mstream.h
312 wx/numformatter.h
313 wx/object.h
314 wx/platform.h
315 wx/platinfo.h
316 wx/power.h
317 wx/process.h
318 wx/ptr_scpd.h
319 wx/ptr_shrd.h
320 wx/recguard.h
321 wx/regex.h
322 wx/rtti.h
323 wx/scopedarray.h
324 wx/scopedptr.h
325 wx/scopeguard.h
326 wx/sharedptr.h
327 wx/snglinst.h
328 wx/sstream.h
329 wx/stack.h
330 wx/stackwalk.h
331 wx/stdpaths.h
332 wx/stdstream.h
333 wx/stockitem.h
334 wx/stopwatch.h
335 wx/strconv.h
336 wx/stream.h
337 wx/string.h
338 wx/stringimpl.h
339 wx/stringops.h
340 wx/strvararg.h
341 wx/sysopt.h
342 wx/tarstrm.h
343 wx/textbuf.h
344 wx/textfile.h
345 wx/thread.h
346 wx/thrimpl.cpp
347 wx/time.h
348 wx/timer.h
349 wx/tls.h
350 wx/tokenzr.h
351 wx/tracker.h
352 wx/translation.h
353 wx/txtstrm.h
354 wx/typeinfo.h
355 wx/types.h
356 wx/unichar.h
357 wx/uri.h
358 wx/ustring.h
359 wx/utils.h
360 wx/variant.h
361 wx/vector.h
362 wx/version.h
363 wx/versioninfo.h
364 wx/volume.h
365 wx/weakref.h
366 wx/wfstream.h
367 wx/wx.h
368 wx/wxchar.h
369 wx/wxcrt.h
370 wx/wxcrtbase.h
371 wx/wxcrtvararg.h
372 wx/wxprec.h
373 wx/xlocale.h
374 wx/xti.h
375 wx/xti2.h
376 wx/xtistrm.h
377 wx/xtictor.h
378 wx/xtihandler.h
379 wx/xtiprop.h
380 wx/xtitypes.h
381 wx/zipstrm.h
382 wx/zstream.h
383 wx/meta/convertible.h
384 wx/meta/if.h
385 wx/meta/implicitconversion.h
386 wx/meta/int2type.h
387 wx/meta/movable.h
388 wx/meta/pod.h
389 wx/meta/removeref.h
390 wx/fswatcher.h
391 wx/generic/fswatcher.h
392 wx/unix/app.h
393 wx/unix/apptbase.h
394 wx/unix/apptrait.h
395 wx/unix/chkconf.h
396 wx/unix/evtloop.h
397 wx/unix/evtloopsrc.h
398 wx/unix/pipe.h
399 wx/unix/stdpaths.h
400 wx/unix/stackwalk.h
401 wx/unix/tls.h
402 wx/unix/fswatcher_kqueue.h
403 wx/unix/execute.h
404 wx/unix/mimetype.h
405 wx/unix/fswatcher_inotify.h
406 wx/fs_inet.h
407 wx/protocol/file.h
408 wx/protocol/ftp.h
409 wx/protocol/http.h
410 wx/protocol/log.h
411 wx/protocol/protocol.h
412 wx/sckaddr.h
413 wx/sckipc.h
414 wx/sckstrm.h
415 wx/socket.h
416 wx/url.h
417 wx/xml/xml.h
418 wx/xtixml.h
419 EOF
420 # --- wxBase headers list ends here ---
421
422 # --- wxBase headers list with paths ---
423 sed -e 's@^@%{_includedir}/wx-%{ver2}/@' wxbase-headers.files > wxbase-headers.paths
424
425
426 # temporarily remove base headers
427 mkdir $RPM_BUILD_ROOT/_save_dir
428 cp -r $RPM_BUILD_ROOT%{_includedir}/wx-%{ver2} $RPM_BUILD_ROOT/_save_dir
429 for f in `cat wxbase-headers.files` ; do
430 rm -f $RPM_BUILD_ROOT%{_includedir}/wx-%{ver2}/$f
431 done
432 # list of all core headers:
433 find $RPM_BUILD_ROOT%{_includedir}/wx-%{ver2} -type f | sed -e "s,$RPM_BUILD_ROOT,,g" >core-headers.files
434 # move base headers (actually all headers) back again
435 cp -f -r $RPM_BUILD_ROOT/_save_dir/* $RPM_BUILD_ROOT%{_includedir}
436 rm -rf $RPM_BUILD_ROOT/_save_dir
437
438 # utils:
439 (cd obj-shared/utils/wxrc; make DESTDIR=$RPM_BUILD_ROOT prefix=%{_prefix} install)
440
441 # wx-config link is created during package installation, remove it for now
442 rm -f $RPM_BUILD_ROOT%{_bindir}/wx-config
443
444 %clean
445 rm -rf $RPM_BUILD_ROOT
446
447 %post
448 /sbin/ldconfig
449
450 %postun
451 /sbin/ldconfig
452
453 %post devel
454 # link wx-config when you install RPM.
455 %if %{unicode}
456 ln -sf %{_libdir}/wx/config/%{wxconfig} %{_bindir}/wx-config
457 %endif
458 # link wx-config with explicit name.
459 ln -sf %{_libdir}/wx/config/%{wxconfig} %{_bindir}/%{wxconfiglink}
460 /sbin/ldconfig
461
462 %postun devel
463 /sbin/ldconfig
464
465 %preun devel
466 %if %{unicode}
467 rm -f %{_bindir}/wx-config
468 %endif
469 rm -f %{_bindir}/%{wxconfiglink}
470
471 %post -n %{wxbasename}
472 /sbin/ldconfig
473
474 %postun -n %{wxbasename}
475 /sbin/ldconfig
476
477 %post -n %{wxbasename}-devel
478 # link wx-config with explicit name.
479 ln -sf %{_libdir}/wx/config/%{wxbaseconfig} %{_bindir}/%{wxbaseconfiglink}
480 /sbin/ldconfig
481
482 %postun -n %{wxbasename}-devel
483 /sbin/ldconfig
484
485 %preun -n %{wxbasename}-devel
486 rm -f %{_bindir}/%{wxbaseconfiglink}
487
488 %post -n %{glname}
489 /sbin/ldconfig
490
491 %postun -n %{glname}
492 /sbin/ldconfig
493
494 %files
495 %defattr(-,root,root)
496 #doc COPYING.LIB *.txt
497 %{_libdir}/libwx_%{buildname}_adv-%{ver2}.so.*
498 %{_libdir}/libwx_%{buildname}_aui-%{ver2}.so.*
499 %{_libdir}/libwx_%{buildname}_core-%{ver2}.so.*
500 %{_libdir}/libwx_%{buildname}_html-%{ver2}.so.*
501 %if ! 0%{?mandriva_version}
502 %{_libdir}/libwx_%{buildname}_media-%{ver2}.so.*
503 %endif
504 %{_libdir}/libwx_%{buildname}_propgrid-%{ver2}.so.*
505 %{_libdir}/libwx_%{buildname}_qa-%{ver2}.so.*
506 %{_libdir}/libwx_%{buildname}_ribbon-%{ver2}.so.*
507 %{_libdir}/libwx_%{buildname}_richtext-%{ver2}.so.*
508 %{_libdir}/libwx_%{buildname}_stc-%{ver2}.so.*
509 %{_libdir}/libwx_%{buildname}_xrc-%{ver2}.so.*
510
511 %files -n wx-i18n
512 %defattr(-,root,root)
513 %{_datadir}/locale/*/LC_MESSAGES/*.mo
514
515 %files devel -f core-headers.files
516 %defattr(-,root,root)
517 %dir %{_includedir}/wx-%{ver2}/wx/aui
518 %dir %{_includedir}/wx-%{ver2}/wx/gtk
519 %dir %{_includedir}/wx-%{ver2}/wx/gtk/gnome
520 %dir %{_includedir}/wx-%{ver2}/wx/gtk/hildon
521 %dir %{_includedir}/wx-%{ver2}/wx/persist
522 %dir %{_includedir}/wx-%{ver2}/wx/propgrid
523 %dir %{_includedir}/wx-%{ver2}/wx/ribbon
524 %dir %{_includedir}/wx-%{ver2}/wx/richtext
525 %dir %{_includedir}/wx-%{ver2}/wx/stc
526 %dir %{_includedir}/wx-%{ver2}/wx/unix
527 %dir %{_includedir}/wx-%{ver2}/wx/xrc
528 # shared libs
529 %{_libdir}/libwx_%{buildname}_adv-%{ver2}.so
530 %{_libdir}/libwx_%{buildname}_aui-%{ver2}.so
531 %{_libdir}/libwx_%{buildname}_core-%{ver2}.so
532 %{_libdir}/libwx_%{buildname}_gl-%{ver2}.so
533 %{_libdir}/libwx_%{buildname}_html-%{ver2}.so
534 %if ! 0%{?mandriva_version}
535 %{_libdir}/libwx_%{buildname}_media-%{ver2}.so
536 %endif
537 %{_libdir}/libwx_%{buildname}_propgrid-%{ver2}.so
538 %{_libdir}/libwx_%{buildname}_qa-%{ver2}.so
539 %{_libdir}/libwx_%{buildname}_ribbon-%{ver2}.so
540 %{_libdir}/libwx_%{buildname}_richtext-%{ver2}.so
541 %{_libdir}/libwx_%{buildname}_stc-%{ver2}.so
542 %{_libdir}/libwx_%{buildname}_xrc-%{ver2}.so
543 # static libs
544 %{_libdir}/libwx_%{buildname}_adv-%{ver2}.a
545 %{_libdir}/libwx_%{buildname}_aui-%{ver2}.a
546 %{_libdir}/libwx_%{buildname}_core-%{ver2}.a
547 %{_libdir}/libwx_%{buildname}_gl-%{ver2}.a
548 %{_libdir}/libwx_%{buildname}_html-%{ver2}.a
549 %if ! 0%{?mandriva_version}
550 %{_libdir}/libwx_%{buildname}_media-%{ver2}.a
551 %endif
552 %{_libdir}/libwx_%{buildname}_propgrid-%{ver2}.a
553 %{_libdir}/libwx_%{buildname}_qa-%{ver2}.a
554 %{_libdir}/libwx_%{buildname}_ribbon-%{ver2}.a
555 %{_libdir}/libwx_%{buildname}_richtext-%{ver2}.a
556 %{_libdir}/libwx_%{buildname}_stc-%{ver2}.a
557 %{_libdir}/libwx_%{buildname}_xrc-%{ver2}.a
558 %dir %{_libdir}/wx
559 %dir %{_libdir}/wx/config
560 %dir %{_libdir}/wx/include
561 %dir %{_libdir}/wx/include/%{wxconfig}
562 %dir %{_libdir}/wx/include/%{wxconfig}/wx
563 %dir %{_libdir}/wx/include/%{wxconfigstatic}
564 %dir %{_libdir}/wx/include/%{wxconfigstatic}/wx
565 %{_libdir}/wx/config/%{wxconfig}
566 %{_libdir}/wx/include/%{wxconfig}/wx/setup.h
567 %{_libdir}/wx/config/%{wxconfigstatic}
568 %{_libdir}/wx/include/%{wxconfigstatic}/wx/setup.h
569 %{_bindir}/wxrc*
570
571 %files -n %{wxbasename}
572 %defattr(-,root,root)
573 %{_libdir}/libwx_base*-%{ver2}.so.*
574
575 %files -n %{wxbasename}-devel -f wxbase-headers.paths
576 %defattr (-,root,root)
577 %dir %{_includedir}/wx-%{ver2}
578 %dir %{_includedir}/wx-%{ver2}/wx
579 %dir %{_includedir}/wx-%{ver2}/wx/generic
580 %dir %{_includedir}/wx-%{ver2}/wx/html
581 %dir %{_includedir}/wx-%{ver2}/wx/meta
582 %dir %{_includedir}/wx-%{ver2}/wx/protocol
583 %dir %{_includedir}/wx-%{ver2}/wx/unix
584 %dir %{_includedir}/wx-%{ver2}/wx/xml
585 %dir %{_datadir}/bakefile/presets
586 %{_libdir}/libwx_base*-%{ver2}.so
587 %{_libdir}/libwx_base*-%{ver2}.a
588 %if %{unicode}
589 %{_libdir}/libwxregexu-%{ver2}.a
590 %endif
591 %{_libdir}/libwxscintilla-%{ver2}.a
592 %dir %{_libdir}/wx
593 %dir %{_datadir}/bakefile
594 %dir %{_datadir}/bakefile/presets
595 %{_datadir}/aclocal/*.m4
596 %{_datadir}/bakefile/presets/*
597
598 %files -n %{glname}
599 %defattr(-,root,root)
600 %{_libdir}/libwx_%{buildname}_gl-%{ver2}.so.*