Committing in .
[wxWidgets.git] / wxGTK.spec
1 # Note that this is NOT a relocatable package
2 %define pref /usr
3 %define ver 2.1.14
4 %define rel 0
5
6 Summary: The GTK+ 1.2 port of the wxWindows library
7 Name: wxGTK
8 Version: %{ver}
9 Release: %{rel}
10 Copyright: wxWindows Licence
11 Group: X11/Libraries
12 Source: wxGTK-%{ver}.tgz
13 URL: http://wesley.informatik.uni-freiburg.de/~wxxt/docs.html
14 Packager: Robert Roebling <roebling@ruf.uni-freiburg.de>
15 BuildRoot: /tmp/wxgtk_root
16
17 # all packages providing an implementation of wxWindows library (regardless of
18 # the toolkit used) should provide the (virtual) wxwin package, this makes it
19 # possible to require wxwin instead of requiring "wxgtk or wxmotif or wxqt..."
20 Provides: wxwin
21
22 %description
23 wxWindows is a free C++ library for cross-platform GUI development.
24 With wxWindows, you can create applications for different GUIs (GTK+,
25 Motif/LessTif, MS Windows, Mac) from the same source code.
26
27 %package devel
28 Summary: The GTK+ 1.2 port of the wxWindows library
29 Group: X11/Libraries
30 Requires: wxGTK
31
32 %description devel
33 Header files for wxGTK, the GTK+ 1.2 port of the wxWindows library.
34
35 %package gl
36 Summary: The GTK+ 1.2 port of the wxWindows library, OpenGl add-on.
37 Group: X11/Libraries
38 Requires: wxGTK
39
40 %description gl
41 OpenGl add-on library for wxGTK, the GTK+ 1.2 port of the wxWindows library.
42
43 %prep
44 %setup -n wxGTK
45 ./configure --prefix=%{pref} --enable-burnt_name --with-odbc --with-opengl
46
47 %build
48 if [ "$SMP" != "" ]; then
49 export MAKE="make -j$SMP"
50 else
51 export MAKE="make"
52 fi
53 $MAKE
54
55 %install
56 rm -rf $RPM_BUILD_ROOT
57 make prefix=$RPM_BUILD_ROOT%{pref} install
58
59 %clean
60 rm -rf $RPM_BUILD_ROOT
61
62 %post
63 /sbin/ldconfig
64
65 %postun
66 /sbin/ldconfig
67
68 %files
69 %defattr (644, root, root, 755)
70 %doc COPYING.LIB INSTALL.txt LICENCE.txt README.txt SYMBOLS.txt TODO.txt
71 %dir %{pref}/share/wx
72 %{pref}/share/wx/*
73 %attr(755, -, -) %{pref}/lib/libwx_gtk*
74
75 %files devel
76 %defattr (644, root, root, 755)
77 %dir %{pref}/include/wx
78 %{pref}/include/wx/*
79 %dir %{pref}/lib/wx
80 %{pref}/lib/wx/*
81 %attr(755, -, -) %{pref}/bin/wxgtk-config
82 %attr(755, -, -) %{pref}/bin/wx-config
83
84 %files gl
85 %attr(755, -, -) %{pref}/lib/libwx_gtk_gl*