]> git.saurik.com Git - wxWidgets.git/blob - wxGTK.spec
compile error with VC6.0 fixed. #include "wx/wxprec.h" moved to top of file
[wxWidgets.git] / wxGTK.spec
1 # Note that this is NOT a relocatable package
2 %define pref /usr
3 %define ver 2.1.0
4 %define rel 9
5
6 Summary: The GTK+ 1.2 port of the wxWindows library
7 Name: wxGTK
8 Version: %{ver}
9 Release: %{rel}
10 Copyright: wxWindows Licence
11 Group: X11/Libraries
12 Source: ftp://wesley.informatik.uni-freiburg.de/pub/linux/wxxt/source/wxGTK-2.1.0-b9.tgz
13 URL: http://wesley.informatik.uni-freiburg.de/~wxxt/docs.html
14 Packager: Robert Roebling <roebling@ruf.uni-freiburg.de>
15 Requires: gtk+ >= 1.2.1
16 BuildRoot: /tmp/wxgtk_root
17
18 # all packages providing an implementation of wxWindows library (regardless of
19 # the toolkit used) should provide the (virtual) wxwin package, this makes it
20 # possible to require wxwin instead of requiring "wxgtk or wxmotif or wxqt..."
21 Provides: wxwin
22
23 %description
24 wxWindows is a free C++ library for cross-platform GUI development.
25 With wxWindows, you can create applications for different GUIs (GTK+,
26 Motif/LessTif, MS Windows, Mac) from the same source code.
27
28 %package devel
29 Summary: The GTK+ 1.2 port of the wxWindows library
30 Group: X11/Libraries
31 Requires: wxGTK
32
33 %description devel
34 Header files for the wxGTK, the GTK+ 1.2 port of the wxWindows library.
35
36 %prep
37 %setup -n wxGTK
38 ./configure --prefix=%{pref} --enable-threads --disable-std_iostreams
39
40 %build
41 make
42
43 %install
44 rm -rf $RPM_BUILD_ROOT
45 make prefix=$RPM_BUILD_ROOT%{pref} install
46
47 %clean
48 rm -rf $RPM_BUILD_ROOT
49
50 %post
51 /sbin/ldconfig
52
53 %postun
54 /sbin/ldconfig
55
56 %files
57 %defattr (644, root, root, 755)
58 %doc COPYING.LIB INSTALL.txt LICENCE.txt README.txt SYMBOLS.txt TODO.txt
59 %dir %{pref}/share/wx
60 %{pref}/share/wx/*
61 %attr(755, -, -) %{pref}/lib/libwx_gtk*
62
63 %files devel
64 %defattr (644, root, root, 755)
65 %dir %{pref}/include/wx
66 %{pref}/include/wx/*
67 %dir %{pref}/lib/wx
68 %{pref}/lib/wx/*
69 %attr(755, -, -) %{pref}/bin/wx-config
70