renamed wx/ptr_shrd.h to wx/sharedptr.h; split wx/ptr_scpd.h in wx/scopedptr.h and...
[wxWidgets.git] / wxX11.spec
1 %define pref /usr
2 %define ver 2.9.0
3 %define ver2 2.9
4 %define rel 1
5
6 # Configurable settings (use --with(out) unicode on rpmbuild cmd line):
7 %define unicode 0
8 %{?_with_unicode: %{expand: %%define unicode 1}}
9 %{?_without_unicode: %{expand: %%define unicode 0}}
10
11 %define portname x11univ
12
13 %if %{unicode}
14 %define wxbasename wx-base-unicode
15 %define name wx-%{portname}-unicode
16 %define wxconfig %{portname}-unicode-release-%{ver2}
17 %define wxconfiglink wx%{portname}u-%{ver2}-config
18 %else
19 %define wxbasename wx-base
20 %define name wx-%{portname}
21 %define wxconfig %{portname}-ansi-release-%{ver2}
22 %define wxconfiglink wx%{portname}-%{ver2}-config
23 %endif
24
25 Summary: The X11 port of the wxWidgets library
26 Name: %{name}
27 Version: %{ver}
28 Release: %{rel}
29 License: wxWindows Licence
30 Group: X11/Libraries
31 Source: wxX11-%{ver}.tar.bz2
32 URL: http://www.wxwidgets.org
33 Packager: Vadim Zeitlin <vadim@wxwindows.org>
34 Prefix: %{pref}
35 BuildRoot: %{_tmppath}/%{name}-root
36 Requires: %{wxbasename} = %{ver}
37
38 # all packages providing an implementation of wxWidgets library (regardless of
39 # the toolkit used) should provide the (virtual) wxwin package, this makes it
40 # possible to require wxwin instead of requiring "wxgtk or wxmotif or wxuniv..."
41 Provides: wxwin
42 Provides: wxX11
43
44 %description
45 wxWidgets is a free C++ library for cross-platform GUI development.
46 With wxWidgets, you can create applications for different GUIs (GTK+,
47 Motif/LessTif, MS Windows, Mac) from the same source code.
48
49 %package devel
50 Summary: The X11 port of the wxWidgets library
51 Group: X11/Libraries
52 Requires: %{name} = %{ver}
53 Requires: %{wxbasename}-devel = %{ver}
54
55 %description devel
56 Header files for wxX11, the X11 port of the wxWidgets library.
57
58 %package gl
59 Summary: The X11 port of the wxWidgets library, OpenGL add-on.
60 Group: X11/Libraries
61 Requires: %{name} = %{ver}
62
63 %description gl
64 OpenGL add-on library for wxX11, the X11 port of the wxWidgets library.
65
66 %package static
67 Summary: wxX11 static libraries
68 Group: Development/Libraries
69 Requires: %{wxbasename}-static
70 Requires: %{name}-devel = %{ver}
71
72 %description static
73 Static libraries for wxX11. You need them if you want to link statically against wxX11.
74
75 %package contrib
76 Summary: Contrib libraries for wxX11.
77 Group: X11/Libraries
78 Requires: %{name} = %{ver}
79
80 %description contrib
81 Contributed libraries for wxX11.
82
83 %package contrib-devel
84 Summary: Contrib libraries for wxX11.
85 Group: X11/Libraries
86 Requires: %{name}-contrib = %{ver}
87 Requires: %{name}-devel = %{ver}
88
89 %description contrib-devel
90 Header files for contributed libraries for wxX11.
91
92 %prep
93 %setup -q -n wxX11-%{ver}
94
95 %build
96 if [ "$SMP" != "" ]; then
97 export MAKE="make -j$SMP"
98 else
99 export MAKE="make"
100 fi
101
102 mkdir obj-shared
103 cd obj-shared
104 ../configure --prefix=%{pref} --with-x11 \
105 %if %{unicode}
106 --enable-unicode \
107 %else
108 --disable-unicode \
109 %endif
110 $MAKE
111
112 cd contrib/src
113 $MAKE
114 cd ../../..
115
116 mkdir obj-static
117 cd obj-static
118 ../configure --prefix=%{pref} --with-x11 --disable-shared \
119 %if %{unicode}
120 --enable-unicode \
121 %else
122 --disable-unicode \
123 %endif
124 --with-opengl
125 $MAKE
126 cd ..
127
128 %install
129 rm -rf $RPM_BUILD_ROOT
130 (cd obj-static; make prefix=$RPM_BUILD_ROOT%{pref} install)
131 (cd obj-shared; make prefix=$RPM_BUILD_ROOT%{pref} install)
132
133 # Remove headers that are part of wx-base-devel:
134
135 # --- wxBase headers list begins here ---
136 cat <<EOF >wxbase-headers.files
137 wx/afterstd.h
138 wx/app.h
139 wx/apptrait.h
140 wx/archive.h
141 wx/arrimpl.cpp
142 wx/arrstr.h
143 wx/atomic.h
144 wx/base64.h
145 wx/beforestd.h
146 wx/buffer.h
147 wx/build.h
148 wx/chartype.h
149 wx/checkeddelete.h
150 wx/chkconf.h
151 wx/clntdata.h
152 wx/cmdargs.h
153 wx/cmdline.h
154 wx/confbase.h
155 wx/config.h
156 wx/convauto.h
157 wx/containr.h
158 wx/cpp.h
159 wx/crt.h
160 wx/datetime.h
161 wx/datstrm.h
162 wx/dde.h
163 wx/debug.h
164 wx/defs.h
165 wx/dir.h
166 wx/dlimpexp.h
167 wx/dlist.h
168 wx/dynarray.h
169 wx/dynlib.h
170 wx/dynload.h
171 wx/encconv.h
172 wx/event.h
173 wx/except.h
174 wx/features.h
175 wx/flags.h
176 wx/ffile.h
177 wx/file.h
178 wx/fileconf.h
179 wx/filefn.h
180 wx/filename.h
181 wx/filesys.h
182 wx/fontenc.h
183 wx/fontmap.h
184 wx/fs_arc.h
185 wx/fs_filter.h
186 wx/fs_mem.h
187 wx/fs_zip.h
188 wx/hash.h
189 wx/hashmap.h
190 wx/hashset.h
191 wx/html/forcelnk.h
192 wx/iconloc.h
193 wx/init.h
194 wx/intl.h
195 wx/iosfwrap.h
196 wx/ioswrap.h
197 wx/ipc.h
198 wx/ipcbase.h
199 wx/kbdstate.h
200 wx/link.h
201 wx/list.h
202 wx/listimpl.cpp
203 wx/log.h
204 wx/longlong.h
205 wx/math.h
206 wx/memconf.h
207 wx/memory.h
208 wx/memtext.h
209 wx/mimetype.h
210 wx/module.h
211 wx/mousestate.h
212 wx/msgout.h
213 wx/mstream.h
214 wx/object.h
215 wx/platform.h
216 wx/platinfo.h
217 wx/power.h
218 wx/process.h
219 wx/ptr_scpd.h
220 wx/ptr_shrd.h
221 wx/recguard.h
222 wx/regex.h
223 wx/scopedarray.h
224 wx/scopedptr.h
225 wx/scopeguard.h
226 wx/sharedptr.h
227 wx/snglinst.h
228 wx/sstream.h
229 wx/stack.h
230 wx/stackwalk.h
231 wx/stdpaths.h
232 wx/stockitem.h
233 wx/stopwatch.h
234 wx/strconv.h
235 wx/stream.h
236 wx/string.h
237 wx/stringimpl.h
238 wx/stringops.h
239 wx/strvararg.h
240 wx/sysopt.h
241 wx/tarstrm.h
242 wx/textbuf.h
243 wx/textfile.h
244 wx/thread.h
245 wx/thrimpl.cpp
246 wx/timer.h
247 wx/tls.h
248 wx/tokenzr.h
249 wx/tracker.h
250 wx/txtstrm.h
251 wx/types.h
252 wx/unichar.h
253 wx/uri.h
254 wx/ustring.h
255 wx/utils.h
256 wx/variant.h
257 wx/vector.h
258 wx/version.h
259 wx/volume.h
260 wx/weakref.h
261 wx/wfstream.h
262 wx/wx.h
263 wx/wxchar.h
264 wx/wxcrt.h
265 wx/wxcrtbase.h
266 wx/wxcrtvararg.h
267 wx/wxprec.h
268 wx/xlocale.h
269 wx/xti.h
270 wx/xtistrm.h
271 wx/zipstrm.h
272 wx/zstream.h
273 wx/meta/convertible.h
274 wx/meta/if.h
275 wx/meta/int2type.h
276 wx/meta/movable.h
277 wx/unix/app.h
278 wx/unix/apptbase.h
279 wx/unix/apptrait.h
280 wx/unix/chkconf.h
281 wx/unix/evtloop.h
282 wx/unix/pipe.h
283 wx/unix/stdpaths.h
284 wx/unix/stackwalk.h
285 wx/unix/tls.h
286 wx/unix/execute.h
287 wx/unix/mimetype.h
288 wx/fs_inet.h
289 wx/protocol/file.h
290 wx/protocol/ftp.h
291 wx/protocol/http.h
292 wx/protocol/protocol.h
293 wx/sckaddr.h
294 wx/sckipc.h
295 wx/sckstrm.h
296 wx/socket.h
297 wx/url.h
298 wx/xml/xml.h
299 wx/xtixml.h
300 EOF
301 # --- wxBase headers list ends here ---
302 for f in `cat wxbase-headers-list` ; do
303 rm -f $RPM_BUILD_ROOT%{_includedir}/wx-%{ver2}/$f
304 done
305
306 # list of all core headers:
307 find $RPM_BUILD_ROOT%{_includedir}/wx-%{ver2} -type f | sed -e "s,$RPM_BUILD_ROOT,,g" >core-headers.files
308
309 # contrib stuff:
310 (cd obj-shared/contrib/src; make prefix=$RPM_BUILD_ROOT%{pref} install)
311 (cd obj-shared/utils/wxrc; make prefix=$RPM_BUILD_ROOT%{pref} install)
312
313 # remove wxBase files so that RPM doesn't complain about unpackaged files:
314 rm -f $RPM_BUILD_ROOT%{_libdir}/libwx_base*
315 %if %{unicode}
316 rm -f $RPM_BUILD_ROOT%{_libdir}/libwxregexu-%{ver2}.a
317 %endif
318 rm -f $RPM_BUILD_ROOT%{_datadir}/aclocal/*
319 rm -f $RPM_BUILD_ROOT%{_datadir}/locale/*/*/*
320
321 %clean
322 rm -rf $RPM_BUILD_ROOT
323
324 %post
325 /sbin/ldconfig
326
327 %postun
328 /sbin/ldconfig
329
330 %post devel
331 # link wx-config when you install RPM.
332 ln -sf %{_libdir}/wx/config/%{wxconfig} %{_bindir}/wx-config
333 # link wx-config with explicit name.
334 ln -sf %{_libdir}/wx/config/%{wxconfig} %{_bindir}/%{wxconfiglink}
335 /sbin/ldconfig
336
337 %postun devel
338 /sbin/ldconfig
339
340 %preun devel
341 if test -f %{_bindir}/wx-config -a -f /usr/bin/md5sum ; then
342 SUM1=`md5sum %{_libdir}/wx/config/%{wxconfig} | cut -c 0-32`
343 SUM2=`md5sum %{_bindir}/wx-config | cut -c 0-32`
344 if test "x$SUM1" = "x$SUM2" ; then
345 rm -f %{_bindir}/wx-config
346 fi
347 fi
348 rm -f %{_bindir}/%{wxconfiglink}
349
350 %post gl
351 /sbin/ldconfig
352
353 %postun gl
354 /sbin/ldconfig
355
356 %post contrib
357 /sbin/ldconfig
358
359 %postun contrib
360 /sbin/ldconfig
361
362 %post contrib-devel
363 /sbin/ldconfig
364
365 %postun contrib-devel
366 /sbin/ldconfig
367
368 %files
369 %defattr(-,root,root)
370 %doc COPYING.LIB *.txt
371 %{_libdir}/libwx_%{portname}*_adv-%{ver2}.so.*
372 %{_libdir}/libwx_%{portname}*_core-%{ver2}.so.*
373 %{_libdir}/libwx_%{portname}*_html-%{ver2}.so.*
374 %{_libdir}/libwx_%{portname}*_media-%{ver2}.so.*
375 %{_libdir}/libwx_%{portname}*_qa-%{ver2}.so.*
376 %{_libdir}/libwx_%{portname}*_xrc-%{ver2}.so.*
377
378
379 %files devel -f core-headers.files
380 %defattr(-,root,root)
381 %{_libdir}/libwx_%{portname}*_adv-%{ver2}.so
382 %{_libdir}/libwx_%{portname}*_core-%{ver2}.so
383 %{_libdir}/libwx_%{portname}*_gl-%{ver2}.so
384 %{_libdir}/libwx_%{portname}*_html-%{ver2}.so
385 %{_libdir}/libwx_%{portname}*_media-%{ver2}.so
386 %{_libdir}/libwx_%{portname}*_qa-%{ver2}.so
387 %{_libdir}/libwx_%{portname}*_xrc-%{ver2}.so
388 %dir %{_libdir}/wx
389 %{_libdir}/wx/*
390 %{_bindir}/wxrc*
391
392 %files gl
393 %defattr(-,root,root)
394 %{_libdir}/libwx_%{portname}*_gl-%{ver2}.so.*
395
396 %files static
397 %defattr (-,root,root)
398 %{_libdir}/libwx_%{portname}*_*-%{ver2}.a
399
400 %files contrib
401 %defattr(-,root,root)
402 %{_libdir}/libwx_%{portname}*_animate-%{ver2}.so.*
403 %{_libdir}/libwx_%{portname}*_deprecated-%{ver2}.so.*
404 %{_libdir}/libwx_%{portname}*_fl-%{ver2}.so.*
405 %{_libdir}/libwx_%{portname}*_gizmos-%{ver2}.so.*
406 %{_libdir}/libwx_%{portname}*_mmedia-%{ver2}.so.*
407 %{_libdir}/libwx_%{portname}*_ogl-%{ver2}.so.*
408 %{_libdir}/libwx_%{portname}*_plot-%{ver2}.so.*
409 %{_libdir}/libwx_%{portname}*_stc-%{ver2}.so.*
410 %{_libdir}/libwx_%{portname}*_svg-%{ver2}.so.*
411
412 %files contrib-devel
413 %defattr(-,root,root)
414 %dir %{_includedir}/wx-%{ver2}/wx/animate
415 %{_includedir}/wx-%{ver2}/wx/animate/*
416 %{_libdir}/libwx_%{portname}*_animate-%{ver2}.so
417
418 %dir %{_includedir}/wx-%{ver2}/wx/deprecated
419 %{_includedir}/wx-%{ver2}/wx/deprecated/*
420 %{_libdir}/libwx_%{portname}*_deprecated-%{ver2}.so
421
422 %dir %{_includedir}/wx-%{ver2}/wx/fl
423 %{_includedir}/wx-%{ver2}/wx/fl/*
424 %{_libdir}/libwx_%{portname}*_fl-%{ver2}.so
425
426 %dir %{_includedir}/wx-%{ver2}/wx/gizmos
427 %{_includedir}/wx-%{ver2}/wx/gizmos/*
428 %{_libdir}/libwx_%{portname}*_gizmos-%{ver2}.so
429
430 %dir %{_includedir}/wx-%{ver2}/wx/mmedia
431 %{_includedir}/wx-%{ver2}/wx/mmedia/*
432 %{_libdir}/libwx_%{portname}*_mmedia-%{ver2}.so
433
434 %dir %{_includedir}/wx-%{ver2}/wx/ogl
435 %{_includedir}/wx-%{ver2}/wx/ogl/*
436 %{_libdir}/libwx_%{portname}*_ogl-%{ver2}.so
437
438 %dir %{_includedir}/wx-%{ver2}/wx/plot
439 %{_includedir}/wx-%{ver2}/wx/plot/*
440 %{_libdir}/libwx_%{portname}*_plot-%{ver2}.so
441
442 %dir %{_includedir}/wx-%{ver2}/wx/stc
443 %{_includedir}/wx-%{ver2}/wx/stc/*
444 %{_libdir}/libwx_%{portname}*_stc-%{ver2}.so
445
446 %dir %{_includedir}/wx-%{ver2}/wx/svg
447 %{_includedir}/wx-%{ver2}/wx/svg/*
448 %{_libdir}/libwx_%{portname}*_svg-%{ver2}.so