renamed wx/ptr_shrd.h to wx/sharedptr.h; split wx/ptr_scpd.h in wx/scopedptr.h and...
[wxWidgets.git] / wxGTK.spec
1 %define _prefix /usr
2 %define ver 2.9.0
3 %define ver2 2.9
4 %define rel 1
5
6 # Configurable settings (use --with(out) {unicode,gtk2} on rpmbuild cmd line):
7 %define unicode 1
8 %{?_with_unicode: %{expand: %%define unicode 1}}
9 %{?_without_unicode: %{expand: %%define unicode 0}}
10
11 %define gtk2 1
12 %{?_with_gtk2: %{expand: %%define gtk2 1}}
13 %{?_without_gtk2: %{expand: %%define gtk2 0}}
14
15 # "buildname" needs to be e.g. gtk2ud for debug builds
16 %if %{gtk2}
17 %define gtkver 2
18 %define portname gtk2
19 %if %{unicode}
20 %define buildname gtk2u
21 %else
22 %define buildname gtk2
23 %endif
24 %else
25 %define gtkver 1.2
26 %define portname gtk
27 %define buildname gtk
28 %endif
29
30 %if %{unicode}
31 %define name wx-%{portname}-unicode
32 %define wxconfig %{portname}-unicode-release-%{ver2}
33 %define wxconfigstatic %{portname}-unicode-release-static-%{ver2}
34 %define wxconfiglink wx%{portname}u-%{ver2}-config
35 %else
36 %define name wx-%{portname}-ansi
37 %define wxconfig %{portname}-ansi-release-%{ver2}
38 %define wxconfigstatic %{portname}-ansi-release-static-%{ver2}
39 %define wxconfiglink wx%{portname}-%{ver2}-config
40 %endif
41
42 %if %{unicode}
43 %define wxbasename wx-base-unicode
44 %define wxbaseconfig base-unicode-release-%{ver2}
45 %define wxbaseconfiglink wxbaseu-%{ver2}-config
46 %else
47 %define wxbasename wx-base-ansi
48 %define wxbaseconfig base-ansi-release-%{ver2}
49 %define wxbaseconfiglink wxbase-%{ver2}-config
50 %endif
51
52 Summary: The GTK+ %{gtkver} port of the wxWidgets library
53 Name: %{name}
54 Version: %{ver}
55 Release: %{rel}
56 License: wxWindows Licence
57 Group: X11/Libraries
58 Source: wxGTK-%{ver}.tar.bz2
59 URL: http://www.wxwidgets.org
60 Packager: Vadim Zeitlin <vadim@wxwindows.org>
61 Prefix: %{_prefix}
62 BuildRoot: %{_tmppath}/%{name}-root
63 Requires: %{wxbasename} = %{ver}
64 %if %{portname} == gtk2
65 BuildRequires: gtk+-2.0-devel
66 %else
67 BuildRequires: gtk+-devel >= 1.2.0
68 %endif
69
70 BuildRequires: zlib-devel, libjpeg-devel, libpng-devel, libtiff-devel
71
72 # all packages providing an implementation of wxWidgets library (regardless of
73 # the toolkit used) should provide the (virtual) wxwin package, this makes it
74 # possible to require wxwin instead of requiring "wxgtk or wxmotif or wxuniv..."
75 Provides: wxwin
76 Provides: wxGTK
77
78 %description
79 wxWidgets is a free C++ library for cross-platform GUI development.
80 With wxWidgets, you can create applications for different GUIs (GTK+,
81 Motif, MS Windows, MacOS X, Windows CE, GPE) from the same source code.
82
83 %package -n wx-i18n
84 Summary: The translations for the wxWidgets library.
85 Group: X11/Libraries
86
87 %description -n wx-i18n
88 The translations files for the wxWidgets library.
89
90 %package devel
91 Summary: The GTK+ %{gtkver} port of the wxWidgets library
92 Group: X11/Libraries
93 Requires: %{name} = %{ver}
94 Requires: %{wxbasename}-devel = %{ver}
95 Provides: wxGTK-devel
96
97 %description devel
98 The GTK+ %{gtkver} port of the wxWidgets library, header files.
99
100 %package gl
101 Summary: The GTK+ %{gtkver} port of the wxWidgets library, OpenGL add-on.
102 Group: X11/Libraries
103 Requires: %{name} = %{ver}
104 Provides: wxGTK-gl
105
106 %description gl
107 OpenGL add-on library for wxGTK, the GTK+ %{gtkver} port of the wxWidgets library.
108
109 %package -n %{wxbasename}
110 Summary: wxBase library - non-GUI support classes of the wxWidgets toolkit
111 Group: Development/Libraries
112 Provides: wxBase
113
114 %description -n %{wxbasename}
115 wxBase is a collection of C++ classes providing basic data structures (strings,
116 lists, arrays), portable wrappers around many OS-specific funstions (file
117 operations, time/date manipulations, threads, processes, sockets, shared
118 library loading) as well as other utility classes (streams, archive and
119 compression). wxBase currently supports Win32, most Unix variants (Linux,
120 FreeBSD, Solaris, HP-UX) and MacOS X (Carbon and Mach-0).
121
122 %package -n %{wxbasename}-devel
123 Summary: wxBase library, header files.
124 Group: Development/Libraries
125 Provides: wxBase-devel
126
127 %description -n %{wxbasename}-devel
128 wxBase library - non-GUI support classes of the wxWidgets toolkit,
129 header files.
130
131 %package contrib
132 Summary: The GTK+ %{gtkver} port of the wxWidgets library, contributed libraries.
133 Group: X11/Libraries
134 Requires: %{name} = %{ver}
135
136 %description contrib
137 Contributed libraries for wxGTK, the GTK+ %{gtkver} port of the wxWidgets library.
138
139 %package contrib-devel
140 Summary: The GTK+ %{gtkver} port of the wxWidgets library
141 Group: X11/Libraries
142 Requires: %{name}-contrib = %{ver}
143 Requires: %{name}-devel = %{ver}
144
145 %description contrib-devel
146 Header files for contributed libraries for wxGTK, the GTK+ %{gtkver} port of the wxWidgets library.
147
148 %prep
149 %setup -q -n wxGTK-%{ver}
150
151 %build
152 if [ "$SMP" != "" ]; then
153 export MAKE="make -j$SMP"
154 else
155 export MAKE="make"
156 fi
157
158 mkdir obj-shared
159 cd obj-shared
160 ../configure --prefix=%{_prefix} \
161 %if ! %{gtk2}
162 --with-gtk=1 \
163 %else
164 --with-gtk=2 \
165 %endif
166 %if %{unicode}
167 --enable-unicode \
168 %else
169 --disable-unicode \
170 %endif
171 --with-opengl
172 $MAKE
173
174 cd contrib/src
175 $MAKE
176 cd ../../..
177
178 mkdir obj-static
179 cd obj-static
180 ../configure --prefix=%{_prefix} \
181 %if ! %{gtk2}
182 --with-gtk=1 \
183 %else
184 --with-gtk=2 \
185 %endif
186 --disable-shared \
187 %if %{unicode}
188 --enable-unicode \
189 %else
190 --disable-unicode \
191 %endif
192 --with-opengl
193 $MAKE
194
195 cd contrib/src
196 $MAKE
197 cd ../../..
198
199 make -C locale allmo
200
201 %install
202 rm -rf $RPM_BUILD_ROOT
203 (cd obj-static; make DESTDIR=$RPM_BUILD_ROOT prefix=%{_prefix} install)
204 (cd obj-shared; make DESTDIR=$RPM_BUILD_ROOT prefix=%{_prefix} install)
205
206 # --- wxBase headers list begins here ---
207 cat <<EOF >wxbase-headers.files
208 wx/afterstd.h
209 wx/app.h
210 wx/apptrait.h
211 wx/archive.h
212 wx/arrimpl.cpp
213 wx/arrstr.h
214 wx/atomic.h
215 wx/base64.h
216 wx/beforestd.h
217 wx/buffer.h
218 wx/build.h
219 wx/chartype.h
220 wx/checkeddelete.h
221 wx/chkconf.h
222 wx/clntdata.h
223 wx/cmdargs.h
224 wx/cmdline.h
225 wx/confbase.h
226 wx/config.h
227 wx/convauto.h
228 wx/containr.h
229 wx/cpp.h
230 wx/crt.h
231 wx/datetime.h
232 wx/datstrm.h
233 wx/dde.h
234 wx/debug.h
235 wx/defs.h
236 wx/dir.h
237 wx/dlimpexp.h
238 wx/dlist.h
239 wx/dynarray.h
240 wx/dynlib.h
241 wx/dynload.h
242 wx/encconv.h
243 wx/event.h
244 wx/except.h
245 wx/features.h
246 wx/flags.h
247 wx/ffile.h
248 wx/file.h
249 wx/fileconf.h
250 wx/filefn.h
251 wx/filename.h
252 wx/filesys.h
253 wx/fontenc.h
254 wx/fontmap.h
255 wx/fs_arc.h
256 wx/fs_filter.h
257 wx/fs_mem.h
258 wx/fs_zip.h
259 wx/hash.h
260 wx/hashmap.h
261 wx/hashset.h
262 wx/html/forcelnk.h
263 wx/iconloc.h
264 wx/init.h
265 wx/intl.h
266 wx/iosfwrap.h
267 wx/ioswrap.h
268 wx/ipc.h
269 wx/ipcbase.h
270 wx/kbdstate.h
271 wx/link.h
272 wx/list.h
273 wx/listimpl.cpp
274 wx/log.h
275 wx/longlong.h
276 wx/math.h
277 wx/memconf.h
278 wx/memory.h
279 wx/memtext.h
280 wx/mimetype.h
281 wx/module.h
282 wx/mousestate.h
283 wx/msgout.h
284 wx/mstream.h
285 wx/object.h
286 wx/platform.h
287 wx/platinfo.h
288 wx/power.h
289 wx/process.h
290 wx/ptr_scpd.h
291 wx/ptr_shrd.h
292 wx/recguard.h
293 wx/regex.h
294 wx/scopedarray.h
295 wx/scopedptr.h
296 wx/scopeguard.h
297 wx/sharedptr.h
298 wx/snglinst.h
299 wx/sstream.h
300 wx/stack.h
301 wx/stackwalk.h
302 wx/stdpaths.h
303 wx/stockitem.h
304 wx/stopwatch.h
305 wx/strconv.h
306 wx/stream.h
307 wx/string.h
308 wx/stringimpl.h
309 wx/stringops.h
310 wx/strvararg.h
311 wx/sysopt.h
312 wx/tarstrm.h
313 wx/textbuf.h
314 wx/textfile.h
315 wx/thread.h
316 wx/thrimpl.cpp
317 wx/timer.h
318 wx/tls.h
319 wx/tokenzr.h
320 wx/tracker.h
321 wx/txtstrm.h
322 wx/types.h
323 wx/unichar.h
324 wx/uri.h
325 wx/ustring.h
326 wx/utils.h
327 wx/variant.h
328 wx/vector.h
329 wx/version.h
330 wx/volume.h
331 wx/weakref.h
332 wx/wfstream.h
333 wx/wx.h
334 wx/wxchar.h
335 wx/wxcrt.h
336 wx/wxcrtbase.h
337 wx/wxcrtvararg.h
338 wx/wxprec.h
339 wx/xlocale.h
340 wx/xti.h
341 wx/xtistrm.h
342 wx/zipstrm.h
343 wx/zstream.h
344 wx/meta/convertible.h
345 wx/meta/if.h
346 wx/meta/int2type.h
347 wx/meta/movable.h
348 wx/unix/app.h
349 wx/unix/apptbase.h
350 wx/unix/apptrait.h
351 wx/unix/chkconf.h
352 wx/unix/evtloop.h
353 wx/unix/pipe.h
354 wx/unix/stdpaths.h
355 wx/unix/stackwalk.h
356 wx/unix/tls.h
357 wx/unix/execute.h
358 wx/unix/mimetype.h
359 wx/fs_inet.h
360 wx/protocol/file.h
361 wx/protocol/ftp.h
362 wx/protocol/http.h
363 wx/protocol/protocol.h
364 wx/sckaddr.h
365 wx/sckipc.h
366 wx/sckstrm.h
367 wx/socket.h
368 wx/url.h
369 wx/xml/xml.h
370 wx/xtixml.h
371 EOF
372 # --- wxBase headers list ends here ---
373 cat <<EOF >wxbase-headers.paths
374 %{_includedir}/wx-%{ver2}/wx/afterstd.h
375 %{_includedir}/wx-%{ver2}/wx/app.h
376 %{_includedir}/wx-%{ver2}/wx/apptrait.h
377 %{_includedir}/wx-%{ver2}/wx/archive.h
378 %{_includedir}/wx-%{ver2}/wx/arrimpl.cpp
379 %{_includedir}/wx-%{ver2}/wx/arrstr.h
380 %{_includedir}/wx-%{ver2}/wx/beforestd.h
381 %{_includedir}/wx-%{ver2}/wx/buffer.h
382 %{_includedir}/wx-%{ver2}/wx/build.h
383 %{_includedir}/wx-%{ver2}/wx/chkconf.h
384 %{_includedir}/wx-%{ver2}/wx/clntdata.h
385 %{_includedir}/wx-%{ver2}/wx/cmdline.h
386 %{_includedir}/wx-%{ver2}/wx/confbase.h
387 %{_includedir}/wx-%{ver2}/wx/config.h
388 %{_includedir}/wx-%{ver2}/wx/containr.h
389 %{_includedir}/wx-%{ver2}/wx/convauto.h
390 %{_includedir}/wx-%{ver2}/wx/datetime.h
391 %{_includedir}/wx-%{ver2}/wx/datstrm.h
392 %{_includedir}/wx-%{ver2}/wx/dde.h
393 %{_includedir}/wx-%{ver2}/wx/debug.h
394 %{_includedir}/wx-%{ver2}/wx/defs.h
395 %{_includedir}/wx-%{ver2}/wx/dir.h
396 %{_includedir}/wx-%{ver2}/wx/dlimpexp.h
397 %{_includedir}/wx-%{ver2}/wx/dynarray.h
398 %{_includedir}/wx-%{ver2}/wx/dynlib.h
399 %{_includedir}/wx-%{ver2}/wx/dynload.h
400 %{_includedir}/wx-%{ver2}/wx/encconv.h
401 %{_includedir}/wx-%{ver2}/wx/event.h
402 %{_includedir}/wx-%{ver2}/wx/except.h
403 %{_includedir}/wx-%{ver2}/wx/features.h
404 %{_includedir}/wx-%{ver2}/wx/ffile.h
405 %{_includedir}/wx-%{ver2}/wx/file.h
406 %{_includedir}/wx-%{ver2}/wx/fileconf.h
407 %{_includedir}/wx-%{ver2}/wx/filefn.h
408 %{_includedir}/wx-%{ver2}/wx/filename.h
409 %{_includedir}/wx-%{ver2}/wx/filesys.h
410 %{_includedir}/wx-%{ver2}/wx/fontenc.h
411 %{_includedir}/wx-%{ver2}/wx/fontmap.h
412 %{_includedir}/wx-%{ver2}/wx/fs_mem.h
413 %{_includedir}/wx-%{ver2}/wx/fs_zip.h
414 %{_includedir}/wx-%{ver2}/wx/hash.h
415 %{_includedir}/wx-%{ver2}/wx/hashmap.h
416 %{_includedir}/wx-%{ver2}/wx/hashset.h
417 %{_includedir}/wx-%{ver2}/wx/html/forcelnk.h
418 %{_includedir}/wx-%{ver2}/wx/iconloc.h
419 %{_includedir}/wx-%{ver2}/wx/init.h
420 %{_includedir}/wx-%{ver2}/wx/intl.h
421 %{_includedir}/wx-%{ver2}/wx/iosfwrap.h
422 %{_includedir}/wx-%{ver2}/wx/ioswrap.h
423 %{_includedir}/wx-%{ver2}/wx/ipc.h
424 %{_includedir}/wx-%{ver2}/wx/ipcbase.h
425 %{_includedir}/wx-%{ver2}/wx/isql.h
426 %{_includedir}/wx-%{ver2}/wx/isqlext.h
427 %{_includedir}/wx-%{ver2}/wx/link.h
428 %{_includedir}/wx-%{ver2}/wx/list.h
429 %{_includedir}/wx-%{ver2}/wx/listimpl.cpp
430 %{_includedir}/wx-%{ver2}/wx/log.h
431 %{_includedir}/wx-%{ver2}/wx/longlong.h
432 %{_includedir}/wx-%{ver2}/wx/math.h
433 %{_includedir}/wx-%{ver2}/wx/memconf.h
434 %{_includedir}/wx-%{ver2}/wx/memory.h
435 %{_includedir}/wx-%{ver2}/wx/memtext.h
436 %{_includedir}/wx-%{ver2}/wx/mimetype.h
437 %{_includedir}/wx-%{ver2}/wx/module.h
438 %{_includedir}/wx-%{ver2}/wx/msgout.h
439 %{_includedir}/wx-%{ver2}/wx/mstream.h
440 %{_includedir}/wx-%{ver2}/wx/object.h
441 %{_includedir}/wx-%{ver2}/wx/platform.h
442 %{_includedir}/wx-%{ver2}/wx/power.h
443 %{_includedir}/wx-%{ver2}/wx/process.h
444 %{_includedir}/wx-%{ver2}/wx/ptr_scpd.h
445 %{_includedir}/wx-%{ver2}/wx/recguard.h
446 %{_includedir}/wx-%{ver2}/wx/regex.h
447 %{_includedir}/wx-%{ver2}/wx/scopeguard.h
448 %{_includedir}/wx-%{ver2}/wx/snglinst.h
449 %{_includedir}/wx-%{ver2}/wx/sstream.h
450 %{_includedir}/wx-%{ver2}/wx/stack.h
451 %{_includedir}/wx-%{ver2}/wx/stackwalk.h
452 %{_includedir}/wx-%{ver2}/wx/stdpaths.h
453 %{_includedir}/wx-%{ver2}/wx/stockitem.h
454 %{_includedir}/wx-%{ver2}/wx/stopwatch.h
455 %{_includedir}/wx-%{ver2}/wx/strconv.h
456 %{_includedir}/wx-%{ver2}/wx/stream.h
457 %{_includedir}/wx-%{ver2}/wx/string.h
458 %{_includedir}/wx-%{ver2}/wx/sysopt.h
459 %{_includedir}/wx-%{ver2}/wx/textbuf.h
460 %{_includedir}/wx-%{ver2}/wx/textfile.h
461 %{_includedir}/wx-%{ver2}/wx/thread.h
462 %{_includedir}/wx-%{ver2}/wx/thrimpl.cpp
463 %{_includedir}/wx-%{ver2}/wx/timer.h
464 %{_includedir}/wx-%{ver2}/wx/tokenzr.h
465 %{_includedir}/wx-%{ver2}/wx/txtstrm.h
466 %{_includedir}/wx-%{ver2}/wx/types.h
467 %{_includedir}/wx-%{ver2}/wx/uri.h
468 %{_includedir}/wx-%{ver2}/wx/utils.h
469 %{_includedir}/wx-%{ver2}/wx/variant.h
470 %{_includedir}/wx-%{ver2}/wx/vector.h
471 %{_includedir}/wx-%{ver2}/wx/version.h
472 %{_includedir}/wx-%{ver2}/wx/volume.h
473 %{_includedir}/wx-%{ver2}/wx/wfstream.h
474 %{_includedir}/wx-%{ver2}/wx/wx.h
475 %{_includedir}/wx-%{ver2}/wx/wxchar.h
476 %{_includedir}/wx-%{ver2}/wx/wxprec.h
477 %{_includedir}/wx-%{ver2}/wx/xti.h
478 %{_includedir}/wx-%{ver2}/wx/xtistrm.h
479 %{_includedir}/wx-%{ver2}/wx/zipstrm.h
480 %{_includedir}/wx-%{ver2}/wx/zstream.h
481 %{_includedir}/wx-%{ver2}/wx/fs_inet.h
482 %{_includedir}/wx-%{ver2}/wx/gsocket.h
483 %{_includedir}/wx-%{ver2}/wx/protocol/file.h
484 %{_includedir}/wx-%{ver2}/wx/protocol/ftp.h
485 %{_includedir}/wx-%{ver2}/wx/protocol/http.h
486 %{_includedir}/wx-%{ver2}/wx/protocol/protocol.h
487 %{_includedir}/wx-%{ver2}/wx/sckaddr.h
488 %{_includedir}/wx-%{ver2}/wx/sckipc.h
489 %{_includedir}/wx-%{ver2}/wx/sckstrm.h
490 %{_includedir}/wx-%{ver2}/wx/socket.h
491 %{_includedir}/wx-%{ver2}/wx/url.h
492 %{_includedir}/wx-%{ver2}/wx/xml/xml.h
493 %{_includedir}/wx-%{ver2}/wx/xtixml.h
494 %{_includedir}/wx-%{ver2}/wx/unix/apptbase.h
495 %{_includedir}/wx-%{ver2}/wx/unix/apptrait.h
496 %{_includedir}/wx-%{ver2}/wx/unix/execute.h
497 %{_includedir}/wx-%{ver2}/wx/unix/gsockunx.h
498 %{_includedir}/wx-%{ver2}/wx/unix/mimetype.h
499 %{_includedir}/wx-%{ver2}/wx/unix/pipe.h
500 %{_includedir}/wx-%{ver2}/wx/unix/private.h
501 %{_includedir}/wx-%{ver2}/wx/unix/stackwalk.h
502 %{_includedir}/wx-%{ver2}/wx/unix/stdpaths.h
503 EOF
504 # --- wxBase headers list ends here ---
505
506 # temporarily remove base headers
507 mkdir $RPM_BUILD_ROOT/_save_dir
508 cp -r $RPM_BUILD_ROOT%{_includedir}/wx-%{ver2} $RPM_BUILD_ROOT/_save_dir
509 for f in `cat wxbase-headers.files` ; do
510 rm -f $RPM_BUILD_ROOT%{_includedir}/wx-%{ver2}/$f
511 done
512 # list of all core headers:
513 find $RPM_BUILD_ROOT%{_includedir}/wx-%{ver2} -type f | sed -e "s,$RPM_BUILD_ROOT,,g" >core-headers.files
514 # move base headers (actually all headers) back again
515 cp -f -r $RPM_BUILD_ROOT/_save_dir/* $RPM_BUILD_ROOT%{_includedir}
516 rm -rf $RPM_BUILD_ROOT/_save_dir
517
518 # contrib stuff:
519 (cd obj-static/contrib; make DESTDIR=$RPM_BUILD_ROOT prefix=%{_prefix} install)
520 (cd obj-shared/contrib; make DESTDIR=$RPM_BUILD_ROOT prefix=%{_prefix} install)
521
522 # utils:
523 (cd obj-shared/utils/wxrc; make DESTDIR=$RPM_BUILD_ROOT prefix=%{_prefix} install)
524
525 # wx-config link is created during package installation, remove it for now
526 rm -f $RPM_BUILD_ROOT%{_bindir}/wx-config
527
528 %clean
529 rm -rf $RPM_BUILD_ROOT
530
531 %post
532 /sbin/ldconfig
533
534 %postun
535 /sbin/ldconfig
536
537 %post devel
538 # link wx-config when you install RPM.
539 %if %{unicode}
540 ln -sf %{_libdir}/wx/config/%{wxconfig} %{_bindir}/wx-config
541 %endif
542 # link wx-config with explicit name.
543 ln -sf %{_libdir}/wx/config/%{wxconfig} %{_bindir}/%{wxconfiglink}
544 /sbin/ldconfig
545
546 %postun devel
547 /sbin/ldconfig
548
549 %preun devel
550 %if %{unicode}
551 rm -f %{_bindir}/wx-config
552 %endif
553 rm -f %{_bindir}/%{wxconfiglink}
554
555 %post -n %{wxbasename}
556 /sbin/ldconfig
557
558 %postun -n %{wxbasename}
559 /sbin/ldconfig
560
561 %post -n %{wxbasename}-devel
562 # link wx-config with explicit name.
563 ln -sf %{_libdir}/wx/config/%{wxbaseconfig} %{_bindir}/%{wxbaseconfiglink}
564 /sbin/ldconfig
565
566 %postun -n %{wxbasename}-devel
567 /sbin/ldconfig
568
569 %preun -n %{wxbasename}-devel
570 rm -f %{_bindir}/%{wxbaseconfiglink}
571
572 %post gl
573 /sbin/ldconfig
574
575 %postun gl
576 /sbin/ldconfig
577
578 %post contrib
579 /sbin/ldconfig
580
581 %postun contrib
582 /sbin/ldconfig
583
584 %post contrib-devel
585 /sbin/ldconfig
586
587 %postun contrib-devel
588 /sbin/ldconfig
589
590 %files
591 %defattr(-,root,root)
592 %doc COPYING.LIB *.txt
593 %{_libdir}/libwx_%{buildname}_adv-%{ver2}.so.*
594 %{_libdir}/libwx_%{buildname}_aui-%{ver2}.so.*
595 %{_libdir}/libwx_%{buildname}_core-%{ver2}.so.*
596 %{_libdir}/libwx_%{buildname}_html-%{ver2}.so.*
597 %{_libdir}/libwx_%{buildname}_mmedia-%{ver2}.so.*
598 %{_libdir}/libwx_%{buildname}_qa-%{ver2}.so.*
599 %{_libdir}/libwx_%{buildname}_richtext-%{ver2}.so.*
600 %{_libdir}/libwx_%{buildname}_xrc-%{ver2}.so.*
601
602 %files -n wx-i18n
603 %defattr(-,root,root)
604 %{_datadir}/locale/*/LC_MESSAGES/*.mo
605
606 %files devel -f core-headers.files
607 %defattr(-,root,root)
608 # shared libs
609 %{_libdir}/libwx_%{buildname}_adv-%{ver2}.so
610 %{_libdir}/libwx_%{buildname}_aui-%{ver2}.so
611 %{_libdir}/libwx_%{buildname}_core-%{ver2}.so
612 %{_libdir}/libwx_%{buildname}_gl-%{ver2}.so
613 %{_libdir}/libwx_%{buildname}_html-%{ver2}.so
614 %{_libdir}/libwx_%{buildname}_mmedia-%{ver2}.so
615 %{_libdir}/libwx_%{buildname}_qa-%{ver2}.so
616 %{_libdir}/libwx_%{buildname}_richtext-%{ver2}.so
617 %{_libdir}/libwx_%{buildname}_xrc-%{ver2}.so
618 # static libs
619 %{_libdir}/libwx_%{buildname}_adv-%{ver2}.a
620 %{_libdir}/libwx_%{buildname}_aui-%{ver2}.a
621 %{_libdir}/libwx_%{buildname}_core-%{ver2}.a
622 %{_libdir}/libwx_%{buildname}_gl-%{ver2}.a
623 %{_libdir}/libwx_%{buildname}_html-%{ver2}.a
624 %{_libdir}/libwx_%{buildname}_qa-%{ver2}.a
625 %{_libdir}/libwx_%{buildname}_richtext-%{ver2}.a
626 %{_libdir}/libwx_%{buildname}_xrc-%{ver2}.a
627 %dir %{_libdir}/wx
628 %{_libdir}/wx/config/%{wxconfig}
629 %{_libdir}/wx/include/%{wxconfig}/wx/setup.h
630 %{_libdir}/wx/config/%{wxconfigstatic}
631 %{_libdir}/wx/include/%{wxconfigstatic}/wx/setup.h
632 %{_bindir}/wxrc*
633
634 %files -n %{wxbasename}
635 %defattr(-,root,root)
636 %{_libdir}/libwx_base*-%{ver2}.so.*
637
638 %files -n %{wxbasename}-devel -f wxbase-headers.paths
639 %defattr (-,root,root)
640 %dir %{_includedir}/wx-%{ver2}
641 %{_libdir}/libwx_base*-%{ver2}.so
642 %{_libdir}/libwx_base*-%{ver2}.a
643 %if %{unicode}
644 %{_libdir}/libwxregexu-%{ver2}.a
645 %endif
646 %dir %{_libdir}/wx
647 %{_datadir}/aclocal/*.m4
648 %{_datadir}/bakefile/presets/*
649
650 %files gl
651 %defattr(-,root,root)
652 %{_libdir}/libwx_%{buildname}_gl-%{ver2}.so.*
653
654 %files contrib
655 %defattr(-,root,root)
656 %{_libdir}/libwx_%{buildname}_animate-%{ver2}.so.*
657 %{_libdir}/libwx_%{buildname}_deprecated-%{ver2}.so.*
658 %{_libdir}/libwx_%{buildname}_fl-%{ver2}.so.*
659 %{_libdir}/libwx_%{buildname}_gizmos-%{ver2}.so.*
660 %{_libdir}/libwx_%{buildname}_gizmos_xrc-%{ver2}.so.*
661 %{_libdir}/libwx_%{buildname}_mmedia-%{ver2}.so.*
662 %{_libdir}/libwx_%{buildname}_ogl-%{ver2}.so.*
663 %{_libdir}/libwx_%{buildname}_plot-%{ver2}.so.*
664 %{_libdir}/libwx_%{buildname}_stc-%{ver2}.so.*
665 %{_libdir}/libwx_%{buildname}_svg-%{ver2}.so.*
666
667 # static libs
668 %{_libdir}/libwx_%{buildname}_animate-%{ver2}.a
669 %{_libdir}/libwx_%{buildname}_deprecated-%{ver2}.a
670 %{_libdir}/libwx_%{buildname}_fl-%{ver2}.a
671 %{_libdir}/libwx_%{buildname}_gizmos-%{ver2}.a
672 %{_libdir}/libwx_%{buildname}_gizmos_xrc-%{ver2}.a
673 %{_libdir}/libwx_%{buildname}_mmedia-%{ver2}.a
674 %{_libdir}/libwx_%{buildname}_ogl-%{ver2}.a
675 %{_libdir}/libwx_%{buildname}_plot-%{ver2}.a
676 %{_libdir}/libwx_%{buildname}_stc-%{ver2}.a
677 %{_libdir}/libwx_%{buildname}_svg-%{ver2}.a
678
679 %files contrib-devel
680 %defattr(-,root,root)
681 %dir %{_includedir}/wx-%{ver2}/wx/animate
682 %{_includedir}/wx-%{ver2}/wx/animate/*
683 %{_libdir}/libwx_%{buildname}_animate-%{ver2}.so
684
685 %dir %{_includedir}/wx-%{ver2}/wx/deprecated
686 %{_includedir}/wx-%{ver2}/wx/deprecated/*
687 %{_libdir}/libwx_%{buildname}_deprecated-%{ver2}.so
688
689 %dir %{_includedir}/wx-%{ver2}/wx/fl
690 %{_includedir}/wx-%{ver2}/wx/fl/*
691 %{_libdir}/libwx_%{buildname}_fl-%{ver2}.so
692
693 %dir %{_includedir}/wx-%{ver2}/wx/gizmos
694 %{_includedir}/wx-%{ver2}/wx/gizmos/*
695 %{_libdir}/libwx_%{buildname}_gizmos-%{ver2}.so
696 %{_libdir}/libwx_%{buildname}_gizmos_xrc-%{ver2}.so
697
698 %dir %{_includedir}/wx-%{ver2}/wx/mmedia
699 %{_includedir}/wx-%{ver2}/wx/mmedia/*
700 %{_libdir}/libwx_%{buildname}_mmedia-%{ver2}.so
701
702 %dir %{_includedir}/wx-%{ver2}/wx/ogl
703 %{_includedir}/wx-%{ver2}/wx/ogl/*
704 %{_libdir}/libwx_%{buildname}_ogl-%{ver2}.so
705
706 %dir %{_includedir}/wx-%{ver2}/wx/plot
707 %{_includedir}/wx-%{ver2}/wx/plot/*
708 %{_libdir}/libwx_%{buildname}_plot-%{ver2}.so
709
710 %dir %{_includedir}/wx-%{ver2}/wx/stc
711 %{_includedir}/wx-%{ver2}/wx/stc/*
712 %{_libdir}/libwx_%{buildname}_stc-%{ver2}.so
713
714 %dir %{_includedir}/wx-%{ver2}/wx/svg
715 %{_includedir}/wx-%{ver2}/wx/svg/*
716 %{_libdir}/libwx_%{buildname}_svg-%{ver2}.so