Wrap <commdlgs.h> as <commctls.h>. Required makefiles rebuilded.
[wxWidgets.git] / wxMotif.spec
1 %define pref /usr
2 %define ver 2.5.4
3 %define ver2 2.5
4 %define rel 1
5
6 %define portname motif
7 %define name wx-%{portname}
8 %define wxbasename wx-base
9 %define wxconfigname wx%{portname}-%{ver2}-config
10
11 Summary: The Motif/Lesstif port of the wxWindows library
12 Name: %{name}
13 Version: %{ver}
14 Release: %{rel}
15 License: wxWindows Licence
16 Group: X11/Libraries
17 Source: wxMOTIF-%{ver}.tar.bz2
18 URL: http://www.wxwidgets.org
19 Packager: wxWindows developers <wx-dev@lists.wxwidgets.org>
20 BuildRoot: /tmp/wxmotif_root
21
22 # all packages providing an implementation of wxWindows library (regardless of
23 # the toolkit used) should provide the (virtual) wxwin package, this makes it
24 # possible to require wxwin instead of requiring "wxgtk or wxmotif or wxuniv..."
25 Provides: wxwin
26
27 Provides: wxMotif
28
29 Requires: %{wxbasename} = %{ver}
30
31 %description
32 wxWindows is a free C++ library for cross-platform GUI development.
33 With wxWindows, you can create applications for different GUIs (GTK+,
34 Motif/LessTif, MS Windows, Mac) from the same source code.
35
36 %package devel
37 Summary: The Motif/Lesstif port of the wxWindows library
38 Group: X11/Libraries
39 Requires: %{name} = %{ver}
40 Requires: %{wxbasename}-devel = %{ver}
41
42 %description devel
43 Header files for wxMotif, the Motif/Lesstif port of the wxWindows library.
44
45 %package gl
46 Summary: The Motif/Lesstif port of the wxWindows library, OpenGL add-on.
47 Group: X11/Libraries
48 Requires: %{name} = %{ver}
49
50 %description gl
51 OpenGL add-on library for wxMotif, the Motif/Lesstif port of the wxWindows library.
52
53 %package static
54 Summary: wxMotif static libraries
55 Group: Development/Libraries
56
57 %description static
58 Static libraries for wxMotif. You need them if you want to link statically against wxMotif.
59
60 %prep
61 %setup -q -n wxMOTIF-%{ver}
62
63 %build
64 if [ "$SMP" != "" ]; then
65 export MAKE="make -j$SMP"
66 else
67 export MAKE="make"
68 fi
69
70 mkdir obj-shared
71 cd obj-shared
72 ../configure --prefix=%{pref} --with-odbc --with-opengl --with-motif
73 $MAKE
74 cd ..
75
76 mkdir obj-static
77 cd obj-static
78 ../configure --prefix=%{pref} --disable-shared --with-odbc --with-opengl --with-motif
79 $MAKE
80 cd ..
81
82 %install
83 rm -rf $RPM_BUILD_ROOT
84 (cd obj-static; make prefix=$RPM_BUILD_ROOT%{pref} install)
85 (cd obj-shared; make prefix=$RPM_BUILD_ROOT%{pref} install)
86
87 # Remove headers that are part of wx-base-devel:
88
89 # --- wxBase headers list begins here ---
90 cat <<EOF >wxbase-headers-list
91 wx/afterstd.h
92 wx/app.h
93 wx/apptrait.h
94 wx/archive.h
95 wx/arrimpl.cpp
96 wx/arrstr.h
97 wx/beforestd.h
98 wx/buffer.h
99 wx/build.h
100 wx/chkconf.h
101 wx/clntdata.h
102 wx/cmdline.h
103 wx/confbase.h
104 wx/config.h
105 wx/containr.h
106 wx/datetime.h
107 wx/datetime.inl
108 wx/datstrm.h
109 wx/dde.h
110 wx/debug.h
111 wx/defs.h
112 wx/dir.h
113 wx/dlimpexp.h
114 wx/dynarray.h
115 wx/dynlib.h
116 wx/dynload.h
117 wx/encconv.h
118 wx/event.h
119 wx/except.h
120 wx/features.h
121 wx/ffile.h
122 wx/file.h
123 wx/fileconf.h
124 wx/filefn.h
125 wx/filename.h
126 wx/filesys.h
127 wx/fontenc.h
128 wx/fontmap.h
129 wx/fs_mem.h
130 wx/fs_zip.h
131 wx/hash.h
132 wx/hashmap.h
133 wx/hashset.h
134 wx/html/forcelnk.h
135 wx/iconloc.h
136 wx/init.h
137 wx/intl.h
138 wx/iosfwrap.h
139 wx/ioswrap.h
140 wx/ipc.h
141 wx/ipcbase.h
142 wx/isql.h
143 wx/isqlext.h
144 wx/list.h
145 wx/listimpl.cpp
146 wx/log.h
147 wx/longlong.h
148 wx/math.h
149 wx/memconf.h
150 wx/memory.h
151 wx/memtext.h
152 wx/mimetype.h
153 wx/module.h
154 wx/msgout.h
155 wx/msgout.h
156 wx/mstream.h
157 wx/object.h
158 wx/platform.h
159 wx/process.h
160 wx/ptr_scpd.h
161 wx/regex.h
162 wx/scopeguard.h
163 wx/snglinst.h
164 wx/sstream.h
165 wx/stack.h
166 wx/stackwalk.h
167 wx/stdpaths.h
168 wx/stockitem.h
169 wx/stopwatch.h
170 wx/strconv.h
171 wx/stream.h
172 wx/string.h
173 wx/sysopt.h
174 wx/textbuf.h
175 wx/textfile.h
176 wx/thread.h
177 wx/thrimpl.cpp
178 wx/timer.h
179 wx/tokenzr.h
180 wx/txtstrm.h
181 wx/types.h
182 wx/uri.h
183 wx/utils.h
184 wx/variant.h
185 wx/vector.h
186 wx/version.h
187 wx/volume.h
188 wx/wfstream.h
189 wx/wx.h
190 wx/wxchar.h
191 wx/wxprec.h
192 wx/xti.h
193 wx/xtistrm.h
194 wx/zipstrm.h
195 wx/zstream.h
196 wx/msw/apptrait.h
197 wx/msw/apptbase.h
198 wx/msw/chkconf.h
199 wx/msw/crashrpt.h
200 wx/msw/dde.h
201 wx/msw/debughlp.h
202 wx/msw/gccpriv.h
203 wx/msw/mimetype.h
204 wx/msw/stackwalk.h
205 wx/msw/winundef.h
206 wx/msw/wrapcctl.h
207 wx/msw/wrapcdlg.h
208 wx/msw/wrapwin.h
209 wx/fs_inet.h
210 wx/gsocket.h
211 wx/protocol/file.h
212 wx/protocol/ftp.h
213 wx/protocol/http.h
214 wx/protocol/protocol.h
215 wx/sckaddr.h
216 wx/sckipc.h
217 wx/sckstrm.h
218 wx/socket.h
219 wx/url.h
220 wx/msw/gsockmsw.h
221 wx/xml/xml.h
222 wx/xtixml.h
223 wx/db.h
224 wx/dbkeyg.h
225 wx/dbtable.h
226 EOF
227 # --- wxBase headers list ends here ---
228 for f in `cat wxbase-headers-list` ; do
229 rm -f $RPM_BUILD_ROOT%{_includedir}/wx-*/$f
230 done
231
232 # list of all core headers:
233 find $RPM_BUILD_ROOT/usr/include/wx -type f | sed -e "s,$RPM_BUILD_ROOT,,g" >core-headers.files
234
235 # remove wxBase files so that RPM doesn't complain about unpackaged files:
236 rm -f $RPM_BUILD_ROOT%{_libdir}/libwx_base*
237 rm -f $RPM_BUILD_ROOT%{_datadir}/aclocal/*
238 rm -f $RPM_BUILD_ROOT%{_datadir}/locale/*/*/*
239
240
241 %clean
242 rm -rf $RPM_BUILD_ROOT
243
244 %post
245 /sbin/ldconfig
246
247 %postun
248 /sbin/ldconfig
249
250 %post gl
251 /sbin/ldconfig
252
253 %postun gl
254 /sbin/ldconfig
255
256
257 %files
258 %defattr(-,root,root)
259 %doc COPYING.LIB *.txt
260 %{_libdir}/libwx_%{portname}*_core*.so.*
261 %{_libdir}/libwx_%{portname}*_html*.so.*
262 %{_libdir}/libwx_%{portname}*_adv*.so.*
263 %{_libdir}/libwx_%{portname}*_dbgrid*.so.*
264
265 %files devel -f core-headers.files
266 %defattr(-,root,root)
267 %{_libdir}/libwx_%{portname}*_core*.so
268 %{_libdir}/libwx_%{portname}*_html*.so
269 %{_libdir}/libwx_%{portname}*_adv*.so
270 %{_libdir}/libwx_%{portname}*_dbgrid*.so
271 %{_libdir}/libwx_%{portname}*_gl*.so
272 %dir %{_libdir}/wx
273 %{_libdir}/wx/*
274 %{_bindir}/%{wxconfigname}
275
276 %files gl
277 %defattr(-,root,root)
278 %{_libdir}/libwx_%{portname}*_gl*.so.*
279
280 %files static
281 %defattr (-,root,root)
282 %{_libdir}/libwx_%{portname}*.a
283