6 # Configurable settings (use --with(out) unicode on rpmbuild command line):
8 %{?_with_unicode: %{expand: %%define unicode 1}}
9 %{?_without_unicode: %{expand: %%define unicode 0}}
12 %define wxconfigname base
-unicode
-release
-%{ver2}
13 %define wxconfiglinkname wxbaseu
-%{ver2}-config
15 %define wxconfigname base
-ansi
-release
-%{ver2}
16 %define wxconfiglinkname wxbase
-%{ver2}-config
20 %define name wx
-base
-unicode
25 Summary: wxBase library
- non
-GUI support classes of wxWindows toolkit
29 License: wxWindows Licence
30 Group: Development
/Libraries
31 Source: wxBase
-%{ver}.tar.bz2
32 URL: http
://www.wxwindows.org
33 Packager: Vadim Zeitlin
<vadim@wxwindows.org
>
35 BuildRoot: /var
/tmp
/%{name}-root
39 wxBase is a collection of C
++ classes providing basic data structures
(strings
,
40 lists
, arrays
), powerful wxDateTime class
for date manipulations
, portable
41 wrappers around many OS
-specific functions allowing to build the same program
42 under all supported folders
, wxThread class
for writing multithreaded programs
43 using either Win32 or POSIX threads and much more. wxBase currently supports
44 the following platforms
: Win32
, generic Unix
(Linux
, FreeBSD
, Solaris
, HP
-UX
,
48 Summary: wxBase headers needed
for developping with wxBase
49 Group: Development
/Libraries
50 Requires: %{name} = %{ver}
51 Provides: wxBase
-devel
54 Header files
for wxBase. You need them to develop programs using wxBase.
57 Summary: wxBase static libraries
58 Group: Development
/Libraries
61 Static libraries
for wxBase. You need them
if you want to link statically against wxBase.
64 %setup -q
-n wxBase
-%{ver}
67 if [ "$SMP"
!= ""
]; then
68 export MAKE
="
make -j$SMP"
75 ..
/configure
--prefix
=%{pref} --disable
-gui \
86 ..
/configure
--prefix
=%{pref} --disable
-shared
--disable
-gui \
96 rm -rf $RPM_BUILD_ROOT
97 (cd obj
-static
; make prefix
=$RPM_BUILD_ROOT
%{pref} install)
98 (cd obj
-shared
; make prefix
=$RPM_BUILD_ROOT
%{pref} install)
103 rm -rf $RPM_BUILD_ROOT
112 # link wx-config when you install RPM.
113 ln
-sf
%{_libdir}/wx/config/%{wxconfigname} %{_bindir}/wx
-config
114 # link wx-config with explicit name.
115 ln
-sf
%{_libdir}/wx/config/%{wxconfigname} %{_bindir}/%{wxconfiglinkname}
118 if test -f
%{_bindir}/wx
-config
-a
-f
/usr
/bin
/md5sum
; then
119 SUM1
=`md5sum
%{_libdir}/wx/config/%{wxconfigname} | cut
-c
0-32`
120 SUM2
=`md5sum
%{_bindir}/wx
-config | cut
-c
0-32`
121 if test "x$SUM1"
= "x$SUM2"
; then
122 rm -f
%{_bindir}/wx
-config
126 rm -f
%{_bindir}/%{wxconfiglinkname}
129 %defattr (-,root
,root
)
130 %doc COPYING.LIB
*.txt
131 %{_libdir}/libwx_base
*so.
*
134 %defattr (-,root
,root
)
135 %dir %{_includedir}/wx
-*
136 %{_includedir}/wx
-*/*
137 %{_libdir}/libwx_base
*.so
140 %{_datadir}/aclocal
/*.m4
143 %defattr (-,root
,root
)