rebaked and regenerated everything after the latest changes (wxWeakRef &c)
[wxWidgets.git] / wxX11.spec
1 %define pref /usr
2 %define ver 2.9.0
3 %define ver2 2.9
4 %define rel 1
5
6 # Configurable settings (use --with(out) unicode on rpmbuild cmd line):
7 %define unicode 0
8 %{?_with_unicode: %{expand: %%define unicode 1}}
9 %{?_without_unicode: %{expand: %%define unicode 0}}
10
11 %define portname x11univ
12
13 %if %{unicode}
14 %define wxbasename wx-base-unicode
15 %define name wx-%{portname}-unicode
16 %define wxconfig %{portname}-unicode-release-%{ver2}
17 %define wxconfiglink wx%{portname}u-%{ver2}-config
18 %else
19 %define wxbasename wx-base
20 %define name wx-%{portname}
21 %define wxconfig %{portname}-ansi-release-%{ver2}
22 %define wxconfiglink wx%{portname}-%{ver2}-config
23 %endif
24
25 Summary: The X11 port of the wxWidgets library
26 Name: %{name}
27 Version: %{ver}
28 Release: %{rel}
29 License: wxWindows Licence
30 Group: X11/Libraries
31 Source: wxX11-%{ver}.tar.bz2
32 URL: http://www.wxwidgets.org
33 Packager: Vadim Zeitlin <vadim@wxwindows.org>
34 Prefix: %{pref}
35 BuildRoot: %{_tmppath}/%{name}-root
36 Requires: %{wxbasename} = %{ver}
37
38 # all packages providing an implementation of wxWidgets library (regardless of
39 # the toolkit used) should provide the (virtual) wxwin package, this makes it
40 # possible to require wxwin instead of requiring "wxgtk or wxmotif or wxuniv..."
41 Provides: wxwin
42 Provides: wxX11
43
44 %description
45 wxWidgets is a free C++ library for cross-platform GUI development.
46 With wxWidgets, you can create applications for different GUIs (GTK+,
47 Motif/LessTif, MS Windows, Mac) from the same source code.
48
49 %package devel
50 Summary: The X11 port of the wxWidgets library
51 Group: X11/Libraries
52 Requires: %{name} = %{ver}
53 Requires: %{wxbasename}-devel = %{ver}
54
55 %description devel
56 Header files for wxX11, the X11 port of the wxWidgets library.
57
58 %package gl
59 Summary: The X11 port of the wxWidgets library, OpenGL add-on.
60 Group: X11/Libraries
61 Requires: %{name} = %{ver}
62
63 %description gl
64 OpenGL add-on library for wxX11, the X11 port of the wxWidgets library.
65
66 %package static
67 Summary: wxX11 static libraries
68 Group: Development/Libraries
69 Requires: %{wxbasename}-static
70 Requires: %{name}-devel = %{ver}
71
72 %description static
73 Static libraries for wxX11. You need them if you want to link statically against wxX11.
74
75 %package contrib
76 Summary: Contrib libraries for wxX11.
77 Group: X11/Libraries
78 Requires: %{name} = %{ver}
79
80 %description contrib
81 Contributed libraries for wxX11.
82
83 %package contrib-devel
84 Summary: Contrib libraries for wxX11.
85 Group: X11/Libraries
86 Requires: %{name}-contrib = %{ver}
87 Requires: %{name}-devel = %{ver}
88
89 %description contrib-devel
90 Header files for contributed libraries for wxX11.
91
92 %prep
93 %setup -q -n wxX11-%{ver}
94
95 %build
96 if [ "$SMP" != "" ]; then
97 export MAKE="make -j$SMP"
98 else
99 export MAKE="make"
100 fi
101
102 mkdir obj-shared
103 cd obj-shared
104 ../configure --prefix=%{pref} --with-x11 \
105 %if %{unicode}
106 --enable-unicode \
107 %else
108 --disable-unicode \
109 %endif
110 $MAKE
111
112 cd contrib/src
113 $MAKE
114 cd ../../..
115
116 mkdir obj-static
117 cd obj-static
118 ../configure --prefix=%{pref} --with-x11 --disable-shared \
119 %if %{unicode}
120 --enable-unicode \
121 %else
122 --disable-unicode \
123 %endif
124 --with-opengl
125 $MAKE
126 cd ..
127
128 %install
129 rm -rf $RPM_BUILD_ROOT
130 (cd obj-static; make prefix=$RPM_BUILD_ROOT%{pref} install)
131 (cd obj-shared; make prefix=$RPM_BUILD_ROOT%{pref} install)
132
133 # Remove headers that are part of wx-base-devel:
134
135 # --- wxBase headers list begins here ---
136 cat <<EOF >wxbase-headers.files
137 wx/afterstd.h
138 wx/app.h
139 wx/apptrait.h
140 wx/archive.h
141 wx/arrimpl.cpp
142 wx/arrstr.h
143 wx/atomic.h
144 wx/base64.h
145 wx/beforestd.h
146 wx/buffer.h
147 wx/build.h
148 wx/chartype.h
149 wx/chkconf.h
150 wx/clntdata.h
151 wx/cmdargs.h
152 wx/cmdline.h
153 wx/confbase.h
154 wx/config.h
155 wx/convauto.h
156 wx/containr.h
157 wx/cpp.h
158 wx/crt.h
159 wx/datetime.h
160 wx/datstrm.h
161 wx/dde.h
162 wx/debug.h
163 wx/defs.h
164 wx/dir.h
165 wx/dlimpexp.h
166 wx/dynarray.h
167 wx/dynlib.h
168 wx/dynload.h
169 wx/encconv.h
170 wx/event.h
171 wx/except.h
172 wx/features.h
173 wx/flags.h
174 wx/ffile.h
175 wx/file.h
176 wx/fileconf.h
177 wx/filefn.h
178 wx/filename.h
179 wx/filesys.h
180 wx/fontenc.h
181 wx/fontmap.h
182 wx/fs_arc.h
183 wx/fs_filter.h
184 wx/fs_mem.h
185 wx/fs_zip.h
186 wx/hash.h
187 wx/hashmap.h
188 wx/hashset.h
189 wx/html/forcelnk.h
190 wx/iconloc.h
191 wx/init.h
192 wx/intl.h
193 wx/iosfwrap.h
194 wx/ioswrap.h
195 wx/ipc.h
196 wx/ipcbase.h
197 wx/link.h
198 wx/list.h
199 wx/listimpl.cpp
200 wx/log.h
201 wx/longlong.h
202 wx/math.h
203 wx/memconf.h
204 wx/memory.h
205 wx/memtext.h
206 wx/mimetype.h
207 wx/module.h
208 wx/msgout.h
209 wx/mstream.h
210 wx/object.h
211 wx/platform.h
212 wx/platinfo.h
213 wx/power.h
214 wx/process.h
215 wx/ptr_scpd.h
216 wx/ptr_shrd.h
217 wx/recguard.h
218 wx/regex.h
219 wx/scopeguard.h
220 wx/snglinst.h
221 wx/sstream.h
222 wx/stack.h
223 wx/stackwalk.h
224 wx/stdpaths.h
225 wx/stockitem.h
226 wx/stopwatch.h
227 wx/strconv.h
228 wx/stream.h
229 wx/string.h
230 wx/stringimpl.h
231 wx/stringops.h
232 wx/strvararg.h
233 wx/sysopt.h
234 wx/tarstrm.h
235 wx/textbuf.h
236 wx/textfile.h
237 wx/thread.h
238 wx/thrimpl.cpp
239 wx/timer.h
240 wx/tokenzr.h
241 wx/tracker.h
242 wx/txtstrm.h
243 wx/types.h
244 wx/unichar.h
245 wx/uri.h
246 wx/utils.h
247 wx/variant.h
248 wx/vector.h
249 wx/version.h
250 wx/volume.h
251 wx/weakref.h
252 wx/wfstream.h
253 wx/wx.h
254 wx/wxchar.h
255 wx/wxcrt.h
256 wx/wxcrtbase.h
257 wx/wxcrtvararg.h
258 wx/wxprec.h
259 wx/xti.h
260 wx/xtistrm.h
261 wx/zipstrm.h
262 wx/zstream.h
263 wx/meta/convertible.h
264 wx/meta/defs.h
265 wx/meta/int2type.h
266 wx/private/fdiodispatcher.h
267 wx/private/selectdispatcher.h
268 wx/unix/app.h
269 wx/unix/apptbase.h
270 wx/unix/apptrait.h
271 wx/unix/chkconf.h
272 wx/unix/evtloop.h
273 wx/unix/pipe.h
274 wx/unix/stdpaths.h
275 wx/unix/execute.h
276 wx/unix/mimetype.h
277 wx/unix/private.h
278 wx/private/gsocketiohandler.h
279 wx/unix/stackwalk.h
280 wx/fs_inet.h
281 wx/gsocket.h
282 wx/protocol/file.h
283 wx/protocol/ftp.h
284 wx/protocol/http.h
285 wx/protocol/protocol.h
286 wx/sckaddr.h
287 wx/sckipc.h
288 wx/sckstrm.h
289 wx/socket.h
290 wx/url.h
291 wx/unix/gsockunx.h
292 wx/xml/xml.h
293 wx/xtixml.h
294 EOF
295 # --- wxBase headers list ends here ---
296 for f in `cat wxbase-headers-list` ; do
297 rm -f $RPM_BUILD_ROOT%{_includedir}/wx-%{ver2}/$f
298 done
299
300 # list of all core headers:
301 find $RPM_BUILD_ROOT%{_includedir}/wx-%{ver2} -type f | sed -e "s,$RPM_BUILD_ROOT,,g" >core-headers.files
302
303 # contrib stuff:
304 (cd obj-shared/contrib/src; make prefix=$RPM_BUILD_ROOT%{pref} install)
305 (cd obj-shared/utils/wxrc; make prefix=$RPM_BUILD_ROOT%{pref} install)
306
307 # remove wxBase files so that RPM doesn't complain about unpackaged files:
308 rm -f $RPM_BUILD_ROOT%{_libdir}/libwx_base*
309 %if %{unicode}
310 rm -f $RPM_BUILD_ROOT%{_libdir}/libwxregexu-%{ver2}.a
311 %endif
312 rm -f $RPM_BUILD_ROOT%{_datadir}/aclocal/*
313 rm -f $RPM_BUILD_ROOT%{_datadir}/locale/*/*/*
314
315 %clean
316 rm -rf $RPM_BUILD_ROOT
317
318 %post
319 /sbin/ldconfig
320
321 %postun
322 /sbin/ldconfig
323
324 %post devel
325 # link wx-config when you install RPM.
326 ln -sf %{_libdir}/wx/config/%{wxconfig} %{_bindir}/wx-config
327 # link wx-config with explicit name.
328 ln -sf %{_libdir}/wx/config/%{wxconfig} %{_bindir}/%{wxconfiglink}
329 /sbin/ldconfig
330
331 %postun devel
332 /sbin/ldconfig
333
334 %preun devel
335 if test -f %{_bindir}/wx-config -a -f /usr/bin/md5sum ; then
336 SUM1=`md5sum %{_libdir}/wx/config/%{wxconfig} | cut -c 0-32`
337 SUM2=`md5sum %{_bindir}/wx-config | cut -c 0-32`
338 if test "x$SUM1" = "x$SUM2" ; then
339 rm -f %{_bindir}/wx-config
340 fi
341 fi
342 rm -f %{_bindir}/%{wxconfiglink}
343
344 %post gl
345 /sbin/ldconfig
346
347 %postun gl
348 /sbin/ldconfig
349
350 %post contrib
351 /sbin/ldconfig
352
353 %postun contrib
354 /sbin/ldconfig
355
356 %post contrib-devel
357 /sbin/ldconfig
358
359 %postun contrib-devel
360 /sbin/ldconfig
361
362 %files
363 %defattr(-,root,root)
364 %doc COPYING.LIB *.txt
365 %{_libdir}/libwx_%{portname}*_adv-%{ver2}.so.*
366 %{_libdir}/libwx_%{portname}*_core-%{ver2}.so.*
367 %{_libdir}/libwx_%{portname}*_html-%{ver2}.so.*
368 %{_libdir}/libwx_%{portname}*_media-%{ver2}.so.*
369 %{_libdir}/libwx_%{portname}*_qa-%{ver2}.so.*
370 %{_libdir}/libwx_%{portname}*_xrc-%{ver2}.so.*
371
372
373 %files devel -f core-headers.files
374 %defattr(-,root,root)
375 %{_libdir}/libwx_%{portname}*_adv-%{ver2}.so
376 %{_libdir}/libwx_%{portname}*_core-%{ver2}.so
377 %{_libdir}/libwx_%{portname}*_gl-%{ver2}.so
378 %{_libdir}/libwx_%{portname}*_html-%{ver2}.so
379 %{_libdir}/libwx_%{portname}*_media-%{ver2}.so
380 %{_libdir}/libwx_%{portname}*_qa-%{ver2}.so
381 %{_libdir}/libwx_%{portname}*_xrc-%{ver2}.so
382 %dir %{_libdir}/wx
383 %{_libdir}/wx/*
384 %{_bindir}/wxrc*
385
386 %files gl
387 %defattr(-,root,root)
388 %{_libdir}/libwx_%{portname}*_gl-%{ver2}.so.*
389
390 %files static
391 %defattr (-,root,root)
392 %{_libdir}/libwx_%{portname}*_*-%{ver2}.a
393
394 %files contrib
395 %defattr(-,root,root)
396 %{_libdir}/libwx_%{portname}*_animate-%{ver2}.so.*
397 %{_libdir}/libwx_%{portname}*_deprecated-%{ver2}.so.*
398 %{_libdir}/libwx_%{portname}*_fl-%{ver2}.so.*
399 %{_libdir}/libwx_%{portname}*_gizmos-%{ver2}.so.*
400 %{_libdir}/libwx_%{portname}*_mmedia-%{ver2}.so.*
401 %{_libdir}/libwx_%{portname}*_ogl-%{ver2}.so.*
402 %{_libdir}/libwx_%{portname}*_plot-%{ver2}.so.*
403 %{_libdir}/libwx_%{portname}*_stc-%{ver2}.so.*
404 %{_libdir}/libwx_%{portname}*_svg-%{ver2}.so.*
405
406 %files contrib-devel
407 %defattr(-,root,root)
408 %dir %{_includedir}/wx-%{ver2}/wx/animate
409 %{_includedir}/wx-%{ver2}/wx/animate/*
410 %{_libdir}/libwx_%{portname}*_animate-%{ver2}.so
411
412 %dir %{_includedir}/wx-%{ver2}/wx/deprecated
413 %{_includedir}/wx-%{ver2}/wx/deprecated/*
414 %{_libdir}/libwx_%{portname}*_deprecated-%{ver2}.so
415
416 %dir %{_includedir}/wx-%{ver2}/wx/fl
417 %{_includedir}/wx-%{ver2}/wx/fl/*
418 %{_libdir}/libwx_%{portname}*_fl-%{ver2}.so
419
420 %dir %{_includedir}/wx-%{ver2}/wx/gizmos
421 %{_includedir}/wx-%{ver2}/wx/gizmos/*
422 %{_libdir}/libwx_%{portname}*_gizmos-%{ver2}.so
423
424 %dir %{_includedir}/wx-%{ver2}/wx/mmedia
425 %{_includedir}/wx-%{ver2}/wx/mmedia/*
426 %{_libdir}/libwx_%{portname}*_mmedia-%{ver2}.so
427
428 %dir %{_includedir}/wx-%{ver2}/wx/ogl
429 %{_includedir}/wx-%{ver2}/wx/ogl/*
430 %{_libdir}/libwx_%{portname}*_ogl-%{ver2}.so
431
432 %dir %{_includedir}/wx-%{ver2}/wx/plot
433 %{_includedir}/wx-%{ver2}/wx/plot/*
434 %{_libdir}/libwx_%{portname}*_plot-%{ver2}.so
435
436 %dir %{_includedir}/wx-%{ver2}/wx/stc
437 %{_includedir}/wx-%{ver2}/wx/stc/*
438 %{_libdir}/libwx_%{portname}*_stc-%{ver2}.so
439
440 %dir %{_includedir}/wx-%{ver2}/wx/svg
441 %{_includedir}/wx-%{ver2}/wx/svg/*
442 %{_libdir}/libwx_%{portname}*_svg-%{ver2}.so