added back .mo files (we do have a separate package for them after all); added bakefi...
[wxWidgets.git] / wxGTK.spec
1 %define _prefix /usr
2 %define ver 2.7.0
3 %define ver2 2.7
4 %define rel 1
5
6 # Configurable settings (use --with(out) {unicode,gtk2} on rpmbuild cmd line):
7 %define unicode 1
8 %{?_with_unicode: %{expand: %%define unicode 1}}
9 %{?_without_unicode: %{expand: %%define unicode 0}}
10
11 %define gtk2 1
12 %{?_with_gtk2: %{expand: %%define gtk2 1}}
13 %{?_without_gtk2: %{expand: %%define gtk2 0}}
14
15 # "buildname" needs to be e.g. gtk2ud for debug builds
16 %if %{gtk2}
17 %define gtkver 2
18 %define portname gtk2
19 %if %{unicode}
20 %define buildname gtk2u
21 %else
22 %define buildname gtk2
23 %endif
24 %else
25 %define gtkver 1.2
26 %define portname gtk
27 %define buildname gtk
28 %endif
29
30 %if %{unicode}
31 %define name wx-%{portname}-unicode
32 %define wxconfig %{portname}-unicode-release-%{ver2}
33 %define wxconfigstatic %{portname}-unicode-release-static-%{ver2}
34 %define wxconfiglink wx%{portname}u-%{ver2}-config
35 %else
36 %define name wx-%{portname}-ansi
37 %define wxconfig %{portname}-ansi-release-%{ver2}
38 %define wxconfigstatic %{portname}-ansi-release-static-%{ver2}
39 %define wxconfiglink wx%{portname}-%{ver2}-config
40 %endif
41
42 %if %{unicode}
43 %define wxbasename wx-base-unicode
44 %define wxbaseconfig base-unicode-release-%{ver2}
45 %define wxbaseconfigstatic base-unicode-release-static-%{ver2}
46 %define wxbaseconfiglink wxbaseu-%{ver2}-config
47 %else
48 %define wxbasename wx-base-ansi
49 %define wxbaseconfig base-ansi-release-%{ver2}
50 %define wxbaseconfigstatic base-ansi-release-static-%{ver2}
51 %define wxbaseconfiglink wxbase-%{ver2}-config
52 %endif
53
54 Summary: The GTK+ %{gtkver} port of the wxWidgets library
55 Name: %{name}
56 Version: %{ver}
57 Release: %{rel}
58 License: wxWindows Licence
59 Group: X11/Libraries
60 Source: wxGTK-%{ver}.tar.bz2
61 URL: http://www.wxwidgets.org
62 Packager: Vadim Zeitlin <vadim@wxwindows.org>
63 Prefix: %{_prefix}
64 BuildRoot: %{_tmppath}/%{name}-root
65 Requires: %{wxbasename} = %{ver}
66 %if %{portname} == gtk2
67 BuildRequires: gtk+-2.0-devel
68 %else
69 BuildRequires: gtk+-devel >= 1.2.0
70 %endif
71
72 BuildRequires: zlib-devel, libjpeg-devel, libpng-devel, libtiff-devel
73
74 # all packages providing an implementation of wxWidgets library (regardless of
75 # the toolkit used) should provide the (virtual) wxwin package, this makes it
76 # possible to require wxwin instead of requiring "wxgtk or wxmotif or wxuniv..."
77 Provides: wxwin
78 Provides: wxGTK
79
80 %description
81 wxWidgets is a free C++ library for cross-platform GUI development.
82 With wxWidgets, you can create applications for different GUIs (GTK+,
83 Motif, MS Windows, MacOS X, Windows CE, GPE) from the same source code.
84
85 %package -n wx-i18n
86 Summary: The translations for the wxWidgets library.
87 Group: X11/Libraries
88
89 %description -n wx-i18n
90 The translations files for the wxWidgets library.
91
92 %package devel
93 Summary: The GTK+ %{gtkver} port of the wxWidgets library
94 Group: X11/Libraries
95 Requires: %{name} = %{ver}
96 Requires: %{wxbasename}-devel = %{ver}
97 Provides: wxGTK-devel
98
99 %description devel
100 The GTK+ %{gtkver} port of the wxWidgets library, header files.
101
102 %package gl
103 Summary: The GTK+ %{gtkver} port of the wxWidgets library, OpenGL add-on.
104 Group: X11/Libraries
105 Requires: %{name} = %{ver}
106 Provides: wxGTK-gl
107
108 %description gl
109 OpenGL add-on library for wxGTK, the GTK+ %{gtkver} port of the wxWidgets library.
110
111 %package -n %{wxbasename}
112 Summary: wxBase library - non-GUI support classes of the wxWidgets toolkit
113 Group: Development/Libraries
114 Provides: wxBase
115
116 %description -n %{wxbasename}
117 wxBase is a collection of C++ classes providing basic data structures (strings,
118 lists, arrays), portable wrappers around many OS-specific funstions (file
119 operations, time/date manipulations, threads, processes, sockets, shared
120 library loading) as well as other utility classes (streams, archive and
121 compression). wxBase currently supports Win32, most Unix variants (Linux,
122 FreeBSD, Solaris, HP-UX) and MacOS X (Carbon and Mach-0).
123
124 %package -n %{wxbasename}-devel
125 Summary: wxBase library, header files.
126 Group: Development/Libraries
127 Provides: wxBase-devel
128
129 %description -n %{wxbasename}-devel
130 wxBase library - non-GUI support classes of the wxWidgets toolkit,
131 header files.
132
133 %package contrib
134 Summary: The GTK+ %{gtkver} port of the wxWidgets library, contributed libraries.
135 Group: X11/Libraries
136 Requires: %{name} = %{ver}
137
138 %description contrib
139 Contributed libraries for wxGTK, the GTK+ %{gtkver} port of the wxWidgets library.
140
141 %package contrib-devel
142 Summary: The GTK+ %{gtkver} port of the wxWidgets library
143 Group: X11/Libraries
144 Requires: %{name}-contrib = %{ver}
145 Requires: %{name}-devel = %{ver}
146
147 %description contrib-devel
148 Header files for contributed libraries for wxGTK, the GTK+ %{gtkver} port of the wxWidgets library.
149
150 %prep
151 %setup -q -n wxGTK-%{ver}
152
153 %build
154 if [ "$SMP" != "" ]; then
155 export MAKE="make -j$SMP"
156 else
157 export MAKE="make"
158 fi
159
160 mkdir obj-shared
161 cd obj-shared
162 ../configure --prefix=%{_prefix} \
163 %if ! %{gtk2}
164 --with-gtk=1 \
165 %else
166 --with-gtk=2 \
167 %endif
168 %if %{unicode}
169 --enable-unicode \
170 %else
171 --disable-unicode \
172 --with-odbc \
173 %endif
174 --with-opengl
175 $MAKE
176
177 cd contrib/src
178 $MAKE
179 cd ../../..
180
181 mkdir obj-static
182 cd obj-static
183 ../configure --prefix=%{_prefix} \
184 %if ! %{gtk2}
185 --with-gtk=1 \
186 %else
187 --with-gtk=2 \
188 %endif
189 --disable-shared \
190 %if %{unicode}
191 --enable-unicode \
192 %else
193 --disable-unicode \
194 --with-odbc \
195 %endif
196 --with-opengl
197 $MAKE
198
199 cd contrib/src
200 $MAKE
201 cd ../../..
202
203 make -C locale allmo
204
205 %install
206 rm -rf $RPM_BUILD_ROOT
207 (cd obj-static; make DESTDIR=$RPM_BUILD_ROOT prefix=%{_prefix} install)
208 (cd obj-shared; make DESTDIR=$RPM_BUILD_ROOT prefix=%{_prefix} install)
209
210 # --- wxBase headers list begins here ---
211 cat <<EOF >wxbase-headers.files
212 wx/afterstd.h
213 wx/app.h
214 wx/apptrait.h
215 wx/archive.h
216 wx/arrimpl.cpp
217 wx/arrstr.h
218 wx/beforestd.h
219 wx/buffer.h
220 wx/build.h
221 wx/chkconf.h
222 wx/clntdata.h
223 wx/cmdline.h
224 wx/confbase.h
225 wx/config.h
226 wx/convauto.h
227 wx/containr.h
228 wx/datetime.h
229 wx/datstrm.h
230 wx/dde.h
231 wx/debug.h
232 wx/defs.h
233 wx/dir.h
234 wx/dlimpexp.h
235 wx/dynarray.h
236 wx/dynlib.h
237 wx/dynload.h
238 wx/encconv.h
239 wx/event.h
240 wx/except.h
241 wx/features.h
242 wx/ffile.h
243 wx/file.h
244 wx/fileconf.h
245 wx/filefn.h
246 wx/filename.h
247 wx/filesys.h
248 wx/fontenc.h
249 wx/fontmap.h
250 wx/fs_mem.h
251 wx/fs_zip.h
252 wx/hash.h
253 wx/hashmap.h
254 wx/hashset.h
255 wx/html/forcelnk.h
256 wx/iconloc.h
257 wx/init.h
258 wx/intl.h
259 wx/iosfwrap.h
260 wx/ioswrap.h
261 wx/ipc.h
262 wx/ipcbase.h
263 wx/isql.h
264 wx/isqlext.h
265 wx/link.h
266 wx/list.h
267 wx/listimpl.cpp
268 wx/log.h
269 wx/longlong.h
270 wx/math.h
271 wx/memconf.h
272 wx/memory.h
273 wx/memtext.h
274 wx/mimetype.h
275 wx/module.h
276 wx/msgout.h
277 wx/mstream.h
278 wx/object.h
279 wx/platform.h
280 wx/power.h
281 wx/process.h
282 wx/ptr_scpd.h
283 wx/recguard.h
284 wx/regex.h
285 wx/scopeguard.h
286 wx/snglinst.h
287 wx/sstream.h
288 wx/stack.h
289 wx/stackwalk.h
290 wx/stdpaths.h
291 wx/stockitem.h
292 wx/stopwatch.h
293 wx/strconv.h
294 wx/stream.h
295 wx/string.h
296 wx/sysopt.h
297 wx/textbuf.h
298 wx/textfile.h
299 wx/thread.h
300 wx/thrimpl.cpp
301 wx/timer.h
302 wx/tokenzr.h
303 wx/txtstrm.h
304 wx/types.h
305 wx/uri.h
306 wx/utils.h
307 wx/variant.h
308 wx/vector.h
309 wx/version.h
310 wx/volume.h
311 wx/wfstream.h
312 wx/wx.h
313 wx/wxchar.h
314 wx/wxprec.h
315 wx/xti.h
316 wx/xtistrm.h
317 wx/zipstrm.h
318 wx/zstream.h
319 wx/unix/apptbase.h
320 wx/unix/apptrait.h
321 wx/unix/execute.h
322 wx/unix/mimetype.h
323 wx/unix/pipe.h
324 wx/unix/private.h
325 wx/unix/stackwalk.h
326 wx/unix/stdpaths.h
327 wx/fs_inet.h
328 wx/gsocket.h
329 wx/protocol/file.h
330 wx/protocol/ftp.h
331 wx/protocol/http.h
332 wx/protocol/protocol.h
333 wx/sckaddr.h
334 wx/sckipc.h
335 wx/sckstrm.h
336 wx/socket.h
337 wx/url.h
338 wx/unix/gsockunx.h
339 wx/xml/xml.h
340 wx/xtixml.h
341 wx/db.h
342 wx/dbkeyg.h
343 wx/dbtable.h
344 EOF
345 # --- wxBase headers list ends here ---
346 cat <<EOF >wxbase-headers.paths
347 %{_includedir}/wx-%{ver2}/wx/afterstd.h
348 %{_includedir}/wx-%{ver2}/wx/app.h
349 %{_includedir}/wx-%{ver2}/wx/apptrait.h
350 %{_includedir}/wx-%{ver2}/wx/archive.h
351 %{_includedir}/wx-%{ver2}/wx/arrimpl.cpp
352 %{_includedir}/wx-%{ver2}/wx/arrstr.h
353 %{_includedir}/wx-%{ver2}/wx/beforestd.h
354 %{_includedir}/wx-%{ver2}/wx/buffer.h
355 %{_includedir}/wx-%{ver2}/wx/build.h
356 %{_includedir}/wx-%{ver2}/wx/chkconf.h
357 %{_includedir}/wx-%{ver2}/wx/clntdata.h
358 %{_includedir}/wx-%{ver2}/wx/cmdline.h
359 %{_includedir}/wx-%{ver2}/wx/confbase.h
360 %{_includedir}/wx-%{ver2}/wx/config.h
361 %{_includedir}/wx-%{ver2}/wx/containr.h
362 %{_includedir}/wx-%{ver2}/wx/datetime.h
363 %{_includedir}/wx-%{ver2}/wx/datstrm.h
364 %{_includedir}/wx-%{ver2}/wx/dde.h
365 %{_includedir}/wx-%{ver2}/wx/debug.h
366 %{_includedir}/wx-%{ver2}/wx/defs.h
367 %{_includedir}/wx-%{ver2}/wx/dir.h
368 %{_includedir}/wx-%{ver2}/wx/dlimpexp.h
369 %{_includedir}/wx-%{ver2}/wx/dynarray.h
370 %{_includedir}/wx-%{ver2}/wx/dynlib.h
371 %{_includedir}/wx-%{ver2}/wx/dynload.h
372 %{_includedir}/wx-%{ver2}/wx/encconv.h
373 %{_includedir}/wx-%{ver2}/wx/event.h
374 %{_includedir}/wx-%{ver2}/wx/except.h
375 %{_includedir}/wx-%{ver2}/wx/features.h
376 %{_includedir}/wx-%{ver2}/wx/ffile.h
377 %{_includedir}/wx-%{ver2}/wx/file.h
378 %{_includedir}/wx-%{ver2}/wx/fileconf.h
379 %{_includedir}/wx-%{ver2}/wx/filefn.h
380 %{_includedir}/wx-%{ver2}/wx/filename.h
381 %{_includedir}/wx-%{ver2}/wx/filesys.h
382 %{_includedir}/wx-%{ver2}/wx/fontenc.h
383 %{_includedir}/wx-%{ver2}/wx/fontmap.h
384 %{_includedir}/wx-%{ver2}/wx/fs_mem.h
385 %{_includedir}/wx-%{ver2}/wx/fs_zip.h
386 %{_includedir}/wx-%{ver2}/wx/hash.h
387 %{_includedir}/wx-%{ver2}/wx/hashmap.h
388 %{_includedir}/wx-%{ver2}/wx/hashset.h
389 %{_includedir}/wx-%{ver2}/wx/html/forcelnk.h
390 %{_includedir}/wx-%{ver2}/wx/iconloc.h
391 %{_includedir}/wx-%{ver2}/wx/init.h
392 %{_includedir}/wx-%{ver2}/wx/intl.h
393 %{_includedir}/wx-%{ver2}/wx/iosfwrap.h
394 %{_includedir}/wx-%{ver2}/wx/ioswrap.h
395 %{_includedir}/wx-%{ver2}/wx/ipc.h
396 %{_includedir}/wx-%{ver2}/wx/ipcbase.h
397 %{_includedir}/wx-%{ver2}/wx/isql.h
398 %{_includedir}/wx-%{ver2}/wx/isqlext.h
399 %{_includedir}/wx-%{ver2}/wx/list.h
400 %{_includedir}/wx-%{ver2}/wx/listimpl.cpp
401 %{_includedir}/wx-%{ver2}/wx/log.h
402 %{_includedir}/wx-%{ver2}/wx/longlong.h
403 %{_includedir}/wx-%{ver2}/wx/math.h
404 %{_includedir}/wx-%{ver2}/wx/memconf.h
405 %{_includedir}/wx-%{ver2}/wx/memory.h
406 %{_includedir}/wx-%{ver2}/wx/memtext.h
407 %{_includedir}/wx-%{ver2}/wx/mimetype.h
408 %{_includedir}/wx-%{ver2}/wx/module.h
409 %{_includedir}/wx-%{ver2}/wx/msgout.h
410 %{_includedir}/wx-%{ver2}/wx/mstream.h
411 %{_includedir}/wx-%{ver2}/wx/object.h
412 %{_includedir}/wx-%{ver2}/wx/platform.h
413 %{_includedir}/wx-%{ver2}/wx/process.h
414 %{_includedir}/wx-%{ver2}/wx/ptr_scpd.h
415 %{_includedir}/wx-%{ver2}/wx/regex.h
416 %{_includedir}/wx-%{ver2}/wx/scopeguard.h
417 %{_includedir}/wx-%{ver2}/wx/snglinst.h
418 %{_includedir}/wx-%{ver2}/wx/sstream.h
419 %{_includedir}/wx-%{ver2}/wx/stack.h
420 %{_includedir}/wx-%{ver2}/wx/stackwalk.h
421 %{_includedir}/wx-%{ver2}/wx/stdpaths.h
422 %{_includedir}/wx-%{ver2}/wx/stockitem.h
423 %{_includedir}/wx-%{ver2}/wx/stopwatch.h
424 %{_includedir}/wx-%{ver2}/wx/strconv.h
425 %{_includedir}/wx-%{ver2}/wx/stream.h
426 %{_includedir}/wx-%{ver2}/wx/string.h
427 %{_includedir}/wx-%{ver2}/wx/sysopt.h
428 %{_includedir}/wx-%{ver2}/wx/textbuf.h
429 %{_includedir}/wx-%{ver2}/wx/textfile.h
430 %{_includedir}/wx-%{ver2}/wx/thread.h
431 %{_includedir}/wx-%{ver2}/wx/thrimpl.cpp
432 %{_includedir}/wx-%{ver2}/wx/timer.h
433 %{_includedir}/wx-%{ver2}/wx/tokenzr.h
434 %{_includedir}/wx-%{ver2}/wx/txtstrm.h
435 %{_includedir}/wx-%{ver2}/wx/types.h
436 %{_includedir}/wx-%{ver2}/wx/uri.h
437 %{_includedir}/wx-%{ver2}/wx/utils.h
438 %{_includedir}/wx-%{ver2}/wx/variant.h
439 %{_includedir}/wx-%{ver2}/wx/vector.h
440 %{_includedir}/wx-%{ver2}/wx/version.h
441 %{_includedir}/wx-%{ver2}/wx/volume.h
442 %{_includedir}/wx-%{ver2}/wx/wfstream.h
443 %{_includedir}/wx-%{ver2}/wx/wx.h
444 %{_includedir}/wx-%{ver2}/wx/wxchar.h
445 %{_includedir}/wx-%{ver2}/wx/wxprec.h
446 %{_includedir}/wx-%{ver2}/wx/xti.h
447 %{_includedir}/wx-%{ver2}/wx/xtistrm.h
448 %{_includedir}/wx-%{ver2}/wx/zipstrm.h
449 %{_includedir}/wx-%{ver2}/wx/zstream.h
450 %{_includedir}/wx-%{ver2}/wx/fs_inet.h
451 %{_includedir}/wx-%{ver2}/wx/gsocket.h
452 %{_includedir}/wx-%{ver2}/wx/protocol/file.h
453 %{_includedir}/wx-%{ver2}/wx/protocol/ftp.h
454 %{_includedir}/wx-%{ver2}/wx/protocol/http.h
455 %{_includedir}/wx-%{ver2}/wx/protocol/protocol.h
456 %{_includedir}/wx-%{ver2}/wx/sckaddr.h
457 %{_includedir}/wx-%{ver2}/wx/sckipc.h
458 %{_includedir}/wx-%{ver2}/wx/sckstrm.h
459 %{_includedir}/wx-%{ver2}/wx/socket.h
460 %{_includedir}/wx-%{ver2}/wx/url.h
461 %{_includedir}/wx-%{ver2}/wx/xml/xml.h
462 %{_includedir}/wx-%{ver2}/wx/xtixml.h
463 %{_includedir}/wx-%{ver2}/wx/db.h
464 %{_includedir}/wx-%{ver2}/wx/dbkeyg.h
465 %{_includedir}/wx-%{ver2}/wx/dbtable.h
466 %{_includedir}/wx-%{ver2}/wx/unix/apptbase.h
467 %{_includedir}/wx-%{ver2}/wx/unix/apptrait.h
468 %{_includedir}/wx-%{ver2}/wx/unix/execute.h
469 %{_includedir}/wx-%{ver2}/wx/unix/gsockunx.h
470 %{_includedir}/wx-%{ver2}/wx/unix/mimetype.h
471 %{_includedir}/wx-%{ver2}/wx/unix/pipe.h
472 %{_includedir}/wx-%{ver2}/wx/unix/stackwalk.h
473 %{_includedir}/wx-%{ver2}/wx/unix/stdpaths.h
474 EOF
475 # --- wxBase headers list ends here ---
476
477 # temporarily remove base headers
478 mkdir $RPM_BUILD_ROOT/_save_dir
479 cp -r $RPM_BUILD_ROOT%{_includedir}/wx-%{ver2} $RPM_BUILD_ROOT/_save_dir
480 for f in `cat wxbase-headers.files` ; do
481 rm -f $RPM_BUILD_ROOT%{_includedir}/wx-%{ver2}/$f
482 done
483 # list of all core headers:
484 find $RPM_BUILD_ROOT%{_includedir}/wx-%{ver2} -type f | sed -e "s,$RPM_BUILD_ROOT,,g" >core-headers.files
485 # move base headers (actually all headers) back again
486 cp -f -r $RPM_BUILD_ROOT/_save_dir/* $RPM_BUILD_ROOT%{_includedir}
487 rm -rf $RPM_BUILD_ROOT/_save_dir
488
489 # contrib stuff:
490 (cd obj-shared/contrib/src; make DESTDIR=$RPM_BUILD_ROOT install)
491 (cd obj-shared/utils/wxrc; make DESTDIR=$RPM_BUILD_ROOT install)
492
493 %clean
494 rm -rf $RPM_BUILD_ROOT
495
496 %post
497 /sbin/ldconfig
498
499 %postun
500 /sbin/ldconfig
501
502 %post devel
503 # link wx-config when you install RPM.
504 %if %{unicode}
505 ln -sf %{_libdir}/wx/config/%{wxconfig} %{_bindir}/wx-config
506 %endif
507 # link wx-config with explicit name.
508 ln -sf %{_libdir}/wx/config/%{wxconfig} %{_bindir}/%{wxconfiglink}
509 /sbin/ldconfig
510
511 %postun devel
512 /sbin/ldconfig
513
514 %preun devel
515 %if %{unicode}
516 rm -f %{_bindir}/wx-config
517 %endif
518 rm -f %{_bindir}/%{wxconfiglink}
519
520 %post -n %{wxbasename}
521 /sbin/ldconfig
522
523 %postun -n %{wxbasename}
524 /sbin/ldconfig
525
526 %post -n %{wxbasename}-devel
527 # link wx-config with explicit name.
528 ln -sf %{_libdir}/wx/config/%{wxbaseconfig} %{_bindir}/%{wxbaseconfiglink}
529 /sbin/ldconfig
530
531 %postun -n %{wxbasename}-devel
532 /sbin/ldconfig
533
534 %preun -n %{wxbasename}-devel
535 rm -f %{_bindir}/%{wxbaseconfiglink}
536
537 %post gl
538 /sbin/ldconfig
539
540 %postun gl
541 /sbin/ldconfig
542
543 %post contrib
544 /sbin/ldconfig
545
546 %postun contrib
547 /sbin/ldconfig
548
549 %post contrib-devel
550 /sbin/ldconfig
551
552 %postun contrib-devel
553 /sbin/ldconfig
554
555 %files
556 %defattr(-,root,root)
557 %doc COPYING.LIB *.txt
558 %{_libdir}/libwx_%{buildname}_adv-%{ver2}.so.*
559 %{_libdir}/libwx_%{buildname}_core-%{ver2}.so.*
560 %if !%{unicode}
561 %{_libdir}/libwx_%{buildname}_dbgrid-%{ver2}.so.*
562 %endif
563 %{_libdir}/libwx_%{buildname}_html-%{ver2}.so.*
564 %{_libdir}/libwx_%{buildname}_media-%{ver2}.so.*
565 %{_libdir}/libwx_%{buildname}_qa-%{ver2}.so.*
566 %{_libdir}/libwx_%{buildname}_xrc-%{ver2}.so.*
567
568 %files -n wx-i18n
569 %defattr(-,root,root)
570 %{_datadir}/locale/*/LC_MESSAGES/*.mo
571
572 %files devel -f core-headers.files
573 %defattr(-,root,root)
574 # shared libs
575 %{_libdir}/libwx_%{buildname}_adv-%{ver2}.so
576 %{_libdir}/libwx_%{buildname}_core-%{ver2}.so
577 %if !%{unicode}
578 %{_libdir}/libwx_%{buildname}_dbgrid-%{ver2}.so
579 %endif
580 %{_libdir}/libwx_%{buildname}_gl-%{ver2}.so
581 %{_libdir}/libwx_%{buildname}_html-%{ver2}.so
582 %{_libdir}/libwx_%{buildname}_media-%{ver2}.so
583 %{_libdir}/libwx_%{buildname}_qa-%{ver2}.so
584 %{_libdir}/libwx_%{buildname}_xrc-%{ver2}.so
585 # static libs
586 %{_libdir}/libwx_%{buildname}_adv-%{ver2}.a
587 %{_libdir}/libwx_%{buildname}_core-%{ver2}.a
588 %if !%{unicode}
589 %{_libdir}/libwx_%{buildname}_dbgrid-%{ver2}.a
590 %endif
591 %{_libdir}/libwx_%{buildname}_gl-%{ver2}.a
592 %{_libdir}/libwx_%{buildname}_html-%{ver2}.a
593 %{_libdir}/libwx_%{buildname}_media-%{ver2}.a
594 %{_libdir}/libwx_%{buildname}_qa-%{ver2}.a
595 %{_libdir}/libwx_%{buildname}_xrc-%{ver2}.a
596 %dir %{_libdir}/wx
597 %{_libdir}/wx/config/%{wxconfig}
598 %{_libdir}/wx/include/%{wxconfig}/wx/setup.h
599 %{_libdir}/wx/config/%{wxconfigstatic}
600 %{_libdir}/wx/include/%{wxconfigstatic}/wx/setup.h
601 %{_bindir}/wxrc*
602
603 %files -n %{wxbasename}
604 %defattr(-,root,root)
605 %{_libdir}/libwx_base*-%{ver2}.so.*
606
607 %files -n %{wxbasename}-devel -f wxbase-headers.paths
608 %defattr (-,root,root)
609 %dir %{_includedir}/wx-%{ver2}
610 %{_libdir}/libwx_base*-%{ver2}.so
611 %{_libdir}/libwx_base*-%{ver2}.a
612 %if %{unicode}
613 %{_libdir}/libwxregexu-%{ver2}.a
614 %endif
615 %dir %{_libdir}/wx
616 %{_libdir}/wx/config/%{wxbaseconfig}
617 %{_libdir}/wx/include/%{wxbaseconfig}/wx/setup.h
618 %{_libdir}/wx/config/%{wxbaseconfigstatic}
619 %{_libdir}/wx/include/%{wxbaseconfigstatic}/wx/setup.h
620 %{_datadir}/aclocal/*.m4
621 %{_datadir}/bakefile/presets/*
622
623 %files gl
624 %defattr(-,root,root)
625 %{_libdir}/libwx_%{buildname}_gl-%{ver2}.so.*
626
627 %files contrib
628 %defattr(-,root,root)
629 %{_libdir}/libwx_%{buildname}_animate-%{ver2}.so.*
630 %{_libdir}/libwx_%{buildname}_deprecated-%{ver2}.so.*
631 %{_libdir}/libwx_%{buildname}_fl-%{ver2}.so.*
632 %{_libdir}/libwx_%{buildname}_gizmos-%{ver2}.so.*
633 %{_libdir}/libwx_%{buildname}_gizmos_xrc-%{ver2}.so.*
634 %{_libdir}/libwx_%{buildname}_mmedia-%{ver2}.so.*
635 %{_libdir}/libwx_%{buildname}_ogl-%{ver2}.so.*
636 %{_libdir}/libwx_%{buildname}_plot-%{ver2}.so.*
637 %{_libdir}/libwx_%{buildname}_stc-%{ver2}.so.*
638 %{_libdir}/libwx_%{buildname}_svg-%{ver2}.so.*
639
640 %files contrib-devel
641 %defattr(-,root,root)
642 %dir %{_includedir}/wx-%{ver2}/wx/animate
643 %{_includedir}/wx-%{ver2}/wx/animate/*
644 %{_libdir}/libwx_%{buildname}_animate-%{ver2}.so
645
646 %dir %{_includedir}/wx-%{ver2}/wx/deprecated
647 %{_includedir}/wx-%{ver2}/wx/deprecated/*
648 %{_libdir}/libwx_%{buildname}_deprecated-%{ver2}.so
649
650 %dir %{_includedir}/wx-%{ver2}/wx/fl
651 %{_includedir}/wx-%{ver2}/wx/fl/*
652 %{_libdir}/libwx_%{buildname}_fl-%{ver2}.so
653
654 %dir %{_includedir}/wx-%{ver2}/wx/gizmos
655 %{_includedir}/wx-%{ver2}/wx/gizmos/*
656 %{_libdir}/libwx_%{buildname}_gizmos-%{ver2}.so
657 %{_libdir}/libwx_%{buildname}_gizmos_xrc-%{ver2}.so
658
659 %dir %{_includedir}/wx-%{ver2}/wx/mmedia
660 %{_includedir}/wx-%{ver2}/wx/mmedia/*
661 %{_libdir}/libwx_%{buildname}_mmedia-%{ver2}.so
662
663 %dir %{_includedir}/wx-%{ver2}/wx/ogl
664 %{_includedir}/wx-%{ver2}/wx/ogl/*
665 %{_libdir}/libwx_%{buildname}_ogl-%{ver2}.so
666
667 %dir %{_includedir}/wx-%{ver2}/wx/plot
668 %{_includedir}/wx-%{ver2}/wx/plot/*
669 %{_libdir}/libwx_%{buildname}_plot-%{ver2}.so
670
671 %dir %{_includedir}/wx-%{ver2}/wx/stc
672 %{_includedir}/wx-%{ver2}/wx/stc/*
673 %{_libdir}/libwx_%{buildname}_stc-%{ver2}.so
674
675 %dir %{_includedir}/wx-%{ver2}/wx/svg
676 %{_includedir}/wx-%{ver2}/wx/svg/*
677 %{_libdir}/libwx_%{buildname}_svg-%{ver2}.so