]> git.saurik.com Git - wxWidgets.git/blob - wxGTK_RR.spec
Corrected two typos.
[wxWidgets.git] / wxGTK_RR.spec
1 %define _prefix /opt/gnome
2 %define ver 2.6.0
3 %define ver2 2.6
4 %define rel 1
5
6 # Configurable settings (use --with(out) {unicode,gtk2} on rpmbuild cmd line):
7 %define unicode 1
8 %{?_with_unicode: %{expand: %%define unicode 1}}
9 %{?_without_unicode: %{expand: %%define unicode 0}}
10
11 %define gtk2 1
12 %{?_with_gtk2: %{expand: %%define gtk2 1}}
13 %{?_without_gtk2: %{expand: %%define gtk2 0}}
14
15 # "buildname" needs to be e.g. gtk2ud for debug builds
16 %if %{gtk2}
17 %define gtkver 2
18 %define portname gtk2
19 %if %{unicode}
20 %define buildname gtk2u
21 %else
22 %define buildname gtk2
23 %endif
24 %else
25 %define gtkver 1.2
26 %define portname gtk
27 %define buildname gtk
28 %endif
29
30 %if %{unicode}
31 %define name wx-%{portname}-unicode
32 %define wxconfig %{portname}-unicode-release-%{ver2}
33 %define wxconfigstatic %{portname}-unicode-release-static-%{ver2}
34 %define wxconfiglink wx%{portname}u-%{ver2}-config
35 %else
36 %define name wx-%{portname}
37 %define wxconfig %{portname}-ansi-release-%{ver2}
38 %define wxconfigstatic %{portname}-ansi-release-static-%{ver2}
39 %define wxconfiglink wx%{portname}-%{ver2}-config
40 %endif
41
42 %if %{unicode}
43 %define wxbasename wx-base-unicode
44 %define wxbaseconfig base-unicode-release-%{ver2}
45 %define wxbaseconfigstatic base-unicode-release-static-%{ver2}
46 %define wxbaseconfiglink wxbaseu-%{ver2}-config
47 %else
48 %define wxbasename wx-base-ansi
49 %define wxbaseconfig base-ansi-release-%{ver2}
50 %define wxbaseconfigstatic base-ansi-release-static-%{ver2}
51 %define wxbaseconfiglink wxbase-%{ver2}-config
52 %endif
53
54 Summary: The GTK+ %{gtkver} port of the wxWidgets library
55 Name: %{name}
56 Version: %{ver}
57 Release: %{rel}
58 License: wxWindows Licence
59 Group: X11/Libraries
60 Source: wxGTK-%{ver}.tar.gz
61 URL: http://www.wxwidgets.org
62 Packager: Vadim Zeitlin <vadim@wxwindows.org>
63 Prefix: %{_prefix}
64 BuildRoot: %{_tmppath}/%{name}-root
65 Requires: %{wxbasename} = %{ver}
66 %if %{portname} == gtk2
67 # BuildRequires: gtk+-2.0-devel
68 %else
69 # BuildRequires: gtk+-devel >= 1.2.0
70 %endif
71
72 BuildRequires: zlib-devel, libjpeg-devel, libpng-devel, libtiff-devel
73
74 # all packages providing an implementation of wxWidgets library (regardless of
75 # the toolkit used) should provide the (virtual) wxwin package, this makes it
76 # possible to require wxwin instead of requiring "wxgtk or wxmotif or wxuniv..."
77 Provides: wxwin
78 Provides: wxGTK
79
80 %description
81 wxWidgets is a free C++ library for cross-platform GUI development.
82 With wxWidgets, you can create applications for different GUIs (GTK+,
83 Motif, MS Windows, MacOS X, Windows CE, GPE) from the same source code.
84
85 %package devel
86 Summary: The GTK+ %{gtkver} port of the wxWidgets library
87 Group: X11/Libraries
88 Requires: %{name} = %{ver}
89 Requires: %{wxbasename}-devel = %{ver}
90 Provides: wxGTK-devel
91
92 %description devel
93 The GTK+ %{gtkver} port of the wxWidgets library, header files.
94
95 %package gl
96 Summary: The GTK+ %{gtkver} port of the wxWidgets library, OpenGL add-on.
97 Group: X11/Libraries
98 Requires: %{name} = %{ver}
99 Provides: wxGTK-gl
100
101 %description gl
102 OpenGL add-on library for wxGTK, the GTK+ %{gtkver} port of the wxWidgets library.
103
104 %package -n %{wxbasename}
105 Summary: wxBase library - non-GUI support classes of the wxWidgets toolkit
106 Group: Development/Libraries
107 Provides: wxBase
108
109 %description -n %{wxbasename}
110 wxBase is a collection of C++ classes providing basic data structures (strings,
111 lists, arrays), portable wrappers around many OS-specific funstions (file
112 operations, time/date manipulations, threads, processes, sockets, shared
113 library loading) as well as other utility classes (streams, archive and
114 compression). wxBase currently supports Win32, most Unix variants (Linux,
115 FreeBSD, Solaris, HP-UX) and MacOS X 10.3.
116
117 %package -n %{wxbasename}-devel
118 Summary: wxBase library, header files.
119 Group: Development/Libraries
120 Provides: wxBase-devel
121
122 %description -n %{wxbasename}-devel
123 wxBase library - non-GUI support classes of the wxWidgets toolkit,
124 header files.
125
126 %package contrib
127 Summary: The GTK+ %{gtkver} port of the wxWidgets library, contributed libraries.
128 Group: X11/Libraries
129 Requires: %{name} = %{ver}
130
131 %description contrib
132 Contributed libraries for wxGTK, the GTK+ %{gtkver} port of the wxWidgets library.
133
134 %package contrib-devel
135 Summary: The GTK+ %{gtkver} port of the wxWidgets library
136 Group: X11/Libraries
137 Requires: %{name}-contrib = %{ver}
138 Requires: %{name}-devel = %{ver}
139
140 %description contrib-devel
141 Header files for contributed libraries for wxGTK, the GTK+ %{gtkver} port of the wxWidgets library.
142
143 %prep
144 %setup -q -n wxGTK-%{ver}
145
146 %build
147 if [ "$SMP" != "" ]; then
148 export MAKE="make -j$SMP"
149 else
150 export MAKE="make"
151 fi
152
153 mkdir obj-shared-no-gui
154 cd obj-shared-no-gui
155 ../configure --prefix=%{_prefix} \
156 --disable-gui \
157 %if %{unicode}
158 --enable-unicode
159 %else
160 --disable-unicode
161 %endif
162 $MAKE
163 cd ..
164
165 mkdir obj-shared
166 cd obj-shared
167 ../configure --prefix=%{_prefix} \
168 %if ! %{gtk2}
169 --disable-gtk2 \
170 %else
171 --enable-gtk2 \
172 %endif
173 %if %{unicode}
174 --enable-unicode \
175 %else
176 --disable-unicode \
177 %endif
178 --with-opengl
179 $MAKE
180
181 cd contrib/src
182 $MAKE
183 cd ../../..
184
185 mkdir obj-static-no-gui
186 cd obj-static-no-gui
187 ../configure --prefix=%{_prefix} \
188 --disable-gui \
189 --disable-shared \
190 %if %{unicode}
191 --enable-unicode
192 %else
193 --disable-unicode
194 %endif
195 $MAKE
196 cd ..
197
198 mkdir obj-static
199 cd obj-static
200 ../configure --prefix=%{_prefix} \
201 %if ! %{gtk2}
202 --disable-gtk2 \
203 %else
204 --enable-gtk2 \
205 %endif
206 --disable-shared \
207 %if %{unicode}
208 --enable-unicode \
209 %else
210 --disable-unicode \
211 %endif
212 --with-opengl
213 $MAKE
214
215 cd contrib/src
216 $MAKE
217 cd ../../..
218
219 %install
220 rm -rf $RPM_BUILD_ROOT
221 (cd obj-static-no-gui; make DESTDIR=$RPM_BUILD_ROOT install)
222 (cd obj-static; make DESTDIR=$RPM_BUILD_ROOT install)
223 (cd obj-shared-no-gui; make DESTDIR=$RPM_BUILD_ROOT install)
224 (cd obj-shared; make DESTDIR=$RPM_BUILD_ROOT install)
225
226 # --- wxBase headers list begins here ---
227 cat <<EOF >wxbase-headers.files
228 wx/afterstd.h
229 wx/app.h
230 wx/apptrait.h
231 wx/archive.h
232 wx/arrimpl.cpp
233 wx/arrstr.h
234 wx/beforestd.h
235 wx/buffer.h
236 wx/build.h
237 wx/chkconf.h
238 wx/clntdata.h
239 wx/cmdline.h
240 wx/confbase.h
241 wx/config.h
242 wx/containr.h
243 wx/datetime.h
244 wx/datetime.inl
245 wx/datstrm.h
246 wx/dde.h
247 wx/debug.h
248 wx/defs.h
249 wx/dir.h
250 wx/dlimpexp.h
251 wx/dynarray.h
252 wx/dynlib.h
253 wx/dynload.h
254 wx/encconv.h
255 wx/event.h
256 wx/except.h
257 wx/features.h
258 wx/ffile.h
259 wx/file.h
260 wx/fileconf.h
261 wx/filefn.h
262 wx/filename.h
263 wx/filesys.h
264 wx/fontenc.h
265 wx/fontmap.h
266 wx/fs_mem.h
267 wx/fs_zip.h
268 wx/hash.h
269 wx/hashmap.h
270 wx/hashset.h
271 wx/html/forcelnk.h
272 wx/iconloc.h
273 wx/init.h
274 wx/intl.h
275 wx/iosfwrap.h
276 wx/ioswrap.h
277 wx/ipc.h
278 wx/ipcbase.h
279 wx/isql.h
280 wx/isqlext.h
281 wx/list.h
282 wx/listimpl.cpp
283 wx/log.h
284 wx/longlong.h
285 wx/math.h
286 wx/memconf.h
287 wx/memory.h
288 wx/memtext.h
289 wx/mimetype.h
290 wx/module.h
291 wx/msgout.h
292 wx/mstream.h
293 wx/object.h
294 wx/platform.h
295 wx/process.h
296 wx/ptr_scpd.h
297 wx/regex.h
298 wx/scopeguard.h
299 wx/snglinst.h
300 wx/sstream.h
301 wx/stack.h
302 wx/stackwalk.h
303 wx/stdpaths.h
304 wx/stockitem.h
305 wx/stopwatch.h
306 wx/strconv.h
307 wx/stream.h
308 wx/string.h
309 wx/sysopt.h
310 wx/textbuf.h
311 wx/textfile.h
312 wx/thread.h
313 wx/thrimpl.cpp
314 wx/timer.h
315 wx/tokenzr.h
316 wx/txtstrm.h
317 wx/types.h
318 wx/uri.h
319 wx/utils.h
320 wx/variant.h
321 wx/vector.h
322 wx/version.h
323 wx/volume.h
324 wx/wfstream.h
325 wx/wx.h
326 wx/wxchar.h
327 wx/wxprec.h
328 wx/xti.h
329 wx/xtistrm.h
330 wx/zipstrm.h
331 wx/zstream.h
332 wx/fs_inet.h
333 wx/gsocket.h
334 wx/protocol/file.h
335 wx/protocol/ftp.h
336 wx/protocol/http.h
337 wx/protocol/protocol.h
338 wx/sckaddr.h
339 wx/sckipc.h
340 wx/sckstrm.h
341 wx/socket.h
342 wx/url.h
343 wx/xml/xml.h
344 wx/xtixml.h
345 wx/db.h
346 wx/dbkeyg.h
347 wx/dbtable.h
348 wx/unix/apptbase.h
349 wx/unix/apptrait.h
350 wx/unix/execute.h
351 wx/unix/gsockunx.h
352 wx/unix/mimetype.h
353 wx/unix/pipe.h
354 wx/unix/stackwalk.h
355 wx/unix/stdpaths.h
356 EOF
357 # --- wxBase headers list ends here ---
358 cat <<EOF >wxbase-headers.paths
359 %{_includedir}/wx-%{ver2}/wx/afterstd.h
360 %{_includedir}/wx-%{ver2}/wx/app.h
361 %{_includedir}/wx-%{ver2}/wx/apptrait.h
362 %{_includedir}/wx-%{ver2}/wx/archive.h
363 %{_includedir}/wx-%{ver2}/wx/arrimpl.cpp
364 %{_includedir}/wx-%{ver2}/wx/arrstr.h
365 %{_includedir}/wx-%{ver2}/wx/beforestd.h
366 %{_includedir}/wx-%{ver2}/wx/buffer.h
367 %{_includedir}/wx-%{ver2}/wx/build.h
368 %{_includedir}/wx-%{ver2}/wx/chkconf.h
369 %{_includedir}/wx-%{ver2}/wx/clntdata.h
370 %{_includedir}/wx-%{ver2}/wx/cmdline.h
371 %{_includedir}/wx-%{ver2}/wx/confbase.h
372 %{_includedir}/wx-%{ver2}/wx/config.h
373 %{_includedir}/wx-%{ver2}/wx/containr.h
374 %{_includedir}/wx-%{ver2}/wx/datetime.h
375 %{_includedir}/wx-%{ver2}/wx/datetime.inl
376 %{_includedir}/wx-%{ver2}/wx/datstrm.h
377 %{_includedir}/wx-%{ver2}/wx/dde.h
378 %{_includedir}/wx-%{ver2}/wx/debug.h
379 %{_includedir}/wx-%{ver2}/wx/defs.h
380 %{_includedir}/wx-%{ver2}/wx/dir.h
381 %{_includedir}/wx-%{ver2}/wx/dlimpexp.h
382 %{_includedir}/wx-%{ver2}/wx/dynarray.h
383 %{_includedir}/wx-%{ver2}/wx/dynlib.h
384 %{_includedir}/wx-%{ver2}/wx/dynload.h
385 %{_includedir}/wx-%{ver2}/wx/encconv.h
386 %{_includedir}/wx-%{ver2}/wx/event.h
387 %{_includedir}/wx-%{ver2}/wx/except.h
388 %{_includedir}/wx-%{ver2}/wx/features.h
389 %{_includedir}/wx-%{ver2}/wx/ffile.h
390 %{_includedir}/wx-%{ver2}/wx/file.h
391 %{_includedir}/wx-%{ver2}/wx/fileconf.h
392 %{_includedir}/wx-%{ver2}/wx/filefn.h
393 %{_includedir}/wx-%{ver2}/wx/filename.h
394 %{_includedir}/wx-%{ver2}/wx/filesys.h
395 %{_includedir}/wx-%{ver2}/wx/fontenc.h
396 %{_includedir}/wx-%{ver2}/wx/fontmap.h
397 %{_includedir}/wx-%{ver2}/wx/fs_mem.h
398 %{_includedir}/wx-%{ver2}/wx/fs_zip.h
399 %{_includedir}/wx-%{ver2}/wx/hash.h
400 %{_includedir}/wx-%{ver2}/wx/hashmap.h
401 %{_includedir}/wx-%{ver2}/wx/hashset.h
402 %{_includedir}/wx-%{ver2}/wx/html/forcelnk.h
403 %{_includedir}/wx-%{ver2}/wx/iconloc.h
404 %{_includedir}/wx-%{ver2}/wx/init.h
405 %{_includedir}/wx-%{ver2}/wx/intl.h
406 %{_includedir}/wx-%{ver2}/wx/iosfwrap.h
407 %{_includedir}/wx-%{ver2}/wx/ioswrap.h
408 %{_includedir}/wx-%{ver2}/wx/ipc.h
409 %{_includedir}/wx-%{ver2}/wx/ipcbase.h
410 %{_includedir}/wx-%{ver2}/wx/isql.h
411 %{_includedir}/wx-%{ver2}/wx/isqlext.h
412 %{_includedir}/wx-%{ver2}/wx/list.h
413 %{_includedir}/wx-%{ver2}/wx/listimpl.cpp
414 %{_includedir}/wx-%{ver2}/wx/log.h
415 %{_includedir}/wx-%{ver2}/wx/longlong.h
416 %{_includedir}/wx-%{ver2}/wx/math.h
417 %{_includedir}/wx-%{ver2}/wx/memconf.h
418 %{_includedir}/wx-%{ver2}/wx/memory.h
419 %{_includedir}/wx-%{ver2}/wx/memtext.h
420 %{_includedir}/wx-%{ver2}/wx/mimetype.h
421 %{_includedir}/wx-%{ver2}/wx/module.h
422 %{_includedir}/wx-%{ver2}/wx/msgout.h
423 %{_includedir}/wx-%{ver2}/wx/mstream.h
424 %{_includedir}/wx-%{ver2}/wx/object.h
425 %{_includedir}/wx-%{ver2}/wx/platform.h
426 %{_includedir}/wx-%{ver2}/wx/process.h
427 %{_includedir}/wx-%{ver2}/wx/ptr_scpd.h
428 %{_includedir}/wx-%{ver2}/wx/regex.h
429 %{_includedir}/wx-%{ver2}/wx/scopeguard.h
430 %{_includedir}/wx-%{ver2}/wx/snglinst.h
431 %{_includedir}/wx-%{ver2}/wx/sstream.h
432 %{_includedir}/wx-%{ver2}/wx/stack.h
433 %{_includedir}/wx-%{ver2}/wx/stackwalk.h
434 %{_includedir}/wx-%{ver2}/wx/stdpaths.h
435 %{_includedir}/wx-%{ver2}/wx/stockitem.h
436 %{_includedir}/wx-%{ver2}/wx/stopwatch.h
437 %{_includedir}/wx-%{ver2}/wx/strconv.h
438 %{_includedir}/wx-%{ver2}/wx/stream.h
439 %{_includedir}/wx-%{ver2}/wx/string.h
440 %{_includedir}/wx-%{ver2}/wx/sysopt.h
441 %{_includedir}/wx-%{ver2}/wx/textbuf.h
442 %{_includedir}/wx-%{ver2}/wx/textfile.h
443 %{_includedir}/wx-%{ver2}/wx/thread.h
444 %{_includedir}/wx-%{ver2}/wx/thrimpl.cpp
445 %{_includedir}/wx-%{ver2}/wx/timer.h
446 %{_includedir}/wx-%{ver2}/wx/tokenzr.h
447 %{_includedir}/wx-%{ver2}/wx/txtstrm.h
448 %{_includedir}/wx-%{ver2}/wx/types.h
449 %{_includedir}/wx-%{ver2}/wx/uri.h
450 %{_includedir}/wx-%{ver2}/wx/utils.h
451 %{_includedir}/wx-%{ver2}/wx/variant.h
452 %{_includedir}/wx-%{ver2}/wx/vector.h
453 %{_includedir}/wx-%{ver2}/wx/version.h
454 %{_includedir}/wx-%{ver2}/wx/volume.h
455 %{_includedir}/wx-%{ver2}/wx/wfstream.h
456 %{_includedir}/wx-%{ver2}/wx/wx.h
457 %{_includedir}/wx-%{ver2}/wx/wxchar.h
458 %{_includedir}/wx-%{ver2}/wx/wxprec.h
459 %{_includedir}/wx-%{ver2}/wx/xti.h
460 %{_includedir}/wx-%{ver2}/wx/xtistrm.h
461 %{_includedir}/wx-%{ver2}/wx/zipstrm.h
462 %{_includedir}/wx-%{ver2}/wx/zstream.h
463 %{_includedir}/wx-%{ver2}/wx/fs_inet.h
464 %{_includedir}/wx-%{ver2}/wx/gsocket.h
465 %{_includedir}/wx-%{ver2}/wx/protocol/file.h
466 %{_includedir}/wx-%{ver2}/wx/protocol/ftp.h
467 %{_includedir}/wx-%{ver2}/wx/protocol/http.h
468 %{_includedir}/wx-%{ver2}/wx/protocol/protocol.h
469 %{_includedir}/wx-%{ver2}/wx/sckaddr.h
470 %{_includedir}/wx-%{ver2}/wx/sckipc.h
471 %{_includedir}/wx-%{ver2}/wx/sckstrm.h
472 %{_includedir}/wx-%{ver2}/wx/socket.h
473 %{_includedir}/wx-%{ver2}/wx/url.h
474 %{_includedir}/wx-%{ver2}/wx/xml/xml.h
475 %{_includedir}/wx-%{ver2}/wx/xtixml.h
476 %{_includedir}/wx-%{ver2}/wx/db.h
477 %{_includedir}/wx-%{ver2}/wx/dbkeyg.h
478 %{_includedir}/wx-%{ver2}/wx/dbtable.h
479 %{_includedir}/wx-%{ver2}/wx/unix/apptbase.h
480 %{_includedir}/wx-%{ver2}/wx/unix/apptrait.h
481 %{_includedir}/wx-%{ver2}/wx/unix/execute.h
482 %{_includedir}/wx-%{ver2}/wx/unix/gsockunx.h
483 %{_includedir}/wx-%{ver2}/wx/unix/mimetype.h
484 %{_includedir}/wx-%{ver2}/wx/unix/pipe.h
485 %{_includedir}/wx-%{ver2}/wx/unix/stackwalk.h
486 %{_includedir}/wx-%{ver2}/wx/unix/stdpaths.h
487 EOF
488 # --- wxBase headers list ends here ---
489
490 # temporarily remove base headers
491 mkdir $RPM_BUILD_ROOT/_save_dir
492 cp -r $RPM_BUILD_ROOT%{_includedir}/wx-%{ver2} $RPM_BUILD_ROOT/_save_dir
493 for f in `cat wxbase-headers.files` ; do
494 rm -f $RPM_BUILD_ROOT%{_includedir}/wx-%{ver2}/$f
495 done
496 # list of all core headers:
497 find $RPM_BUILD_ROOT%{_includedir}/wx-%{ver2} -type f | sed -e "s,$RPM_BUILD_ROOT,,g" >core-headers.files
498 # move base headers (actually all headers) back again
499 cp -f -r $RPM_BUILD_ROOT/_save_dir/* $RPM_BUILD_ROOT%{_includedir}
500 rm -rf $RPM_BUILD_ROOT/_save_dir
501
502 # contrib stuff:
503 (cd obj-shared/contrib/src; make DESTDIR=$RPM_BUILD_ROOT install)
504 (cd obj-shared/utils/wxrc; make DESTDIR=$RPM_BUILD_ROOT install)
505
506 %clean
507 rm -rf $RPM_BUILD_ROOT
508
509 %post
510 /sbin/ldconfig
511
512 %postun
513 /sbin/ldconfig
514
515 %post devel
516 # link wx-config when you install RPM.
517 %if %{unicode}
518 ln -sf %{_libdir}/wx/config/%{wxconfig} %{_bindir}/wx-config
519 %endif
520 # link wx-config with explicit name.
521 ln -sf %{_libdir}/wx/config/%{wxconfig} %{_bindir}/%{wxconfiglink}
522 /sbin/ldconfig
523
524 %postun devel
525 /sbin/ldconfig
526
527 %preun devel
528 if test -f %{_bindir}/wx-config -a -f /usr/bin/md5sum ; then
529 SUM1=`md5sum %{_libdir}/wx/config/%{wxconfig} | cut -c 0-32`
530 SUM2=`md5sum %{_bindir}/wx-config | cut -c 0-32`
531 if test "x$SUM1" = "x$SUM2" ; then
532 rm -f %{_bindir}/wx-config
533 fi
534 fi
535 rm -f %{_bindir}/%{wxconfiglink}
536
537 %post -n %{wxbasename}
538 /sbin/ldconfig
539
540 %postun -n %{wxbasename}
541 /sbin/ldconfig
542
543 %post -n %{wxbasename}-devel
544 # link wx-config with explicit name.
545 ln -sf %{_libdir}/wx/config/%{wxbaseconfig} %{_bindir}/%{wxbaseconfiglink}
546 /sbin/ldconfig
547
548 %postun -n %{wxbasename}-devel
549 /sbin/ldconfig
550
551 %preun -n %{wxbasename}-devel
552 rm -f %{_bindir}/%{wxbaseconfiglink}
553
554 %post gl
555 /sbin/ldconfig
556
557 %postun gl
558 /sbin/ldconfig
559
560 %post contrib
561 /sbin/ldconfig
562
563 %postun contrib
564 /sbin/ldconfig
565
566 %post contrib-devel
567 /sbin/ldconfig
568
569 %postun contrib-devel
570 /sbin/ldconfig
571
572 %files
573 %defattr(-,root,root)
574 %doc COPYING.LIB *.txt
575 %{_libdir}/libwx_%{buildname}_adv-%{ver2}.so.*
576 %{_libdir}/libwx_%{buildname}_core-%{ver2}.so.*
577 %if !%{unicode}
578 %{_libdir}/libwx_%{buildname}_dbgrid-%{ver2}.so.*
579 %endif
580 %{_libdir}/libwx_%{buildname}_html-%{ver2}.so.*
581 %{_libdir}/libwx_%{buildname}_media-%{ver2}.so.*
582 %{_libdir}/libwx_%{buildname}_qa-%{ver2}.so.*
583 %{_libdir}/libwx_%{buildname}_xrc-%{ver2}.so.*
584
585
586 %files devel -f core-headers.files
587 %defattr(-,root,root)
588 # shared libs
589 %{_libdir}/libwx_%{buildname}_adv-%{ver2}.so
590 %{_libdir}/libwx_%{buildname}_core-%{ver2}.so
591 %if !%{unicode}
592 %{_libdir}/libwx_%{buildname}_dbgrid-%{ver2}.so
593 %endif
594 %{_libdir}/libwx_%{buildname}_gl-%{ver2}.so
595 %{_libdir}/libwx_%{buildname}_html-%{ver2}.so
596 %{_libdir}/libwx_%{buildname}_media-%{ver2}.so
597 %{_libdir}/libwx_%{buildname}_qa-%{ver2}.so
598 %{_libdir}/libwx_%{buildname}_xrc-%{ver2}.so
599 # static libs
600 %{_libdir}/libwx_%{buildname}_adv-%{ver2}.a
601 %{_libdir}/libwx_%{buildname}_core-%{ver2}.a
602 %if !%{unicode}
603 %{_libdir}/libwx_%{buildname}_dbgrid-%{ver2}.a
604 %endif
605 %{_libdir}/libwx_%{buildname}_gl-%{ver2}.a
606 %{_libdir}/libwx_%{buildname}_html-%{ver2}.a
607 %{_libdir}/libwx_%{buildname}_media-%{ver2}.a
608 %{_libdir}/libwx_%{buildname}_qa-%{ver2}.a
609 %{_libdir}/libwx_%{buildname}_xrc-%{ver2}.a
610 %dir %{_libdir}/wx
611 %{_libdir}/wx/config/%{wxconfig}
612 %{_libdir}/wx/include/%{wxconfig}/wx/setup.h
613 %{_libdir}/wx/config/%{wxconfigstatic}
614 %{_libdir}/wx/include/%{wxconfigstatic}/wx/setup.h
615 %{_bindir}/wxrc*
616
617 %files -n %{wxbasename}
618 %defattr(-,root,root)
619 %{_libdir}/libwx_base*-%{ver2}.so.*
620 #%{_datadir}/locale/*/*/*
621
622 %files -n %{wxbasename}-devel -f wxbase-headers.paths
623 %defattr (-,root,root)
624 %dir %{_includedir}/wx-%{ver2}
625 %{_libdir}/libwx_base*-%{ver2}.so
626 %{_libdir}/libwx_base*-%{ver2}.a
627 %if %{unicode}
628 %{_libdir}/libwxregexu-%{ver2}.a
629 %endif
630 %dir %{_libdir}/wx
631 %{_libdir}/wx/config/%{wxbaseconfig}
632 %{_libdir}/wx/include/%{wxbaseconfig}/wx/setup.h
633 %{_libdir}/wx/config/%{wxbaseconfigstatic}
634 %{_libdir}/wx/include/%{wxbaseconfigstatic}/wx/setup.h
635 %{_datadir}/aclocal/*.m4
636
637 %files gl
638 %defattr(-,root,root)
639 %{_libdir}/libwx_%{buildname}_gl-%{ver2}.so.*
640
641 %files contrib
642 %defattr(-,root,root)
643 %{_libdir}/libwx_%{buildname}_animate-%{ver2}.so.*
644 %{_libdir}/libwx_%{buildname}_deprecated-%{ver2}.so.*
645 %{_libdir}/libwx_%{buildname}_fl-%{ver2}.so.*
646 %{_libdir}/libwx_%{buildname}_gizmos-%{ver2}.so.*
647 %{_libdir}/libwx_%{buildname}_gizmos_xrc-%{ver2}.so.*
648 %{_libdir}/libwx_%{buildname}_mmedia-%{ver2}.so.*
649 %{_libdir}/libwx_%{buildname}_ogl-%{ver2}.so.*
650 %{_libdir}/libwx_%{buildname}_plot-%{ver2}.so.*
651 %{_libdir}/libwx_%{buildname}_stc-%{ver2}.so.*
652 %{_libdir}/libwx_%{buildname}_svg-%{ver2}.so.*
653
654 %files contrib-devel
655 %defattr(-,root,root)
656 %dir %{_includedir}/wx-%{ver2}/wx/animate
657 %{_includedir}/wx-%{ver2}/wx/animate/*
658 %{_libdir}/libwx_%{buildname}_animate-%{ver2}.so
659
660 %dir %{_includedir}/wx-%{ver2}/wx/deprecated
661 %{_includedir}/wx-%{ver2}/wx/deprecated/*
662 %{_libdir}/libwx_%{buildname}_deprecated-%{ver2}.so
663
664 %dir %{_includedir}/wx-%{ver2}/wx/fl
665 %{_includedir}/wx-%{ver2}/wx/fl/*
666 %{_libdir}/libwx_%{buildname}_fl-%{ver2}.so
667
668 %dir %{_includedir}/wx-%{ver2}/wx/gizmos
669 %{_includedir}/wx-%{ver2}/wx/gizmos/*
670 %{_libdir}/libwx_%{buildname}_gizmos-%{ver2}.so
671 %{_libdir}/libwx_%{buildname}_gizmos_xrc-%{ver2}.so
672
673 %dir %{_includedir}/wx-%{ver2}/wx/mmedia
674 %{_includedir}/wx-%{ver2}/wx/mmedia/*
675 %{_libdir}/libwx_%{buildname}_mmedia-%{ver2}.so
676
677 %dir %{_includedir}/wx-%{ver2}/wx/ogl
678 %{_includedir}/wx-%{ver2}/wx/ogl/*
679 %{_libdir}/libwx_%{buildname}_ogl-%{ver2}.so
680
681 %dir %{_includedir}/wx-%{ver2}/wx/plot
682 %{_includedir}/wx-%{ver2}/wx/plot/*
683 %{_libdir}/libwx_%{buildname}_plot-%{ver2}.so
684
685 %dir %{_includedir}/wx-%{ver2}/wx/stc
686 %{_includedir}/wx-%{ver2}/wx/stc/*
687 %{_libdir}/libwx_%{buildname}_stc-%{ver2}.so
688
689 %dir %{_includedir}/wx-%{ver2}/wx/svg
690 %{_includedir}/wx-%{ver2}/wx/svg/*
691 %{_libdir}/libwx_%{buildname}_svg-%{ver2}.so