rebaked after wxUSE_EXTENDED_RTTI and wx/flags.h addition
[wxWidgets.git] / wxMotif.spec
1 %define pref /usr
2 %define ver 2.9.0
3 %define ver2 2.9
4 %define rel 1
5
6 %define portname motif
7 %define name wx-%{portname}
8 %define wxbasename wx-base
9
10 %define wxconfig %{portname}-ansi-release-%{ver2}
11 %define wxconfiglink wx%{portname}-%{ver2}-config
12
13 Summary: The Motif/Lesstif port of the wxWidgets library
14 Name: %{name}
15 Version: %{ver}
16 Release: %{rel}
17 License: wxWindows Licence
18 Group: X11/Libraries
19 Source: wxMotif-%{ver}.tar.bz2
20 URL: http://www.wxwidgets.org
21 Packager: wxWidgets developers <wx-dev@lists.wxwidgets.org>
22 BuildRoot: %{_tmppath}/%{name}-root
23 Requires: %{wxbasename} = %{ver}
24
25 # all packages providing an implementation of wxWidgets library (regardless of
26 # the toolkit used) should provide the (virtual) wxwin package, this makes it
27 # possible to require wxwin instead of requiring "wxgtk or wxmotif or wxuniv..."
28 Provides: wxwin
29 Provides: wxMotif
30
31 %description
32 wxWidgets is a free C++ library for cross-platform GUI development.
33 With wxWidgets, you can create applications for different GUIs (GTK+,
34 Motif/LessTif, MS Windows, Mac) from the same source code.
35
36 %package devel
37 Summary: The Motif/Lesstif port of the wxWidgets library
38 Group: X11/Libraries
39 Requires: %{name} = %{ver}
40 Requires: %{wxbasename}-devel = %{ver}
41
42 %description devel
43 Header files for wxMotif, the Motif/Lesstif port of the wxWidgets library.
44
45 %package gl
46 Summary: The Motif/Lesstif port of the wxWidgets library, OpenGL add-on.
47 Group: X11/Libraries
48 Requires: %{name} = %{ver}
49
50 %description gl
51 OpenGL add-on library for wxMotif, the Motif/Lesstif port of the wxWidgets library.
52
53 %package static
54 Summary: wxMotif static libraries
55 Group: Development/Libraries
56 Requires: %{wxbasename}-static
57 Requires: %{name}-devel = %{ver}
58
59 %description static
60 Static libraries for wxMotif. You need them if you want to link statically against wxMotif.
61
62 %package contrib
63 Summary: Contrib libraries for wxMotif
64 Group: X11/Libraries
65 Requires: %{name} = %{ver}
66
67 %description contrib
68 Contrib libraries for wxMotif
69
70 %package contrib-devel
71 Summary: Contrib libraries for wxMotif
72 Group: X11/Libraries
73 Requires: %{name}-contrib = %{ver}
74 Requires: %{name}-devel = %{ver}
75
76 %description contrib-devel
77 Header files for contributed libraries for wxMotif.
78
79 %prep
80 %setup -q -n wxMotif-%{ver}
81
82 %build
83 if [ "$SMP" != "" ]; then
84 export MAKE="make -j$SMP"
85 else
86 export MAKE="make"
87 fi
88
89 mkdir obj-shared
90 cd obj-shared
91 ../configure --prefix=%{pref} --with-motif --with-odbc --with-opengl
92 $MAKE
93
94 cd contrib/src
95 $MAKE
96 cd ../../..
97
98 mkdir obj-static
99 cd obj-static
100 ../configure --prefix=%{pref} --with-motif --disable-shared --with-odbc --with-opengl
101 $MAKE
102 cd ..
103
104 %install
105 rm -rf $RPM_BUILD_ROOT
106 (cd obj-static; make prefix=$RPM_BUILD_ROOT%{pref} install)
107 (cd obj-shared; make prefix=$RPM_BUILD_ROOT%{pref} install)
108
109 # Remove headers that are part of wx-base-devel:
110
111 # --- wxBase headers list begins here ---
112 cat <<EOF >wxbase-headers.files
113 wx/afterstd.h
114 wx/app.h
115 wx/apptrait.h
116 wx/archive.h
117 wx/arrimpl.cpp
118 wx/arrstr.h
119 wx/beforestd.h
120 wx/buffer.h
121 wx/build.h
122 wx/chartype.h
123 wx/chkconf.h
124 wx/clntdata.h
125 wx/cmdline.h
126 wx/confbase.h
127 wx/config.h
128 wx/convauto.h
129 wx/containr.h
130 wx/cpp.h
131 wx/datetime.h
132 wx/datstrm.h
133 wx/dde.h
134 wx/debug.h
135 wx/defs.h
136 wx/dir.h
137 wx/dlimpexp.h
138 wx/dynarray.h
139 wx/dynlib.h
140 wx/dynload.h
141 wx/encconv.h
142 wx/event.h
143 wx/except.h
144 wx/features.h
145 wx/flags.h
146 wx/ffile.h
147 wx/file.h
148 wx/fileconf.h
149 wx/filefn.h
150 wx/filename.h
151 wx/filesys.h
152 wx/fontenc.h
153 wx/fontmap.h
154 wx/fs_arc.h
155 wx/fs_filter.h
156 wx/fs_mem.h
157 wx/fs_zip.h
158 wx/hash.h
159 wx/hashmap.h
160 wx/hashset.h
161 wx/html/forcelnk.h
162 wx/iconloc.h
163 wx/init.h
164 wx/intl.h
165 wx/iosfwrap.h
166 wx/ioswrap.h
167 wx/ipc.h
168 wx/ipcbase.h
169 wx/isql.h
170 wx/isqlext.h
171 wx/link.h
172 wx/list.h
173 wx/listimpl.cpp
174 wx/log.h
175 wx/longlong.h
176 wx/math.h
177 wx/memconf.h
178 wx/memory.h
179 wx/memtext.h
180 wx/mimetype.h
181 wx/module.h
182 wx/msgout.h
183 wx/mstream.h
184 wx/object.h
185 wx/platform.h
186 wx/platinfo.h
187 wx/power.h
188 wx/process.h
189 wx/ptr_scpd.h
190 wx/recguard.h
191 wx/regex.h
192 wx/scopeguard.h
193 wx/snglinst.h
194 wx/sstream.h
195 wx/stack.h
196 wx/stackwalk.h
197 wx/stdpaths.h
198 wx/stockitem.h
199 wx/stopwatch.h
200 wx/strconv.h
201 wx/stream.h
202 wx/string.h
203 wx/stringimpl.h
204 wx/strvararg.h
205 wx/sysopt.h
206 wx/tarstrm.h
207 wx/textbuf.h
208 wx/textfile.h
209 wx/thread.h
210 wx/thrimpl.cpp
211 wx/timer.h
212 wx/tokenzr.h
213 wx/txtstrm.h
214 wx/types.h
215 wx/unichar.h
216 wx/uri.h
217 wx/utils.h
218 wx/variant.h
219 wx/vector.h
220 wx/version.h
221 wx/volume.h
222 wx/wfstream.h
223 wx/wx.h
224 wx/wxchar.h
225 wx/wxcrt.h
226 wx/wxprec.h
227 wx/xti.h
228 wx/xtistrm.h
229 wx/zipstrm.h
230 wx/zstream.h
231 wx/unix/apptbase.h
232 wx/unix/apptrait.h
233 wx/unix/execute.h
234 wx/unix/mimetype.h
235 wx/unix/pipe.h
236 wx/unix/private.h
237 wx/unix/stackwalk.h
238 wx/unix/stdpaths.h
239 wx/fs_inet.h
240 wx/gsocket.h
241 wx/protocol/file.h
242 wx/protocol/ftp.h
243 wx/protocol/http.h
244 wx/protocol/protocol.h
245 wx/sckaddr.h
246 wx/sckipc.h
247 wx/sckstrm.h
248 wx/socket.h
249 wx/url.h
250 wx/unix/gsockunx.h
251 wx/xml/xml.h
252 wx/xtixml.h
253 wx/db.h
254 wx/dbkeyg.h
255 wx/dbtable.h
256 EOF
257 # --- wxBase headers list ends here ---
258 for f in `cat wxbase-headers-list` ; do
259 rm -f $RPM_BUILD_ROOT%{_includedir}/wx-%{ver2}/$f
260 done
261
262 # list of all core headers:
263 find $RPM_BUILD_ROOT%{_includedir}/wx-%{ver2} -type f | sed -e "s,$RPM_BUILD_ROOT,,g" >core-headers.files
264
265 # contrib stuff:
266 (cd obj-shared/contrib/src; make prefix=$RPM_BUILD_ROOT%{pref} install)
267 (cd obj-shared/utils/wxrc; make prefix=$RPM_BUILD_ROOT%{pref} install)
268
269 # remove wxBase files so that RPM doesn't complain about unpackaged files:
270 rm -f $RPM_BUILD_ROOT%{_libdir}/libwx_base*
271 rm -f $RPM_BUILD_ROOT%{_datadir}/aclocal/*
272 rm -f $RPM_BUILD_ROOT%{_datadir}/locale/*/*/*
273
274 %clean
275 rm -rf $RPM_BUILD_ROOT
276
277 %post
278 /sbin/ldconfig
279
280 %postun
281 /sbin/ldconfig
282
283 %post devel
284 # link wx-config when you install RPM.
285 ln -sf %{_libdir}/wx/config/%{wxconfig} %{_bindir}/wx-config
286 # link wx-config with explicit name.
287 ln -sf %{_libdir}/wx/config/%{wxconfig} %{_bindir}/%{wxconfiglink}
288 /sbin/ldconfig
289
290 %postun devel
291 /sbin/ldconfig
292
293 %preun devel
294 if test -f %{_bindir}/wx-config -a -f /usr/bin/md5sum ; then
295 SUM1=`md5sum %{_libdir}/wx/config/%{wxconfig} | cut -c 0-32`
296 SUM2=`md5sum %{_bindir}/wx-config | cut -c 0-32`
297 if test "x$SUM1" = "x$SUM2" ; then
298 rm -f %{_bindir}/wx-config
299 fi
300 fi
301 rm -f %{_bindir}/%{wxconfiglink}
302
303 %post gl
304 /sbin/ldconfig
305
306 %postun gl
307 /sbin/ldconfig
308
309 %post contrib
310 /sbin/ldconfig
311
312 %postun contrib
313 /sbin/ldconfig
314
315 %post contrib-devel
316 /sbin/ldconfig
317
318 %postun contrib-devel
319 /sbin/ldconfig
320
321 %files
322 %defattr(-,root,root)
323 %doc COPYING.LIB *.txt
324 %{_libdir}/libwx_%{portname}*_adv-%{ver2}.so.*
325 %{_libdir}/libwx_%{portname}*_core-%{ver2}.so.*
326 %{_libdir}/libwx_%{portname}*_dbgrid-%{ver2}.so.*
327 %{_libdir}/libwx_%{portname}*_html-%{ver2}.so.*
328 %{_libdir}/libwx_%{portname}*_media-%{ver2}.so.*
329 %{_libdir}/libwx_%{portname}*_qa-%{ver2}.so.*
330 %{_libdir}/libwx_%{portname}*_xrc-%{ver2}.so.*
331
332
333 %files devel -f core-headers.files
334 %defattr(-,root,root)
335 %{_libdir}/libwx_%{portname}*_adv-%{ver2}.so
336 %{_libdir}/libwx_%{portname}*_core-%{ver2}.so
337 %{_libdir}/libwx_%{portname}*_dbgrid-%{ver2}.so
338 %{_libdir}/libwx_%{portname}*_gl-%{ver2}.so
339 %{_libdir}/libwx_%{portname}*_html-%{ver2}.so
340 %{_libdir}/libwx_%{portname}*_media-%{ver2}.so
341 %{_libdir}/libwx_%{portname}*_qa-%{ver2}.so
342 %{_libdir}/libwx_%{portname}*_xrc-%{ver2}.so
343 %dir %{_libdir}/wx
344 %{_libdir}/wx/*
345 %{_bindir}/wxrc*
346
347 %files gl
348 %defattr(-,root,root)
349 %{_libdir}/libwx_%{portname}*_gl-%{ver2}.so.*
350
351 %files static
352 %defattr (-,root,root)
353 %{_libdir}/libwx_%{portname}*_*-%{ver2}.a
354
355 %files contrib
356 %defattr(-,root,root)
357 %{_libdir}/libwx_%{portname}*_animate-%{ver2}.so.*
358 %{_libdir}/libwx_%{portname}*_deprecated-%{ver2}.so.*
359 %{_libdir}/libwx_%{portname}*_fl-%{ver2}.so.*
360 %{_libdir}/libwx_%{portname}*_gizmos-%{ver2}.so.*
361 %{_libdir}/libwx_%{portname}*_mmedia-%{ver2}.so.*
362 %{_libdir}/libwx_%{portname}*_ogl-%{ver2}.so.*
363 %{_libdir}/libwx_%{portname}*_plot-%{ver2}.so.*
364 %{_libdir}/libwx_%{portname}*_stc-%{ver2}.so.*
365 %{_libdir}/libwx_%{portname}*_svg-%{ver2}.so.*
366
367 %files contrib-devel
368 %defattr(-,root,root)
369 %dir %{_includedir}/wx-%{ver2}/wx/animate
370 %{_includedir}/wx-%{ver2}/wx/animate/*
371 %{_libdir}/libwx_%{portname}*_animate-%{ver2}.so
372
373 %dir %{_includedir}/wx-%{ver2}/wx/deprecated
374 %{_includedir}/wx-%{ver2}/wx/deprecated/*
375 %{_libdir}/libwx_%{portname}*_deprecated-%{ver2}.so
376
377 %dir %{_includedir}/wx-%{ver2}/wx/fl
378 %{_includedir}/wx-%{ver2}/wx/fl/*
379 %{_libdir}/libwx_%{portname}*_fl-%{ver2}.so
380
381 %dir %{_includedir}/wx-%{ver2}/wx/gizmos
382 %{_includedir}/wx-%{ver2}/wx/gizmos/*
383 %{_libdir}/libwx_%{portname}*_gizmos-%{ver2}.so
384
385 %dir %{_includedir}/wx-%{ver2}/wx/mmedia
386 %{_includedir}/wx-%{ver2}/wx/mmedia/*
387 %{_libdir}/libwx_%{portname}*_mmedia-%{ver2}.so
388
389 %dir %{_includedir}/wx-%{ver2}/wx/ogl
390 %{_includedir}/wx-%{ver2}/wx/ogl/*
391 %{_libdir}/libwx_%{portname}*_ogl-%{ver2}.so
392
393 %dir %{_includedir}/wx-%{ver2}/wx/plot
394 %{_includedir}/wx-%{ver2}/wx/plot/*
395 %{_libdir}/libwx_%{portname}*_plot-%{ver2}.so
396
397 %dir %{_includedir}/wx-%{ver2}/wx/stc
398 %{_includedir}/wx-%{ver2}/wx/stc/*
399 %{_libdir}/libwx_%{portname}*_stc-%{ver2}.so
400
401 %dir %{_includedir}/wx-%{ver2}/wx/svg
402 %{_includedir}/wx-%{ver2}/wx/svg/*
403 %{_libdir}/libwx_%{portname}*_svg-%{ver2}.so