6 # Configurable settings (use --with(out) unicode on rpmbuild command line):
8 %{?_with_unicode: %{expand: %%define unicode 1}}
9 %{?_without_unicode: %{expand: %%define unicode 0}}
12 %define wxconfigname wxbaseu
-%{ver2}-config
14 %define wxconfigname wxbase
-%{ver2}-config
18 %define name wx
-base
-unicode
23 Summary: wxBase library
- non
-GUI support classes of wxWindows toolkit
27 License: wxWindows Licence
28 Group: Development
/Libraries
29 Source: wxBase
-%{ver}.tar.bz2
30 URL: http
://www.wxwindows.org
31 Packager: Vadim Zeitlin
<vadim@wxwindows.org
>
33 BuildRoot: /var
/tmp
/%{name}-root
37 wxBase is a collection of C
++ classes providing basic data structures
(strings
,
38 lists
, arrays
), powerful wxDateTime class
for date manipulations
, portable
39 wrappers around many OS
-specific functions allowing to build the same program
40 under all supported folders
, wxThread class
for writing multithreaded programs
41 using either Win32 or POSIX threads and much more. wxBase currently supports
42 the following platforms
: Win32
, generic Unix
(Linux
, FreeBSD
, Solaris
, HP
-UX
,
46 Summary: wxBase headers needed
for developping with wxBase
47 Group: Development
/Libraries
48 Requires: %{name} = %{ver}
49 Provides: wxBase
-devel
52 Header files
for wxBase. You need them to develop programs using wxBase.
55 Summary: wxBase static libraries
56 Group: Development
/Libraries
59 Static libraries
for wxBase. You need them
if you want to link statically against wxBase.
62 %setup -q
-n wxBase
-%{ver}
65 if [ "$SMP"
!= ""
]; then
66 export MAKE
="
make -j$SMP"
73 ..
/configure
--prefix
=%{pref} --disable
-gui \
84 ..
/configure
--prefix
=%{pref} --disable
-shared
--disable
-gui \
94 rm -rf $RPM_BUILD_ROOT
95 (cd obj
-static
; make prefix
=$RPM_BUILD_ROOT
%{pref} install)
96 (cd obj
-shared
; make prefix
=$RPM_BUILD_ROOT
%{pref} install)
101 rm -rf $RPM_BUILD_ROOT
110 %defattr (-,root
,root
)
111 %doc COPYING.LIB
*.txt
112 %{_libdir}/libwx_base
*so.
*
115 %defattr (-,root
,root
)
116 %dir %{_includedir}/wx
-*
117 %{_includedir}/wx
-*/*
118 %{_libdir}/libwx_base
*.so
121 %{_bindir}/wxbase*-%{ver2}-config
123 %{_datadir}/aclocal
/*.m4
126 %defattr (-,root
,root
)