Remove obsolete VisualAge-related files.
[wxWidgets.git] / wxX11.spec
1 %define pref /usr
2 %define ver 3.0.0
3 %define ver2 3.0
4 %define rel 1
5
6 # Configurable settings (use --with(out) unicode on rpmbuild cmd line):
7 %define unicode 0
8 %{?_with_unicode: %{expand: %%define unicode 1}}
9 %{?_without_unicode: %{expand: %%define unicode 0}}
10
11 %define portname x11univ
12
13 %if %{unicode}
14 %define wxbasename wx-base-unicode
15 %define name wx-%{portname}-unicode
16 %define wxconfig %{portname}-unicode-%{ver2}
17 %define wxconfiglink wx%{portname}u-%{ver2}-config
18 %else
19 %define wxbasename wx-base
20 %define name wx-%{portname}
21 %define wxconfig %{portname}-ansi-%{ver2}
22 %define wxconfiglink wx%{portname}-%{ver2}-config
23 %endif
24
25 Summary: The X11 port of the wxWidgets library
26 Name: %{name}
27 Version: %{ver}
28 Release: %{rel}
29 License: wxWindows Licence
30 Group: X11/Libraries
31 Source: wxX11-%{ver}.tar.bz2
32 URL: http://www.wxwidgets.org
33 Packager: Vadim Zeitlin <vadim@wxwindows.org>
34 Prefix: %{pref}
35 BuildRoot: %{_tmppath}/%{name}-root
36 Requires: %{wxbasename} = %{ver}
37
38 # all packages providing an implementation of wxWidgets library (regardless of
39 # the toolkit used) should provide the (virtual) wxwin package, this makes it
40 # possible to require wxwin instead of requiring "wxgtk or wxmotif or wxuniv..."
41 Provides: wxwin
42 Provides: wxX11
43
44 %description
45 wxWidgets is a free C++ library for cross-platform GUI development.
46 With wxWidgets, you can create applications for different GUIs (GTK+,
47 Motif/LessTif, MS Windows, Mac) from the same source code.
48
49 %package devel
50 Summary: The X11 port of the wxWidgets library
51 Group: X11/Libraries
52 Requires: %{name} = %{ver}
53 Requires: %{wxbasename}-devel = %{ver}
54
55 %description devel
56 Header files for wxX11, the X11 port of the wxWidgets library.
57
58 %package gl
59 Summary: The X11 port of the wxWidgets library, OpenGL add-on.
60 Group: X11/Libraries
61 Requires: %{name} = %{ver}
62
63 %description gl
64 OpenGL add-on library for wxX11, the X11 port of the wxWidgets library.
65
66 %package static
67 Summary: wxX11 static libraries
68 Group: Development/Libraries
69 Requires: %{wxbasename}-static
70 Requires: %{name}-devel = %{ver}
71
72 %description static
73 Static libraries for wxX11. You need them if you want to link statically against wxX11.
74
75 %prep
76 %setup -q -n wxX11-%{ver}
77
78 %build
79 if [ "$SMP" != "" ]; then
80 export MAKE="make -j$SMP"
81 else
82 export MAKE="make"
83 fi
84
85 mkdir obj-shared
86 cd obj-shared
87 ../configure --prefix=%{pref} --with-x11 \
88 %if %{unicode}
89 --enable-unicode \
90 %else
91 --disable-unicode \
92 %endif
93 $MAKE
94 cd ..
95
96 mkdir obj-static
97 cd obj-static
98 ../configure --prefix=%{pref} --with-x11 --disable-shared \
99 %if %{unicode}
100 --enable-unicode \
101 %else
102 --disable-unicode \
103 %endif
104 --with-opengl
105 $MAKE
106 cd ..
107
108 %install
109 rm -rf $RPM_BUILD_ROOT
110 (cd obj-static; make prefix=$RPM_BUILD_ROOT%{pref} install)
111 (cd obj-shared; make prefix=$RPM_BUILD_ROOT%{pref} install)
112
113 # Remove headers that are part of wx-base-devel:
114
115 # --- wxBase headers list begins here ---
116 cat <<EOF >wxbase-headers.files
117 wx/afterstd.h
118 wx/any.h
119 wx/anystr.h
120 wx/app.h
121 wx/apptrait.h
122 wx/archive.h
123 wx/arrimpl.cpp
124 wx/arrstr.h
125 wx/atomic.h
126 wx/base64.h
127 wx/beforestd.h
128 wx/buffer.h
129 wx/build.h
130 wx/chartype.h
131 wx/checkeddelete.h
132 wx/chkconf.h
133 wx/clntdata.h
134 wx/cmdargs.h
135 wx/cmdline.h
136 wx/compiler.h
137 wx/confbase.h
138 wx/config.h
139 wx/convauto.h
140 wx/containr.h
141 wx/cpp.h
142 wx/crt.h
143 wx/datetime.h
144 wx/datstrm.h
145 wx/dde.h
146 wx/debug.h
147 wx/defs.h
148 wx/dir.h
149 wx/dlimpexp.h
150 wx/dlist.h
151 wx/dynarray.h
152 wx/dynlib.h
153 wx/dynload.h
154 wx/encconv.h
155 wx/event.h
156 wx/eventfilter.h
157 wx/evtloop.h
158 wx/except.h
159 wx/features.h
160 wx/flags.h
161 wx/ffile.h
162 wx/file.h
163 wx/fileconf.h
164 wx/filefn.h
165 wx/filename.h
166 wx/filesys.h
167 wx/fontenc.h
168 wx/fontmap.h
169 wx/fs_arc.h
170 wx/fs_filter.h
171 wx/fs_mem.h
172 wx/fs_zip.h
173 wx/hash.h
174 wx/hashmap.h
175 wx/hashset.h
176 wx/html/forcelnk.h
177 wx/iconloc.h
178 wx/init.h
179 wx/intl.h
180 wx/iosfwrap.h
181 wx/ioswrap.h
182 wx/ipc.h
183 wx/ipcbase.h
184 wx/kbdstate.h
185 wx/language.h
186 wx/link.h
187 wx/list.h
188 wx/listimpl.cpp
189 wx/log.h
190 wx/longlong.h
191 wx/math.h
192 wx/memconf.h
193 wx/memory.h
194 wx/memtext.h
195 wx/mimetype.h
196 wx/module.h
197 wx/mousestate.h
198 wx/msgout.h
199 wx/msgqueue.h
200 wx/mstream.h
201 wx/numformatter.h
202 wx/object.h
203 wx/platform.h
204 wx/platinfo.h
205 wx/power.h
206 wx/process.h
207 wx/ptr_scpd.h
208 wx/ptr_shrd.h
209 wx/recguard.h
210 wx/regex.h
211 wx/rtti.h
212 wx/scopedarray.h
213 wx/scopedptr.h
214 wx/scopeguard.h
215 wx/sharedptr.h
216 wx/snglinst.h
217 wx/sstream.h
218 wx/stack.h
219 wx/stackwalk.h
220 wx/stdpaths.h
221 wx/stdstream.h
222 wx/stockitem.h
223 wx/stopwatch.h
224 wx/strconv.h
225 wx/stream.h
226 wx/string.h
227 wx/stringimpl.h
228 wx/stringops.h
229 wx/strvararg.h
230 wx/sysopt.h
231 wx/tarstrm.h
232 wx/textbuf.h
233 wx/textfile.h
234 wx/thread.h
235 wx/thrimpl.cpp
236 wx/time.h
237 wx/timer.h
238 wx/tls.h
239 wx/tokenzr.h
240 wx/tracker.h
241 wx/translation.h
242 wx/txtstrm.h
243 wx/typeinfo.h
244 wx/types.h
245 wx/unichar.h
246 wx/uri.h
247 wx/ustring.h
248 wx/utils.h
249 wx/variant.h
250 wx/vector.h
251 wx/version.h
252 wx/versioninfo.h
253 wx/volume.h
254 wx/weakref.h
255 wx/wfstream.h
256 wx/wx.h
257 wx/wxchar.h
258 wx/wxcrt.h
259 wx/wxcrtbase.h
260 wx/wxcrtvararg.h
261 wx/wxprec.h
262 wx/xlocale.h
263 wx/xti.h
264 wx/xti2.h
265 wx/xtistrm.h
266 wx/xtictor.h
267 wx/xtihandler.h
268 wx/xtiprop.h
269 wx/xtitypes.h
270 wx/zipstrm.h
271 wx/zstream.h
272 wx/meta/convertible.h
273 wx/meta/if.h
274 wx/meta/implicitconversion.h
275 wx/meta/int2type.h
276 wx/meta/movable.h
277 wx/meta/pod.h
278 wx/meta/removeref.h
279 wx/fswatcher.h
280 wx/generic/fswatcher.h
281 wx/unix/app.h
282 wx/unix/apptbase.h
283 wx/unix/apptrait.h
284 wx/unix/chkconf.h
285 wx/unix/evtloop.h
286 wx/unix/evtloopsrc.h
287 wx/unix/pipe.h
288 wx/unix/stdpaths.h
289 wx/unix/stackwalk.h
290 wx/unix/tls.h
291 wx/unix/fswatcher_kqueue.h
292 wx/unix/execute.h
293 wx/unix/mimetype.h
294 wx/unix/fswatcher_inotify.h
295 wx/fs_inet.h
296 wx/protocol/file.h
297 wx/protocol/ftp.h
298 wx/protocol/http.h
299 wx/protocol/log.h
300 wx/protocol/protocol.h
301 wx/sckaddr.h
302 wx/sckipc.h
303 wx/sckstrm.h
304 wx/socket.h
305 wx/url.h
306 wx/xml/xml.h
307 wx/xtixml.h
308 EOF
309 # --- wxBase headers list ends here ---
310 for f in `cat wxbase-headers-list` ; do
311 rm -f $RPM_BUILD_ROOT%{_includedir}/wx-%{ver2}/$f
312 done
313
314 # list of all core headers:
315 find $RPM_BUILD_ROOT%{_includedir}/wx-%{ver2} -type f | sed -e "s,$RPM_BUILD_ROOT,,g" >core-headers.files
316
317 # remove wxBase files so that RPM doesn't complain about unpackaged files:
318 rm -f $RPM_BUILD_ROOT%{_libdir}/libwx_base*
319 %if %{unicode}
320 rm -f $RPM_BUILD_ROOT%{_libdir}/libwxregexu-%{ver2}.a
321 %endif
322 rm -f $RPM_BUILD_ROOT%{_datadir}/aclocal/*
323 rm -f $RPM_BUILD_ROOT%{_datadir}/locale/*/*/*
324
325 %clean
326 rm -rf $RPM_BUILD_ROOT
327
328 %post
329 /sbin/ldconfig
330
331 %postun
332 /sbin/ldconfig
333
334 %post devel
335 # link wx-config when you install RPM.
336 ln -sf %{_libdir}/wx/config/%{wxconfig} %{_bindir}/wx-config
337 # link wx-config with explicit name.
338 ln -sf %{_libdir}/wx/config/%{wxconfig} %{_bindir}/%{wxconfiglink}
339 /sbin/ldconfig
340
341 %postun devel
342 /sbin/ldconfig
343
344 %preun devel
345 if test -f %{_bindir}/wx-config -a -f /usr/bin/md5sum ; then
346 SUM1=`md5sum %{_libdir}/wx/config/%{wxconfig} | cut -c 0-32`
347 SUM2=`md5sum %{_bindir}/wx-config | cut -c 0-32`
348 if test "x$SUM1" = "x$SUM2" ; then
349 rm -f %{_bindir}/wx-config
350 fi
351 fi
352 rm -f %{_bindir}/%{wxconfiglink}
353
354 %post gl
355 /sbin/ldconfig
356
357 %postun gl
358 /sbin/ldconfig
359
360 %files
361 %defattr(-,root,root)
362 %doc COPYING.LIB *.txt
363 %{_libdir}/libwx_%{portname}*_adv-%{ver2}.so.*
364 %{_libdir}/libwx_%{portname}*_core-%{ver2}.so.*
365 %{_libdir}/libwx_%{portname}*_html-%{ver2}.so.*
366 %{_libdir}/libwx_%{portname}*_media-%{ver2}.so.*
367 %{_libdir}/libwx_%{portname}*_qa-%{ver2}.so.*
368 %{_libdir}/libwx_%{portname}*_xrc-%{ver2}.so.*
369
370
371 %files devel -f core-headers.files
372 %defattr(-,root,root)
373 %{_libdir}/libwx_%{portname}*_adv-%{ver2}.so
374 %{_libdir}/libwx_%{portname}*_core-%{ver2}.so
375 %{_libdir}/libwx_%{portname}*_gl-%{ver2}.so
376 %{_libdir}/libwx_%{portname}*_html-%{ver2}.so
377 %{_libdir}/libwx_%{portname}*_media-%{ver2}.so
378 %{_libdir}/libwx_%{portname}*_qa-%{ver2}.so
379 %{_libdir}/libwx_%{portname}*_xrc-%{ver2}.so
380 %dir %{_libdir}/wx
381 %{_libdir}/wx/*
382 %{_bindir}/wxrc*
383
384 %files gl
385 %defattr(-,root,root)
386 %{_libdir}/libwx_%{portname}*_gl-%{ver2}.so.*
387
388 %files static
389 %defattr (-,root,root)
390 %{_libdir}/libwx_%{portname}*_*-%{ver2}.a
391