extract (and expand and clean up and document) the header window implementation used...
[wxWidgets.git] / wxMotif.spec
1 %define pref /usr
2 %define ver 2.9.0
3 %define ver2 2.9
4 %define rel 1
5
6 %define portname motif
7 %define name wx-%{portname}
8 %define wxbasename wx-base
9
10 %define wxconfig %{portname}-ansi-release-%{ver2}
11 %define wxconfiglink wx%{portname}-%{ver2}-config
12
13 Summary: The Motif/Lesstif port of the wxWidgets library
14 Name: %{name}
15 Version: %{ver}
16 Release: %{rel}
17 License: wxWindows Licence
18 Group: X11/Libraries
19 Source: wxMotif-%{ver}.tar.bz2
20 URL: http://www.wxwidgets.org
21 Packager: wxWidgets developers <wx-dev@lists.wxwidgets.org>
22 BuildRoot: %{_tmppath}/%{name}-root
23 Requires: %{wxbasename} = %{ver}
24
25 # all packages providing an implementation of wxWidgets library (regardless of
26 # the toolkit used) should provide the (virtual) wxwin package, this makes it
27 # possible to require wxwin instead of requiring "wxgtk or wxmotif or wxuniv..."
28 Provides: wxwin
29 Provides: wxMotif
30
31 %description
32 wxWidgets is a free C++ library for cross-platform GUI development.
33 With wxWidgets, you can create applications for different GUIs (GTK+,
34 Motif/LessTif, MS Windows, Mac) from the same source code.
35
36 %package devel
37 Summary: The Motif/Lesstif port of the wxWidgets library
38 Group: X11/Libraries
39 Requires: %{name} = %{ver}
40 Requires: %{wxbasename}-devel = %{ver}
41
42 %description devel
43 Header files for wxMotif, the Motif/Lesstif port of the wxWidgets library.
44
45 %package gl
46 Summary: The Motif/Lesstif port of the wxWidgets library, OpenGL add-on.
47 Group: X11/Libraries
48 Requires: %{name} = %{ver}
49
50 %description gl
51 OpenGL add-on library for wxMotif, the Motif/Lesstif port of the wxWidgets library.
52
53 %package static
54 Summary: wxMotif static libraries
55 Group: Development/Libraries
56 Requires: %{wxbasename}-static
57 Requires: %{name}-devel = %{ver}
58
59 %description static
60 Static libraries for wxMotif. You need them if you want to link statically against wxMotif.
61
62 %package contrib
63 Summary: Contrib libraries for wxMotif
64 Group: X11/Libraries
65 Requires: %{name} = %{ver}
66
67 %description contrib
68 Contrib libraries for wxMotif
69
70 %package contrib-devel
71 Summary: Contrib libraries for wxMotif
72 Group: X11/Libraries
73 Requires: %{name}-contrib = %{ver}
74 Requires: %{name}-devel = %{ver}
75
76 %description contrib-devel
77 Header files for contributed libraries for wxMotif.
78
79 %prep
80 %setup -q -n wxMotif-%{ver}
81
82 %build
83 if [ "$SMP" != "" ]; then
84 export MAKE="make -j$SMP"
85 else
86 export MAKE="make"
87 fi
88
89 mkdir obj-shared
90 cd obj-shared
91 ../configure --prefix=%{pref} --with-motif --with-opengl
92 $MAKE
93
94 cd contrib/src
95 $MAKE
96 cd ../../..
97
98 mkdir obj-static
99 cd obj-static
100 ../configure --prefix=%{pref} --with-motif --disable-shared --with-opengl
101 $MAKE
102 cd ..
103
104 %install
105 rm -rf $RPM_BUILD_ROOT
106 (cd obj-static; make prefix=$RPM_BUILD_ROOT%{pref} install)
107 (cd obj-shared; make prefix=$RPM_BUILD_ROOT%{pref} install)
108
109 # Remove headers that are part of wx-base-devel:
110
111 # --- wxBase headers list begins here ---
112 cat <<EOF >wxbase-headers.files
113 wx/afterstd.h
114 wx/app.h
115 wx/apptrait.h
116 wx/archive.h
117 wx/arrimpl.cpp
118 wx/arrstr.h
119 wx/atomic.h
120 wx/base64.h
121 wx/beforestd.h
122 wx/buffer.h
123 wx/build.h
124 wx/chartype.h
125 wx/chkconf.h
126 wx/clntdata.h
127 wx/cmdargs.h
128 wx/cmdline.h
129 wx/confbase.h
130 wx/config.h
131 wx/convauto.h
132 wx/containr.h
133 wx/cpp.h
134 wx/crt.h
135 wx/datetime.h
136 wx/datstrm.h
137 wx/dde.h
138 wx/debug.h
139 wx/defs.h
140 wx/dir.h
141 wx/dlimpexp.h
142 wx/dlist.h
143 wx/dynarray.h
144 wx/dynlib.h
145 wx/dynload.h
146 wx/encconv.h
147 wx/event.h
148 wx/except.h
149 wx/features.h
150 wx/flags.h
151 wx/ffile.h
152 wx/file.h
153 wx/fileconf.h
154 wx/filefn.h
155 wx/filename.h
156 wx/filesys.h
157 wx/fontenc.h
158 wx/fontmap.h
159 wx/fs_arc.h
160 wx/fs_filter.h
161 wx/fs_mem.h
162 wx/fs_zip.h
163 wx/hash.h
164 wx/hashmap.h
165 wx/hashset.h
166 wx/html/forcelnk.h
167 wx/iconloc.h
168 wx/init.h
169 wx/intl.h
170 wx/iosfwrap.h
171 wx/ioswrap.h
172 wx/ipc.h
173 wx/ipcbase.h
174 wx/kbdstate.h
175 wx/link.h
176 wx/list.h
177 wx/listimpl.cpp
178 wx/log.h
179 wx/longlong.h
180 wx/math.h
181 wx/memconf.h
182 wx/memory.h
183 wx/memtext.h
184 wx/mimetype.h
185 wx/module.h
186 wx/mousestate.h
187 wx/msgout.h
188 wx/mstream.h
189 wx/object.h
190 wx/platform.h
191 wx/platinfo.h
192 wx/power.h
193 wx/process.h
194 wx/ptr_scpd.h
195 wx/ptr_shrd.h
196 wx/recguard.h
197 wx/regex.h
198 wx/scopeguard.h
199 wx/snglinst.h
200 wx/sstream.h
201 wx/stack.h
202 wx/stackwalk.h
203 wx/stdpaths.h
204 wx/stockitem.h
205 wx/stopwatch.h
206 wx/strconv.h
207 wx/stream.h
208 wx/string.h
209 wx/stringimpl.h
210 wx/stringops.h
211 wx/strvararg.h
212 wx/sysopt.h
213 wx/tarstrm.h
214 wx/textbuf.h
215 wx/textfile.h
216 wx/thread.h
217 wx/thrimpl.cpp
218 wx/timer.h
219 wx/tls.h
220 wx/tokenzr.h
221 wx/tracker.h
222 wx/txtstrm.h
223 wx/types.h
224 wx/unichar.h
225 wx/uri.h
226 wx/ustring.h
227 wx/utils.h
228 wx/variant.h
229 wx/vector.h
230 wx/version.h
231 wx/volume.h
232 wx/weakref.h
233 wx/wfstream.h
234 wx/wx.h
235 wx/wxchar.h
236 wx/wxcrt.h
237 wx/wxcrtbase.h
238 wx/wxcrtvararg.h
239 wx/wxprec.h
240 wx/xlocale.h
241 wx/xti.h
242 wx/xtistrm.h
243 wx/zipstrm.h
244 wx/zstream.h
245 wx/meta/convertible.h
246 wx/meta/if.h
247 wx/meta/int2type.h
248 wx/meta/movable.h
249 wx/private/fdiodispatcher.h
250 wx/private/selectdispatcher.h
251 wx/unix/app.h
252 wx/unix/apptbase.h
253 wx/unix/apptrait.h
254 wx/unix/chkconf.h
255 wx/unix/evtloop.h
256 wx/unix/pipe.h
257 wx/unix/stdpaths.h
258 wx/unix/stackwalk.h
259 wx/unix/tls.h
260 wx/unix/execute.h
261 wx/unix/mimetype.h
262 wx/fs_inet.h
263 wx/protocol/file.h
264 wx/protocol/ftp.h
265 wx/protocol/http.h
266 wx/protocol/protocol.h
267 wx/sckaddr.h
268 wx/sckipc.h
269 wx/sckstrm.h
270 wx/socket.h
271 wx/url.h
272 wx/xml/xml.h
273 wx/xtixml.h
274 EOF
275 # --- wxBase headers list ends here ---
276 for f in `cat wxbase-headers-list` ; do
277 rm -f $RPM_BUILD_ROOT%{_includedir}/wx-%{ver2}/$f
278 done
279
280 # list of all core headers:
281 find $RPM_BUILD_ROOT%{_includedir}/wx-%{ver2} -type f | sed -e "s,$RPM_BUILD_ROOT,,g" >core-headers.files
282
283 # contrib stuff:
284 (cd obj-shared/contrib/src; make prefix=$RPM_BUILD_ROOT%{pref} install)
285 (cd obj-shared/utils/wxrc; make prefix=$RPM_BUILD_ROOT%{pref} install)
286
287 # remove wxBase files so that RPM doesn't complain about unpackaged files:
288 rm -f $RPM_BUILD_ROOT%{_libdir}/libwx_base*
289 rm -f $RPM_BUILD_ROOT%{_datadir}/aclocal/*
290 rm -f $RPM_BUILD_ROOT%{_datadir}/locale/*/*/*
291
292 %clean
293 rm -rf $RPM_BUILD_ROOT
294
295 %post
296 /sbin/ldconfig
297
298 %postun
299 /sbin/ldconfig
300
301 %post devel
302 # link wx-config when you install RPM.
303 ln -sf %{_libdir}/wx/config/%{wxconfig} %{_bindir}/wx-config
304 # link wx-config with explicit name.
305 ln -sf %{_libdir}/wx/config/%{wxconfig} %{_bindir}/%{wxconfiglink}
306 /sbin/ldconfig
307
308 %postun devel
309 /sbin/ldconfig
310
311 %preun devel
312 if test -f %{_bindir}/wx-config -a -f /usr/bin/md5sum ; then
313 SUM1=`md5sum %{_libdir}/wx/config/%{wxconfig} | cut -c 0-32`
314 SUM2=`md5sum %{_bindir}/wx-config | cut -c 0-32`
315 if test "x$SUM1" = "x$SUM2" ; then
316 rm -f %{_bindir}/wx-config
317 fi
318 fi
319 rm -f %{_bindir}/%{wxconfiglink}
320
321 %post gl
322 /sbin/ldconfig
323
324 %postun gl
325 /sbin/ldconfig
326
327 %post contrib
328 /sbin/ldconfig
329
330 %postun contrib
331 /sbin/ldconfig
332
333 %post contrib-devel
334 /sbin/ldconfig
335
336 %postun contrib-devel
337 /sbin/ldconfig
338
339 %files
340 %defattr(-,root,root)
341 %doc COPYING.LIB *.txt
342 %{_libdir}/libwx_%{portname}*_adv-%{ver2}.so.*
343 %{_libdir}/libwx_%{portname}*_core-%{ver2}.so.*
344 %{_libdir}/libwx_%{portname}*_html-%{ver2}.so.*
345 %{_libdir}/libwx_%{portname}*_media-%{ver2}.so.*
346 %{_libdir}/libwx_%{portname}*_qa-%{ver2}.so.*
347 %{_libdir}/libwx_%{portname}*_xrc-%{ver2}.so.*
348
349
350 %files devel -f core-headers.files
351 %defattr(-,root,root)
352 %{_libdir}/libwx_%{portname}*_adv-%{ver2}.so
353 %{_libdir}/libwx_%{portname}*_core-%{ver2}.so
354 %{_libdir}/libwx_%{portname}*_gl-%{ver2}.so
355 %{_libdir}/libwx_%{portname}*_html-%{ver2}.so
356 %{_libdir}/libwx_%{portname}*_media-%{ver2}.so
357 %{_libdir}/libwx_%{portname}*_qa-%{ver2}.so
358 %{_libdir}/libwx_%{portname}*_xrc-%{ver2}.so
359 %dir %{_libdir}/wx
360 %{_libdir}/wx/*
361 %{_bindir}/wxrc*
362
363 %files gl
364 %defattr(-,root,root)
365 %{_libdir}/libwx_%{portname}*_gl-%{ver2}.so.*
366
367 %files static
368 %defattr (-,root,root)
369 %{_libdir}/libwx_%{portname}*_*-%{ver2}.a
370
371 %files contrib
372 %defattr(-,root,root)
373 %{_libdir}/libwx_%{portname}*_animate-%{ver2}.so.*
374 %{_libdir}/libwx_%{portname}*_deprecated-%{ver2}.so.*
375 %{_libdir}/libwx_%{portname}*_fl-%{ver2}.so.*
376 %{_libdir}/libwx_%{portname}*_gizmos-%{ver2}.so.*
377 %{_libdir}/libwx_%{portname}*_mmedia-%{ver2}.so.*
378 %{_libdir}/libwx_%{portname}*_ogl-%{ver2}.so.*
379 %{_libdir}/libwx_%{portname}*_plot-%{ver2}.so.*
380 %{_libdir}/libwx_%{portname}*_stc-%{ver2}.so.*
381 %{_libdir}/libwx_%{portname}*_svg-%{ver2}.so.*
382
383 %files contrib-devel
384 %defattr(-,root,root)
385 %dir %{_includedir}/wx-%{ver2}/wx/animate
386 %{_includedir}/wx-%{ver2}/wx/animate/*
387 %{_libdir}/libwx_%{portname}*_animate-%{ver2}.so
388
389 %dir %{_includedir}/wx-%{ver2}/wx/deprecated
390 %{_includedir}/wx-%{ver2}/wx/deprecated/*
391 %{_libdir}/libwx_%{portname}*_deprecated-%{ver2}.so
392
393 %dir %{_includedir}/wx-%{ver2}/wx/fl
394 %{_includedir}/wx-%{ver2}/wx/fl/*
395 %{_libdir}/libwx_%{portname}*_fl-%{ver2}.so
396
397 %dir %{_includedir}/wx-%{ver2}/wx/gizmos
398 %{_includedir}/wx-%{ver2}/wx/gizmos/*
399 %{_libdir}/libwx_%{portname}*_gizmos-%{ver2}.so
400
401 %dir %{_includedir}/wx-%{ver2}/wx/mmedia
402 %{_includedir}/wx-%{ver2}/wx/mmedia/*
403 %{_libdir}/libwx_%{portname}*_mmedia-%{ver2}.so
404
405 %dir %{_includedir}/wx-%{ver2}/wx/ogl
406 %{_includedir}/wx-%{ver2}/wx/ogl/*
407 %{_libdir}/libwx_%{portname}*_ogl-%{ver2}.so
408
409 %dir %{_includedir}/wx-%{ver2}/wx/plot
410 %{_includedir}/wx-%{ver2}/wx/plot/*
411 %{_libdir}/libwx_%{portname}*_plot-%{ver2}.so
412
413 %dir %{_includedir}/wx-%{ver2}/wx/stc
414 %{_includedir}/wx-%{ver2}/wx/stc/*
415 %{_libdir}/libwx_%{portname}*_stc-%{ver2}.so
416
417 %dir %{_includedir}/wx-%{ver2}/wx/svg
418 %{_includedir}/wx-%{ver2}/wx/svg/*
419 %{_libdir}/libwx_%{portname}*_svg-%{ver2}.so